18:05:06 <SergeyLukjanov> #startmeeting savanna
18:05:07 <openstack> Meeting started Thu Dec  5 18:05:06 2013 UTC and is due to finish in 60 minutes.  The chair is SergeyLukjanov. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:05:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:05:11 <openstack> The meeting name has been set to 'savanna'
18:05:12 <SergeyLukjanov> #topic Agenda
18:05:21 <SergeyLukjanov> #link https://wiki.openstack.org/wiki/Meetings/SavannaAgenda
18:05:30 <SergeyLukjanov> #topic Icehouse-1 released
18:05:45 <aignatov> hurraahhhh!
18:05:48 <SergeyLukjanov> #info the icehouse-1 (2014.1.b1) was released
18:05:55 <SergeyLukjanov> it's about the main savanna code
18:06:10 <SergeyLukjanov> i'll push corresponding tags to other projects tonight
18:06:31 <SergeyLukjanov> #info python-savannaclient 0.4.0 was released too
18:06:36 <mattf> yay
18:06:38 <SergeyLukjanov> in Mon or Tue I think
18:07:21 <SergeyLukjanov> mattf, your change was already landed ;)
18:08:02 <SergeyLukjanov> this release of main savanna code was driven by ttx
18:08:18 <SergeyLukjanov> so, now we're are really following OpenStack release cycle :)
18:08:24 <mattf> also yay
18:08:31 <aignatov> that's very cool
18:09:05 <SergeyLukjanov> any question?
18:09:15 <mattf> nooe
18:09:45 <SergeyLukjanov> #topic Action items from the last meeting
18:09:50 <SergeyLukjanov> #link http://eavesdrop.openstack.org/meetings/savanna/2013/savanna.2013-11-21-18.04.html
18:09:58 <SergeyLukjanov> there are no action items :)
18:10:11 <SergeyLukjanov> #topic Roadmap update / cleanup
18:10:23 <SergeyLukjanov> #link https://wiki.openstack.org/wiki/Savanna/Roadmap
18:10:35 <SergeyLukjanov> I've added some points that was discussed on summit
18:10:53 <mattf> glad to see that
18:11:13 <SergeyLukjanov> #action SergeyLukjanov to check that all blueprints created and ping guys to make them if not
18:11:34 <SergeyLukjanov> #action SergeyLukjanov add links to the blueprints to roadmao
18:11:49 <SergeyLukjanov> #topic News / updates
18:11:56 <SergeyLukjanov> guys, please
18:12:12 <mattf> no news from me this week, mostly turkey recovery
18:12:15 <SergeyLukjanov> #info first devstack-gate jobs was added to savanna (non-voting)
18:12:21 <aignatov> my notes: I'm continue working on patch dmitryme sent on the review
18:12:30 <aignatov> it's about Heat integration
18:12:48 <SergeyLukjanov> about the d-g jobs - savanna now installed by devstack in them
18:12:56 <SergeyLukjanov> so, it checks devstack integration at least
18:13:08 <jspeidel> not much from me this week
18:13:10 <SergeyLukjanov> I'm working now on initial set of api tests for the tempest
18:13:20 <aignatov> d-g jobs? what is d-g?
18:13:23 <aignatov> gating?
18:13:29 <SergeyLukjanov> devstack-gate == d-g
18:13:36 <mattf> SergeyLukjanov, that's interesting to me, this is for python-savannaclient?
18:13:45 <SergeyLukjanov> mattf, nope
18:13:57 <SergeyLukjanov> in tempest api tests use own simple client
18:14:00 <aignatov> SergeyLukjanov: that's exactly I thought about :)
18:14:10 <SergeyLukjanov> it's for testing api w/ dep on client
18:14:19 <SergeyLukjanov> any other news?
18:14:22 <jmaron> working on rack awareness for HDP plugin and disconnected installation (Installation in envs with no access to external repos)
18:14:42 * mattf is looking forward to ^^
18:14:43 <SergeyLukjanov> jmaron, great
18:15:22 <SergeyLukjanov> mattf, sorry, typo in my msg
18:15:33 <SergeyLukjanov> it's for testing api *W/O* dep on client
18:15:36 <mattf> i'm guessing w/o dep?
18:15:43 <SergeyLukjanov> yup
18:16:00 <SergeyLukjanov> as the first step will write api test in tempest
18:16:18 <SergeyLukjanov> and then will transform out savanna/tests/integration to the scenario tests in tempest
18:16:48 <SergeyLukjanov> so, after that we'll be able to use tempest in savanna-ci
18:16:59 <SergeyLukjanov> and propably the dull d-g approach
18:17:31 <SergeyLukjanov> #info savanna-ci still works non-deterministic
18:17:42 <SergeyLukjanov> crobertsrh, any news?
18:18:12 <SergeyLukjanov> mattf, crobertsrh, do you now about what tmckay doing atm?
18:18:26 <crobertsrh> Nothing major.  Most (maybe all?) of the bug fixes I was working on are ready.
18:18:52 <crobertsrh> I'll be looking through blueprints/bugs for icehouse and starting work on those.
18:18:59 <mattf> SergeyLukjanov, yeah, he's around
18:20:00 <SergeyLukjanov> ok, looks like that's all for news
18:20:11 <SergeyLukjanov> General discussion
18:20:15 <SergeyLukjanov> #topic General discussion
18:20:51 <SergeyLukjanov> nothing interesting to tell about from my side
18:21:14 <MikeSpreitzer> I'd like to ask about that patch that uses Heat
18:21:29 <MikeSpreitzer> At the end of the summit I asked why savanna is not using heat, and was told some reasons.
18:21:30 <SergeyLukjanov> MikeSpreitzer, sure
18:21:37 <MikeSpreitzer> Does the patch address them, and if so, how?
18:22:24 <SergeyLukjanov> MikeSpreitzer, there are mostly all needed features available in Havana Heat
18:22:42 <SergeyLukjanov> but there is a bunch of smaill improvements needed by savanna
18:22:43 <aignatov> actually current our implemtation is pretty simple and we use all of needed for savanna
18:22:56 <SergeyLukjanov> for example, a-a could be implelemented but it'll work pretty slow
18:23:01 <SergeyLukjanov> a-a == anti-affinity
18:23:12 <aignatov> we didnt
18:23:20 <aignatov> even try this Sergey
18:23:41 <dmitryme> aignatov: we're pretty sure it is slow
18:23:45 <alazarev> and as I understand current heat patch is only for VMs provisioning, other staff will still be in savanna
18:24:00 <MikeSpreitzer> So the current patch makes no attempt at anti-affiniity for VMs, right?
18:24:06 <SergeyLukjanov> alazarev, yup, it's about resources orchestration
18:24:20 <dmitryme> alazarev: other stuff will be handler by guest agent
18:24:29 <aignatov> yes, other stuff, alazarev will be moved to guest agents I think
18:24:58 <MikeSpreitzer> Another gap I was told about is there is no way to ask for compute and storage to be co-located.
18:24:58 <dmitryme> MikeSpreitzer: it does anti-affinity, but we expect it to work very slow
18:25:00 <aignatov> MikeSpreitzer: AA is on TODO list in this patch
18:25:09 <ruhe> alazarev: correction - other stuff will be done by corresponding plugin. it's important to note that some plugins utilise vendor-specific tools (such as Ambari) to install and configure Hadoop
18:25:26 <SergeyLukjanov> ruhe, yeah, very important note
18:25:43 <MikeSpreitzer> ruhe, you mean heat plugin, right?
18:25:55 <ruhe> MikeSpreitzer, no. savanna plugi
18:25:57 <SergeyLukjanov> MikeSpreitzer, it's about vanilla or hdp plugins
18:25:57 <ruhe> *plugin
18:26:08 <dmitryme> MikeSpreitzer: yes, that is true, there is no collocation
18:26:32 <SergeyLukjanov> MikeSpreitzer, I think that it should be on the heat's roadmap
18:26:50 <SergeyLukjanov> btw does anyone have question about releasing?
18:26:53 <MikeSpreitzer> I am trying to get it on nova+cinder's roadmap (the colocation)
18:27:01 <ruhe> here is doc about savanna plugin http://docs.openstack.org/developer/savanna/userdoc/plugins.html
18:27:34 <SergeyLukjanov> MikeSpreitzer, I think that it could be easily supported in Heat right after it'll be landed to nova+cinder
18:27:52 <MikeSpreitzer> Sergey: I also hope this
18:27:53 <SergeyLukjanov> MikeSpreitzer, do you any blueprints or threads on this topic?
18:28:04 <SergeyLukjanov> have*
18:28:13 <MikeSpreitzer> Yes, there were several related
18:28:29 <MikeSpreitzer> Current roadmap is very incremental  :-(
18:28:42 <MikeSpreitzer> It starts with the instance group API extension to nova
18:28:52 <SergeyLukjanov> and there was some threads about holistic scheduling
18:29:04 <MikeSpreitzer> yes, that's what I am talking about
18:29:15 <SergeyLukjanov> MikeSpreitzer, yup, we're hope that group api will be approved and landed
18:30:02 <MikeSpreitzer> https://docs.google.com/document/d/17OIiBoIavih-1y4zzK0oXyI66529f-7JTCVj-BcXURA/edit?pli=1 is more like it, but that's not the first step
18:30:39 <MikeSpreitzer> even that URL is only about Nova, we want to go cross-service after that
18:30:44 <SergeyLukjanov> MikeSpreitzer, what do you think about possibility to land instance groups in icehouse?
18:31:02 <MikeSpreitzer> My co-consipirators promised patches this week for the first step
18:31:15 <MikeSpreitzer> but that promise was made last week, I think current nova plans may delay a bit
18:31:25 <MikeSpreitzer> but I do hope for the first step in Icehouse for sure.
18:31:33 <aignatov> I was on this design session where it was discussed :) really interesting feature - AA between node groups and AA between instances within single node group
18:31:35 <MikeSpreitzer> First step is only instance groups with no internal structure
18:32:00 <MikeSpreitzer> Yes, I definitely want groups with internal structure
18:32:01 <SergeyLukjanov> MikeSpreitzer, awesome, please, add me to reviewers when the patch will be created
18:32:07 <MikeSpreitzer> OK
18:32:24 <MikeSpreitzer> Have been doing Hadoop exercises with IBM research code that is pure OpenStack client
18:32:31 <MikeSpreitzer> but roughly similar in approach
18:32:34 <SergeyLukjanov> MikeSpreitzer, internal structure like nested groups?
18:32:37 <MikeSpreitzer> yes
18:32:44 <SergeyLukjanov> MikeSpreitzer, cool
18:33:28 <tmckay> SergeyLukjanov, hi.  Sorry I'm late :)
18:33:37 <SergeyLukjanov> tmckay, np ;)
18:33:43 <SergeyLukjanov> tmckay, any news/updates?
18:33:56 <tmckay> I see you asking about me in the log.  I have been on extra-savanna stuff for a few weeks, but happily I think it is mostly put to rest.
18:34:01 <akuznetsov> MikeSpreitzer will your scheduler be aware about rack location?
18:34:02 <SergeyLukjanov> tmckay, i1 was partially released released, details in logs :0
18:34:03 <tmckay> Looking for where to go next.
18:34:21 <tmckay> Maybe hdfs storage for EDP objects>
18:34:23 <tmckay> ?
18:34:34 <MikeSpreitzer> See https://docs.google.com/drawings/d/1nridrUUwNaDrHQoGwSJ_KXYC7ik09wUuV3vXw1MyvlY/edit for an example of structured input
18:34:48 <SergeyLukjanov> tmckay, we have an idea to make it able to store jobs in swift in tell Oozie to take them from it
18:35:00 <MikeSpreitzer> Yes, we worked examples that support Hadoop rack awareness, want that in Nova+cinder
18:35:03 <SergeyLukjanov> tmckay, it'll make us avoid sending jars
18:35:34 <tmckay> okay.  Is there a doc or a pad somewhere talking about this?
18:35:55 <SergeyLukjanov> tmckay, just thoughts, we can discuss it in out channel
18:36:00 <tmckay> k
18:36:13 <SergeyLukjanov> tmckay, mainly we're thinking about it due to the creating guest agents
18:36:26 <akuznetsov> MikeSpreitzer cool
18:37:00 <aignatov> tmckay: also EDP must have improvements like applying command lime arguments for jobs
18:37:23 <SergeyLukjanov> yup, I'm really missing pi job :(
18:37:31 <tmckay> aignatov, ack.  I will be happy to work on EDP again.
18:38:30 <aignatov> also we have Hive not working in secure way or not working at all, I think we need to make it working somehow :)
18:38:46 <aignatov> hive with swift I mean
18:38:55 <tmckay> lots to do.
18:39:22 <SergeyLukjanov> tmckay, yeah, a lot of tbd stuff in EDP too
18:39:44 <SergeyLukjanov> tmckay, and you the main EDP dev for icehouse I think :)
18:40:18 <akuznetsov> also we can change auth schema for working with Swift, currently user should give username/password to Savanna, we should change this to oAuth
18:40:27 <aignatov> btw, here is a lot about EDP discussed: https://etherpad.openstack.org/p/savanna-icehouse-roadmap
18:40:28 <tmckay> really?  Has nprivalova abandoned me? ;-)
18:40:43 <SergeyLukjanov> tmckay, she's working on ceilo atm
18:41:25 <tmckay> Okay.  I'll do my best. 8-)
18:41:40 <SergeyLukjanov> great :)
18:41:48 <aignatov> cool
18:42:56 <aignatov> tmckay: you can contact me or akuznetsov about EDP related questions
18:43:13 <MikeSpreitzer> BTW, if you're willing to back up, can someone explain why the current anti-affinity solution is expected to be slow?
18:43:26 <tmckay> alright, wonderful.  I'll take a look through current blueprints, bugs, roadmap, etc
18:43:39 <SergeyLukjanov> MikeSpreitzer, sure
18:43:55 <SergeyLukjanov> MikeSpreitzer, in heat you can specify scheduler_hints
18:44:01 <SergeyLukjanov> like we're doing it in savanna now
18:44:25 <SergeyLukjanov> smth like "don't setup this instance on host X, Y, Z"
18:44:47 <SergeyLukjanov> correction: on host where instance X, Y, Z are running
18:44:59 <SergeyLukjanov> and we need IDs of instances
18:45:13 <SergeyLukjanov> in heat it'll generate dependenciesbetween instances
18:45:35 <SergeyLukjanov> and each new instance will wait for active state of prev. to take ID
18:45:50 <MikeSpreitzer> so the template asks for a chain of VMs, each not on any of the hosts used for earlier VMs, is that it?
18:46:02 <MikeSpreitzer> ah, it's startup that is slow
18:46:07 <SergeyLukjanov> we'are not check it atm, but it was confirmed but heat folks
18:46:09 <MikeSpreitzer> because it's linear
18:46:20 <SergeyLukjanov> exactly!
18:46:24 <MikeSpreitzer> got it, thatnks
18:46:26 <MikeSpreitzer> thanks
18:46:27 <SergeyLukjanov> np
18:46:58 <MikeSpreitzer> it's also not small, template size is quadratic in number of slaves
18:47:16 <dmitryme> yep, it is true
18:47:19 <SergeyLukjanov> I hope that it probably could be improved in heat due the fact that ID available right after the instance creation response received
18:48:03 <MikeSpreitzer> yes, it should only have to wait for ID.  But even that is dismaying for a linear arrangement.
18:48:44 <SergeyLukjanov> MikeSpreitzer, it's not bad
18:48:59 <SergeyLukjanov> because id is available after sending instance creation request
18:49:22 <dmitryme> our old pre-Heat code launched instances linearly and it worked pretty fast
18:49:30 <SergeyLukjanov> in savanna we're creating instances linearly
18:49:32 * tmckay has to drop again, I'll check the log
18:49:44 <SergeyLukjanov> tmckay, have a good day
18:49:53 <SergeyLukjanov> and it setups 200 node cluster in 5 mins
18:49:59 <dmitryme> the launch of 200-node cluster took around 5 minutes
18:50:17 <dmitryme> and only part of that time was launching instances
18:50:29 <SergeyLukjanov> 50-50 I think
18:50:39 <dmitryme> I believe it was not more around 1 minute
18:50:53 <dmitryme> * just around 1 minute
18:51:56 <MikeSpreitzer> that's pretty good
18:52:05 <MikeSpreitzer> you've got an unusually non-broken OpenStack installation
18:52:14 <MikeSpreitzer> :-)
18:52:25 <aignatov> MikeSpreitzer: lol!
18:52:32 <dmitryme> :-) not exactly, we fix it after each second launch
18:52:41 <MikeSpreitzer> oh
18:53:08 <SergeyLukjanov> yeah, that's the dark side of this test :)
18:53:11 <SergeyLukjanov> btw http://logs.openstack.org/06/60306/1/check/check-tempest-dsvm-savanna-neutron/3f1d7d1/logs/screen-savanna.txt.gz
18:53:37 <SergeyLukjanov> ^^ savanna screen logs from the first correctly working d-g job
18:53:48 <ruhe> hooray!
18:55:04 <dmitryme> yep, that is cool
18:55:29 <SergeyLukjanov> anything more to discuss?
18:55:41 <SergeyLukjanov> out timeslot ends in 5 mins
18:56:22 <SergeyLukjanov> ok, let's end it
18:56:28 <SergeyLukjanov> thank you all guys
18:56:36 <SergeyLukjanov> #info JFYI you can always use openstack-dev@lists.openstack.org mailing lists and #savanna irc channel to find us and ask your questions
18:56:39 <SergeyLukjanov> #endmeeting