21:00:13 <oneswig> #startmeeting scientific-sig
21:00:14 <openstack> Meeting started Tue Jan  8 21:00:13 2019 UTC and is due to finish in 60 minutes.  The chair is oneswig. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:18 <openstack> The meeting name has been set to 'scientific_sig'
21:00:29 <oneswig> I even spelled it right first time
21:00:40 <oneswig> Hello SIG
21:01:01 <oneswig> #link agenda for today https://wiki.openstack.org/wiki/Scientific_SIG#IRC_Meeting_January_8th_2019
21:02:58 <oneswig> I'm hoping this year to revive one or two of our oft-discussed activities
21:03:22 <janders> g'day oneswig :)
21:03:32 <janders> Denver CFP open - exciting! :)
21:03:32 <jmlowe> Hello everybody, happy new year
21:03:32 <oneswig> janders: happy new year!
21:03:43 <oneswig> Hi jmlowe, same to you
21:03:45 <janders> Happy New Year 2019 to you guys! :)
21:04:11 <oneswig> Should be an interesting one
21:04:33 <janders> indeed! :)
21:04:39 <oneswig> jmlowe: Are you hosting the LUG again this year?
21:04:45 <jmlowe> I believe I still owe janders a couple of emails
21:04:54 <jmlowe> I don't know
21:05:43 <oneswig> Some of our team here rightly made the point that we've talked a lot about better Lustre support and have yet to do anything about it.
21:05:45 <jmlowe> Looks like Houston
21:06:03 <oneswig> Ah, thanks for checking
21:06:11 <jmlowe> so we probably have people involved, but not on campus like 2017
21:06:46 <oneswig> janders: there was somebody from Pawsey with a close interest on Lustre, do you remember their details?
21:08:26 <oneswig> Our company has a team design summit at the end of this week, I'm hoping we can help generate a spec proposal.  Would be good to understand more about use cases for that
21:08:41 <janders_> sorry, I got kicked out for some reason
21:08:59 <janders_> did my question about Lustre-GPFS approach make it or was it lost?
21:09:00 <oneswig> hey janders_, but you gained an underscore on the way back in :-)
21:09:02 <martial__> (by the end of the year I will have 12 underscore at the end of that nick :) )
21:09:08 <oneswig> lost to me, sorry
21:09:10 <oneswig> hi martial__
21:09:15 <janders_> no worries
21:09:15 <oneswig> #chair martial__
21:09:16 <openstack> Current chairs: martial__ oneswig
21:09:31 <janders_> I was wondering if running Lustre via GPFS re-export could be of interest?
21:10:08 <janders_> I haven't done it myself but I've got another GPFS project going and some of the participants are praising GPFS ability to re-export other filesystems
21:10:09 <oneswig> yikes - could that work?  And should it?
21:10:34 <janders_> now GPFS seems to have heaps better OpenStack integration than Lustre (at least in some use cases)
21:11:03 <oneswig> If you've paid for GPFS, you might use it natively instead.
21:11:23 <janders_> I will probably test the current state of OpenStack-GPFS integration in the next month or two (I used it successfully in 2016 but not recently)
21:11:40 <oneswig> Interesting thought
21:11:53 <janders_> true, however i was thinking of a use case where there is a substantial amount of data already on Lustre
21:12:44 <oneswig> I had in mind Manila integration with Lustre - there are people with this use case I'm aware of.  I don't think the GPFS work covers that does it?
21:13:04 <janders_> no, I don't think it does Manila nicely at this point in time
21:13:19 <janders_> I used it for nova, glance and cinder back in the day, I think it can do object too
21:13:19 <jmlowe> I'm attempting to conjure Jonathan Mills, he's done a lot of work with gpfs and openstack at NASA
21:13:40 <oneswig> jmlowe: go for it :-)
21:14:26 <janders_> I will report back as I learn more about the current state of things with OpenStack and GPFS
21:14:33 <martial__> Magic Mike ;)
21:14:54 <jmlowe> Slightly related, Bob's last day at PSC is this week, he's leaving to go to NASA to work with Jonathan
21:15:14 <martial__> man, did not know ... good for him
21:15:17 <oneswig> Theres news - good luck to him
21:15:44 <oneswig> Who's going to look after Bridges?
21:15:48 <martial__> NASA is open?
21:16:13 <jmlowe> Not sure, the other systems guy and heir apparent is also leaving PSC this week
21:16:41 <jmlowe> NASA is openish, I don't think they can afford to idle the HPC machines
21:17:20 <martial__> make sense
21:17:28 <janders_> I just realised that what I said about GPFS&Manila is partly wrong:
21:17:31 <janders_> https://docs.openstack.org/manila/pike/contributor/gpfs_driver.html
21:17:39 <janders_> it does support manila, however through Ganesha
21:18:23 <oneswig> Good digging janders_
21:19:24 <oneswig> In the Lustre analogy, I'd love to see an Lnet router in place of Ganesha.  Would that work?
21:20:58 <oneswig> janders_: the equivalent page for queens & rocky is not present, does that mean something?
21:21:17 <jmlowe> I think it would, you'd have to write a driver for it
21:22:34 <jmlowe> other drivers fire up instances and export volumes over kernel nfs, so it stands to reason that the framework is fairly flexible
21:22:41 <oneswig> It looks like the config is still there for queens & rocky : https://docs.openstack.org/manila/rocky/configuration/shared-file-systems/samples/manila.conf.html
21:23:06 <oneswig> (gpfs)
21:23:34 <janders_> oneswig: from my experience, GPFS support is often a release or two behind
21:23:49 <janders_> however when I last deployed it, N-1 config happily worked in the N release
21:23:52 <jmlowe> I could see a driver that would fire up an instance and configure it as a lnet router
21:24:10 <janders_> I will test it with Queens in the near future and will report back how well or badly it works :)
21:25:17 <oneswig> I think this is the person from Pawsey I was looking for: https://www.mail-archive.com/lustre-discuss@lists.lustre.org/msg15189.html
21:26:04 <oneswig> #action oneswig to revive discussion on Lustre + Manila with Andrew Elwell
21:26:30 <oneswig> OK - move on?
21:27:54 <oneswig> #topic conferences and CFPs
21:28:08 <oneswig> Tim Randles reminded me
21:28:20 <oneswig> When the summit goes to Denver
21:28:31 <jmlowe> re: gpfs and openstack "It works!" - Jonathan Mills
21:28:42 <oneswig> thanks jmlowe!
21:28:47 <janders_> what talks/topics would you guys be interested it?
21:28:49 <janders_> thanks mate! :)
21:29:07 <janders_> what versions of GPFS and OpenStack is Jonathan referring to? Would be great to know :)
21:29:37 <oneswig> When the summit goes to Denver Tim's looking to organise a post-summit trip to the baseball for SIG members
21:29:38 <janders_> Denver CFP... what topics/talks would you guys like to see? :)
21:30:13 <jmlowe> conference call is preventing his attendance today
21:30:14 <oneswig> (but with people buying their own tickets, mind)
21:30:32 <jmlowe> I'm in for baseball
21:30:53 <oneswig> jmlowe: Tim said to mail him @gmail with your interest
21:31:20 <oneswig> Unfortunately I must leave promptly and can't stay for the game, much though I'd like to.
21:31:28 <jmlowe> I'm interested in gpu's and AI use cases, scientific computing uses of storage
21:31:29 <oneswig> I've heard it's just like cricket
21:31:49 <martial__> seems right
21:32:27 <oneswig> janders_: I want to hear from anything that pushes the envelope for infrastructure and performance.
21:32:45 <jmlowe> general catch up on other people using openstack to service scientific computing
21:33:15 <oneswig> Are you track chairing perchance? :-)
21:33:29 <jmlowe> I could I suppose
21:33:40 <jmlowe> I should either serve or submit
21:34:08 <oneswig> I've not had the call this time round...
21:34:14 <jmlowe> I don't have any ideas for submissions right now so committee service it will probably be
21:35:13 <oneswig> I'd be interested to hear about people doing HIPAA, Fedramp, etc in production (nb, not just thinking about it)
21:35:22 <jmlowe> oh, that too
21:36:20 <jmlowe> how do you serve medical research use cases while protecting varying degrees of ephi
21:36:59 <oneswig> They are apparently the majority of the SIG (although none are apparently present today...)
21:37:54 <oneswig> That's good food for thought.  We should all submit talks to enrich the track
21:38:05 <janders_> +1! :)
21:38:23 <oneswig> jmlowe: Are you planning to go to Lugano this year?
21:39:14 <oneswig> martial__: given the emphasis on containers last year, this could be a good one for DataMachines (although are you international?)
21:39:39 <oneswig> #link HPCAC CFP http://hpcadvisorycouncil.com/events/2019/swiss-workshop/submissions.php
21:40:51 <oneswig> I don't see anyone online within 6 timezones of London so I'll skip that one.
21:41:01 <jmlowe> No plans as of right now, usually the director level attend unless there is a specific topic that has been invited.
21:42:13 <jmlowe> I would like to catch up on what CSCS and Switch have been up to over the past couple of years
21:43:22 <oneswig> Too bad you weren't in Berlin, we were all in a log cabin themed restaurant :-)
21:44:13 <jmlowe> :/
21:44:22 <jmlowe> No broken legs?
21:45:06 <oneswig> It was all "simulated"...
21:45:37 <jmlowe> 2 different SC attendees broke their tibias a few hours after I had spoken with them
21:45:56 <oneswig> jmlowe: anger management course needed perhaps?
21:46:08 <oneswig> "spoken"...
21:46:51 <martial__> that and bad drivers in Dallas we are told
21:46:57 <jmlowe> vehicle vs pedestrian and Blair's parkour could use some work
21:47:10 <oneswig> What are the Americas conferences coming up?  Is there a CFP for the NSF conference?
21:48:13 <jmlowe> most of the nsf resource providers will be here https://www.pearc.org/
21:48:14 <jmlowe> Chicago this yar
21:48:15 <jmlowe> year
21:48:58 <oneswig> Are you going?
21:49:14 <jmlowe> I don't see how I can't
21:50:55 <oneswig> #topic AOB
21:51:12 <janders_> going back to the manila topic:
21:51:42 <janders_> I wonder if it is possible to take a slightly more generic approach to RDMA filesytems
21:52:00 <janders_> so that we can do Lustre, BeeGFS, maybe GPFS-native through Manila
21:52:42 <oneswig> janders_: it does make sense that there are some common challenges.  Quite a few differences too though.
21:53:02 <janders_> at the end of the day, if the implementation involves spinning up dual-homed storage router instances, there might be enough overlap to support this approach
21:53:15 <oneswig> But I do agree, if something was to be created, we wouldn't want a vendor to make it exclusive to one technology
21:54:17 <janders_> what's your feel regarding Thinkparq's interest in OpenStack integration?
21:54:28 <janders_> (of BeeGFS)?
21:55:05 <janders_> do you think they might be happy to get some of their guys to work on it or is it more like "if the community does the work, we'll help them out a bit"?
21:56:20 <oneswig> I don't know
21:56:36 <oneswig> I know they are enthusiastic for OpenStack support
21:56:51 <oneswig> but I am not sure what they can commit themselves.
21:57:10 <janders_> ok!
21:57:45 <oneswig> I think they'll do what they can to help.  I don't know what that means.
21:57:45 <janders_> I will ponder this topic a bit more
21:58:09 <oneswig> We are nearly at the hour
21:58:14 <janders_> we're in regular touch with Thinparq regarding our BeeGFS work
21:58:21 <oneswig> jmlowe: wanted to ask, how is Jetstream?
21:58:45 <janders_> I will bring this up when the time is right (I want them focused on the scratch filesystem for now :)
21:58:52 <oneswig> janders_: I expect you know much more than I do then
21:58:58 <oneswig> I only see them at conferences
21:59:15 <janders_> unfortunately not on this topic (at least not yet)
21:59:53 <janders_> thanks for the chat guys!
21:59:55 <janders_> have a good one
22:00:01 <oneswig> time to close, thanks all
22:00:03 <janders_> all the best in the New Year 2019! :)
22:00:09 <janders_> it'll be an exciting one
22:00:26 <oneswig> janders_: no fate but what we make :-)
22:00:29 <oneswig> #endmeeting