21:00:19 <oneswig> #startmeeting scientific-sig
21:00:20 <openstack> Meeting started Tue Jun  9 21:00:19 2020 UTC and is due to finish in 60 minutes.  The chair is oneswig. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:23 <openstack> The meeting name has been set to 'scientific_sig'
21:00:29 <oneswig> Hello!
21:00:46 <oneswig> #link Today's agenda https://wiki.openstack.org/wiki/Scientific_SIG#IRC_Meeting_June_9th_2020
21:02:07 <oneswig> I have a challenging bit of AOB, wrt Ceph Octopus
21:03:49 <b1airo> hi!
21:03:59 <oneswig> Hi b1airo, how's things?
21:04:09 <martial> on irc, yes :)
21:04:17 <oneswig> #chair b1airo martial
21:04:18 <openstack> Current chairs: b1airo martial oneswig
21:04:25 <janders> g'day guys!
21:04:30 <oneswig> Hi janders
21:05:04 <b1airo> good thanks oneswig - i come to you live from an actual room based office... as opposed to the loosely converted garage i've been using for the previous 18 months
21:05:25 <martial> imagine all the toys he must have had in that garage :)
21:05:45 <oneswig> Still in the Christchurch area?
21:05:53 <b1airo> toys ~= cr@p ?
21:06:23 <trandles> LOL I've been at our dining room table since mid-March. Not like we need it for a party or anything.
21:06:35 <b1airo> yep, just down the hill a bit from where we were - another house built by my old man
21:06:54 <b1airo> trandles: :-(
21:07:00 <janders> nice!
21:07:06 <trandles> Hi b1airo
21:07:09 <b1airo> heaps of parties in NZ now :-P
21:07:32 <trandles> Like you in NZ need an excuse
21:07:45 <oneswig> Must be a hard life b1airo
21:08:06 <oneswig> What precautions remain in place?  I'm assuming it's not completely back to normal
21:08:07 <b1airo> hobbits are shocking after a couple of meads
21:09:26 <b1airo> just border restrictions
21:09:48 <janders> I suppose us Aussies can drop in for a visit soon, just gotta get our state governments get their border story straight first :)
21:10:02 <oneswig> What's NZ like without all the teenagers on gap year?  Pretty quiet I imagine.
21:10:25 <janders> ...and no noisy Aussie tourists...
21:10:30 <b1airo> haha
21:10:46 <b1airo> i'm looking forward to a queue free ski season
21:11:38 <b1airo> but yes, will be good to catch up with the aussies once the whole travel bubble thing gets sorted
21:13:01 <b1airo> anyway, what did i miss at the PTG? sorry about being awol for that :-/ ! i only realised the timing on the weekend prior and then got totally distracted with settlement, moving, cleaning etc
21:13:05 <oneswig> Guess we should talk over the PTG.  Thanks to everyone who came along.
21:13:36 <martial> Kendall sent me a link to the recordings
21:13:53 <oneswig> The first session went well but we didn't have much more to cover in the second.
21:14:33 <oneswig> #link PTG session Etherpad https://etherpad.opendev.org/p/victoria-ptg-scientific-sig
21:15:25 <martial> well we got an interesting demo in the second one
21:16:17 <oneswig> I think the "bring a problem, share a solution" format seemed to go well
21:16:29 <diurnalist> I think that was one action item for me (jason btw, I have a bit of a split personality w/ aliases)-- to open-source some of our Jupyter-specific things, like the Keystone authenticator
21:16:43 <diurnalist> and share them w/ y'all
21:16:54 <oneswig> Hi Jason, welcome back :-)
21:17:08 <oneswig> Would be good to see that, for sure.
21:17:13 <diurnalist> yes, apologies for being late
21:17:35 <oneswig> no worries, what time is it anyway :-)
21:17:52 <b1airo> that's the Keystone authenticator for JupyterHub ?
21:18:27 <diurnalist> b1airo: yes - it allows logging in via Keystone and storing a Keystone access token on the auth info, so you can e.g. drop it in a environment for the user
21:19:02 <b1airo> ahh nice. i was going to ask what it does other than logging in :-)
21:19:23 <diurnalist> oneswig: a much more reasonable time for me over here
21:19:31 <b1airo> is it used to provision the single user server infrastructure too?
21:20:09 <oneswig> BTW I heard recently that Grafana 7 has (finally) added a pluggable authentication framework, improving the prospects for Keystone authentication to Grafana.
21:20:14 <diurnalist> b1airo: yes, we use it so users get their own environment (a Docker container in our case), which has all the OpenStack clients built in. our users often use openstack clients in notebooks
21:20:40 <diurnalist> oneswig: that is interesting and overdue :)
21:21:23 <oneswig> Absolutely.  Monasca has been using a fork of a 4.x Grafana and I'm hopeful that a better system will come of this.
21:21:29 <diurnalist> don't mean to hijack the discussion, but oneswig: you might have insights onto the monasca/grafana integration. i'd be curious if it's going to be mainlined together
21:21:32 <diurnalist> aha
21:21:45 <diurnalist> i will follow that development :)
21:23:41 <oneswig> diurnalist: I'm hoping that someone will create a plugin for Grafana 7 and that will resolve it.
21:24:09 <b1airo> so the new thing is that there's a way to build your own open plugins?
21:24:36 <oneswig> yes, from what I've heard.
21:25:24 <oneswig> hardly revolutionary, but good all the same.
21:26:00 <oneswig> Let's look through the etherpad and note all the actions
21:26:27 <oneswig> #action SIG meeting on contact tracing applications
21:26:59 <oneswig> #action Organise session with Manila team
21:27:07 <martial> " invite Manila / Ganesha people to one of our IRC meeting"
21:27:23 <martial> (doh too late)
21:27:32 * gouthamr hi!
21:27:49 * gouthamr is a manila/ganesha person, reading scrollback
21:28:10 <oneswig> Hi gouthamr, ears burning :-)
21:28:16 <martial> hello gouthamr :)
21:28:48 <oneswig> We've got on our list a follow-up discussion on the state of play with Manila and Ganesha
21:29:36 <martial> #action follow-up session on CentOS 8 experiences
21:30:12 <diurnalist> there is also a TODO in the etherpad to schedule a SIG to discuss IoT research enablement. it was not bolded as with the others
21:30:35 <gouthamr> hey oneswig martial! glad you're considering using manila with cephfs-nfs, i see tbarron was on your etherpad - we can def connect you to cephfs folks; do let us know :)
21:30:42 <martial> #action schedule a SIG discussion on IoT research enablement
21:30:55 <martial> thanks Jason
21:30:59 <oneswig> Thanks gouthamr, got you in my sights!
21:31:17 <oneswig> What timezone are you in?
21:34:02 * vkmc is manila/ganesha too
21:34:04 <vkmc> nice!
21:34:11 <oneswig> It's probably worth an updated session on billing and CloudKitty as well, there were a few folks interested in that.
21:34:28 <gouthamr> oneswig: UTC-8
21:35:31 <oneswig> Thanks gouthamr, that makes you a better fit for our 2100UTC slot than 1100UTC, right?
21:37:25 <oneswig> #action update on billing and CloudKitty
21:37:44 <oneswig> Were there any other actions we should follow up on?
21:38:58 <oneswig> Ok, lets move on
21:38:59 <gouthamr> oneswig: yep :)
21:39:02 <oneswig> #topic AOB
21:39:16 <oneswig> I've been using Ceph Octopus this week.
21:40:35 <oneswig> Quite an adjustment - almost deliberately it's hard to use previous tools for managing Ceph.
21:40:46 <oneswig> Anyone else been there yet?
21:41:44 <janders> not yet
21:42:00 <janders> what would be the top 3 differences?
21:42:01 <b1airo> can't turn off cephadm?
21:42:18 <martial> same would like to understand the pros and cons
21:42:36 <oneswig> I'm not sure if you can turn it off.  I'd probably choose to based on the pain of adjustment.
21:43:38 <oneswig> So everything's containerised, even the ceph commands - you run a container for the command.  So all the commands start out with a 'cephadm shell -- ...' prefix.
21:44:21 <b1airo> i haven't been paying close attention, but a brief read of the release notes suggests they're attempting to hide complexity and make things simpler to manage, but with that comes less choice
21:44:22 <oneswig> The ceph.conf is minimal and all config is slurped into Ceph's internal state
21:45:18 <oneswig> There's no Ansible to manage Octopus yet (and I'm not sure it'll ever be the standard), so everything had to be done by hand.
21:45:31 <b1airo> sounds like it would be a nicer greenfields experience at least, the though of upgrading makes me pucker though
21:45:46 <oneswig> I inadvertently restarted dockerd and it got into a proper state.
21:46:34 <oneswig> There's some new cleverness though - the PG counts keep going up and down in a smooth ballet of technology
21:46:41 <janders> it sounds a bit like switching from uncontainerised OSP10 to containerised OSP13
21:46:53 <janders> uh... where's *everything* ? :)
21:47:11 <oneswig> janders: I'm feeling that, to a degree.
21:48:12 <oneswig> There was a maddening issue that containers are running with --rm flag, so they disappear on exit.  I couldn't find where my monitors had gone for a couple of fun hours.
21:48:33 <oneswig> my, how I laughed.
21:48:52 <b1airo> ah the lols
21:49:32 <martial> lol indeed
21:49:46 <b1airo> i see a couple of nice base improvements:
21:49:46 <oneswig> The PG thing I am sure is a genuine improvement.
21:49:48 <b1airo> "Objects can now be brought in sync during recovery by copying only the modified portion of the object, reducing tail latencies during recovery."
21:50:06 <b1airo> "Ceph will allow recovery below min_size for Erasure coded pools, wherever possible."
21:50:57 <oneswig> b1airo: is Monash still one of the biggest in the southern hemisphere?
21:52:23 <oneswig> I think octopus can be managed in standard configuration frameworks again, it'll be a significant improvement.
21:52:24 <b1airo> so far as i know yes. though if they've added any more capacity since my departure then I think it would have just been another rack of the last order (Dell R740XDs)
21:52:49 <b1airo> RBD: "Images can be online re-sparsified to reduce the usage of zeroed extents."
21:53:35 <b1airo> some nice RGW additions too
21:53:51 <oneswig> Interesting how M3 went from 3 vendors to one for GPU, NIC and switches.
21:55:24 <b1airo> :-)
21:56:05 <b1airo> there are DGX's in it too, so can count some of the boxen as NVIDIA as well
21:56:10 <oneswig> They must have liked what they saw.
21:56:54 <oneswig> Nearly out of time.  Any further confessions to make this week?
21:57:51 <martial> a quick not to mention that christian Kniep is holding HPCWW remotely this year
21:58:00 <martial> and he still has a few slots to fill
21:58:17 <oneswig> Ah - remote ISC.
21:58:37 <martial> Details at http://qnib.org/isc/ for those interested
21:58:49 <oneswig> Thanks martial
21:58:54 <janders> remote conferencing is interesting challange
21:58:55 <b1airo> nothing specific from me other than some curiousity to touch base on Jetstream2 and where janders is at with his SuperCloud concept. we're looking at refresh of our "capacity" infrastructure next year, so planning for what it looks like is underway now
21:59:01 <janders> I'd call it "distributed jet lag"
21:59:54 <oneswig> b1airo: on that tasty snippet, 1 minute to go...
22:00:10 <janders> thanks all!
22:00:18 <oneswig> Thanks everyone
22:00:19 <b1airo> yeah - TBC
22:00:24 <b1airo> o/
22:00:24 <oneswig> #endmeeting