21:00:37 <oneswig> #startmeeting scientific-sig
21:00:39 <openstack> Meeting started Tue Mar 30 21:00:37 2021 UTC and is due to finish in 60 minutes.  The chair is oneswig. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:40 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:42 <openstack> The meeting name has been set to 'scientific_sig'
21:00:49 <oneswig> greetings
21:01:34 <oneswig> alas no agenda has been set but it would be good to discuss PTG activities
21:02:36 <oneswig> Apologies - I'm not sure I'll stay for the full hour - clocks have changed here and it's getting a little late
21:03:42 <oneswig> #topic PTG planning
21:03:49 <martial> great topic!
21:03:53 <oneswig> We don't have days or times booked yet (but there's space)
21:03:57 <oneswig> hi martial
21:04:02 <oneswig> #chair martial
21:04:03 <openstack> Current chairs: martial oneswig
21:04:40 <martial> I did see the email about the PTG
21:05:05 <martial> I do like the idea of the Lighting talks being recorded
21:05:20 <oneswig> Right, I think it would be good too
21:05:42 <oneswig> We just need people to stump up talks in a year where not many conference presentations are happening :-)
21:06:05 <martial> this will give people an incentive to share content independently; especially if we can split the video for people to share them
21:06:55 <julianp> What sort of lightning talks are in scope?
21:07:05 <oneswig> Good idea
21:07:20 <oneswig> julianp: anything goes, provided it's broadly on theme
21:07:51 <martial> keyword: openstack, hpc, ... ?
21:08:03 <julianp> Righto.
21:09:08 <oneswig> julianp: I'm sure you've got something up your sleeve that would be good.  Previously the talks were ~3 minutes, possibly 5 minutes.  5 minutes seems about right.
21:10:43 <oneswig> What's the best means of recording?  I know Zoom is problematic for some
21:11:07 <martial> I can host a google meet, just like last time
21:11:41 <oneswig> You've got the record option?  That would be great.
21:12:45 <martial> yes Sir, I was checking, it exports to mp4
21:13:07 <martial> I just need to host the meeting basically
21:13:19 <oneswig> If you don't mind doing the editing, I think that would work very well.
21:13:36 <martial> should be easy, I have a Mac
21:14:15 <martial> Actually I can just stop the recording in between lighting talks
21:14:29 <martial> so we get separate files per presenters
21:15:31 <oneswig> That seems straightforward - hopefully google does it that way
21:15:31 <julianp> So checking - every working group arranges their own logistics?
21:15:43 <martial> how many people do we expect? I like the 10 minutes presentation, 4 minutes question, 1 minute transition
21:15:50 <oneswig> For the PTG, yes, we ask for slots that suit our plans.
21:16:11 <oneswig> martial: seems fair.
21:16:48 <oneswig> In previous virtual PTG sessions, we've done two shorter sessions to span the most timezones.
21:17:48 <martial> it seemed to work fine too
21:21:29 <oneswig> martial: shall I bag a US-morning and US-afternoon slot for us?  If they are far enough apart it will also cover EMEA and APAC
21:21:51 <martial> I would think that would work for most people
21:22:16 <oneswig> OK will do
21:22:30 <oneswig> #action oneswig to book two sessions for PTG
21:24:55 <martial> is there a preferred day?
21:24:59 <oneswig> Hmmm the ethercalc sign up is saying "502 bad gateway"...
21:26:24 <oneswig> martial: no strong preference, how about you?
21:26:42 <martial> checking the PTG dates quickly
21:27:02 <martial> April 19-23
21:27:02 <b1airo> g'day folks. just ducking in to say hello - in a meeting though
21:27:10 <martial> Hi Blair
21:27:22 <oneswig> hi b1airo
21:27:25 <oneswig> #chair b1airo
21:27:26 <openstack> Current chairs: b1airo martial oneswig
21:28:04 <b1airo> hi oneswig martial , hope you're keeping well!
21:28:28 <martial> how about 21 or 22?
21:28:40 <oneswig> Surviving thanks.  Although I think I may turn in shortly.  The time zones changed and today's been a long one
21:29:02 <oneswig> What's new with you b1airo?
21:29:29 <oneswig> martial: those days equally good for me.
21:29:38 <julianp> Ditto.
21:29:52 <b1airo> new... hmm - i've been in auckland for a week working on our RFP - getting to the pointy end
21:29:53 <martial> I am thinking "middle of the week" this way
21:30:29 <b1airo> Easter long weekend here, i'm away Thurs-Tues - woo!
21:30:29 <oneswig> According to my calendar April 21 is the Queen's birthday.  Just saying.
21:30:38 <oneswig> Nice!
21:30:44 <b1airo> then back up to Auckland straight away :-)
21:31:00 <oneswig> You flying b1airo?  I remember doing that.
21:31:08 <b1airo> sadly i missed the yacht racing in person here, but still a bunch of superyachts hanging around the harbour
21:31:09 <martial> 20 or 22 then?
21:31:23 <oneswig> martial: 21st is fine :-)
21:31:33 <oneswig> I doubt she'd have come anyway
21:31:51 <martial> is it a day off?
21:32:24 <julianp> b1airo: I met your acquaintance Sam Morrison yesterday. I told him about the SIG Slack. Does he know about the PTG?
21:32:54 <oneswig> no, not a day off
21:33:02 <oneswig> b1airo: who won?  Dare I ask?
21:33:04 <b1airo> hey julianp . yeah Sam has attended PTGs in the past, and the SIG meetings
21:33:20 <julianp> Righto.
21:33:44 <b1airo> good idea to pass him a direct Slack link though, suspect that has passed him by
21:35:03 <b1airo> he was previously involved in the operators forums and large scale work, has been mostly focused on technical side as opposed to user committee stuff like the SIG
21:36:15 <b1airo> who won oneswig !? us, of course! ;-)
21:36:45 <julianp> b1airo: Sounds like they might be looking at CloudKitty for usage tracking. Probably a bit early, but there might be lightning talk there.
21:37:13 <julianp> ... if they get around to testing it at scale.
21:37:22 <b1airo> yeah he mentioned some movement towards at least some kind of showback mechanism
21:37:23 <julianp> (and by 'they' I mean Nectar cloud folks)
21:37:42 <oneswig> b1airo: gah, shoulda known, well done NZ
21:39:49 <oneswig> julianp: did you pass on a Slack link to Sam?
21:40:05 <julianp> I just did.
21:41:20 <oneswig> OK great
21:44:00 <julianp> Anything else before oneswig runs away?
21:44:18 <oneswig> I'm catching up on Americas cup footage now...
21:44:18 <martial> I think we have a tentative plan for the PTG
21:44:20 <b1airo> anyone run their hypervisor stack on a bluefield NIC yet :troll:
21:44:26 <martial> that was the core item here
21:45:33 <b1airo> i probably missed the PTG plan bit - you mean a SIG agenda for the PTG?
21:45:44 <oneswig> b1airo: On the Mellanox NIC front we did manage to get this blog out this week https://www.stackhpc.com/vflag-kayobe.html
21:46:22 <b1airo> oh nice oneswig - i was just reviewing the Mellanox VF-LAG docs yesterday
21:46:38 <oneswig> you found some? :-)
21:46:52 <oneswig> It's lightly documented...
21:47:45 <oneswig> The blog doesn't have specific performance in it - I have requested to include the data.
21:48:24 <b1airo> standard Mellanox approach really... here's how you do it by hand on an older OS that we tested this on once, none of this is permanent and you need to touch device files and driver config, doing that persistently is left as an exercise for the reader
21:48:41 <b1airo> requested from Mellanox or your customer?
21:49:10 <oneswig> Customer in this case.  Get it working and one VM can hit just under 100Gb/s
21:49:59 <b1airo> in theory a single VM should be able to do that if you are using a HDR NIC though right?
21:50:13 <b1airo> did you test failover?
21:50:46 <oneswig> The first bottleneck is the PCIe gen 3 bus on the servers we had.  Failover works but I didn't test it under full load
21:51:45 <b1airo> cool. did you test failover with an RDMA based workload?
21:52:42 <oneswig> RDMA was mostly out of scope.  Will get a better chance for that on a current project.
21:58:31 <martial> okay reaching the top of the hour
21:58:45 <martial> Thanks everyone for coming :)
21:59:02 <julianp> :thumbs-up: Till next time.
21:59:15 <martial> #endmeeting