21:02:01 <b1airo> #startmeeting scientific-wg
21:02:02 <openstack> Meeting started Tue May 31 21:02:01 2016 UTC and is due to finish in 60 minutes.  The chair is b1airo. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:02:07 <openstack> The meeting name has been set to 'scientific_wg'
21:02:11 <b1airo> #chair oneswig
21:02:12 <openstack> Current chairs: b1airo oneswig
21:02:20 <oneswig> Thank you sir!
21:02:21 <b1airo> morning
21:02:23 <oneswig> evening
21:02:27 <b1airo> :-)
21:02:31 <leong> hi
21:02:44 <b1airo> hi leong
21:02:47 <oneswig> Hi Leong
21:03:05 <b1airo> hi LyleWinton
21:03:16 <LyleWinton> hey Blair
21:03:37 <oneswig> Hi Lyle
21:03:59 <LyleWinton> Stig?
21:04:03 <oneswig> The same!
21:04:10 <LyleWinton> Hi!
21:05:38 <b1airo> ok, let's get into it then
21:06:00 <b1airo> quick roll call...
21:06:07 <oneswig> here
21:06:09 <leong> o/
21:06:22 <craigs> here
21:06:28 <LyleWinton> here
21:06:35 <b1airo> (if for nothing more than to get the meetbot stats up ;-) )
21:06:51 <oneswig> +1 :-)
21:06:54 <anteaya> an important stat
21:07:17 <b1airo> leong, craigs - would you please remind me of your names so I can try to recall?
21:07:42 <leong> leong from Intel
21:07:42 <craigs> Craig Sterrett
21:07:47 <craigs> from Intel
21:07:51 <leong> Yih Leong Sun :)
21:08:00 <b1airo> actually i should probably check irc before asking (sorry) ...
21:08:27 <b1airo> thanks!
21:09:07 <b1airo> #topic User Stories
21:09:14 <anteaya> do we have an agenda?
21:09:24 <oneswig> We do, bear with me...
21:09:28 <anteaya> might we link to the agenda if we have one?
21:09:32 <b1airo> yes: #link https://wiki.openstack.org/wiki/Scientific_working_group#IRC_Meeting_May_31st_2016
21:09:32 <anteaya> oneswig: thanks
21:09:39 <anteaya> wonderful thank you
21:09:43 <oneswig> Got there first b1airo!
21:10:07 <b1airo> had it open
21:10:16 <anteaya> :)
21:10:25 <oneswig> OK, first item under user stories was the idea of creating a whitepaper describing the current position on OpenStack and HPC
21:11:09 <rockyg> o/
21:11:19 <oneswig> There is interest in creating this in a similar form to the previous papers on OpenStack and containers (for example)
21:11:27 <b1airo> yes, so perhaps you can remind us of the approach you're talking with the cambridge paper oneswig ?
21:11:54 * b1airo admits he hasn't read one of those papers
21:12:03 <oneswig> OK, so the background is I have a contract with Cambridge Uni to deliver a very similar study for informing their purposes
21:12:31 <rockyg> cool
21:12:44 <b1airo> and by the way, still happy to contribute to that if we can do so usefully
21:12:49 <oneswig> And the plan is to extend that paper with further contribution, reshape it and improve it and then work with th eFoundation to shape it to their needs
21:13:09 <oneswig> b1airo: thanks, looking forward to that, will be in touch...
21:13:17 <anteaya> what needs does the foundation have here?
21:13:34 <anteaya> the user stories are for the scientific working group's consumption I had thought
21:13:36 <b1airo> glossary brochures by the sound of it :-)
21:13:37 <leong> oneswig can you share the whitepaper/sutdy with cambridge?
21:13:47 <anteaya> b1airo: can't have too many of those
21:14:04 <oneswig> anteaya: I'd say it's for anyone but the Scientific WG members
21:14:13 <oneswig> In the sense that that would be preaching to the choir
21:14:31 <oneswig> It's aim I think is to be outreach for organisations that could be considering this option
21:14:32 <anteaya> oneswig: oh I mis-understood then
21:14:38 <LyleWinton> agree with oneswig
21:14:46 <b1airo> but you make a good point anteaya - the User Stories we want to define should be from the user base of the scientific-wg
21:14:50 <leong> I think it will be great to produce a whitepaper talking about how OpenStack can support the HPC use case
21:15:16 <LyleWinton> Was the most frequent question after the scientific clouds panel in Austin, HPC and OS.
21:15:20 <anteaya> b1airo: yes that was what I had thought I heard from the beginning
21:15:30 <b1airo> yeah, there's a big gap there - we should simply create a wiki.o.o/HPC in the mean time
21:15:43 <anteaya> LyleWinton: what was the most frequent question?
21:16:08 <b1airo> "Can I do HPC with/on OS?"
21:16:14 <LyleWinton> anteaya: questions regarding HPC and OS.
21:16:31 <anteaya> LyleWinton: right
21:16:47 <anteaya> yes, that was what I had thought
21:16:56 <anteaya> I just wonder where the foundation needs got in there?
21:16:57 <oneswig> The interesting item to discuss for this WG is what members of this group might be able to contribute as material that exemplifies how OpenStack can be configured to deliver HPC
21:17:16 <b1airo> to which the answer is "yes, for some definitions of HPC and OS"
21:17:49 <oneswig> b1airo: Right, but lets say the document sticks some stakes in the ground (helping to skirt that tar pit!)
21:18:05 <anteaya> b1airo: awesome and the user stories provide the definitions and examples, yeah?
21:18:41 <b1airo> anteaya, i guess that would be ideal - but we need to define those...
21:19:10 <anteaya> okay thanks
21:19:18 <oneswig> I'm intending to produce with Cambridge a document that describes in some technical depth how a series of capabilities are delivered on OpenStack and introduce case studies and input from project leaders to reinforce
21:19:47 <anteaya> oneswig: can that be open sourced and considered a user story?
21:19:54 <b1airo> oneswig, by project leaders i guess you mean science projects that use the infrastructure
21:20:16 <oneswig> yes and yes, that's what I menat :-)
21:20:26 <anteaya> oneswig: awesome!
21:20:37 <anteaya> I think that will make a great user story
21:20:59 <anteaya> and help drive the conversation in this space when you lead by example
21:21:08 <oneswig> There would be a varying degree of reworking by the Foundation to make it into a freestanding whitepaper - or perhaps a set of connected chapters
21:21:13 <LyleWinton> I have a slide (as of last night) on clusters/HPC cases in the NeCTAR research cloud.  11 specific cases I could follow up in more detail if needed.
21:21:34 <anteaya> oneswig: 'reworking by the Foundation' what do you mean?
21:21:38 <oneswig> LyleWinton: that's exactly the kind of material that would be help
21:22:06 <LyleWinton> b1airo happens to be one of them ;)
21:22:16 <oneswig> anteaya: I don't think anything i can produce matches the technical material the Foundation can produce, it'll need some polishing without doubt
21:22:24 <anteaya> oneswig: as long as you have a licence on it that is one of our accepted open source licences it should be good
21:22:33 <oneswig> ASL2?
21:23:02 <anteaya> oneswig: ah let's not put the cart before the horse, I think if you open source what you produce for cambridge we can address any issues that arise
21:23:13 <anteaya> let's not create obstacles before you begin
21:23:20 <oneswig> Every deliverable for this project is open source - terms of the contract
21:23:31 <anteaya> oneswig: awesome, makes it easy then
21:24:11 <b1airo> so should we have a 5 minute brainstorm on what some of our User Stories might be?
21:24:22 <oneswig> Good idea
21:25:17 <LyleWinton> Other user stories do you mean b1airo:
21:25:40 <oneswig> One user story that is endless in its variation is cluster-as-a-service.  Is it possible to capture that in some constructive way and compare the ways?
21:25:46 <b1airo> #idea I want to give users an easy on-demand HPC platform
21:26:11 <b1airo> jinx oneswig
21:26:42 <b1airo> or perhaps from the user's perspective (i always think architect/operator) ?
21:27:25 <LyleWinton> oneswig: we have a number of operators re-using patterns (orchestration scripts) created by other operators for building clusters, and several are in production use.
21:28:53 <anteaya> what is your definition of cluster?
21:28:53 <oneswig> LyleWinton: that's useful information.  And another way of doing it too.  Vive la difference
21:28:56 <anteaya> is a cloud a cluster?
21:28:56 <b1airo> #idea I want to run my (persistent) HPC platform/service using OpenStack as the infrastructure provisioning system
21:29:10 <oneswig> anteaya: typically I'd say in scientific compute people would think of a workload manager queue system - typically SLURM
21:29:20 <anteaya> thanks
21:29:36 <LyleWinton> anteaya: these are mostly HPC like clusters, slurm or torque front ended.
21:29:52 <b1airo> anteaya, yes probably, but i think we're usually talking about HPCC (high performance cluster computing) when we say clusters - which means batch system and/or low-latency interconnect
21:30:38 <b1airo> good to see we all agree on that :-)
21:30:39 <LyleWinton> anteaya: but some of the users say "they aren't HPC" because they use general purpose cloud infrastructure. never stopped most researchers using the definition in the past, but it's a distinction
21:30:45 <oneswig> There's an open-ended discussion on how to count the ways, should we go onto idea 2?
21:30:58 <b1airo> please
21:31:04 <anteaya> thank you
21:31:21 <dfflanders> Perhaps in addition to this ideas for the use cases you would like to have, would be to approach contacts from around the community and ask them to put forward use cases?  See what arises from requesting use cases be put forward from well known scientific users like CERN, NASA, NSA, Cambridge, etc.
21:32:08 <oneswig> dfflanders: that's a good point
21:32:34 <b1airo> dfflanders, definitely - but part of the problem i think we want to get towards solving today is figuring out a few examples to set the scene, else it's very open ended
21:32:44 <dfflanders> +1
21:33:01 <b1airo> so i said: "I want to run my (persistent) HPC platform/service using OpenStack as the infrastructure provisioning system" as a possible #2. thoughts?
21:33:15 <oneswig> b1airo: how does OpenStack as an infrastructure provisioning system (idea 2) differ?
21:33:21 <dfflanders> going to the users with some exemplars you'd like to achieve is a good approach imho.
21:33:38 <oneswig> Is this "I submit a job to SLURM, SLURM uses OpenStack to create infrastructure to run the job"?
21:33:43 <b1airo> that's distinct from HPC-aaS because the end-user does not necessarily see cloud anywhere
21:34:25 <b1airo> oneswig, it could be that dynamic yes, or just that all the compute nodes managed by SLURM are running on an OS cloud
21:34:51 <b1airo> with operator controlled expansion/contraction
21:35:13 <LyleWinton> Could I offer a perspective on how this might look to the world.  scientific openstack = HPC !  Should we seek a different user story to HPC.
21:35:36 <b1airo> and also typically a managed system, whereas HPC-aaS is usually fire and forget
21:36:06 <b1airo> LyleWinton, for sure - getting there :-)
21:36:14 <sdake_> dhellmann i'll pick up the tag reviews this week
21:36:15 <b1airo> you have #3
21:36:15 <LyleWinton> K
21:36:35 <sdake_> dhellmann apologies on lag, been super busy dealing with backlog
21:36:39 <sdake_> which keeps getting longer and longer
21:36:41 <b1airo> oneswig, make sense?
21:36:41 <sdake_> going wrong direction :(
21:36:54 <b1airo> sdake_, there's a meeting on in here :-)
21:37:26 <rockyg> sdake:  could you be in the wrong channel?  Maybe you want openstack-release?
21:37:37 <oneswig> I'm thinking ... what a nice way of hiding the details of a cloud-centric implementation
21:38:14 <b1airo> i think #2 is where HPFS is likely to come in too
21:38:18 <oneswig> A discussion for a user story would be interesting and I'd be interested to see how it might hide the overhead of OpenStack infrastrcutre creation
21:39:30 <rockyg> So, in some ways, what I'm reading is that you folks are identifying "work loads" or "work flows" which the scientific community uses and you need to define what they look like on OS
21:39:31 <oneswig> HPFS could cut across many use cases, lets not box it in
21:40:04 <b1airo> that's true, but is that a use case on its own ?
21:40:20 <oneswig> rockyg: I think so, there's an amount of transposition between the interactive and flexible world of cloud versus the fast-but-inflexible world that HPC has lived in thus far
21:40:22 <b1airo> or does it just fit into various others ?
21:41:08 <oneswig> b1airo: perhaps discussion HPFS impelmentation strategies falls better as reference architecture than user story, could this be a distinction?
21:41:57 <rockyg> then another good set of user stories is how OS allows a team/multi-team to move from one format to another or live side by side on the same cloud....
21:42:00 <LyleWinton> One of our use cases is a bit hybrid if you like. Automated Galaxy portal creation back-ended by clusterman HPC creation.
21:42:23 <b1airo> rockyg, +1
21:42:51 <LyleWinton> rockyg +1
21:43:11 <b1airo> oneswig, yes that sounds eminently sensible
21:43:50 <LyleWinton> rockyg: we may have stories where OS allows separate research project to live side by side, which is of significant research value
21:44:25 <b1airo> LyleWinton, I think that's a great exemplar of #1 ?
21:44:35 <rockyg> oneswig, ++  so identify architectures, identify workloads, the boundaries of each and how to morph across them?
21:44:41 <b1airo> Galaxy I mean
21:45:11 <LyleWinton> Ah, yes, you're right
21:45:44 <oneswig> LyleWinton: The Galaxy project is a good example of how cloud can be used to deliver something better than matching the functionality of what came before.  I'd put it above cluster-as-a-service
21:46:03 <LyleWinton> b1airo: Oh, yes, it was one of the 11 that I was speaking of
21:46:21 <b1airo> So we might be slowly getting somewhere here :-) - sounds like we want use-cases with exemplars and reference architectures for specific capabilities ...?
21:47:05 <LyleWinton> oneswig: me too, but it's a cluster related pattern. One with a newer front end than slurm
21:47:13 <rockyg> blairo, ++  might be easier to start with exemplars and fit the defining bits around them
21:47:58 <b1airo> rockyg, sure, either way is fine with me
21:48:20 <anteaya> sounds like it would be up to the person who wants to write them
21:48:25 <rockyg> Pick a set of projects, then figure out the buckets that are the same and the ones that are different.  Build the matrix, then reason about the info displayed
21:48:45 <b1airo> so just quickly, before we spend the last 10 minutes on this did anyone want to move on to other specific topics? i think this is a valuable discussion and happy to keep it going...
21:48:55 <anteaya> I think that would depend on who is volunteering to do the work, so far it is oneswig
21:49:21 <anteaya> so I'd say whatever he is most comfortable with
21:49:29 <b1airo> we are more than open to having volunteers!
21:49:30 <oneswig> I am definitely interested in hearing about volunteers to discuss areas of subject expertise!
21:49:30 <rockyg> anteaya, ++
21:49:38 <anteaya> b1airo: oh yes
21:50:21 <oneswig> I have your powerpoint in my sights Lyle :-)
21:50:43 <LyleWinton> On my todo list to send you!
21:50:57 <oneswig> LyleWinton: thanks, appreciated
21:51:21 <oneswig> b1airo: last ten minutes.
21:51:31 <oneswig> Anything to report from last week
21:51:57 <b1airo> yeah let's move on then
21:52:28 <b1airo> #action Send summary of use-cases discussion to lists and seek input
21:52:50 <b1airo> so i have a skeleton for the science cloud wiki page up: https://wiki.openstack.org/wiki/Science_Clouds
21:52:59 <b1airo> #link https://wiki.openstack.org/wiki/Science_Clouds
21:53:36 <b1airo> still need to transfer more of the actual list over and follow up on checking out some of the clouds that were listed at the bottom
21:53:48 <anteaya> the table looks good
21:53:52 <b1airo> but mainly interested in feedback around the "Science Cloud" definition
21:54:01 <anteaya> did you mean for Grid500 to be in square brackets?
21:54:28 <oneswig> Looks good so far.  There are many Euro projects in this area I'm only dimly aware of
21:54:38 <b1airo> anteaya: no, just a formatting glitch
21:54:57 <anteaya> b1airo: okay great, the wiki has a preview button you might find handy
21:55:16 <anteaya> also when editing a page it is helpful to add a note so you can find edits in the history
21:55:24 <b1airo> i think the original etherpad was dfflanders brainchild but scientific-wg is best place to curate it from i guess
21:55:37 <anteaya> the page looks good to me
21:56:02 <rockyg> So, it sounds like this is more the Public Research cloud definition than Science
21:56:09 <anteaya> I have something if we are in open discussion phase
21:56:48 <b1airo> rockyg, what's the distinction there (especially, what do you mean by Public)?
21:57:04 <b1airo> #topic General
21:57:06 <oneswig> rockyg: It's interesting that there is a distinction.  Mostly the distinction is in who gets to use it perhaps?
21:57:34 <oneswig> anteaya: shoot
21:57:47 <anteaya> thanks I have some suggestions for https://wiki.openstack.org/wiki/Scientific_working_group
21:57:59 <rockyg> Well, both are good questions.  The reason I said public research is specifically because of the footnote for "non-commercial"
21:58:05 <anteaya> put the history section above meetings and the meetings section as the last itme
21:58:07 <anteaya> item
21:58:25 <anteaya> then have the agendas in reverse chronological order, so the most recent agenda is at the top
21:58:30 <oneswig> anteaya: no problem with that, makes sense to me
21:58:32 <LyleWinton> Feedback on wiki page. Not sure if research "data" needs mentioning explicitly.
21:58:35 <anteaya> the page will get very long very fast
21:58:37 <b1airo> rockyg, ahh right - i meant not-for-profit cloud infrastructure, not clear enough i guess
21:58:38 <anteaya> oneswig: thanks
21:58:58 <anteaya> oneswig: I think it will improve useabiltiy once you have 30 or so meeting agendas in there
21:59:33 <oneswig> anteaya: by that point perhaps all but the most recent meetings ought to be punted onto another page?
21:59:38 <b1airo> i think we should just cap the number of agendas there
21:59:42 <leong> that might also be different for "community science cloud" whereby it is only used by a subset of universities but not offered to "public consumption"
21:59:46 <anteaya> let's not plan on that
21:59:53 <anteaya> let's plan for what we have now
21:59:57 <rockyg> leong, ++
22:00:07 <anteaya> and then make changes once we have something concrete
22:00:19 <b1airo> oneswig, better yet, we just dump the agenda into the IRC history and let that be the Internet reference for it (then delete from the wiki)
22:00:34 <anteaya> b1airo: there you go
22:00:41 <oneswig> b1airo: seems OK to me, no value in keeping it for too long
22:00:47 <rockyg> blairo ++
22:00:57 <b1airo> just creating work for ourselves in shuffling content around
22:01:00 <anteaya> technical committee and infra just change the same agenda in place: https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
22:01:05 <anteaya> and link to the meeting logs
22:01:09 <oneswig> time's up
22:01:17 <anteaya> thank you
22:01:18 <oneswig> thanks everyone
22:01:20 <b1airo> so it is!
22:01:20 <anteaya> lovely meeting
22:01:23 <b1airo> thanks all
22:01:28 <oneswig> until next time!
22:01:36 <rockyg> Thanks all!
22:01:39 <LyleWinton> TTFN
22:01:44 <b1airo> #endmeeting