21:03:24 <b1airo> #startmeeting scientific-wg
21:03:25 <openstack> Meeting started Tue Jun 14 21:03:24 2016 UTC and is due to finish in 60 minutes.  The chair is b1airo. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:03:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:03:26 <b1airo> oops
21:03:29 <openstack> The meeting name has been set to 'scientific_wg'
21:03:35 <b1airo> #chair oneswig
21:03:36 <openstack> Current chairs: b1airo oneswig
21:03:50 <oneswig> #link https://wiki.openstack.org/wiki/Scientific_working_group#IRC_Meeting_June_14th_2016 This week's agenda
21:04:05 <oneswig> Hello everyone
21:04:09 <rbudden> hello
21:04:10 <jonmills> Howdy
21:04:14 <oneswig> #topic roll-call
21:04:19 <jmlowe> Hello
21:04:22 <leong> o/
21:04:25 <dfflanders> G'Day
21:04:40 <b1airo> does pasting the agenda work oneswig ? let's find out...
21:04:42 <craigs> o/
21:04:47 <b1airo> IRC Meeting June 14th 2016
21:04:47 <b1airo> 2016-06-14 2100 UTC in channel #openstack-meeting
21:04:47 <b1airo> New items:
21:04:47 <b1airo> Scientific OpenStack at Supercomputing 2016. OpenStack activities related to HPC and research computing at the annual Supercomputing conference in Salt Lake City in November.
21:04:47 <b1airo> Panel session on OpenStack for HPC & research computing
21:04:48 <b1airo> Proposal for a Birds-of-Feather session
21:04:50 <b1airo> White paper on OpenStack and HPC
21:04:52 <b1airo> Carried over from last meeting:
21:04:54 <b1airo> Bare metal
21:04:56 <b1airo> Feature development for Newton cycle
21:04:58 <b1airo> Parallel filesystems
21:05:00 <b1airo> Looking for a lead for this activity area
21:05:02 <b1airo> Accounting and scheduling
21:05:04 <b1airo> Looking for a lead for this activity area
21:05:06 <b1airo> Other business
21:05:22 <oneswig> You're just in it for the line count on eavesdrop, I shall retaliate with man bash
21:05:43 <b1airo> lol
21:05:47 <oneswig> :-)
21:05:50 <b1airo> brb - child has just thrown up on floor here :-/
21:06:00 <anteaya> #link https://wiki.openstack.org/wiki/Scientific_working_group#IRC_Meeting_June_14th_2016
21:06:04 <anteaya> for my benefit
21:06:12 <oneswig> Great, I think we are all pretty excited
21:06:24 <oneswig> anteaya: thanks
21:06:32 <oneswig> #topic SC2016 activities
21:06:42 <anteaya> oneswig: welcome
21:06:56 <oneswig> So, there are at least three things that might be going on at SC related to OpenStack
21:07:27 <oneswig> The panel session organised by Bill Boas is first on the list
21:07:42 <Rockyg> o/
21:07:53 <oneswig> The proposal for a birds-of-feather session
21:08:19 <oneswig> And a whitepaper on OpenStack and HPC
21:08:26 <b1airo> Bill is the planned moderator for that panel isn't he oneswig ?
21:08:38 <oneswig> dfflanders: will there be a booth?
21:08:58 <oneswig> Do you have a link to it on sc.org?
21:09:02 <dfflanders> we are trying to piggy back with someone who has one, we couldn't get one
21:09:20 <dfflanders> hoping UTSA might be able to help
21:09:48 <rbudden> PSC will have a booth, but I’m not sure I’m in the position to volunteer it ;)
21:10:11 <rbudden> I can always ask
21:10:15 <jmlowe> We have a large booth, grandfathered in from the late 90's, should I see if we can accommodate?
21:10:21 <b1airo> should try and have openstack stuff at every booth possible - tom has *lots* of stickers
21:10:32 <dfflanders> thank you rbudden
21:10:48 <dfflanders> yes please jmlowe
21:10:53 <jonmills> NASA always has a booth.  but also, I don't have authority to volunteer it.  but I can ask...
21:11:09 <dfflanders> if anything we would like slots at booths to do mini trainings or the like?
21:11:15 <rbudden> rbudden: I’m sure we wouldn’t mind stickers, etc. and I will ask about the booth as well
21:11:40 <dfflanders> thank you jonmills
21:11:44 <rbudden> if we know more about what we’d like to do with a portion of booth space, etc. that would be good to know in advance
21:12:28 <dfflanders> options: stickers > whitepapers > banners > mini trainings
21:12:36 <jmlowe> I can volunteer room for stickers and other materials without asking, posters and displays will require checking
21:12:43 <oneswig> dfflanders: do you envisage openstack staff assisting with attending the 'mini-booth'
21:12:52 <jmlowe> booth space for demos is a go as well
21:12:56 <dfflanders> yes myself and Chris will be in attendance
21:13:38 <jmlowe> just need to schedule the space for a few sessions
21:13:40 <oneswig> let me capture some actions
21:14:25 <oneswig> #action jonmills jmlowe rbudden are at orgs that will have booths, enquire on the possibility of including some OpenStack content
21:15:25 <oneswig> #action dfflanders also investigate UTSA booth?
21:16:03 <oneswig> #topic SC2016 BoF
21:16:12 <b1airo> we sometimes jump on another aussie booth (e.g. with NCI), but i'm not across those plans yet
21:16:12 <priteau> Kate Keahey asked me to tell you that she will be happy to help organize activities at SC16
21:16:48 <priteau> I assume we will have some Chameleon presence as well on TACC's booth
21:16:52 <oneswig> priteau: thanks!  Is that through Chicago, Argonne or ?
21:16:56 <dfflanders> FTW
21:17:18 <b1airo> great thanks priteau - should we loop you into any such comms too?
21:17:58 <priteau> b1airo: Rather Kate directly
21:19:05 <oneswig> Perhaps we form a distribution list including the SC participants here and Kate
21:19:21 <jonmills> +1
21:19:27 <priteau> oneswig: We often have activities through the DoE booth
21:20:36 <oneswig> priteau: that's another interesting path, there are Openstack activities underway across the DoE
21:21:26 <oneswig> dfflanders: are you the point of contact in the Foundation for SC planning?
21:21:49 <dfflanders> yes that's fine as is Denise
21:23:02 <oneswig> #action oneswig to kick off an email distribution for SC planning discussions
21:23:29 <oneswig> I'll make sure you're all on it...
21:23:52 <oneswig> OK, Birds-of-a-feather?
21:24:52 <oneswig> jonmills: your previous BoF was more general but do we feel the scope can/should be narrowed to OpenStack?
21:25:20 <jonmills> Yeah, I'm in agreement.  Last year we were trying to sneak in under the radar.
21:25:40 <jonmills> But the amount of interest, in my mind, justifies a dedicated topic
21:25:55 <oneswig> How big are the bof sessions typically at SC?
21:26:02 <b1airo> just got to looking at jonmills previous BoF format - looks the same as I was suggesting in email, i.e., short/lightening talks by a few folks and then open discussion with some possible guide questions
21:26:28 <b1airo> did that format work well jonmills ?
21:26:59 <jonmills> the discussion session was lively.  very much so.  a few of the presentations were rather dry.
21:27:10 <oneswig> b1airo: I think this is a good format.  We can cover some of the capabilities members of this WG might rightly feel were worth sharing
21:27:15 <jonmills> I would budget 2:1 discussion:presentation time
21:28:28 <oneswig> Is the aim of a BoF more about sharing common problems or solutions do you think?
21:28:31 <jonmills> I think a challenge is going to be choosing the subtopics to discuss in BoF
21:28:36 <b1airo> sounds like good advice. do you have any feeling on what folks would be interested in hearing about in terms of presentations? i suspect high-level architecture overviews of real OpenStack+HPC deployments, what works, what doesn't?
21:29:22 <anteaya> oneswig: BoF is just a gathering of folks with a common interest, you can do anything you want with the time
21:29:25 <b1airo> oneswig, judging by the conversations in the DellXL/DellHPC forum i think there will be a lot of people testing the water
21:29:46 <jonmills> I'm very interested in the networking side of things.  But we also have this topic of parallel filesystems that will find a sympathetic audience at SC
21:29:59 <b1airo> so the majority of the audience will probably not yet have any/much openstack experience
21:30:18 <rbudden> b1airo: +1 on the deployment scenario, i think people seeing how it’s currently being used in HPC will be of interest
21:30:39 <b1airo> jonmills, +1 (your email questions about network scaling are quite interesting to me as well)
21:31:10 <dfflanders> The past three conferences have had more than 50% new to or never heard of OpenStack questions
21:31:27 <b1airo> rbudden, to flesh that idea out further i think we want to cover both virtualised and bare-metal openstacks there
21:32:02 <b1airo> dfflanders, you mean summit attendees?
21:32:03 <oneswig> b1airo: makes good sense, it's not one-size-fits-all after all
21:32:25 <jmlowe> +1 on bare metal vs virt, which one for which apps
21:32:36 <jonmills> @b1airo in terms of attendance, fire marshall was taking people out of the back of the room.  You can't assume that the attendees are OpenStack newbies.  Many will be those in existing HPC centers fighting to shoehorn OpenStack into the infrastructure
21:32:41 <dfflanders> different conferences: K8S, cloud foundry, pycon
21:32:47 <rbudden> b1airo: agreed. they both serve unique purposes in HPC
21:32:48 <oneswig> jmlowe: a worthy discussion on its own
21:33:27 <anteaya> as a note using @ in front of an irc nick is unnecessary
21:33:39 <b1airo> oneswig, jmlowe - and therein lays the problem for us in framing the BoF, so much to talk about!
21:33:59 <oneswig> jonmills: I think those people are tremendously useful, in that perhaps they have got this far by themselves and the community content could get them much further
21:34:33 <jmlowe> one existing deployment of each type, and a couple of apps they are best for
21:34:49 <jonmills> the BoF submission format I think allows you to guestimate the attendence, or room size. I wouldn't pick the smallest room
21:35:23 <oneswig> Do we have a volunteer for submitting the BoF proposal?
21:35:36 <jmlowe> I'd pick the biggest, having been very disappointed by being turned away at the door of the last one
21:36:02 <b1airo> oneswig, i think Bill was happy to coordinate the submission again
21:36:11 <jonmills> So I suggest a continuation of google doc shared editing, to construct the BoF submission
21:36:12 <b1airo> but we need to write the thing
21:36:20 <b1airo> jonmills, +1
21:36:20 <dfflanders> I had 50ppl show up at PyCon for the training I did with zero promotion
21:36:26 <jonmills> and I'm willing to help contribute
21:36:46 <oneswig> jonmills: great and thanks
21:36:49 <dfflanders> Foundation will look to help promote given forthcoming whitepaper
21:36:56 <jonmills> I can even submit it if you want, but it allows for listing co-contributors
21:36:59 <oneswig> b1airo: I think Bill was up for that too
21:37:17 <anteaya> does the group know about etherpad? https://etherpad.openstack.org/ an open source shared editing tool?
21:37:36 <oneswig> Lets follow up with Bill before we sign him up
21:37:53 <oneswig> anteaya: etherpad could be a good call here, better for multi-party editing
21:38:01 <anteaya> and open source!
21:38:04 <b1airo> anteaya, yes most of these folks were at the summit, but etherpad is not so good for building a doc i think
21:38:05 <jmlowe> anteaya: we used it several times in Austin, not so great for editing a paper for submission
21:38:20 <b1airo> i prefer commenting streams in gdoc
21:38:27 <jonmills> me too
21:38:52 <b1airo> but, i think we could use etherpad to good effect in the actual BoF session
21:39:02 <rbudden> etherpad would be handy maybe for notes from these meetings. I found them handy at the design summit session in Austin
21:39:03 <oneswig> I can do either...
21:39:28 <jmlowe> organizing and brainstorming in prep for the bof submission would be a good use for etherpad
21:39:28 <rbudden> back on topic though, i’m available to contribute as well
21:39:49 <oneswig> rbudden: that's great
21:40:13 <persia> Seeing conference discussions: are there plans for anything at ISC-HPC next week?
21:40:52 <oneswig> So I think the consensus is we generate a google doc for submission and use etherpad's interactive strengths for meetings
21:40:55 <b1airo> hi persia - not that i'm aware of
21:40:58 <anteaya> persia: I do believe that is the topic under discussion
21:41:03 <anteaya> oh sorry
21:41:29 <dfflanders> persia wasn't on our radar, should it be?
21:41:32 <anteaya> persia: so many acryonyms, hard to keep track of them all
21:41:36 <oneswig> persia: nothing formal AFAIK but I'd be interested to hear?
21:41:45 <b1airo> no doubt openstack will be part of a few papers presented there, but no specific sessions/groups that scientific-wg knows about
21:42:06 <b1airo> oneswig, agreed
21:42:19 <persia> dfflanders: probably late for this year, but my understanding is that it was kind of like SC Europe.  I may be mistaken.
21:42:28 <oneswig> A couple of my colleagues are going and will be interested in OpenStack discussions there
21:42:35 <b1airo> anteaya, no probs, just to clarify what we're talking about here is the Supercomputing Conference in November
21:42:45 <anteaya> b1airo: great thank you
21:42:51 <oneswig> persia: that's pretty much it
21:42:55 <anteaya> I had thought you were discussing the event next week
21:43:08 <b1airo> we submitted a panel proposal for that immediately following the summit and it was just accepted
21:43:19 <anteaya> b1airo: congratulations
21:43:21 <dfflanders> may we ask for some reports back persia oneswig so we can potentially go next year: number of ppl, hot topics, applicability to OS
21:43:37 <oneswig> persia: are you going?
21:44:03 <anteaya> dabukalam: is going
21:44:05 <persia> oneswig: yes, but unrelated to OpenStack.
21:44:14 <persia> dfflanders: happy to share.
21:44:23 <jmlowe> I went to ISC in 2011, my impression was that the exhibitor part was a fraction of the size but the academic portion of the conference was larger
21:44:24 <dfflanders> thank you persia
21:44:42 <oneswig> #action oneswig persia to report back on OpenStack activities and discussion at ISC next week
21:45:02 <b1airo> jmlowe, i've never been, but that's the 2nd hand impression i have too
21:45:23 <oneswig> OK, move on?
21:45:24 <dfflanders> jmlowe sounds promising especially for our scholarly app efforts
21:45:34 <jonmills> okay, so who is taking the action to launch the gdoc for the BoF and share the link to it?
21:45:56 <oneswig> jonmills: can you fork the layout of the last one?
21:46:04 <jonmills> I can
21:46:27 <oneswig> That would be great, we can build on that I think
21:46:42 <b1airo> sounds good
21:46:57 <oneswig> Follow up with the upcoming distribution list for addresses to share
21:47:04 <oneswig> I'll note it
21:47:40 <oneswig> #action jonmills to fork previous submission for creating new submission for OpenStack/HPC BoF
21:47:53 <oneswig> Thanks Jon
21:47:58 <b1airo> suggest we paste in the panel proposal too and then go from there merging bits together and focusing more specifically on openstack. i think we can be explicit that this in an openstack scientific-wg outreach BoF?
21:48:00 <jonmills> np
21:48:15 <oneswig> b1airo: good plan
21:48:30 <dfflanders> +1
21:48:32 <rbudden> b1airo: +1
21:48:57 <oneswig> #topic SC2016 OpenStack/HPC whitepaper
21:49:34 <oneswig> We've had previous discussions touching on this, I wanted to share an example of the kind of material the Foundation can produce:
21:49:36 <b1airo> so this is an SC thing now oneswig ?
21:49:52 <oneswig> #link https://www.openstack.org/assets/pdf-downloads/Containers-and-OpenStack.pdf example whitepaper on containers
21:50:05 <b1airo> or are we just aiming to have something released around that time?
21:50:12 <oneswig> b1airo: I think the Foundation wants it in time for SC, right dfflanders
21:50:17 <dfflanders> y
21:50:29 <dfflanders> launch at SC, not an SC thing
21:50:50 <oneswig> My coincidence is that I'm contracted to deliver something similar for Cambridge Uni earlier, and feed that into the foundation's efforts
21:51:02 <dfflanders> win win ;-)
21:51:15 <oneswig> In theory yes!
21:51:57 <b1airo> hmm, anybody else get the TLDR feeling when looking at something like that in pdf form?
21:52:56 <jonmills> Well my eyes glaze over when I see marketing-looking stuff.  I wanna see CLI commands LOL
21:53:02 <rbudden> lol
21:53:05 <anteaya> b1airo: I don't know whitepapers, how long are they usually?
21:53:12 <oneswig> b1airo: I like the content of the containers paper, but it's not instantly grabbing.  There's more information in here than most booth content
21:53:17 <b1airo> i'm with you jonmills - i'm just so used to "whitepapers" being marketing fluff
21:53:24 <dfflanders> depends on audience, CIO/CTOs will read, dev no.  Would be interesting to explore other non-PDF formats?
21:53:45 <anteaya> yeah, I really would like to ensure this retains the integrity of meeting the needs of the scientific working group as to style and presentation
21:54:28 <b1airo> oneswig, yes it looks like there is decent content here, but i feel like it should be published as an online doc too. big problem is there is no index, which for 19 pages is not so great
21:54:46 <dfflanders> aside: been playing with gitbooks recently...  though content first, format anon?
21:54:54 <oneswig> I'd prefer something thorough - agree on the online format - surely room for both
21:55:12 <oneswig> I had quality time today with sphinx-doc...
21:55:21 <anteaya> oneswig: how did it go?
21:55:36 <oneswig> the hours flew by!
21:55:36 <anteaya> oneswig: dhellmann is a great sphinx resource
21:55:43 <anteaya> oneswig: I bet
21:55:52 <b1airo> oneswig: lol
21:55:53 <dfflanders> I think the foundation would really like to see some of the members of scientific-wg willing to have interviews so we can publish case studies?
21:56:33 <dfflanders> ^^ does that sound content worthy? <-- @oneswig for your plans as well?
21:56:40 <b1airo> and to clarify, dfflanders means other than oneswig and i (i think)
21:56:45 <anteaya> I thought the scientific working group has an subteam to publish case studies/user stories
21:56:48 <anteaya> or am I confused
21:57:04 <oneswig> I have the idea that we generate a paper as a collection of case studies for specific HPC capabilities.  That way you get a comprehensive big study or a library of two-pagers
21:57:05 <b1airo> anteaya, correct
21:57:15 <dfflanders> +1
21:57:20 <anteaya> okay thanks
21:57:32 <b1airo> #topic Other Business
21:57:40 <oneswig> The time!
21:57:46 <b1airo> better wrap this up i think o_0
21:57:52 <anteaya> o/
21:58:05 <anteaya> I have an item if I may
21:58:11 <b1airo> thanks anteaya - see you in the ether
21:58:12 <dfflanders> nothing like IRC and tea time in the morning :) goes by so fast...
21:58:15 <oneswig> go ahead
21:58:18 <anteaya> thanks
21:58:28 <anteaya> sounds like tehre is a lot of emailing happening which is great
21:58:32 <b1airo> oh, that was a hand up, not a wave :-)
21:58:42 <anteaya> can folks work to defaulting to public lists for email?
21:58:57 <anteaya> I think there is some great deployment content here the devs would love to know about
21:59:11 <anteaya> if folks would be willing to default thier discussions to public
21:59:19 <anteaya> perhaps the user-committee mailing list?
21:59:26 <anteaya> thank you, that's all I had
21:59:39 <dfflanders> +1 for mailing lists wherever possible, please use user-committee with [scientific-wg] in the subject line
21:59:39 <oneswig> The discussions that have gone to the operators list have been picked up, it's a good point
21:59:54 <b1airo> anteaya, definitely, i agree and we are actively doing that when a discussion arises
21:59:55 <dfflanders> and any other lists.
22:00:02 <anteaya> wonderful thank you
22:00:20 <dfflanders> great meeting as usual blairo oneswig - thank you!
22:00:29 <oneswig> I think that is all we have time for - thank you everyone
22:00:29 <Rockyg> thanks!
22:00:29 <dfflanders> l8er
22:00:35 <rbudden> thanks
22:00:48 <jmlowe> looking forward to next time
22:00:54 <b1airo> just asked jonmills this morning if we can take his latest update to the list
22:01:11 <oneswig> great idea
22:01:20 <anteaya> priteau: are you available after the meeting to discuss in #openstack-infra?
22:01:32 <anteaya> b1airo: thank you
22:01:36 <anteaya> and thanks jonmills
22:01:45 <b1airo> thanks all! bfn
22:02:02 <b1airo> #endmeeting