07:00:47 <oneswig> #startmeeting scientific_wg
07:00:48 <openstack> Meeting started Wed Jun 22 07:00:47 2016 UTC and is due to finish in 60 minutes.  The chair is oneswig. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:00:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
07:00:52 <openstack> The meeting name has been set to 'scientific_wg'
07:01:02 <oneswig> #chair blair
07:01:03 <openstack> Current chairs: blair oneswig
07:01:21 <oneswig> #link minutes to meeting https://wiki.openstack.org/wiki/Scientific_working_group#IRC_Meeting_June_22nd_2016
07:01:34 <oneswig> Oops I mean agenda...
07:02:05 <oneswig> #topic roll call
07:02:25 <oneswig> Hi all, who is here?
07:02:39 <oneswig> #chair b1airo
07:02:40 <b1airo> howdy
07:02:40 <openstack> Current chairs: b1airo blair oneswig
07:02:50 <oneswig> Evening Blair
07:03:52 <b1airo> i'm just heading to the bus so might drop out a bit
07:04:15 <oneswig> np, looks like a quiet one so far...
07:05:24 <verdurin> Morning - Adam from Francis Crick here
07:05:46 <oneswig> Hi Adam, just three of us at present
07:07:53 <oneswig> verdurin: there will be an HPC/Research speaker track at Barcelona, are you planning to submit a talk?
07:08:47 <verdurin> oneswig: yes, hope so
07:10:00 <oneswig> Same theme do you think?
07:10:13 <verdurin> Similar, yes.
07:10:21 <verdurin> Of course, we're all a little older and wiser now
07:10:26 <oneswig> :-)
07:10:36 <oneswig> I'm certainly older!
07:11:56 <oneswig> Let's cover the agenda items, perhaps others will join mid-session like last time
07:12:07 <b1airo> copy
07:12:24 <aloga> hi all
07:12:25 <oneswig> #topic Supercomputing 2016
07:12:31 <oneswig> Hi aloga
07:12:39 <b1airo> oneswig, have you got a copy of the agenda handy - good to paste
07:12:57 <oneswig> Yeah, I accidentally posted as minutes earlier, here it comes
07:13:12 <oneswig> Scientific OpenStack at Supercomputing 2016. OpenStack activities related to HPC and research computing at the annual Supercomputing conference in Salt Lake City in November.
07:13:12 <oneswig> Possibility of organisations with booths providing space for OpenStack-related content
07:13:12 <oneswig> Panel session on OpenStack for HPC & research computing
07:13:14 <oneswig> Proposal for a Birds-of-Feather session
07:13:16 <oneswig> White paper on OpenStack and HPC
07:13:18 <oneswig> HPC / Research track at OpenStack Barcelona summit
07:13:20 <oneswig> Deadline for presentation submissions
07:13:22 <oneswig> Cross-promotion of the HPC/Research track in other channels
07:13:24 <oneswig> Use cases and reference architectures
07:14:03 <b1airo> so i guess we could save the SC topic till last then
07:14:28 <oneswig> b1airo: Ok, fine by me
07:14:44 <b1airo> just in case others come in
07:14:52 <oneswig> #topic HPC/Research track at Barcelona
07:15:22 <oneswig> After the success of the track at Austin, there's going to be another at Barcelona, hooray!
07:15:40 <verdurin> Good news.
07:15:49 <verdurin> Does it have to be "justified" each time?
07:15:58 <oneswig> The hope is that people cross-post details on the track in any other related channels
07:16:01 <verdurin> Or can it become a standing track?
07:16:25 <b1airo> good question verdurin - by the time i heard about the track proposal process it was already listed
07:16:25 <oneswig> verdurin: not sure.  The fact that it was so successful has to be positive
07:17:06 <oneswig> verdurin: and the realisation that so much of the user base is research-oriented!
07:17:06 <verdurin> oneswig: definitely - I would certainly prefer it to be a permanent feature of the Summits
07:17:21 <b1airo> so yes, there is a process for deciding on tracks, but no, i don't think it is necessarily widely known or well publicised (given neither oneswig or i knew about it)
07:18:04 <b1airo> probably something we should ask dfflanders or tom about
07:18:37 <verdurin> Do you have a theme in mind?
07:18:45 <oneswig> aloga: will you be proposing to talk about OPIE at the summit?
07:18:52 <aloga> oneswig: yes
07:19:05 <b1airo> great!
07:19:27 <oneswig> verdurin: Going from last time, the talks were selected for widest subject coverage rather than focusing on a theme.  Thoughts on that?
07:19:40 <aloga> taking into account the removal of all the extensions plumbing from the OpenStack API, it won't be sustainable as a standalone project
07:19:52 <aloga> so yes, I need to push for it :)
07:20:19 <verdurin> oneswig: that makes sense to me
07:20:28 <oneswig> aloga: That sounds like a good talk to seek out, good luck with the process
07:21:05 <oneswig> Last time for example I saw there were cross-posts to mailing lists I didn't know of, like UK Cloud SIG
07:21:32 <aloga> oneswig: thanks
07:21:42 <b1airo> so any thoughts about where to promote the track? i was wondering about lists like hpc-announce, but need to be clear about what we want (i.e., not Cloud Computing Research)
07:22:09 <aloga> probably we will submit another one on the TOSCA usage, together with CERN
07:23:38 <oneswig> b1airo: no ideas from here but I'll keep thinking
07:24:12 <verdurin> I can mention it on the UK HPC-SIG list, if oneswig wasn't already planning to do so
07:24:27 <b1airo> i wonder if we want to try and draft a generic message?
07:24:38 <aloga> probably the EGI federated cloud is a good place to ask as wekk
07:24:44 <aloga> s/wekk/well/
07:24:51 <aloga> s/ask/announce/
07:24:59 <oneswig> verdurin: please do, I'm not on that list
07:25:54 <oneswig> aloga: are you in that group?  Would be good if you could promote that
07:25:57 <verdurin> b1airo: yes, a generic message would be useful
07:26:02 <aloga> oneswig: yes
07:26:03 <oneswig> b1airo: agreed
07:27:02 <aloga> b1airo: I do agree with the generic message
07:27:07 <oneswig> The main items to cover would be a couple of sentences on the last track
07:27:13 <aloga> b1airo: kind of a "call for participation"
07:27:24 <oneswig> and to note the deadline and link to the submission form
07:27:51 <oneswig> aloga: exactly, but perhaps not so readily deleteable
07:27:55 <oneswig> :-)
07:28:13 <aloga> oneswig: thats why I used the colons ;)
07:29:01 <b1airo> hehe
07:29:06 <aloga> I mean, if somebody could draft some boilerplate message that could be easily be adapted for each target group (so that it does not seem like generic spam) that would be great
07:29:11 <oneswig> aloga: I don't have an email for you if we follow-up on this after the meeting
07:29:30 <oneswig> 1 sec
07:29:46 <aloga> oneswig: https://launchpad.net/~aloga
07:30:28 <oneswig> aloga: cool thanks
07:31:01 <aloga> oneswig: anyway I'm always on freenode, so I would read any private message sooner or later
07:32:43 <oneswig> #action oneswig b1airo aloga verdurin to work on draft email for HPC/Research for circulation
07:33:29 <oneswig> #link This might be how to start https://etherpad.openstack.org/p/hpc-research-circulation-email
07:34:07 <b1airo> good idea oneswig
07:34:08 <aloga> we (EGI fedcloud) have a meeting next week, so I think that I could even encourage people in the group not only by email O:-)
07:34:23 <oneswig> aloga: great, please do
07:34:25 <oneswig> b1airo: shall we cover user stories?
07:34:50 <b1airo> oneswig, yep sounds good
07:34:56 <oneswig> #topic Use cases and reference architectures
07:35:23 <oneswig> b1airo: you had some specific thoughts to cover?
07:37:08 <b1airo> was thinking about who our intended audience is
07:37:52 <b1airo> i think for the most part it's probably OS newbies
07:38:28 <oneswig> Likely so - new to OpenStack but very familiar with research computing
07:38:39 <b1airo> so i think the approach you're taking for the cambridge whitepaper is probably very much applicable
07:38:53 <oneswig> Great, I hope so
07:40:14 <b1airo> e.g., the filesystem integration focus area might generate a few use-cases with a few solution architecture options - not "reference architectures" per se, just lightweight, here's a way to do this in openstack and here's the relevant docs etc
07:40:26 <aloga> do you have a link to that whitepaper?
07:40:46 <b1airo> aloga, it doesn't exist yet - oneswig is working on it :-)
07:40:57 <oneswig> aloga: still early planning, it doesn't exist in any meaningful form yet
07:41:12 <oneswig> I'm also working on documenting some of the config we are deploying at the moment.  Those things have a short lifespan - will probably go into some blog posts
07:41:30 <oneswig> b1airo: is there a blog for monarch?
07:41:47 <oneswig> verdurin: or the Crick?
07:42:12 <oneswig> I'm interested to read about how other people approach these infrastructure challenges
07:42:29 <b1airo> there is some material but it's not very technical (and also the compuute node hosting our blog's DB went down today and i haven't brought the blog back up yet ;-) )
07:42:32 <verdurin> oneswig: not yet, no - would like to have one, though
07:44:24 <oneswig> b1airo: self-hosted documentation has to have limitations when there's trouble!
07:45:08 <oneswig> In the long term a kind of Scientific WG "planet" aggregation of activity would be a good thing
07:45:46 <b1airo> it's clouds all the way down oneswig
07:46:22 <oneswig> b1airo: somewhere beneath the clouds I believe there is concrete, into which your crater is formed!
07:46:57 <oneswig> Anyway, shall we cover SC?
07:47:13 <b1airo> sure
07:47:22 <oneswig> #topic Supercomputing 2016
07:47:46 <b1airo> so we have two booth coop opportunities now
07:47:47 <oneswig> In the discussion in the other timezone last week there were some people from organisations who take out booths at SC
07:47:55 <oneswig> b1airo: go ahead
07:48:09 <b1airo> yeah was going to say what i think you were oneswig
07:48:23 <b1airo> i.e., does anyone have an SC booth in which
07:48:24 <aloga> regarding the previous topic, http://www.egi.eu/blog/tags/cloud/ may be useful as well
07:48:43 <b1airo> they'd be happy to donate some space to OpenStack "things"
07:50:14 <oneswig> AFAIK Cambridge doesn't do anything like renting a booth, does anybody else's org?
07:50:36 <b1airo> what those "things" are need to be determined, but the foundation does not have a booth, so we're looking for options
07:50:42 <verdurin> We don't.
07:52:16 <oneswig> I heard talk of giving demos, but I'm not sure if that was initiated by the foundation or the WG members
07:53:07 <b1airo> i think it was more dfflanders making suggestions, but i'm not sure whether there is something canned or he wanted to develop material
07:53:44 <oneswig> Otherwise I guess it's about leaflets etc. - sections of the whitepaper perhaps
07:54:07 <b1airo> i can't see us (Monash) being able to do much there, though perhaps something about MASSIVE and CVL on OpenStack
07:54:17 <b1airo> timelines are likely to be a problem
07:54:43 <oneswig> right.  November's not actually that far out for making these things
07:55:40 <b1airo> indeed, especially when you're working on building the platforms o_0
07:56:28 <b1airo> oh and re. SC, for folks that might not be aware, we have an OpenStack HPC/Research panel
07:56:43 <b1airo> and are working on a BoF proposal
07:56:59 <b1airo> not that i've got near looking at that yet this week
07:57:06 <oneswig> b1airo: do you recall the deadline for that?
07:57:43 <b1airo> still a ways off, maybe another 5 weeks
07:58:07 <b1airo> #topic Other Business
07:58:40 <b1airo> better wrap up, especially as i'm standing at the bus stop freezing
07:59:09 <oneswig> You're in Australia, man, stop complaining :-)
07:59:21 <oneswig> Nothing more from me
07:59:39 <verdurin> Nor me.
07:59:45 <b1airo> true true, it's a very chilly 8 degrees C or so
08:00:07 <oneswig> Fair enough.  Let's finish a minute early to get you on your way
08:00:07 <aloga> are we free to add our clouds here https://wiki.openstack.org/wiki/Science_Clouds?
08:00:15 <b1airo> so my shorts, singlet and things are letting me down a bit :-P
08:00:26 <b1airo> aloga, yes please!
08:00:28 <oneswig> aloga: great idea, b1airo is maintaining that
08:00:44 <b1airo> i haven't finished copying the list from the etherpad yet but do go ahead
08:00:58 <oneswig> OK we are out of time.  Thanks b1airo verdurin aloga
08:01:13 <oneswig> #endmeeting