09:00:44 <oneswig> #startmeeting scientific-wg
09:00:45 <openstack> Meeting started Wed Aug 3 09:00:44 2016 UTC and is due to finish in 60 minutes. The chair is oneswig. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:48 <openstack> The meeting name has been set to 'scientific_wg'
09:01:14 <oneswig> Greetings EMEAns
09:01:34 <priteau> Good morning
09:01:36 <DaveH> good morning :)
09:01:43 <annabelleonabike> good morning!
09:01:46 <verdurin> Morning.
09:01:50 <zz9pzza> Morning ( james@sanger)
09:01:59 <oneswig> unusual nick...
09:02:06 <dariov> morning!
09:02:35 <oneswig> #link Agenda for today (such as it is) https://wiki.openstack.org/wiki/Scientific_working_group#IRC_Meeting_August_3rd_2016
09:02:42 <jpr> morning
09:02:55 <enolfc> good morning
09:03:26 <oneswig> Hello all. I heard from b1airo earlier but I'll give him a prod, hold on
09:04:49 <oneswig> Ah, he'll be here in 10 mins, lets press on
09:05:24 <oneswig> #topic COA courses for students
09:05:36 <oneswig> Anne are you here?
09:05:38 <annabelleonabike> I am!
09:05:47 <oneswig> Hello, thanks for coming!
09:05:59 <oneswig> Would you like to talk over the course?
09:06:13 <annabelleonabike> Thanks for having me!
09:06:21 <annabelleonabike> Just a quick announcement for those who work with students! The Foundation recently launched a student pricing option for the Certified OpenStack Administrator (COA) exam. The student pricing is 50% off, and is available to current and recently graduated students who can show a current student ID, or a student ID that has expired in the last 90 days. For students and recent grads who have experience working on OpenStack,
09:06:21 <annabelleonabike> COA is a great way for them to distinction and validation to the work they’ve done, particularly for those who are beginning to search for jobs in the industry.
09:07:18 <annabelleonabike> There’s a page specifically for students at http://www.openstack.org/coa/student, but I’m more than happy to chat with anyone who has questions, or student groups/individuals about specifics. Reachable at anne@openstack.org
09:07:28 <oneswig> Is it an exam only or is there online material and a syllabus to work through?
09:07:44 <annabelleonabike> The exam is only online, and can be scheduled at your convenience
09:08:11 <annabelleonabike> what’s covered on the exam is available here: http://www.openstack.org/coa/requirements
09:08:48 <oneswig> Looks like plenty to be getting on with there...
09:08:52 <annabelleonabike> we recommend people sitting the exam have approximately 6 months experience on OpenStack, but you can also get a feel for what will be covered via the requirements, and people may feel ready to sit with less experience than that
09:09:57 <oneswig> How do people show a student ID to qualify for the discount?
09:10:18 <annabelleonabike> Good question! There is a live proctor during your exam, and they will ask for ID. This is the time you will show the student ID
09:10:58 <annabelleonabike> If students do not have an ID for whatever reason, any official uni document that shows current, active enrollment will suffice
09:11:40 <oneswig> Are there restrictions on the kind of student - PhD students and post-docs?
09:12:25 <annabelleonabike> No restrictions! The rules are fairly generous since our intent was about making this accessible to current students, as well as recent graduates. If a student has graduated in the last 90 days, they are still eligilbe for the discount
09:12:52 <annabelleonabike> If people have feedback on the requirements for receiving the discount, I’m all ears. This is mostly about giving students the opportunity to sit the exam
09:13:34 <oneswig> One thought: it might be helpful to qualify students before they enter the exam. What if they find at that point that their discount is invalid?
09:13:57 <annabelleonabike> Unfortunately, the way it is set up now, their exam will end, and their fee will be applied to a full price exam
09:14:08 <zz9pzza> The one year between buying the exam and taking might make it harder to verify
09:14:21 <annabelleonabike> That’s a great point
09:14:57 <annabelleonabike> The exam is able to be scheduled up to a year after purchase, so we should review how that fits with the student qualificaiton
09:15:43 <annabelleonabike> This is a brand new feature, so we’re still finding the roadblocks and loopholes :)
09:16:14 <zz9pzza> I am sure we can work around it if we are aware.
09:16:19 <oneswig> I think it has a lot of potential, I'm happy to help with that exercise
09:16:31 <annabelleonabike> That would be great! Would love input
09:16:59 <oneswig> Any other questions/comments for annabelleonabike?
09:17:31 <oneswig> annabelleonabike: how can we give feedback later - to anne@openstack.org or on a mailing list?
09:17:41 <annabelleonabike> anne@openstack.org is probably best
09:18:17 <oneswig> OK that's great. Thanks Anne for coming to talk with the WG
09:18:33 <oneswig> I am sure this will be a useful thing at our university
09:18:38 <annabelleonabike> Thanks so much!
09:19:04 <oneswig> #topic Superuser award for Research / Government
09:19:22 <oneswig> annabelleonabike also mentioned we have a new awards category
09:19:35 <oneswig> to be handed out at the keynotes in Barcelona (I guess)
09:19:53 <annabelleonabike> Yes! I’m very excited about this. The Superuser award is now broken out into four categories, including a Research/Gov category. So we’d love to see you all apply!
09:20:07 <oneswig> #link Superuser awards http://superuser.openstack.org/awards
09:20:14 <b1airo> howdy
09:20:21 <oneswig> Evening b1airo
09:20:24 <oneswig> #chair b1airo
09:20:25 <openstack> Current chairs: b1airo oneswig
09:20:31 <aloga> is this self-nominating stuff?
09:21:24 <annabelleonabike> Can be self nominated or you can nominate another org
09:21:37 <aloga> annabelleonabike: tnx
09:22:18 <dariov> looks interesting!
09:22:27 <b1airo> annabelleonabike - that's a mouthful, thankful for autocomplete :-)
09:22:55 <b1airo> thanks for coming by the way
09:23:14 <annabelleonabike> thanks for having me!
09:24:02 <oneswig> annabelleonabike: typically there has been a regional tie with the winning superuser. Is that implicit or is it declared somewhere?
09:24:28 <oneswig> Like CERN wins at the Paris show, NTT wins in Tokyo, AT&T in Austin, etc.
09:24:52 <annabelleonabike> Ah, that would just be conicidence. No regional influence.
09:25:22 <oneswig> ah ok thanks
09:25:46 <oneswig> Any further discussion on this?
09:25:57 <b1airo> so the news here is that there's a new category for "Research / Government" ?
09:26:22 <oneswig> b1airo: that's it. Double points for governmental research
09:26:40 <b1airo> ha
09:27:00 <b1airo> ok, should nominate NeCTAR
09:27:23 <b1airo> might suggest it on our mailing list
09:27:26 <oneswig> Well overdue I'd say.
09:27:41 <oneswig> And if you win, you can buy us all a beer :-)
09:28:12 <oneswig> ok, lets move on?
09:28:32 <oneswig> #topic Upcoming OpenStack / HPC events
09:28:57 <oneswig> So I put this on the agenda because they are apparently like buses, and this week I had 3 mails
09:29:27 <oneswig> I thought it might be good to make an ad-hoc calendar of OpenStack and scientific computing events
09:29:45 <b1airo> nice idea
09:29:54 <oneswig> I saw these things:
09:30:03 <b1airo> or even an actual calendar... public google like?
09:30:31 <verdurin> Curious about the London one, for which I haven't seen any notification yet
09:30:34 <oneswig> b1airo: Might be good, should be easy to organise
09:31:08 <priteau> I suppose you all know of https://www.openstack.org/community/events/
09:31:14 <oneswig> September 15th is Bristol OpenStack day - https://openstackday.uk - not many confirmed speakers as yet
09:32:00 <oneswig> September 22nd is an OpenStack London meetup, but verdurin you're right it doesn't appear to be on the site yet (http://www.meetup.com/Openstack-London/)
09:32:20 <b1airo> priteau, no i was not aware of that o_0
09:32:20 <zz9pzza> Its just after the lusre user group too.
09:32:21 <oneswig> That one is sponsored by Mellanox with an OpenStack HPC theme
09:34:03 <oneswig> I also had a mail for this OpenStack/HPC workshop in Luxembourg, December 12-15: http://2016cloudcom.ux.uis.no/conf/workshops/hpcloudsys.html
09:34:06 <b1airo> hmm, there's a concord flying overhead bristol... bit old?
09:34:33 <oneswig> b1airo: just you wait for our proud city's next supersonic airliner :-)
09:36:28 <oneswig> priteau: The events link is good but I wish it was in a form that could present more relevant content. I'm not interested in meetups in Atlanta for example.
09:36:40 <aloga> oneswig++
09:36:42 <priteau> oneswig: Yes, I wish we could filter by location
09:36:50 <aloga> the location filter should be a must
09:36:51 <oneswig> Perhaps the thing to do is to work on refactoring this page instead of reinventing
09:37:12 <oneswig> I'll note that
09:37:41 <oneswig> #action oneswig to enquire on the OpenStack.org events page to make it more regional
09:38:13 <oneswig> ... and present in ical format too so it can be slotted into a google calendar
09:38:54 <oneswig> I put this item on the agenda in case there were other events coming up in this region that people knew about?
09:39:08 <enolfc> would a research/HPC category also make sense?
09:39:50 <oneswig> enolfc: It would certainly help improve the ranking of events, I'd say
09:40:03 <verdurin> That events list should also enforce showing some details about each event
09:40:12 <verdurin> so you can see at a glance whether it's relevant to you.
09:40:14 <zz9pzza> It would need to be more generic, maybe mirroring the awards "Enterprise,Public cloud service provider,Research / government organization,Telecom "
09:40:27 <oneswig> verdurin: right, I saw some that were empty, full of TBD
09:40:35 <aloga> enolfc++
09:41:00 <oneswig> Is this one to take to the user-committee mailing list?
09:41:33 <DaveH> seeing lots of events is great for reassurance that the community is active, but yes, filtering/localising is needed to make relevant events easier to find
09:41:35 <b1airo> yep i'd say so
09:41:50 <oneswig> OK I'll get onto that. Good point DaveH
09:42:39 <oneswig> Anything to add here?
09:43:39 <oneswig> #topic Tracking WG activities in Trello
09:44:06 <oneswig> Late item on the agenda this one. b1airo had a good idea of organising and tracking things better
09:44:17 <b1airo> possibly worth adding that SC stuff has closed and that we have the confirmed panel and a BoF proposal submitted
09:44:40 <oneswig> b1airo: on the coat-tails, good point
09:45:52 <b1airo> yeah so i set this up a while ago but haven't done much of a job of gardening it yet - https://trello.com/b/fzgRxJrJ
09:46:36 <b1airo> might have a go at hacking up a script that can push actions from irc logs into trello list
09:46:46 <oneswig> Ah, yes. Actions from IRC meetings ought to become tickets in Trello. Great idea.
09:46:53 <oneswig> Can the script then perform the action, I wonder?
09:47:11 <b1airo> import ai
09:47:48 <oneswig> I'm guilty of neglecting this board, will endeavour to use it more
09:48:13 <oneswig> And I hope it'll become generally useful for any WG activities, it is open to group members
09:48:22 <b1airo> it should be publicly visible, and more than happy to give other people access if they want to get involved
09:48:49 <b1airo> just didn't want to make it publicly editable to avoid spam (assuming that's a problem for trello too)
09:49:12 <oneswig> b1airo: good point.
09:49:16 <zz9pzza> ( I really dislike trello :) )
09:49:32 <jpr> so it trello more for a todo list management or is there tie in with outcomes?
09:49:53 <b1airo> zz9pzza, fair enough, i'm agnostic, mostly dislike working :-)
09:50:18 <oneswig> jpr: it's just for recording tasks and tracking them. A to-do list on steroids
09:50:46 <oneswig> There's more involved/interconnected things out there but this seems to be the lightest of lightweight task trackers
09:50:46 <b1airo> jpr, mainly to-do, but depends on how you use it
09:51:32 <b1airo> in my experience it is good for coordinating a disparate team (along with chat of course)
09:51:51 <oneswig> I like this idea of coupling with the IRC meetings, good one b1airo
09:52:24 <oneswig> Anything else for this before we go to AOB?
09:52:47 <oneswig> #topic Any other business
09:52:57 <oneswig> What's new everyone?
09:53:50 <verdurin> oneswig: any news on that white paper you mentioned a while ago?
09:54:29 <oneswig> It is coming on, I have a self-imposed deadline to get two topics to draft for expert review this week before I go on holiday next week
09:55:16 <oneswig> Problem is, I started with the topic "HPC and the overhead of virtualisation", and when ever I add some content that has a bit of substance to it, I realise it's better off in one of the other sections
09:55:26 <oneswig> So it's a slow but steady process thus far.
09:55:47 <DaveH> that's a big/wide topic
09:55:50 <oneswig> I am hoping to share links to the WG from 2 weeks time
09:56:05 <oneswig> DaveH: right, easy to do a big paper, hard to do a small one!
09:56:22 <b1airo> hmm network hiccup
09:56:30 <oneswig> wondered what we'd said...
09:56:42 <oneswig> I was wondering: how is Mirantis' move to non-Kolla containerised deployment going to affect Kolla? Good or bad for Kolla?
09:56:48 <b1airo> sorry about that, what was the last thing i successfully said?
09:57:15 <oneswig> b1airo: about trello - coordinating a disparate team
09:57:23 <b1airo> bad presumably (mirantis could be contributing)
09:57:35 <b1airo> ok, so then i said:
09:57:41 <b1airo> anyway, there's one task there that i haven't gotten back to for some time - summarising Austin etherpads
09:57:46 <b1airo> i've been thinking about this and would like some help
09:57:51 <b1airo> planning to create a new page or pages on the wiki where some condensed write-ups can be placed for posterity along with a bit of a general intro to HPC/Research computing on OpenStack
09:57:56 <b1airo> e.g., maybe a w.o.o/hpc
09:58:26 <oneswig> Flanders previously mentioned a "landing page" of this kind
09:58:38 <b1airo> wonder if i could get any volunteers to work on summaries of any of the activity areas?
09:59:13 <oneswig> I can take user stories
09:59:45 <verdurin> b1airo: suggest this on the mailing list
10:00:01 <oneswig> I think Mike Lowe offered to help on these a while back
10:00:33 <oneswig> verdurin: good idea, circumvents the time zone issues of WG meetings
10:00:42 <b1airo> verdurin, yep will do, mainly just wanted some feedback on this from the die hards :-)
10:01:11 <oneswig> #action b1airo to mail the list for help summarising WG activity areas
10:01:16 <verdurin> I'd like to help, but I wasn't at Austin and free-time extremely limited at present
10:01:52 <oneswig> Thanks verdurin, could do with some help reviewing the white papers - I've got your number
10:01:55 <oneswig> OK everyone, we are out of time again
10:02:00 <oneswig> Let's wrap up
10:02:12 <oneswig> Thanks for joining
10:02:18 <b1airo> verdurin, no probs, totally sympathise with that problem
10:02:31 <oneswig> #endmeeting