21:01:49 <b1airo> #startmeeting scientific-wg
21:01:50 <openstack> Meeting started Tue Sep  6 21:01:49 2016 UTC and is due to finish in 60 minutes.  The chair is b1airo. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:52 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:01:54 <openstack> The meeting name has been set to 'scientific_wg'
21:02:03 * anteaya pictures b1airo as Mr Music
21:02:15 <oneswig> an easy picture!
21:02:23 <priteau> Good evening everyone
21:02:31 <b1airo> heh, you happen to have that agenda handy oneswig ?
21:02:33 <oneswig> Hello
21:02:38 <oneswig> coming right up
21:02:50 <oneswig> #link agenda for today's meeting https://wiki.openstack.org/wiki/Scientific_working_group#IRC_Meeting_September_6th_2016
21:03:45 <b1airo> and inline...
21:03:47 <b1airo> WG activity space requested at the Barcelona summit.
21:03:47 <b1airo> BoF for poster sessions and lightning talks
21:03:48 <b1airo> Working group meeting for progress review and planning
21:03:48 <b1airo> Possible venue for social (Thursday night)
21:03:48 <b1airo> Supercomputing preparation
21:03:48 <b1airo> Discussion topics for SC panel session
21:03:50 <b1airo> Priority items for SC BoF (which was accepted!)
21:03:52 <b1airo> Other business
21:03:54 <b1airo> Diary date - OpenStack/HPC meetup in London on 1st December
21:03:56 <b1airo> Cloud-native applications for research computing - target list for App Ecosystem WG
21:04:00 <b1airo> hmm sorry about the formatting
21:04:11 <oneswig> Ah, forgot you preferred it that way
21:04:17 <b1airo> #topic WG activity space requested at the Barcelona summit
21:04:38 <rbudden> hello
21:04:49 <oneswig> I put in for two sessions but perhaps we should request another based on user-committee mails today
21:04:57 <oneswig> Hi rbudden!
21:05:04 <rbudden> sorry, i’m a tad late!
21:05:11 <b1airo> o/
21:05:32 <oneswig> Question was whether we could get a BoF session together, and whether it would overspill one room into two
21:05:40 <oneswig> No use if they are not close by though
21:05:57 <b1airo> yeah
21:06:29 <b1airo> i'm not overly hopeful, sounds like things are gonna be tight
21:06:44 <oneswig> This session 2 weeks ago, martial suggested it might be good to bring posters - if anyone has one handy?
21:07:12 <oneswig> blairo: it does.  I'll ask anyway, we have 2 sessions reserved.
21:07:43 <b1airo> i for one do not have any poster fodder readily available
21:08:10 <b1airo> but i suppose there is a chance we could create something as an artifact of our joint summit presentation...
21:08:41 <b1airo> (...need to ping wojciech about that)
21:08:47 <oneswig> Me neither but that's a good idea
21:09:13 <oneswig> Wojciech has tonsilitis, poor guy, will be offline for a few days
21:09:33 <b1airo> nasty
21:09:44 <oneswig> So don't expect an immediate response
21:09:55 <b1airo> i certainly like the idea of lightening talks in a scientific-wg bof
21:10:09 <oneswig> But a poster from the Lustre talk is a good idea, and talks are also good
21:10:57 <b1airo> anybody present keen to talk about their recent challenges and/or wins related to openstack for science/hpc ?
21:11:16 <b1airo> (in a lightening talk in barcelona)
21:11:38 <jmlowe> maybe, I'll have to think of something
21:11:48 <oneswig> I'm happy to talk on either getting SRIOV devices configured in a TripleO deployment or configuring Dell BIOS using Ansible
21:12:00 <oneswig> ... been one crazy summer
21:12:31 <oneswig> Note as actions perhaps?
21:12:36 <martial> (sorry I am late)
21:12:39 <jmlowe> I might have something in lightening form to say about deploying 300 nodes using salt
21:12:57 <b1airo> was thinking that but maybe let's hold it till a later date when we have more concrete details of summit sessions ?
21:13:12 <b1airo> hi martial !
21:13:23 <b1airo> jmlowe, that sounds pretty interesting
21:13:26 <b1airo> BM nodes?
21:13:31 <priteau> I could give a quick presentation of the Blazar project and how we use it
21:14:02 <b1airo> priteau, that would definitely be nice, i suspect a bunch of folks don't even know what it does
21:14:19 <jmlowe> priteau: I'd go to that one
21:14:58 <oneswig> priteau: saw your UI today on chameleoncloud.org, looks good, I had no idea Blazar had that
21:16:07 <priteau> the Horizon support for Blazar that we have is half integration of two year old patches never merged, half own development
21:16:38 <oneswig> Patches that old, do they become like fine wine?
21:17:04 <b1airo> damn, australian access federation doesn't get me into chameleon
21:17:40 <b1airo> or mouldy cheese perhaps ? :-D
21:17:56 <oneswig> OK it sounds like good enthusiasm for a lightning talk model right now, lets go with that and fill in the slots nearer the time
21:18:09 <priteau> oneswig: some age better than others ;-)
21:18:23 <rbudden> I may be able to do a lightning talk about using Ansible in conjunction with the Slurm prologue to allow Slurm reservations to automate the setup of Nova Compute/OVS for reserving traditional cluster nodes to host VMs/Containers
21:18:44 <priteau> b1airo: we're only federated with GENI so far
21:19:06 <oneswig> rbudden: sounds good, what's the impact on job startup time?
21:19:13 <jmlowe> b1airo: seems like AU/EU/US NSF federation should be a thing, especially with cloud resources
21:19:16 <b1airo> rbudden, a sort of dynamic slurm? that sounds neat
21:19:23 <priteau> rbudden: I would be very interested to hear about this
21:20:20 <oneswig> All the more reason to attend the WG meeting then...
21:20:43 <b1airo> we use slurm at monash but i'm not close enough to hpc queue admin-ing to have looked into existing slurm support for on-demand expansion/contraction of the cluster
21:21:17 <b1airo> is there such a thing already, or just the hooks?
21:21:23 <rbudden> this is all in the early testing phases but we have a few non traditional use cases where we’ve had to spin up large quantities of VMs
21:22:14 <rbudden> the idea was to have Slurm feed Ansible the requirements so we could metadata tag the nova hypervisors and auto create host aggregates for the user on demand
21:22:35 <oneswig> The people at OSU use SLURM in a similar way IIRC, VMs are created for running each workload.  Seems like hard work for the control plane if workloads are short lived?
21:22:57 <oneswig> I think they do it to inject the inter-VM SHMEM gadget
21:22:59 <rbudden> that way they could do a slurm reservation and within a few min have the resources just show up inside the dashboard and have proper flavors associated with the nodes
21:23:49 <oneswig> rbudden: so you salloc in slurm and nova instances are created?  Ooh.
21:23:55 <b1airo> rbudden, ahh with you now, interesting, catering to "i want my own environment / i need root" hpc users
21:24:04 <rbudden> yep, exactly
21:24:36 <rbudden> we use slurm for all our accounting, so it makes it easy to charge since the reservation is tied to a project/charge-id
21:24:49 <b1airo> i would be very interested to see how that turns out, we have some of those cases here too
21:25:11 <b1airo> grumble grumble bioinformaticians
21:25:52 <oneswig> How does slurm know how many resources are available to it, and what happens when someone else uses them?
21:26:03 <b1airo> of course, giving them a chunk of a parallel filesystem securely is another challenge
21:26:56 <rbudden> we have slurm tied in with pam, so only admins and users who have an active job/servervation can login to the nodes they have been given
21:27:36 <rbudden> b1airo: yes, filesystem access is complicated
21:28:04 <rbudden> the majority of our VMs right now are gateway type workloads and they want access to distributed filesystems of Bridges
21:28:10 <rbudden> so they don’t get root on those ;)
21:28:34 <oneswig> We probably ought to move on?
21:28:35 <b1airo> fair enough!
21:28:40 <rbudden> eventually they can on our Slash2 filesystem because i’ll be implementing ticket based auth
21:29:09 <rbudden> so that trust is not at the client level
21:29:23 <b1airo> rbudden, how modern! :-)
21:29:32 <rbudden> feel free to ping offline if ppl want to banter about it ;)
21:30:13 <oneswig> rbudden: might just do that
21:30:20 <rbudden> :)
21:30:25 <b1airo> yeah this sort of area would be good delve into more detail on
21:30:49 <b1airo> #action: take PFS auth discussion to mailing list
21:31:22 <b1airo> #help
21:31:30 <oneswig> Is anyone hungry?
21:31:42 <b1airo> hmm meetbot may have gone awry
21:31:55 <b1airo> yeah, last dot point here was drinks/dinner in barcelona
21:32:12 <oneswig> #link Possible candidate for Thursday evening in Barcelona - after Blair's talk - http://www.asadordearanda.net/en
21:32:33 <oneswig> recommended by a former workmate who is an occasion local
21:33:05 <rbudden> i’m hungry now
21:33:25 <oneswig> It's under 5km from the conference venue, 8 stops on the metro.  Could fit the bill
21:33:39 <oneswig> I checked today, they have room for 30 :-)
21:33:40 <jmlowe> I do have one concern, I'm not planning on bringing much if any cash, so if they are more friendly to a big pile of credit cards than the place in Austin was that would be good
21:34:53 <oneswig> jmlowe: hard to know, European places might be more open to it, cash is less prevalent than card AFAIK
21:35:37 <b1airo> they have a bunch of set group menu options for ~45 euro / head
21:36:09 <oneswig> Yes, thats' for something pretty big, I was reckoning on a course from the basic menu and some beer or wine...
21:36:47 <martial> all of it sounds very nice so far :)
21:36:55 <jmlowe> we did that at a Lebanese restaurant with a smaller group in Vancouver, it was great
21:37:08 <priteau> oneswig: They have three venus in Barcelona, which one did you have in mind?
21:37:10 <oneswig> jmlowe: sounds ideal.
21:37:18 <oneswig> Calle ...err ... holdon
21:37:25 <rbudden> jmlowe: yes, that was fun indeed
21:37:38 <oneswig> Pau Claris
21:37:58 <b1airo> Vancouver was so far the winning summit for beer
21:38:06 <b1airo> IMHO
21:38:16 <rbudden> they did have good beer
21:38:19 <b1airo> gotta get the basics right!
21:38:21 <rbudden> gelatto was amazing too
21:39:35 <priteau> http://www.asadordearanda.net/en/content/barcelona-pau-claris
21:40:05 <oneswig> Nearer the time, I might need to get a head count to ensure the booking's within a power of 10
21:40:13 <b1airo> lol
21:40:34 <b1airo> i assume it's just like Ceph PGs, round up to the nearest power of 2 ?
21:40:49 <oneswig> Tell that to the maitre d', he'll love it
21:41:08 <b1airo> i'd prefer to leave with my teeth intact
21:41:20 <oneswig> lol indeed!
21:41:29 <b1airo> #topic Supercomputing preparation
21:42:01 <b1airo> firstly, our BOF was accepted - w00t!
21:42:09 <oneswig> excellent!
21:42:11 <rbudden> nice
21:42:17 <oneswig> Does anyone know which days the panel and bof are?
21:42:27 <jmlowe> Pannel is Thursday?
21:42:42 <rbudden> panel is thursday at 3:30-5pm
21:42:47 <oneswig> jmlowe: do you have a link to it?
21:42:49 <b1airo> yeah that's right for panel, not sure the BOF timing is set yet though
21:43:03 <jmlowe> checking....
21:43:09 <rbudden> http://sc16.supercomputing.org/presentation/?id=pan127&sess=sess184
21:43:27 <martial> really sweet on the BOF :)
21:43:56 <jmlowe> http://sc16.supercomputing.org/presentation/?id=bof180&sess=sess361
21:44:34 <b1airo> ah there it is!
21:44:50 <oneswig> Wonderful, thanks jmlowe rbudden
21:47:13 <b1airo> i thought we take a moment to brain-dump some discussion points for the SC panel that might help get things underway
21:48:09 <oneswig> It's an interesting one, who's a typical attendee?  Cloud skeptics will probably steer clear.
21:50:00 <oneswig> In writing this study, I've learned some interesting capabilities I didn't know about what can be achieved in OpenStack.  Do you think this is an infrastructure-level discussion or higher level?
21:51:30 <b1airo> i think if we get it right it will range higher level down to infrastructure and back to "business" level again
21:52:16 <b1airo> #link SC16 panel brainstorm etherpad - https://etherpad.openstack.org/p/scientificwg-SC16-panel
21:53:13 <oneswig> Good plan, I'll keep thinking on it in the background
21:54:29 <b1airo> excellent
21:54:30 <oneswig> Next item?
21:55:31 <b1airo> #topic AOB
21:55:52 <b1airo> london meetup oneswig ?
21:56:09 <oneswig> I had one item - limited use in this group - London meetup for HPC / OpenStack is now 1st December
21:56:26 <oneswig> Sponsored by Mellanox
21:56:43 <b1airo> we're having an OpenStack Australia Government Day here soon - http://australiaday.openstack.org.au/
21:57:42 <oneswig> This is selling to Government or government of OpenStack??
21:57:49 <b1airo> haha
21:58:11 <b1airo> yeah i think it's more aptira selling to government
21:58:22 <b1airo> or hoping to anyway
21:59:01 <oneswig> Turns out the UK gov likes OpenStack, why not AU...
22:00:09 <b1airo> i have no idea where gov is at with private/hybrid cloud, but to complicate matters we have federal and state govs with separate practices and departmental guidelines
22:00:34 <oneswig> OK we are out of time alas,
22:00:46 <oneswig> I am left wondering why they chose an image with no clouds in it...
22:00:58 <b1airo> little bit silly with states of ~6-7 million ppl at most
22:01:06 <oneswig> So typical of Australia
22:01:09 <oneswig> :-)
22:01:32 <b1airo> i will turn to my NZ citizenship at this point
22:01:37 <b1airo> ;-)
22:01:41 <oneswig> Got to go, thanks all
22:01:52 <jmlowe> pleasure as always
22:01:52 <rbudden> thanks
22:01:57 <b1airo> thanks folks!
22:02:07 <b1airo> #endmeeting