09:00:17 <oneswig> #startmeeting scientific_wg
09:00:17 <openstack> Meeting started Wed Jan 18 09:00:17 2017 UTC and is due to finish in 60 minutes. The chair is oneswig. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:21 <openstack> The meeting name has been set to 'scientific_wg'
09:00:47 <oneswig> #link Agenda items for today https://wiki.openstack.org/wiki/Scientific_working_group#IRC_Meeting_January_18th_2017
09:01:08 <priteau> Hi
09:01:12 <oneswig> Blair sends apologies - data centre upgrade in full flow
09:01:25 <oneswig> Hi priteau, how's things?
09:01:41 <aloga> howdy
09:01:51 <priteau> oneswig: Going all right
09:01:51 <oneswig> Hi aloga
09:02:36 <oneswig> We were talking about Chameleon in Cambridge last week and would like to hear more about how it is done. I'll follow up offline
09:02:56 <StefanPaetowJisc> Morning all!
09:03:00 <oneswig> Hi StefanPaetowJisc
09:03:26 <priteau> oneswig: sounds great
09:04:22 <oneswig> The items for today were on two broad topics - firstly, what's coming in terms of events and secondly, what can we do w.r.t federation for the Boston summit
09:05:09 <oneswig> Before all that though - if you're interested in being a track chair for the HPC/Research speaker track, the deadline for nomination is today
09:05:24 <oneswig> #link track chair nomination https://openstackfoundation.formstack.com/forms/openstack_summit_boston2017_track_chair_nominations
09:05:54 <zioproto> hello
09:06:02 <zioproto> started already ?
09:06:06 <oneswig> I've helped out for the last two cycles but I'm sure other people have better opinions on what makes a good talk :-)
09:06:11 <oneswig> Hi zioproto
09:06:15 <oneswig> welcome!
09:06:22 <oneswig> Just getting going
09:06:28 <StefanPaetowJisc> Ciao zioproto
09:06:32 <zioproto> hello all
09:06:37 <oneswig> covered the track chair nominations, that's all
09:06:55 <zioproto> sorry I have a very messy agenda today, I have to jump to another meeting at 11:15, is a nightmare ! :(
09:07:09 <zioproto> I came by because somebody was looking for me for datasets :) !
09:07:21 <oneswig> No problem, a good WG member is a busy one
09:07:39 <oneswig> Flanders - hoping he'll join too but he's in Melbourne
09:07:44 <zioproto> I will stay as much as I can and I will read the minutes after :D
09:07:55 <oneswig> Great
09:08:03 <oneswig> OK, lets roll
09:08:09 <oneswig> #topic upcoming events
09:08:21 <oneswig> zioproto: while you're here, how's the operators midcycle looking for Milan?
09:08:30 <zioproto> dates are confirmed
09:08:35 <zioproto> 15 and 16 march
09:08:49 <oneswig> Do you know if it has sold out? Agenda looks great
09:08:55 <zioproto> #link https://etherpad.openstack.org/p/MIL-ops-meetup
09:09:02 <zioproto> I think tickers are not out yet
09:09:12 <zioproto> also Mariano from enter.it was looking for sponsors
09:09:30 <zioproto> there will be a mail on the ops mailing list when tickets will be out
09:09:40 <zioproto> usually that is on eventbrite
09:09:43 <oneswig> I don't see an eventbrite link in place yet, will keep watching the list
09:10:23 <oneswig> Anyone else thinking of going?
09:10:35 <zioproto> there is another important event
09:10:40 <oneswig> I'm interested
09:10:44 <zioproto> the CS3 conference in amsterdam organized by Surfsara
09:10:47 <zioproto> let me find the link
09:11:02 <oneswig> What is the scope of it?
09:11:02 <zioproto> https://cs3.surfsara.nl/
09:11:42 <zioproto> so the conference is about sync and share
09:11:42 <zioproto> but there will be a OSO
09:11:43 <zioproto> session
09:11:51 <zioproto> OSO is Openstack Operators
09:11:59 <simon-AS559> o/ sorry for being late
09:12:16 <StefanPaetowJisc> Oops :-/
09:12:16 <oneswig> Hi simon-AS559
09:13:16 <zioproto> simon-AS559: I was explaining about CS3 conference in Amsterdam
09:13:27 <zioproto> why it is related to openstack operators
09:13:29 <oneswig> Just looking for the programme but my wireless is dropping...
09:13:42 <zioproto> switch will present: Experience with running Owncloud on virtualized infrastructure (Openstack/Ceph) (continuation of talk at C3 2016)
09:14:03 <zioproto> and there is a talk from SURFsara: Manila, Sahara and Cloud integration in Openstack using NetApp NFS datastores
09:14:26 <zioproto> anyway a broadtopic there is Object Storage
09:14:35 <zioproto> so if you are interested in datasets
09:14:38 <StefanPaetowJisc> *nod*
09:14:40 <zioproto> you will find it interesting
09:15:21 <oneswig> OK Thanks zioproto
09:15:32 <oneswig> Anyone going to the project teams gathering (PTG)?
09:15:43 <oneswig> #link https://www.openstack.org/ptg/
09:15:46 <zioproto> oneswig: not me
09:15:47 <oneswig> Feb 20-24
09:15:50 <zioproto> I have to run ! ciao !
09:15:56 <oneswig> later zigo
09:16:01 <oneswig> later zioproto!
09:16:03 <priteau> I cannot go either
09:16:09 <simon-AS559> Me neither
09:16:26 <priteau> A few Blazar contributors will be there
09:16:38 <oneswig> I'm not going but one of our team will be there to work on Ironic and Kolla
09:16:55 <oneswig> priteau: is there a session on Blazar?
09:17:00 <oneswig> or for other things?
09:17:02 <StefanPaetowJisc> That clashes with one of my federation things, so no.
09:17:38 <oneswig> OK anyone for FOSDEM?
09:17:41 <aloga> no
09:17:44 <oneswig> #link https://fosdem.org/2017/
09:18:11 <priteau> oneswig: Not any official one. Masahito is seeing if others are interested in a short ad-hoc meeting
09:18:32 <StefanPaetowJisc> FOSDEM looks interesting
09:18:37 <oneswig> Apparently there'll be a low-key presence at FOSDEM for OpenStack
09:19:11 <oneswig> One of our team is presenting at PGdays the break-out on Postgres - talking Monasca on Postgres
09:19:13 <oneswig> #link https://www.postgresql.eu/events/schedule/fosdem2017/session/1447-infrastructure-monitoring-with-postgres
09:19:43 <priteau> I saw there was a call for someone to present OpenStack deployment with RDO/TripleO at FOSDEM
09:19:57 <oneswig> I'm not aware of any other OpenStack-related talks currently but plenty of tangential stuff
09:20:18 <priteau> https://www.redhat.com/archives/rdo-list/2017-January/msg00050.html
09:20:27 <oneswig> priteau: funny you should mention that - upgrading via TripleO is going on right now over here...
09:21:38 <oneswig> OK - other interesting events coming up?
09:21:52 <priteau> oneswig: at FOSDEM in the CentOS Dojo there is also an OpenStack talk from CERN
09:22:09 <priteau> #link https://wiki.centos.org/Events/Dojo/Brussels2017 last one in the list
09:22:18 <StefanPaetowJisc> Hmmm... Networkshop in Nottingham in April but I don't think there's anything OS related
09:22:33 <StefanPaetowJisc> I can check with the organisers
09:22:45 <aloga> priteau: https://indico.egi.eu/indico/event/3249/
09:22:56 <aloga> EGI conference in Catania (May)
09:23:12 <aloga> this is a top-down event, but there's a call for posters
09:23:43 <simon-AS559> I don't know whether zioproto had mentioned the HPC Advisory Council http://www.hpcadvisorycouncil.com/ in Lugano in April; he has been asked whether we'd like to present OpenStack-related things there.
09:24:16 <oneswig> simon-AS559: No, not seen that - interesting. Will you do it?
09:24:52 <simon-AS559> I think zioproto has an idea for a presentation, I'll try to think of one myself
09:25:28 <oneswig> Sounds good, looks good too
09:26:09 <simon-AS559> If anyone wants to present there about OpenStack, especially with an HPC background, they would be thrilled to have you I guess.
09:26:18 <oneswig> aloga: The EGI conference conflicts with the OS summit alas - you're required in Catania rihgt?
09:26:19 <simon-AS559> zioproto or I could make introductions if necessary
09:26:28 <aloga> oneswig: yes
09:26:40 <oneswig> simon-AS559: Could be interesting - I'll follow up offline
09:26:54 <simon-AS559> Good, thanks
09:26:54 <aloga> oneswig: it conflicts and I must attend
09:27:18 <StefanPaetowJisc> I wonder whether emedLab would be interested, oneswig
09:27:24 <oneswig> aloga: too bad
09:27:30 <aloga> oneswig: indeed
09:27:46 <oneswig> StefanPaetowJisc: I don't see them too often, but will check
09:27:56 <oneswig> Move on to the summit?
09:28:12 <oneswig> #topic WG and related activities at the Boston Summit
09:28:44 <oneswig> OK, so we need to plan space for WG activities but there's also something bigger which is closely related to the federation interests
09:28:55 <oneswig> Flanders, you there?
09:29:18 <oneswig> OK lets do WG activities first then...
09:29:51 <oneswig> How can we contribute to existing work on federation?
09:31:20 <oneswig> One area I had been thinking was to extend and refresh the ebook written last year - needs a chapter on federation in research use cases
09:31:28 <aloga> oneswig: that is a really good idea
09:31:42 <aloga> oneswig: federation is sometimes a too broad term
09:31:46 <StefanPaetowJisc> That makes sense.
09:32:05 <aloga> oneswig: having a chapter shaping what federation means, or at least illustrating some use cases is a good idea
09:32:10 <StefanPaetowJisc> aloga: especially when it comes to OS
09:32:17 <aloga> StefanPaetowJisc: +1
09:32:24 <oneswig> The topics previously have been about 10 pages of google doc, with pictures and case studies
09:32:59 <oneswig> Previously I've written the introductory body and had others review it and contribute case studies
09:33:20 <oneswig> but I don't know enough about federation to do a decent job of this one!
09:33:48 <oneswig> Two ways forward - somebody else drives it, or does a lot of reviewing of my text :-)
09:33:58 <aloga> oneswig: I can help there, of course
09:34:09 <StefanPaetowJisc> Ok... we had a chat with eMedLab the other day so there's a possible study there.
09:34:11 <aloga> oneswig: in either way we choose ;)
09:34:25 <StefanPaetowJisc> oneswig: I can help review, sure
09:34:33 <oneswig> Thanks both
09:35:10 <oneswig> Got a preference on how to work?
09:35:43 <aloga> oneswig: maybe you can start with an skeleton on the contribution (even just a boilerplate) and then pass us the baton
09:36:02 <aloga> oneswig: so that we know what you are expecting :)
09:36:06 <StefanPaetowJisc> aloga: +1
09:36:15 <oneswig> OK aloga sounds like a good plan to me. I'll take that on
09:36:39 <oneswig> #action oneswig to generate skeleton document for study on federation for research use cases
09:37:05 <aloga> oneswig: another thing is documentation
09:37:19 <aloga> for instance the keystone documentation needs a push
09:37:54 <oneswig> aloga: previously you've said the biggest shortfall is in documentation - is there anything we could do at the summit to share knowledge and experience, perhaps hands-on?
09:38:07 <oneswig> oh, forgot - you're not going :-(
09:38:15 <StefanPaetowJisc> That's been flagged up before in Barcelona
09:38:33 <oneswig> StefanPaetowJisc: are you making progress with Assent?
09:38:46 <aloga> oneswig: I think that a sprint (or something similar) for federation documentation would be great
09:38:59 <StefanPaetowJisc> It's on the long list of things...
09:39:10 <aloga> oneswig: at least clearly documenting the most common cases (say SAML, oidc, etc.)
09:39:26 <oneswig> aloga: agreed, but I'm not familiar enough to contribute
09:39:35 <StefanPaetowJisc> We've got several new features that I have to document so I've not given it much precedence :-/
09:39:56 <aloga> oneswig: I am reviewing the oidc specific stuff, so I can take that
09:40:04 <aloga> oneswig: (I have to do it anyway)
09:40:04 <StefanPaetowJisc> And the macOS client is in progress so...
09:40:46 <oneswig> aloga: That's great, always better to have multiple benefits for one piece of work. Share and enjoy!
09:40:48 <StefanPaetowJisc> But there's documentation to use a helper script to get keystone tokens
09:41:08 <StefanPaetowJisc> With Moonshot that is.
09:41:11 <oneswig> StefanPaetowJisc: something you need or something you have?
09:41:13 <aloga> maybe the WG could help reviewing it (you know, documentation is clear for the one that writes it, but maybe not for others)
09:41:48 <oneswig> aloga: feel free to add me as reviewer (I'm like a man in the street for this) - anyone else?
09:41:59 <aloga> oneswig: great!
09:42:07 <StefanPaetowJisc> You can add me too
09:42:30 <aloga> StefanPaetowJisc: thanks
09:43:13 <oneswig> The other activity discussed around the Boston summit is something being called the Boston Cloud Declaration - shall we cover that?
09:43:21 <StefanPaetowJisc> I really need to give OS my attention more. This will hopefully change after March
09:43:43 <StefanPaetowJisc> oneswig: sure!
09:43:44 <oneswig> StefanPaetowJisc: would be great to have you more active!
09:43:49 <aloga> oneswig: indeed
09:44:23 <oneswig> I don't think I have a link for this but it's a policy-driven discussion on federation and sharing between research clouds that have a degree of open access to them
09:45:15 <aloga> #link https://wiki.openstack.org/wiki/Boston-Cloud-Congress
09:45:33 <oneswig> ooh thanks
09:45:34 <StefanPaetowJisc> Ooooooo! EGI and EUDAT would probably find that interesting. They're working on identity interfederation
09:45:56 <aloga> StefanPaetowJisc: indeed, I've introduced EGI.eu relevant people to Flanders
09:46:26 <aloga> however, it clashes with the EGI conference, so timing here is not appropiate
09:47:04 <oneswig> aloga: It would be interesting to know if EGI people would travel to Boston the following week, if it remained on 15-16 May?
09:47:30 <oneswig> That would need to be traded off against who would come to the summit but not remain an extra week
09:47:58 <aloga> oneswig: yes, you're right
09:48:49 <oneswig> Perhaps a doodle poll is the way forward, I can't gauge it otherwise
09:49:25 <oneswig> The other question is whether this discussion could take place during the summit and be complementary rather than conflicting with other summit activities
09:49:41 <aloga> oneswig: let me check beforehand with EGI people to see if they are willing to travel
09:49:56 <aloga> oneswig: another option is a two-phase event, one in the US, one in the EU
09:50:16 <oneswig> aloga: the relevant people in EGI are aware of this effort, right?
09:50:22 <aloga> oneswig: yes
09:51:14 <oneswig> I think there's more "decide the date" discussion to be had before a "save the date" announcement
09:51:42 <oneswig> aloga: can you let me know if you have a response and I'll feed back to Flanders and Khalil
09:51:50 <aloga> oneswig: yes
09:51:58 <oneswig> OK thanks aloga
09:52:09 <aloga> you're welcome
09:52:28 <oneswig> Anything more to add on this?
09:52:48 <oneswig> #topic any other business
09:53:00 <StefanPaetowJisc> None from me
09:53:10 <oneswig> So what's new everyone?
09:53:35 <priteau> There is a thread on openstack-operators asking for feature requests for Pike: http://lists.openstack.org/pipermail/openstack-operators/2017-January/012428.html
09:53:46 <priteau> Tim Bell has already replied
09:54:07 <StefanPaetowJisc> Other than the macOS Moonshot client making progress, but that's not strictly OS related.
09:54:28 <oneswig> I saw his mail - seems like some of the nested project and quota capability he's been looking for is developing
09:54:36 <oneswig> StefanPaetowJisc: Go Mac! :-)
09:54:42 <StefanPaetowJisc> Hahaha
09:54:47 <dariov> oh - good to know quotas are coming :-)
09:54:47 <oneswig> Can't wait to get it on mine
09:54:57 <oneswig> Hi dariov, just in time :-)
09:54:58 <dariov> (hello everybody, sorry - very very late today)
09:55:05 <dariov> yeah, sorry
09:55:15 <oneswig> no worries!
09:55:39 <oneswig> We are doing practice runs upgrading TripleO and OSP
09:56:26 <oneswig> Got some interesting issues, hopefully they'd save somebody else some pain
09:56:30 <mgoddard> ^^^ not exactly going smoothly
09:56:49 <StefanPaetowJisc> Oy vey!
09:57:02 <oneswig> ??
09:57:22 <dariov> we’re about to roll out a mitaka-based cloud
09:57:29 <dariov> hopefully production soon
09:57:41 <mgoddard> upgrade or fresh?
09:57:45 <dariov> fresh
09:57:48 <oneswig> dariov: how are you doing it?
09:58:28 <dariov> well, I know our ops guys got some headaches with that
09:58:35 <dariov> but it’s up and running now
09:58:36 <priteau> dariov: FYI Mitaka will be EOL in less than 3 months
09:58:54 <dariov> we’re starting to run some compute there
09:59:26 <dariov> we’ll see how far we go
09:59:51 <dariov> priteau, our cloud guys were a bit scare to get on newer ones
09:59:54 <oneswig> Good luck dariov :-) got that "new cloud" smell
10:00:02 <dariov> I would need to check with them why, though
10:00:12 <oneswig> OK bell has gone - lets wrap up
10:00:33 <oneswig> Thanks all, useful session
10:00:39 <dariov> bye!
10:00:50 <oneswig> #endmeeting