09:00:51 <oneswig> #startmeeting scientific_wg
09:00:52 <openstack> Meeting started Wed Feb  1 09:00:51 2017 UTC and is due to finish in 60 minutes.  The chair is oneswig. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:53 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:55 <openstack> The meeting name has been set to 'scientific_wg'
09:01:09 <oneswig> Hello!
09:01:41 <oneswig> #link agenda for today https://wiki.openstack.org/wiki/Scientific_working_group#IRC_Meeting_February_1st_2017
09:01:49 <priteau> Hello!
09:02:00 <oneswig> Morning priteau!
09:02:32 <oneswig> Quiet one today ...
09:02:44 <priteau> Small crowd today?
09:02:49 <oneswig> How are you Pierre, your deadline's coming up?
09:03:21 <oneswig> #chair b1airo
09:03:22 <openstack> Current chairs: b1airo oneswig
09:03:33 <oneswig> g'day Blair, you made it :-)
09:03:34 <b1airo> hallo
09:03:42 <b1airo> finally!
09:03:51 <priteau> oneswig: yeah we're in full swing
09:03:54 <oneswig> We were just getting going but it's just me and priteau thus far
09:04:04 <b1airo> yes sorry for the being AWOL
09:04:08 <oneswig> priteau: new phase for chameleon?
09:04:08 <zioproto> hello
09:04:14 <oneswig> Hi zioproto!
09:04:21 <b1airo> hi priteau zioproto !
09:05:07 <oneswig> b1airo priteau zioproto: I was wondering, what metrics do you use to gauge success on a cloud infrastructure project?
09:05:33 <zioproto> oneswig, not bankrupting is a good start :)
09:05:36 <priteau> oneswig: review of the current phase first
09:06:23 <zioproto> oneswig, no kidding, is very different if you have paying customers or not
09:06:29 <oneswig> two good points.  Sounds like the old "three envelopes" story :-)
09:06:44 <oneswig> Isn't SWITCH public funded?
09:07:10 <zioproto> if you have paying customers it is easy to measure the success.  But usually in research the people dont pay for cloud resources provided by an institution. Or at least they dont pay like they would pay amazon. So it is more difficult to measure
09:07:27 <priteau> oneswig: for a non commercial cloud, I would say utilization rate (quantity) and user success stories (quality)
09:07:36 <b1airo> hmm i suppose for private/hybrid cloud you'd have to define what success looks like before embarking... seems there are a lot of stories of management having the expectation that simply using cloud infrastructure will automatically make them more agile, but reality is somewhat different
09:08:01 <StefanPaetowJisc> Good morning all
09:08:05 <zioproto> oneswig, I wish it was ! :) We dont run the cloud on public money. We have a tarif on our website.
09:08:10 <oneswig> Hi StefanPaetowJisc
09:08:36 <b1airo> Hi Stefan
09:08:45 <oneswig> OK, thanks for that, think it answers my question!
09:08:53 <oneswig> Lets look at the agenda...
09:09:00 <StefanPaetowJisc> Sorry I'm late!
09:09:24 <oneswig> Before we get going, anyone going to the PTG in Atlanta in a few weeks?
09:09:36 <oneswig> I am not but one of our team is
09:09:46 <zioproto> I cant go to US anymore :)
09:09:54 <StefanPaetowJisc> Not me I'm afraid... the US is now out of bounds for me
09:10:10 <oneswig> zioproto: legally - or morally?
09:10:12 <priteau> Not me either
09:10:18 <zioproto> oneswig, Iranian wife
09:10:37 <verdurin> Morning - I'm not supposed to be here, but keeping an eye open
09:10:39 <StefanPaetowJisc> Crazy, isn't it?
09:10:41 <oneswig> Ah.  I am outraged on your behalf...
09:10:53 <oneswig> Hi verdurin, we'll keep it quiet :-)
09:11:00 <zioproto> I have at least 1 trip to Iran every year since 2011, I dont want to be sent back after 6 hours flight just because I have been visiting my mother in law
09:11:34 <zioproto> so, for me no PTG and no Boston
09:11:55 <StefanPaetowJisc> Yeah, given current circumstances you wouldn't even get to board
09:11:58 <oneswig> zioproto: I don't think it would be a good experience if that happened
09:12:18 <b1airo> sad
09:12:22 <oneswig> OK, how about Italy everyone?
09:12:29 <oneswig> #topic Milan Ops meetup
09:12:40 <zioproto> I am going ! :)
09:12:46 <oneswig> Any takers?  I booked a ticket this week
09:12:53 <StefanPaetowJisc> I'll have a word with my boss to check if it's ok to go
09:13:11 <StefanPaetowJisc> He's in the office today
09:13:19 <oneswig> StefanPaetowJisc: It's even closer than Rome, you have a clear precedent :-)
09:13:24 <zioproto> I am looking for other operators in Milano that are working on Kolla
09:13:49 <oneswig> zioproto: you're working on Kolla?  We are working on Kolla :-)
09:13:53 <StefanPaetowJisc> Haha. And it's Milano.
09:13:55 <zioproto> I have done a lot of work because we want to migrate our control plane to Kolla, but is hard to get documentation or talk to people with experience
09:14:09 <zioproto> oneswig, good to know ! on ubuntu ??
09:14:26 <oneswig> Ubuntu?  No, sorry.  Not this time.
09:14:32 <verdurin> zioproto: Kolla or Stackanetes? Or Kolla-Kubernetes?
09:14:43 <zioproto> now I am trying Kolla-ansible
09:14:49 <zioproto> on stable/newton
09:14:58 <zioproto> I am installing the operator seed node using snapcraft.io
09:15:13 <oneswig> verdurin: for us it's Kolla without Kubernetes, don't need that level of dynamism for launching the control plane, it's not that big for this system
09:15:22 <zioproto> because Kolla is not packaged for ubuntu
09:15:37 <zioproto> it would be nice to gather in Milano with other people that use Kolla
09:16:11 <verdurin> If I get to go, very happy to contribute
09:16:24 <oneswig> OK so we are deploying an Ironic system and developing Kolla containers for Monasca.  Should be well underway by the Milan meetup (and I should know a little more about it by then)
09:16:26 <zioproto> oneswig, are you using centos ?
09:16:48 <zioproto> I think the most important thing to discuss is how you migrate from a existing cloud based on something else, to Kolla
09:16:55 <oneswig> One of our team - the guy going to the PTG - is well experienced in it and knows the way...
09:17:06 <oneswig> zioproto: CentOS, possible RHEL
09:17:14 <zioproto> oneswig, who is legendary person
09:17:15 <zioproto> ??
09:17:36 <zioproto> oneswig, is this person coming to Milano as well ??
09:17:49 <b1airo> zioproto, i agree - very much like the look of kolla... but how to get there when we have existing control plane and puppet configs??
09:17:52 <oneswig> Mark Goddard - was in my team at Cray
09:18:12 <StefanPaetowJisc> Why does that name ring a bell?
09:18:18 <zioproto> b1airo, lets say I have more or less a plan, but I need to discuss it face to face with others to understand if it is doable
09:18:23 <oneswig> zioproto: it's an interesting possibility... I'll ask him
09:18:51 <b1airo> excellent, i will watch this space and hope to benefit!
09:18:54 <verdurin> zioproto: you're basically after something like the ceph-ansible playbook that does exactly this for Ceph
09:18:56 <zioproto> b1airo, my idea is to describe also the existing puppet infrastructure in the kolla inventoruy, and then run kolla-ansible with --tags and --limits
09:20:19 <oneswig> zioproto: Is there already a session on Kolla planned?
09:20:21 <b1airo> so kolla to deploy and containerise but optionally using puppet inside the containers or something along those lines...?
09:21:50 <zioproto> b1airo, no, no puppet in the containers
09:22:01 <zioproto> have you seen the Dockerfile.j2 shipped with Kolla ?
09:22:05 <zioproto> there is one for each container
09:22:13 <zioproto> if you read one of them, start with the horizon
09:22:27 <zioproto> you immediately figure out that you can throw away your puppet modules
09:22:58 <b1airo> i like the sound of that
09:23:08 <zioproto> Wait I search a link for you
09:23:10 <oneswig> zioproto: in-place migration to Kolla... I might look at spending some time crafting the equivalent Ansible config to your existing Puppet, Is that your paln?
09:23:41 <oneswig> Morning mgoddard, thanks for joining :-)
09:23:42 <zioproto> b1airo, https://github.com/openstack/kolla/blob/master/docker/horizon/Dockerfile.j2
09:23:57 <b1airo> yes, already open ;-)
09:24:21 <zioproto> oneswig, it is a bit more because this will also create and run containers for you
09:24:28 <zioproto> oneswig, but yes, that is more or less the plan
09:24:57 <oneswig> zioproto: sure, got it.
09:25:09 <mgoddard> morning all
09:25:24 <oneswig> mgoddard: we were just talking about how one might migrate to Kolla in-place from something non-containerised
09:25:27 <StefanPaetowJisc> Good morning mgoddard
09:25:30 <zioproto> #agreed a lot of interest in Kolla during the OPS Milano event
09:26:11 <mgoddard> we were building up a repeatable migration from systemd to Kolla at Cray
09:26:22 <mgoddard> it was a PITA :)
09:26:30 <mgoddard> but is possible
09:26:36 <zioproto> PITA ?
09:26:42 <zioproto> ahhh
09:26:45 <zioproto> I got it
09:26:47 <zioproto> sorry :)
09:27:15 <oneswig> Good to see there is lots of interest out there zioproto, as you say
09:27:21 <mgoddard> it will depend on your requirements - some downtime will be necessary
09:27:39 <zioproto> for example we would like to keep Ceph out of Kolla, but it is not clear if it is easy to maitain such a hybrid system
09:27:56 <oneswig> mgoddard: Did you plan an upgrade in a single move or could it be done service by service?
09:28:03 <zioproto> also, is kolla-ansible going to be maintaned ? or kolla-kubernetes will win ?
09:28:37 <mgoddard> zioproto: the focus is one kolla-kubernetes currently but I think that's mostly because it's shiny
09:29:13 <mgoddard> I certainly hope they continue to support kolla-ansible, kubernetes is one turtle too many for most deployments IMHO
09:29:16 <zioproto> unfortunately I have a physical meeting at 10:30 ... I will keep an eye on the chat if you tag me for specific questions, otherwise I will read the logs later ! sorry !
09:29:32 <oneswig> See you later zioproto
09:29:50 <StefanPaetowJisc> Bye zioproto
09:30:16 <mgoddard> should be possible to upgrade service by service, with care (use enable_* feature flags and ansible tags where they fail)
09:30:42 <oneswig> mgoddard: might enable you to gain confidence in the method, changing one thing at a time
09:30:54 <oneswig> ... or might protract the pain endlessly...
09:31:25 <oneswig> OK - move on?
09:31:25 <mgoddard> probably both
09:31:45 <oneswig> #topic Boston summit
09:32:05 <oneswig> Round we go again, only ever so slightly faster
09:32:30 <oneswig> Anyone with plans to speak, your deadline for submission is next Monday
09:32:42 <b1airo> oneswig, i notice the agenda said "WG room bookings submitted"
09:33:03 <oneswig> Ah, a slight error of tense / possibly optimistic on my part
09:33:18 <b1airo> ah dang, i was so hopeful
09:33:33 <oneswig> I had the plan to book the meeting plus double-bill BoF last night, but had to put up some curtains instead
09:33:47 <b1airo> sounds like a similar evening all round
09:33:49 <oneswig> We could, given it's been discussed, assume they are filed
09:33:58 <StefanPaetowJisc> Hahaha!
09:34:02 <oneswig> and I'll do it after the meeting :-)
09:34:23 <StefanPaetowJisc> Ok, got your email by the way, oneswig
09:34:40 <oneswig> StefanPaetowJisc: great
09:35:05 <b1airo> sounds great - was that the consensus we ended up with in terms of WG sessions?
09:35:33 <oneswig> b1airo: I think so.  How the two sessions are filled I recall discussion but forget details
09:35:47 <oneswig> Lightning talks and open discussion perhaps
09:35:52 <b1airo> ok, i need to catch up on the meeting logs
09:36:05 <b1airo> yes that was certainly one of the original suggestions
09:36:34 <StefanPaetowJisc> Ditto
09:36:38 <oneswig> One development in progress - I have OpenStack-ised the documents from the last cycle and added empty space for gathering data from this cycle
09:36:55 <oneswig> #link generated output from sphinx: http://www.telfer.org/~stig/scientific-wg/
09:37:07 <b1airo> nice work oneswig !
09:37:11 <verdurin> That's an ugly verbing, oneswig
09:37:29 <priteau> oneswig: Looks great!
09:37:30 <oneswig> Sorry, perhaps I should have verdurinned my sentence first?
09:37:32 <StefanPaetowJisc> Hahaha
09:38:02 <verdurin> Very useful work, though
09:38:36 <oneswig> So I'm hopeful we can put together a few additional topics from this cycle.  My next plan is to graft in much of the text of zioproto's use case on federation
09:38:47 <oneswig> And have the team take it from there.
09:39:21 <oneswig> Unless anyone thinks this is the wrong path, I'll start the process of getting it into openstack-infra
09:40:00 <StefanPaetowJisc> I'll have a look at what you sent hopefully this week or next
09:40:25 <oneswig> One idea previously discussed was to organise a working session at the Forum for hacking on it collectively
09:40:39 <oneswig> To keep the older bits up to date as well
09:42:04 <oneswig> Another thought on Boston - anyone know the city enough to propose a venue for a social?  I used to live there but my knowledge is old
09:43:19 <StefanPaetowJisc> Our dev team for Moonshot are based out there so I'll check with them this afternoon what they could suggest
09:43:52 <oneswig> Thanks StefanPaetowJisc, that'd be very useful
09:44:09 <oneswig> OK, any more to add on Boston this week?
09:44:32 <b1airo> did we get anywhere with the cross-over sessions?
09:44:38 <oneswig> #action Stig to file request for repo with OpenStack infra
09:45:13 <oneswig> b1airo: Ah, good point, this must have been the second session... no I don't think so
09:45:31 <b1airo> from the mailing lists it seems like there is a fair bit of interest in sessions on quota management and api policy
09:45:47 <oneswig> The discussion on Pike?
09:46:06 <b1airo> the latter is not particularly a scientific problem, but seems to impact our use cases fairly universally
09:46:17 <b1airo> yes, the Pike thread was one
09:47:33 <oneswig> For the summit arrangements, do you know how that session might be organised?
09:48:41 <b1airo> no, i took an action to figure it out 3 weeks ago and then disappeared down several day job rabbit holes
09:49:28 <oneswig> I'll have a look afterwards, and if it's not obvious I'll mail Flanders - how's that for a plan
09:49:59 <b1airo> sounds great thanks oneswig (i have new ceph nodes to get ready for prod...)
09:50:20 <oneswig> OK, thanks for the reminder b1airo - any more on Boston before we head west to Denver?
09:50:43 <oneswig> #topic SC2017 workshops
09:51:17 <oneswig> This opportunity came up - we can apply for one (or two) OpenStack hands-on workshops at SC2017
09:51:37 <oneswig> There was some discussion on it last week and people were interested.
09:52:03 <oneswig> Likely more of the US gang were planning on attending though - is anyone here planning to attend SC2017?
09:52:21 <StefanPaetowJisc> No... not me
09:52:38 <priteau> oneswig: I am pretty sure Kate will be there
09:52:57 <oneswig> I'm probably going, but not guaranteed (especially if I'm going to Sydney)
09:53:22 <priteau> I probably won't go
09:53:32 <b1airo> highly like i will be there
09:53:36 <b1airo> *likely
09:54:15 <b1airo> particularly as i'll be reviewing papers!
09:54:36 <oneswig> OK, so it's not fertile ground to hunt for volunteers to help with the workshop.  I think it's worth applying given the interest from the group's other wing.
09:55:04 <oneswig> b1airo: I'd forgotten about that, have you started?
09:55:14 <oneswig> #topic AOB
09:55:21 <b1airo> yes, i think the first order of business is brainstorming of topics and activities that could fill a workshop
09:56:27 <b1airo> presumably flanders and his hackathon minions have that format down, but it's not all that clear to me whether the SC crowd would go for it - but i think it's worth proposing for sure
09:56:47 <verdurin> Maybe worth mentioning that I'll be attending a meeting with Tim Bell at Sanger in March, regarding CERN's (hyper-)activity
09:57:02 <StefanPaetowJisc> Oooooooo!
09:57:12 <oneswig> b1airo: Last week's discussion split on two themes - infrastructure and application workloads.  I was wondering about something like a clinic (susceptible to who turns up, and with what) or a set of worked examples
09:57:43 <b1airo> as for infra centric stuff, maybe: architecting an openstack cloud for high-performance
09:58:07 <b1airo> performance tuning and monitoring
09:58:11 <oneswig> verdurin: sounds good, hopefully see you there.  I understand there's an HPC pub night after-party
09:58:58 <oneswig> b1airo: I think along those lines, makes sense.  The application side is more sketchy to me but Heat would kill a few hours...
09:59:20 <oneswig> We are nearly out of time - Any Other Business?
09:59:27 <b1airo> however it'd be hard not to make such a workshop opinionated about design/architecture choices, e.g., have to decide up front if we're doing Ironic or Nova KVM
09:59:57 <verdurin> b1airo: before we go, thanks for you and your colleague's recent help
10:00:22 <b1airo> verdurin, was that sam?
10:00:36 <oneswig> Share and enjoy, verdurin b1airo - great to hear it!
10:00:36 <b1airo> i don't remember doing anything! :-D
10:00:53 <StefanPaetowJisc> No AOB from me, sorry!
10:01:09 <oneswig> OK all, we'd better clear off - thanks everyone
10:01:12 <oneswig> #endmeeting