17:00:50 <tmcpeak> #startmeeting security
17:00:50 <openstack> Meeting started Thu Jul 16 17:00:50 2015 UTC and is due to finish in 60 minutes.  The chair is tmcpeak. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:51 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:54 <openstack> The meeting name has been set to 'security'
17:00:55 <tmcpeak> o/
17:00:55 <sigmavirus24> o/
17:00:59 <gmurphy> sup
17:01:00 <nkinder> o/
17:01:03 <Daviey> \o
17:01:08 <mvaldes> o/
17:01:09 <elmiko> heyo/
17:01:13 <federico3> \o
17:01:26 <sicarie> o/
17:01:44 <tmcpeak> cool
17:01:45 <tmcpeak> good crowd
17:02:00 <tmcpeak> ok
17:02:03 <timkennedy> o/
17:02:09 <dg_> hey
17:02:22 <tmcpeak> cool
17:02:26 <tmcpeak> let's roll right into agenda
17:02:36 <tmcpeak> (btw we have an agenda): https://wiki.openstack.org/wiki/Meetings/OpenStackSecurity
17:02:38 <tmcpeak> #link https://wiki.openstack.org/wiki/Meetings/OpenStackSecurity
17:02:43 <sigmavirus24> :shockedface:
17:02:44 <sigmavirus24> =P
17:02:51 <tmcpeak> (I'm supposed to use hashtags heavily)
17:02:55 <tmcpeak> #topic Anchor Update
17:03:02 <tmcpeak> dg_ tkelsey: take it away
17:03:09 <tmcpeak> #yolo
17:03:37 <dg_> no update from me this week, tkelsey?
17:04:22 <Daviey> The migration to openstack namespace seemed to be uneventful
17:04:33 <tmcpeak> tkelsey is has crashed from whatever energy substance has enabled him to write all these Bandit patches
17:04:34 <sigmavirus24> Daviey: no fireworks happened for you?
17:05:00 <Daviey> sigmavirus24: after a git pull rebease, it was ok :)
17:05:01 <dg_> weve had a couple of users be confused because they cant clone from the old link, but I've gone through and update the wiki pages, so hopefully we shouldnt have too many more
17:06:02 <tmcpeak> cool
17:06:08 <mvaldes> oh, quick reminder
17:06:08 <mvaldes> http://meetbot.debian.net/Manual.html#user-reference
17:06:10 <tmcpeak> yeah, everything for the most part just seems to have worked
17:06:23 <tmcpeak> mvaldes: cool, thank you
17:06:33 <sigmavirus24> tmcpeak: we owe our infra team something then
17:06:43 <tmcpeak> yep, beer usually works
17:06:58 <tmcpeak> cool
17:07:01 <tmcpeak> #topic Bandit Update
17:07:09 <tmcpeak> so we've had a ton of good work going in
17:07:14 <tmcpeak> I think 3-5 patches this week
17:07:19 <tmcpeak> tkelsey is going nuts
17:07:22 <Daviey> and some questionable work
17:07:33 <tmcpeak> Daviey: what do you mean?
17:07:43 <Daviey> tmcpeak: self deprecating.
17:07:44 <tkelsey> hey sorry im late :O
17:07:47 <tmcpeak> haha
17:07:48 <tmcpeak> ;)
17:07:52 <tmcpeak> your patch was great
17:08:14 <tmcpeak> we finally have a wordlist again :)
17:08:24 <browne> yay
17:08:24 <sigmavirus24> wordlists working? that's so 90s
17:08:28 <tmcpeak> I did want to bring up one thing though..
17:08:45 <tmcpeak> the project seems to have grown to the point where it can be difficult to synchronize on big changes
17:08:57 <tkelsey> tmcpeak: +1 agreed
17:09:00 <tmcpeak> for simple fixes, enhancements, etc what we're doing seems to be working
17:09:12 <tmcpeak> but for big changes I'd like it if we start using blueprints, specs, or whatever
17:09:31 <tmcpeak> we had a big change and backtrack with the statement stuff
17:09:34 <browne> agree.  probably just blueprints is fine for now.  not sure we need specs yet
17:09:36 <elmiko> +1
17:09:39 <tkelsey> tmcpeak: +1 I think we need some organisation around larger stuff
17:09:43 <tmcpeak> if we had a clear goal in mind we could avoid backtracking
17:09:46 <tmcpeak> cool
17:09:50 <nkinder> well, we have an area for specs now...
17:09:51 * Daviey started writing a spec for using stevedore for the plugins.
17:10:00 <tmcpeak> sounds like we have agtreement
17:10:08 <browne> do we already have a bandit-specs repo?
17:10:15 <tmcpeak> Daviey: the hipster of spec usage ;)
17:10:17 <nkinder> the question is, shoudl we align to the release schedule for the rest of OpenStack?
17:10:28 <tkelsey> nkinder: good question
17:10:32 <nkinder> i.e. - approve specs for a release by a cut-off date
17:10:32 <tmcpeak> nkinder: I'd rather not, 6 months is pretty slow for Bandit I think
17:10:36 <elmiko> nkinder: doesn't seem to make sense for bandit
17:10:45 <Daviey> #link https://git.openstack.org/cgit/openstack/security-specs/tree/specs/liberty
17:10:51 <browne> agree, don't think it makes sense for bandit
17:10:55 <tmcpeak> Daviey: thank you, saved me the googles
17:11:06 <browne> Daviey: oh cool
17:11:16 <elmiko> although that does make the spec repo layout more complicated
17:11:18 <tkelsey> nkinder: humm, I dont want to loose velocity on stuff by going too far in that direction, but some organisation is needed i think
17:11:30 <elmiko> we had agreed on release/project/
17:11:31 <nkinder> yeah, not recommending it.  Just raisign it for discussion
17:11:38 <tmcpeak> nkinder: +1
17:11:41 <tkelsey> nkinder: its good input
17:11:45 <tmcpeak> ok, so let's do this
17:11:48 <nkinder> we have to be careful that we don't make drastic changes that break the gate for other projects that use us
17:11:53 <nkinder> ...especially late in a cycle
17:11:53 <elmiko> if we change to allow some projects to have different release schedules we might want a different layout
17:11:57 <tmcpeak> if you want to write a feature that you know is small - bring it up on IRC
17:12:05 <tmcpeak> if you aren't sure whether it should have a spec, ask on ML
17:12:07 <tkelsey> nkinder: agreed
17:12:11 <tmcpeak> if you know it should have a spec write it :)
17:12:12 <nkinder> maybe we just should have a later cut-off that most
17:12:27 <tmcpeak> nkinder: +1
17:12:34 <Daviey> tmcpeak: IMO, spec for stevedore conversation is overkill.. but seemed like a good excuse to dry run the process.
17:12:36 <tkelsey> nkinder: +1
17:12:42 <tmcpeak> nkinder: I'd like to automate that "making sure"
17:12:49 <elmiko> nkinder: +1, very reasonable
17:12:50 <sigmavirus24> Daviey: stevedore in which project? bandit?
17:12:53 <tmcpeak> chair6 merged something that can audit what projects have Bandit gates
17:12:55 <Daviey> sigmavirus24: yah
17:12:56 <tkelsey> Daviey: that makes a good test bed
17:13:04 <sigmavirus24> Daviey: we should sync up
17:13:08 <tmcpeak> lol
17:13:15 <tmcpeak> sigmavirus24 has merged that already ;)
17:13:18 * sigmavirus24 added stevedore already =P
17:13:27 <Daviey> sigmavirus24: Happy for you to sit in the driving seat if you prefer.
17:13:45 <sigmavirus24> Daviey: not necessarily drive anything, but I'm interested in what you want to add with stevedore is all
17:13:51 <tkelsey> hehe, a good example of needing more organisation :)
17:13:58 <elmiko> tkelsey: +1
17:13:58 <tmcpeak> tkelsey: +1
17:14:35 <Daviey> chair6's audit script was really rather nice. i imagined something that inspected ~/git/openstack/*/tox.ini or something, which seemed really nasty.. but it is quite graceful how it queries zuul config.
17:15:49 <tmcpeak> ok cool
17:15:58 <tmcpeak> seems like we're in agreement as to the need to have blueprints for big changes
17:16:13 <tkelsey> +1
17:16:16 <tmcpeak> so we can start doing that and avoid reversing course and wasting time like we did with statements, but live and learn
17:16:16 <browne> yep
17:16:31 <tmcpeak> we still have great momentum and a great community around Bandit, so if this is our biggest problem we're doing ok
17:16:47 <tmcpeak> anything else for Bandit?
17:17:08 <browne> so should bandit be in feature freeze now?
17:17:34 <tmcpeak> browne: we can.. we can keep doing development and not pin another version until we unfreeze
17:17:49 <sigmavirus24> Probably silly, but would I be a terrible person to request some documentation around bandit's release management? (E.g., feature freezes, release schedule, etc.)?
17:17:50 <Daviey> Do we have a release cadence for bandit?
17:17:54 <tmcpeak> when's the freeze for other projects
17:18:02 <Daviey> sigmavirus24: just what i was thinking!
17:18:04 <tmcpeak> Daviey: no, we could probably use one
17:18:04 <sigmavirus24> Daviey: we're were thinking the same thing:D
17:18:12 <tmcpeak> sigmavirus24: ^
17:18:16 <sigmavirus24> tmcpeak: it's a per-project thing
17:18:26 <sigmavirus24> Glance, for example, really doesn't freeze until milestone 3
17:18:31 <sigmavirus24> Others tend to freeze earlier
17:18:37 <tmcpeak> how about anybody interested can collaborate on this with… a spec :)
17:18:38 <sigmavirus24> But that's because Glance specs are borken
17:18:47 <Daviey> tmcpeak has a new toy
17:18:50 <tmcpeak> haha
17:18:52 <sigmavirus24> tmcpeak: so a monthly release schedule is okay? =P
17:18:54 <tmcpeak> I'll definitely participate
17:18:55 <sigmavirus24> that's what my spec will say =P
17:19:04 <tmcpeak> LGTM
17:19:17 <tkelsey> can we have a ML discussion on this please
17:19:30 <tkelsey> so other projects know we take it seriously and what our plans are
17:19:31 <tmcpeak> tkelsey: good point
17:19:41 <tmcpeak> #action tkelsey to start Bandit ML discussion on Bandit release cadence
17:19:43 <Daviey> Who is taking the action?
17:19:48 <Daviey> :)
17:19:51 <tmcpeak> tkelsey is: ^ ;)
17:20:05 <tkelsey> looks like i got volunteered :P
17:20:09 <tmcpeak> cool, allright
17:20:12 <tmcpeak> next up
17:20:18 <tmcpeak> #topic Security Guide
17:20:25 <tmcpeak> sicarie, elmiko, Daviey
17:20:27 <tmcpeak> wassup
17:20:35 <sigmavirus24> tkelsey: voluntold ;)
17:20:36 <sicarie> plugging away on the RST migration
17:20:55 <tmcpeak> awesome
17:20:56 <sicarie> Hopefully a bp will landin the spec repo this week or early next
17:20:57 <Daviey> sicarie: Formalizing the meeting schedule ?
17:21:08 <sicarie> Daviey: yep
17:21:21 <sicarie> we've filled in the info on the Specialty Team wiki
17:21:27 <sicarie> I have a change in to get us listed in the meetings
17:21:33 <elmiko> \o/
17:21:41 <tmcpeak> sweet!
17:21:41 <sicarie> It's going to stand in #openstack-security at 10am PST Mondays
17:22:01 <tmcpeak> good stuff
17:22:03 <sicarie> And we were wanting to bring meetbot into the security room
17:22:06 <sicarie> for logging etc
17:22:06 <Daviey> The bot works there, just pending approval from infra to get the meeting schedule merged
17:22:11 <sicarie> any opinion for/against?
17:22:15 <tmcpeak> about time you guys get a formal schedule and meeting going.  That will probably help attract volunteers too
17:22:21 <sigmavirus24> +1
17:22:26 <sicarie> tmcpeak: +1
17:22:26 <tmcpeak> meetbot is fine
17:22:35 <tmcpeak> we already have logging in there
17:22:39 <sigmavirus24> I'm surprised if #openstack-security isn't already logged
17:22:40 <sigmavirus24> ah
17:22:44 <sigmavirus24> We do :D
17:22:48 <tmcpeak> yeah, it is
17:22:50 <tmcpeak> :D
17:22:58 <sicarie> Excellent
17:23:16 <tmcpeak> good stuff
17:23:24 <Daviey> I don't think anything major has happened with the doc this week?
17:23:28 <tmcpeak> you guys have enough volunteers to plug through your backlog?
17:23:33 <sicarie> I'm still trying to find a good way to make a security guide sprint easy to do for people not familiar with a given project
17:23:37 <elmiko> i think those were the major things ;)
17:23:38 <sicarie> I think day 1 might be research
17:23:44 <Daviey> My cinder wipe one is still too single-vendor centric.. need to work out how to deal with that
17:23:49 <tmcpeak> it could be time to get out there and start shaking the can again
17:23:56 <sicarie> tmcpeak: we always have more bugs, but I think they're generally triaged
17:24:04 <elmiko> Daviey: i've talked with eharney about the fedora/centos/rhel side, he commented on the review
17:24:22 <tmcpeak> not for triaging, I mean for actually doing work - do you guys have sufficient participation or should we plan another socializing our efforts tour?
17:24:24 <Daviey> elmiko: Yeah
17:24:42 <sicarie> I think I'm almost ready to finish the case studies, I am going to volun-script people next sec guide meeting to review the ones I don't think need to be changed
17:24:49 <sicarie> er, Alice's case studies
17:24:52 <sicarie> Bob's still needs work
17:25:00 <sicarie> And then the Compute chapter needs a few more touches
17:25:04 <sicarie> but overall it's coming along
17:25:13 <Daviey> Personally, i kinda think security-doc should be doing more shepherding of content from subject matter experts.. rather than feeling personally responsible for writing new content whilst learning project detail
17:25:13 <elmiko> sicarie: +1
17:25:20 <tmcpeak> nkinder: would you be interested in doing another "intro to OpenStack Security" thing like I initially found you guys at?
17:25:27 <tmcpeak> elmiko, sicarie, etc
17:25:40 <tmcpeak> could be good to get a couple of meetups going, one in Seattle and one in the Bay or something
17:25:47 <tmcpeak> bring in some new blood
17:25:52 <nkinder> tmcpeak: yeah
17:25:52 <sicarie> Daviey: that's a very interesting discussion
17:26:04 <sicarie> but one for another venue :)
17:26:09 <sicarie> +1 tmcpeak
17:26:11 <Daviey> indeed
17:26:15 <tmcpeak> cool, ok impromptu agenda item
17:26:19 <elmiko> agreed about Daviey's comment
17:26:23 <tmcpeak> #topic Socializing OS-Security
17:26:50 <tmcpeak> so I discovered OpenStack Security about 15 months ago from a tour nkinder and bdpayne were doing
17:26:57 <tmcpeak> I think it could be cool to set up something else like that
17:27:13 <tkelsey> tmcpeak: interesting idea
17:27:41 <tmcpeak> maybe we could actually do 3: UK, Seattle, Bay
17:27:47 <tmcpeak> anybody interested in working on something like that?
17:28:04 <tmcpeak> our community really benefits from participation, and you never know who we might discover
17:28:14 <elmiko> sounds cool, i'm kinda far from those locales though :/
17:28:26 <elmiko> i could provide moral support =)
17:28:27 <nkinder> elmiko: that means you can give one local to you... :)
17:28:32 <tmcpeak> elmiko: :)
17:28:46 <elmiko> nkinder: yea, i'd be curious to talk more about it
17:28:50 <Daviey> OpenStack London meetup 21st July, anyone going?
17:29:02 <nkinder> Basically, we shoudl develop a presentation that any of us can re-use to recruit and evangelize
17:29:06 <tkelsey> maybe see if local PyCon's or what not would have a guest talk on OS sec
17:29:10 <elmiko> nkinder: +1
17:29:15 <tmcpeak> nkinder: +1
17:29:25 <tkelsey> nkinder: +1
17:29:29 <tmcpeak> I think hyakuhei has some deck we could do a little surgery on and present
17:29:32 <dg_> theres an OS london meetup?
17:29:38 <dg_> Tkelsey? fancy a day out?
17:29:43 <Daviey> #link http://www.meetup.com/Openstack-London/
17:29:57 <Daviey> dg_: I might even let you buy me a beer.
17:30:08 <tkelsey> dg_: why not :)
17:30:34 <nkinder> yeah, I can take my old deck and modernize it too
17:30:44 <tmcpeak> nkinder: awesome
17:30:50 <Daviey> nkinder: in git?
17:30:54 <tmcpeak> nkinder: do you have bandwidth and interest to lead this?
17:31:15 <mvaldes> we have a local appsec conference in austin in october that might be a good venue for this
17:31:31 <tmcpeak> mvaldes: awesome! yeah, Austin seems like it would be a prime location too
17:31:48 <sicarie> With bluebox/ibm local we have a rather active group up here too - I'd be interested in helping develop content, though I'm not a huge fan of speaking in front of people
17:31:50 <mvaldes> #link http://lascon.org/
17:31:52 <tmcpeak> so I guess general plan is get a basic deck/preso worked out, then get one or two people from each location to find a venue and present
17:31:53 <nkinder> tmcpeak: I'll resurrect my slide deck and we can collaborate to build on it
17:32:00 <tmcpeak> nkinder: great!
17:32:07 <nkinder> probably a good item to get in shape at the midcycle
17:32:14 <tmcpeak> nkinder: for sure, great idea
17:32:36 <tmcpeak> we can carve off a day for it, might really pay off
17:32:50 <tmcpeak> ok, next :)
17:32:56 <tmcpeak> #topic Notes
17:33:00 <tmcpeak> nkinder: take it away :)
17:33:52 <nkinder> There's not too much activity lately.  Daviey has a note out as a WIP.
17:34:06 <Daviey> nkinder: I could do with your input on how to declare Affects: Keystone + anything that uses it.
17:34:10 <nkinder> I'm in the middle of reviewing it, so comments are coming your way Daviey :)
17:34:16 <Daviey> Oh super, thanks
17:34:23 <tkelsey> link?
17:34:29 <Daviey> https://review.openstack.org/#/c/200303/
17:34:33 <tkelsey> ty :)
17:34:34 <Daviey> #link https://review.openstack.org/#/c/200303/
17:34:54 <nkinder> There's still a healthy backlog of notes to choose from...
17:35:10 <sicarie> nkinder: backlog link?
17:35:10 <tkelsey> lol @ cowsay
17:35:22 <tkelsey> nkinder: I will try to pick one up
17:35:26 <nkinder> backlog - https://bugs.launchpad.net/ossn/
17:35:34 <nkinder> tkelsey: great, thanks!
17:35:39 <tkelsey> but i didnt manage it last time I said that
17:36:32 <nkinder> that's really it on OSSNs right now.  I'm hoping to hack on the parsing tool I mentioned last week pretty soon
17:36:35 <Daviey> I I have OSSN-0051 rough draft, but i wanted to land 50 first
17:36:39 <elmiko> nkinder: i'll look into picking another up too
17:37:20 <tmcpeak> awesome, great work as usual Mr. Kinder
17:37:31 <nkinder> elmiko: thanks!
17:37:33 <tmcpeak> #topic Midcycle
17:37:54 <tmcpeak> ok so I think we all know about the midcycle, we had some maybes I'd really like to get there
17:38:00 <tmcpeak> elmiko, sigmavirus24, nkinder
17:38:11 <Daviey> Whilst it is most unlikely I'll be at the mid-cycle, I was tempted by the specific AirBNB (option 4) on the wiki.. worth looking at!
17:38:14 <Daviey> #link https://wiki.openstack.org/wiki/Sprints/SecurityLibertySprint#Hotels
17:38:15 <tmcpeak> #link https://etherpad.openstack.org/p/security-liberty-midcycle
17:38:21 <elmiko> tmcpeak: i'm trying, its just a budgetary issue at this point
17:38:29 * sigmavirus24 can't go.
17:38:42 <sigmavirus24> We have a quarterly team sync up at HQ that I have to go to that week
17:38:50 <tmcpeak> Daviey: we did an AirBnb place in San Francisco with the HP folks and it was lots of fun
17:38:58 <tmcpeak> sigmavirus24: ahh bummer
17:39:04 <sigmavirus24> tell me about it
17:39:16 <tmcpeak> elmiko: cool, keep working it - drop in management terms, explain the ROI, etc etc etc
17:39:19 <tmcpeak> :P
17:39:26 <elmiko> haha, for sure =)
17:39:28 <Daviey> tmcpeak: you should look at that one, i suspect it'll be less fun
17:39:29 * sigmavirus24 may be able to participate remotely though
17:39:46 <tmcpeak> Daviey: lmao
17:40:12 <tmcpeak> I'm guessing this is Rob's doing, since it's written in pounds
17:40:26 <Daviey> considering there is an active part of the security team that likely will not be there, i wonder if we could think of /some/ sprinty things to complement the week?
17:40:35 <tmcpeak> although the whole UK side of the pond is full of snark, so it could really be any of you
17:40:35 <Daviey> (another time, but just an idea)
17:40:51 <tmcpeak> Daviey: that's a great idea
17:41:12 <sigmavirus24> Infra also has some teleconferencing software set up that we can use
17:41:54 <Daviey> Whilst remote conf' is useful for the remote attendees, it often changes the dynamics of the local attendees - such that much of the value of local collab is lost
17:41:56 <tmcpeak> I'm definitely willing to give it a shot, I mean I work entirely from home at the moment, so I know it's possible to effectively conference :)
17:41:57 <Daviey> (IMO)
17:42:20 <tmcpeak> Daviey: yeah, I think we should shoot for a different time that isn't the midcycle
17:43:03 <tmcpeak> Daviey: you want to put together some ideas so we don't drop this?
17:43:14 <Daviey> uh, ok
17:43:17 <tmcpeak> sigmavirus24: etc
17:43:43 <sigmavirus24> tmcpeak: was that a wilco reference? (Jesus, etc.)
17:43:58 <tmcpeak> no, I don't know what that is
17:44:07 <sigmavirus24> I'll show you later
17:44:10 <tmcpeak> okies
17:44:23 <tmcpeak> does anybody want an action for this, or shall we pick it up another time?
17:44:49 <tmcpeak> another time it is ;)
17:44:53 <Daviey> tmcpeak: lets thrash some of it out another time in the main channel?
17:44:58 <tmcpeak> Daviey: cool
17:45:01 <tmcpeak> sounds like a plan
17:45:13 <tmcpeak> #topic API Testing
17:45:15 <tmcpeak> mvaldes: shoot
17:45:30 <mvaldes> cool. we have a PoC up and running
17:45:38 <tmcpeak> awesome?
17:45:41 <tmcpeak> I mean awesome!
17:45:42 <Daviey> linky?
17:45:43 <tmcpeak> link?
17:45:47 <elmiko> lol
17:45:51 <mvaldes> yes :)
17:46:01 <Daviey> if this is a rickroll, i'll be unimpressed.
17:46:11 <mvaldes> no link  yet. hoping to open source it in the next week-ish
17:46:20 <tmcpeak> lol
17:46:32 <tkelsey> mvaldes: cool, looking forward to seeing it :)
17:46:33 <mvaldes> but it is doing things
17:46:54 <tmcpeak> mvaldes: awesome
17:47:07 <tmcpeak> do you want to say anything about it or wait until it's posted and we can go over it together?
17:47:21 <mvaldes> so far i equate it to automating much of what we use burp intruder for
17:47:48 <tmcpeak> that sounds like a useful start
17:48:12 <mvaldes> that's about all i have for now i think
17:48:15 <tmcpeak> cool, so…
17:48:24 <tmcpeak> #topic Open Bugs, Crypto Oversight, AOB
17:48:45 <tmcpeak> I'm squashing these because I expect we won't have any updates on the crypto thing since hyakuhei was leading it
17:48:51 <tmcpeak> and he's gonzo
17:49:12 <tmcpeak> open floor, anybody have anything to discuss?
17:49:38 <tkelsey> nothing from me, just to let folks know I'll be pushing on Bandit bugs this comming week still
17:49:49 * sigmavirus24 gives tkelsey a round of applause
17:49:56 <tmcpeak> +1
17:50:02 <tkelsey> heh thanks sigmavirus24 :)
17:50:20 <sigmavirus24> I might work out a spec to give bandit the ability to do analysis using multiprocessing
17:50:32 <sigmavirus24> There's a bp registered for it, but might as well toy with our specs
17:50:40 <sigmavirus24> We'll see how much time I have
17:50:42 <tmcpeak> sigmavirus24: awesome, sounds like a good usage for them
17:50:43 <tkelsey> sigmavirus24: interesting :)
17:51:08 <sigmavirus24> Hopefully it'll take analyzing glance from ~20s to like 5
17:51:22 <tmcpeak> that would be impressive :)
17:51:31 <sigmavirus24> Flake8 has seen similarly drastic performance benefits
17:51:47 <tkelsey> sigmavirus24: exciting stuff
17:52:14 <tmcpeak> sounds exciting, and a perfect use for specs :D
17:52:32 <tmcpeak> allright, anything else before I call it?
17:52:42 <Daviey> lets go home?
17:53:58 <tmcpeak> lol sounds like a plan
17:54:00 <tmcpeak> #endmeeting