09:02:47 <aspiers> #startmeeting self-healing
09:02:48 <openstack> Meeting started Wed Nov 21 09:02:47 2018 UTC and is due to finish in 60 minutes.  The chair is aspiers. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:02:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:02:51 <openstack> The meeting name has been set to 'self_healing'
09:03:08 <aspiers> Well it looks like we have critical mass for the first ever meeting :)
09:03:30 * witek waves
09:04:02 <aspiers> ifat_afek: yes, we discussed the meeting in Berlin. No, I meant to announce it on the list in the last day or two but I had too many things going on in my head so I forgot ;-/
09:04:06 <aspiers> hi witek!
09:04:25 <aspiers> and hi Xiangyu! really glad you could make it
09:04:32 <ifat_afek> aspiers: ok, thanks
09:04:56 <aspiers> #action aspiers to announce the meeting times on the list
09:05:22 <aspiers> #link http://eavesdrop.openstack.org/#Self-healing_SIG_Meeting
09:05:26 <aspiers> #topic Berlin recap
09:05:43 <aspiers> OK, let's do a quick recap of the two Berlin sessions
09:06:10 <aspiers> #link https://etherpad.openstack.org/p/berlin-self-healing-sig-brainstorm
09:06:20 <aspiers> That's the etherpad we used for both sessions
09:06:55 <aspiers> The first session was a BoF, and the second was the Forum's official working group session for the SIG
09:07:38 <aspiers> We tried to play the agenda for both by ear, depending on who was there and what they were interested in
09:08:14 <aspiers> #action aspiers to send a recap of the Berlin sessions to the list (and maybe blog about it too)
09:08:25 <aspiers> We had good attendance and some nice discussions
09:08:49 <aspiers> Also there seems to still be quite a bit of interest in compute node HA
09:09:55 <aspiers> There was one new interesting use case raised around memory leaks in OVS
09:10:19 <aspiers> I think we had a volunteer to submit a use case to the repo for that, but I forgot to take a name
09:10:48 <aspiers> #action try to find out who raised memory leak use case
09:11:12 <aspiers> I think we can talk about compute node HA as a separate topic in the next few minutes
09:11:29 <aspiers> but first, any questions about the items in the etherpad?
09:11:41 <aspiers> especially from people who weren't there
09:11:48 <ifat_afek> Unfortunately I couldn’t attend this summit, seems like you had interesting discussions
09:11:57 <ifat_afek> I’m going over them now...
09:12:37 <aspiers> Yeah it was good, people came and went from the two sessions so I think we must have had more than 40 people in total
09:13:24 <tojuvone> yes, we had plenty of people while room was hard to reach
09:13:39 <aspiers> right, the room was the furthest away in the whole conference ;-)
09:13:43 <aspiers> ifat_afek: there were questions about what to use for notification
09:13:57 <ifat_afek> What kind of notification?
09:14:08 <aspiers> sorry, I mean monitoring ;-)
09:14:14 <aspiers> brain is not working yet
09:14:17 <ifat_afek> Oh :-)
09:14:30 <aspiers> I said that I thought the SIG should not be opinionated about that, but only assist in sharing knowledge
09:14:38 <aspiers> about what is possible, or what is being worked on
09:14:57 <ifat_afek> I’m familiar with Zabbix and a bit Prometheus. I’m not sure if the SIG should recommend monitors
09:15:00 <aspiers> since some operators want to use monasca / zabbix etc.
09:15:08 <ifat_afek> I would expect a general architecture that allows using different monitors
09:15:13 <aspiers> exactly
09:15:17 <ifat_afek> Of course, Monasca as well
09:15:21 <aspiers> right
09:15:26 <witek> Monasca gives great monitoring possibilities, which should also be listed with other options
09:15:34 <ifat_afek> Right
09:16:02 <aspiers> #action aspiers to update the SIG scope on the wiki home page to be clear about not being opinionated about which components to use
09:16:02 <witek> Monasca having support for Prometheus, so Prometheus metrics can be scraped and stored in Monasca backend
09:16:23 <ifat_afek> Sounds good
09:16:54 <aspiers> #topic compute HA
09:17:11 <aspiers> since we have Xiangyu here, let's talk about compute HA
09:17:23 <aspiers> there were two presentations on new solutions for compute HA
09:17:35 <aspiers> one from China Mobile
09:17:57 <aspiers> on Guardian
09:18:05 <aspiers> and I am trying to remember the other one :)
09:18:10 <aspiers> it's in my notes somewhere ...
09:18:30 <aspiers> ah, found it
09:18:36 <aspiers> https://www.openstack.org/summit/berlin-2018/summit-schedule/events/22100/a-better-vm-ha-solution-split-brain-solving-and-host-network-fault-awareness
09:18:57 <aspiers> sampath and I attended both talks and talked to the presenters afterwards
09:19:14 <aspiers> to ask if they would like to collaborate with upstream, especially with masakari
09:19:28 <aspiers> since masakari is already an official project doing compute HA
09:19:52 <aspiers> both of the new solutions have some interesting features which masakari does not have, but they also overlap a lot too
09:20:12 <aspiers> IIUC currently neither are open source yet, but there are plans to open source Guardian I think
09:20:30 <ifat_afek> Were they aware of Masakari?
09:20:45 <aspiers> I think so
09:21:28 <aspiers> the Fiberhome solution decided to avoid existing solutions, but the reasons they gave did not make sense to me
09:21:44 <aspiers> but maybe I was missing something
09:22:09 <aspiers> Xiangyu: would you like to say anything about Guardian?
09:22:22 <aspiers> e.g. possibility to collaborate upstream?
09:23:25 <Xiangyu> yes, we would like to share our gains.
09:23:57 <aspiers> BTW we heard from Chinese contributors in a separate session (TC community outreach) that IRC meetings are sometimes difficult for Chinese contributors, so I'm really glad to see you here :)
09:24:36 <aspiers> Xiangyu: I see you are on #openstack-masakari too, so we can discuss there also
09:25:02 <Xiangyu> Guardian is also focus on VM HA now, and has some special features.
09:25:28 <aspiers> yes it has some nice features, so it would be great to converge to one solution upstream
09:25:41 <aspiers> maybe we can set up a separate meeting with samP about this?
09:25:52 <Xiangyu> I'm also very glad to join in this meeting.
09:26:21 <Xiangyu> yes, of course.
09:26:56 <aspiers> OK, great! I am always available in IRC to discuss, since I know masakari reasonably well
09:27:09 <aspiers> and I know samP is keen to discuss too
09:27:20 <aspiers> OK, I guess we don't need to go into the details of that now
09:27:35 <aspiers> #topic raising awareness of the SIG
09:27:53 <aspiers> I raised this topic in a seperate Forum session https://etherpad.openstack.org/p/expose-sigs-and-wgs
09:28:27 <aspiers> actually, Rico Lin raised it
09:28:48 <aspiers> but there are a few different aspects:
09:28:57 <aspiers> 1. collecting feedback from users/ops
09:29:10 <aspiers> 2. coordinating work across projects
09:29:15 <aspiers> 3. finding developers
09:29:31 <aspiers> self-healing SIG currently needs help most with 1.
09:29:55 <aspiers> I think 2. is already working fine via Storyboard and we have a specs template too (not used yet, but hopefully soon!)
09:30:37 <ifat_afek> Sorry to interrupt, I need to leave for another meeting… I plan to join the second meeting today
09:30:38 <aspiers> IIRC the session agreed that 3. is not a good idea. If the devs are available, they are available. If not, there is no magic solution to find them
09:30:50 <aspiers> no problem ifat_afek, thanks a lot for coming and see you later!
09:31:26 <aspiers> if anyone has ideas on how to increase engagement with ops/users, it would be really helpful to hear them
09:31:47 <aspiers> either now or later on IRC or the mailing list
09:31:58 <witek> ad. 2 do we have the link to specs page on wiki?
09:32:10 <aspiers> good question
09:32:35 <aspiers> well, there is a link yes
09:32:45 <aspiers> second link under https://wiki.openstack.org/wiki/Self-healing_SIG#Community_Infrastructure_.2F_Resources
09:32:54 <witek> got it
09:33:00 <aspiers> but it's called "Official SIG documentation" so maybe it's not obvious enough
09:33:23 <aspiers> #action aspiers to clarify docs link on wiki page
09:33:46 <aspiers> #action aspiers to update meeting info in wiki page
09:33:52 <aspiers> just noticed that too ;-)
09:34:11 <witek> ad. 1 should we advertise StoryBoard as the place to collect user stories from ops?
09:34:24 <witek> is it the right tool?
09:34:27 <aspiers> I'm not sure
09:34:34 <aspiers> it's a lot better than nothing
09:34:38 <witek> :)
09:34:47 <aspiers> personally I think I would prefer them to first discuss on IRC or mailing list
09:34:51 <aspiers> and then submit to the git repo
09:35:07 <aspiers> but Storyboard could be used to track it too
09:35:19 <aspiers> Rico did originally suggest this
09:35:34 <aspiers> so we should probably try it and see how it goes
09:36:06 <witek> as of now, git repo holds implemented use cases and has a place for design documents
09:36:11 <aspiers> #action aspiers to put another call for user stories out to the list
09:36:22 <aspiers> right
09:36:42 <aspiers> but the git repo can hold unimplemented use cases too :)
09:36:53 <aspiers> that was always my intention
09:36:54 <witek> IRC or mailing list is good, proposing a spec is more effort and could be a barrier I think
09:37:03 <aspiers> although I'm not sure if I made that clear
09:37:14 <aspiers> I agree, spec is more about technical details of implementation
09:37:24 <aspiers> spec would only happen once there are developers on board
09:37:48 <aspiers> so maybe we need a "How To Contribute" document
09:37:51 <aspiers> to make this clear
09:38:02 <tojuvone> Maybe some short instructions to write a story if not irc first
09:38:10 <aspiers> yes
09:38:49 <aspiers> ah
09:38:49 <tojuvone> it is easy to write
09:38:52 <aspiers> I just remembered
09:38:55 <aspiers> https://docs.openstack.org/self-healing-sig/latest/meta/CONTRIBUTING.html
09:38:58 <aspiers> I wrote this :-)
09:39:34 <aspiers> #action improve CONTRIBUTING.rst to explain how / when to propose stories / specs
09:39:51 <aspiers> #action link to CONTRIBUTING.html from wiki page
09:40:05 <aspiers> OK
09:40:18 <aspiers> tojuvone: do you want to discuss Fenix a bit?
09:40:41 <tojuvone> well, ifat_afek is not present
09:40:58 <tojuvone> maybe just some words
09:41:05 <aspiers> ah, OK we can discuss later today too
09:41:07 <aspiers> #topic Fenix (new project)
09:41:14 <tojuvone> So, there is new project: Fenix - Rolling maintenance, upgrade and scaling
09:41:25 <aspiers> #link https://wiki.openstack.org/wiki/Fenix
09:41:27 <tojuvone> I introdicid a bit in session
09:41:48 <tojuvone> and one can find link to it from the etherpad
09:42:01 <tojuvone> read and reach to know more
09:42:08 <aspiers> do you have an IRC channel?
09:42:29 <tojuvone> just the bit for any self-healing project like Vitrage and Masakari
09:42:40 <tojuvone> #link https://fenix.readthedocs.io/en/latest/notification/notifications.html#admin
09:43:01 <tojuvone> So as Fenix does maintenance there is a notification telling host is in maintenance or not
09:43:23 <tojuvone> so this awareness might be good for those projects
09:43:47 <tojuvone> Yes, irc is: #openstack-fenix
09:43:52 * aspiers joins :)
09:44:19 <aspiers> OK cool
09:44:28 <tojuvone> Maybe not more for here now
09:44:32 <aspiers> let's discuss again with ifat_afek at the meeting later today
09:44:38 <aspiers> thanks tojuvone :)
09:44:48 <aspiers> #topic AOB (Any Other Business)
09:44:55 <aspiers> does anyone else want to bring up any other topics?
09:45:04 <aspiers> witek: anything from you?
09:45:36 <witek> perhaps short update from previous virtual Vitrage PTG
09:45:46 <aspiers> oh that would be great!
09:45:58 <witek> I have joined to discuss Monasca - Vitrage integration
09:46:09 <aspiers> very nice :)
09:46:17 <witek> we've created three stories in StoryBoard for this
09:46:19 <aspiers> this was one of the big gaps in Vitrage IIUC
09:46:29 <witek> https://storyboard.openstack.org/#!/story/2004064
09:47:06 <witek> unfortunately we don't have anyone who could work on this now :(
09:47:22 <aspiers> ah :/
09:47:28 <witek> looking for developers
09:47:30 <aspiers> well, a plan is a good start anyway
09:47:43 <aspiers> maybe this SIG can help find developers
09:48:02 <witek> that's our hope, too
09:48:09 <aspiers> I have added the link in line 74 of https://etherpad.openstack.org/p/self-healing-project-integrations
09:48:39 <witek> thanks
09:48:44 <aspiers> I would love to work on that, but won't be able to any time soon :-/
09:48:47 <aspiers> maybe in the future
09:49:09 <aspiers> can you share a link to the virtual PTG?
09:49:43 <witek> the work item seems pretty well defined, so it should be well suited for new developers
09:49:49 <aspiers> nice
09:49:55 <witek> also, we're willing to help
09:50:08 <witek> I'd have to dig for the PTG link
09:50:36 <aspiers> I think it's https://etherpad.openstack.org/p/vitrage-ptg-queens
09:50:39 <aspiers> no
09:50:42 <aspiers> that's old
09:51:28 <aspiers> https://etherpad.openstack.org/p/vitrage-stein-ptg
09:51:38 <aspiers> that one, right?
09:52:03 <witek> yes, thanks
09:52:10 <aspiers> cool
09:52:21 <aspiers> OK, anything else anyone wants to mention?
09:52:25 <aspiers> I think we are pretty much done
09:53:08 <tojuvone> nothing from my side
09:53:18 <aspiers> of course anyone is very welcome to also join the Americas/EMEA session in ~7 hours from now
09:53:29 <aspiers> hopefully ekcs will be joining then too
09:53:47 <aspiers> since I might have to drop early from that one :-o
09:54:07 <aspiers> and of course anyone is free to chat in this channel at any other times too
09:54:19 <aspiers> thanks a lot everyone and bye for now!
09:54:25 <aspiers> o/
09:54:39 <witek> thanks everyone, bye
09:54:49 <tojuvone> tnaks, byez
09:54:56 <aspiers> #endmeeting