17:05:39 <aspiers> #startmeeting self-healing
17:05:40 <openstack> Meeting started Wed Jan  2 17:05:39 2019 UTC and is due to finish in 60 minutes.  The chair is aspiers. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:05:41 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:05:43 <openstack> The meeting name has been set to 'self_healing'
17:05:46 <aspiers> #topic backlog review
17:06:00 <aspiers> BTW I noticed that storyboard has nice permalinks now
17:06:14 <aspiers> #link https://storyboard.openstack.org/#!/project/openstack/self-healing-sig for SIG backlog
17:06:40 <aspiers> #link http://eavesdrop.openstack.org/meetings/self_healing/2018/self_healing.2018-12-19-09.02.html last meeting
17:07:05 <aspiers> we didn't have a meeting this morning, but I had a quick chat with ifat_afek
17:07:38 <aspiers> in Dec she already delivered on the action from last meeting about submitting a spec
17:07:59 <aspiers> #link https://review.openstack.org/#/c/627180/
17:08:23 <aspiers> I think that's all you missed recently
17:08:58 <ekcs> oh got it that’s great
17:09:32 <ekcs> very helpful work to document how to identify with monasca alarms based on dimensions.
17:09:40 <aspiers> yeah
17:09:44 <ekcs> will be useful even beyond vitrage.
17:09:52 <aspiers> I need to get my head around that, it's new stuff for me
17:10:34 <aspiers> just looking at what else is ongoing
17:10:51 <aspiers> damn, I still didn't send out a summary of Berlin
17:10:59 <ekcs> aspiers: I see you’ve signed up for quite a few SIG admin things. I can off load some if you’d like just let me know.
17:11:06 <aspiers> that would be great :)
17:11:21 <aspiers> I feel like we have to keep hammering away at https://storyboard.openstack.org/#!/story/2004537
17:11:36 <aspiers> It's gonna take regular publicity from multiple angles
17:12:06 <aspiers> maybe you could take 28285 or 28309?
17:13:04 <ekcs> great.
17:13:11 <ekcs> I can take both.
17:13:36 <ekcs> changed on board.
17:15:12 <aspiers> awesome thanks!
17:15:38 <aspiers> I guess it should be easy to finish https://storyboard.openstack.org/#!/story/2004536
17:15:52 <aspiers> I can do that now
17:16:30 <ekcs> of back to f2f events: if you already have events in mind to look into pls let me know so I can make sure I don’t overlook them in my search.
17:16:41 <aspiers> I don't have any in mind
17:16:55 <aspiers> not sure where to get visibility of that
17:17:03 <aspiers> maybe we can reach out to the UC?
17:17:18 <aspiers> I guess they will know about all the OpenStack Days and Meetups
17:17:33 <ekcs> ok great I’ll dig around and update.
17:17:36 <aspiers> I'm gonna ask on #openstack-uc now
17:17:42 <ekcs> ok
17:18:17 <aspiers> OK done
17:18:32 <aspiers> #action clarify on wiki page where to find docs / storyboard
17:18:56 <aspiers> hrm forgot to include action owner
17:20:10 <aspiers> #action aspiers to ask the UC about how to find out upcoming events
17:20:26 <aspiers> regarding https://storyboard.openstack.org/#!/story/2004535 I emailed the guy who proposed it but never heard back
17:20:36 <aspiers> so I guess it's up to us to submit this use case (task 28279)
17:21:02 <ekcs> I see3
17:21:18 <aspiers> I can try to find time for that, unless it's particularly appealing to you
17:22:14 <ekcs> I am interested. But I’m quite unfamiliar with that territory.
17:22:25 <aspiers> No less familiar than me I guess ;-)
17:22:55 <aspiers> It's just a matter of taking the template and replacing the boilerplate with the info about a memory leak scenario
17:23:08 <ekcs> cool I’ll take a first crack at it.
17:23:13 <aspiers> cool thanks!
17:23:26 <aspiers> the example he gave was a leak in ovs-vswitchd
17:23:32 <aspiers> https://etherpad.openstack.org/p/berlin-self-healing-sig-brainstorm line 53
17:23:38 <aspiers> but it could be any service really
17:24:39 <ekcs> I’ll need to read up on current practices on how to even detect memory leaks over time.
17:24:50 <aspiers> yeah
17:25:13 <aspiers> the use case doc doesn't necessarily have to go into details, at least not at first
17:25:19 <aspiers> I think it's OK if it's initially quite vague
17:25:24 <ekcs> ok got it.
17:25:35 <aspiers> we can flesh it out later, or add details in a separate spec if coding is required
17:26:00 <aspiers> maybe it can all be done simply using Vitrage + Mistral + $monitoring_component
17:26:31 <aspiers> it would still be nice just to have the idea documented, to get people's creative juices flowing :)
17:26:41 <ekcs> perfect.
17:27:17 <aspiers> I think we can abandon https://storyboard.openstack.org/#!/story/2003423
17:27:36 <aspiers> based on discussion in Berlin, or maybe it was Denver - I can't remember :)
17:27:41 <ekcs> yes that makes sense.
17:27:45 <ekcs> denver.
17:27:49 <aspiers> fungi suggested using survey.openstack.org instead
17:27:55 <aspiers> and we already have a task for that
17:28:14 <aspiers> OK cool, I'll add a comment and close it
17:29:13 <aspiers> #action find the Denver etherpad which covered the User Survey discussion, and close the corresponding story
17:29:22 <aspiers> doh, forgot to assign myself again
17:30:24 <aspiers> I guess we don't need to discuss https://storyboard.openstack.org/#!/story/2002684
17:30:33 <aspiers> since that's already in Ifat's very capable hands :)
17:30:58 <aspiers> next one is https://storyboard.openstack.org/#!/story/2002129
17:31:06 <aspiers> ugh, I have been the bottleneck on that forever :-(
17:31:25 <aspiers> need to resurrect that doodle poll
17:33:05 <aspiers> do you think my idea of a kickoff video conference still makes sense? I feel like the key to success here would be to get SUSE + Red Hat + one or two other companies to all donate ~0.5 engineers to the cause
17:33:28 <aspiers> to form a virtual team
17:33:48 <aspiers> without a bit of dedicated resource it seems unlikely it will happen any time soon, since it's not trivial
17:33:59 <aspiers> sampath would definitely join the effort
17:34:15 <aspiers> since he's probably the only one working on it right now
17:35:02 <ekcs> hmm. that makes sense.
17:35:18 <aspiers> maybe rather than spend the next 25 mins discussing the rest of the backlog, we could wrap up this meeting early and I could actually see how many things I can close off in 25 mins ;-)
17:35:29 <aspiers> for example https://storyboard.openstack.org/#!/story/2001628 should be low-hanging fruit too
17:35:31 <ekcs> not sure how best to take the initial approach tho.
17:36:06 <aspiers> well, we can at least try to get enough interested people in the same conf call
17:36:12 <ekcs> great.
17:36:16 <aspiers> if it works, great - if not, we tried :)
17:36:27 <ekcs> right.
17:36:42 <aspiers> alright
17:36:52 <aspiers> anything else you wanna raise right now?
17:37:01 <ekcs> nothing on my side at the moment =)
17:37:05 <aspiers> OK cool
17:37:18 <aspiers> I'll be around on this channel anyway
17:37:30 <aspiers> thanks!
17:37:36 <aspiers> #endmeeting