17:03:08 <aspiers> #startmeeting self-healing
17:03:09 <openstack> Meeting started Wed Apr 24 17:03:08 2019 UTC and is due to finish in 60 minutes.  The chair is aspiers. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:03:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:03:13 <openstack> The meeting name has been set to 'self_healing'
17:03:31 <aspiers> I've only got 20-25 mins unfortunately but I doubt we'll need more anyway
17:03:43 <aspiers> #topic RPC health checks
17:04:09 <aspiers> my colleague Jiri submitted https://review.opendev.org/#/c/653707/
17:04:24 <aspiers> I'm just working on another patch set which makes a few minor tidy ups
17:04:48 <aspiers> then I think it's probably ready to approve
17:04:56 <ekcs> oh great! will take a look.
17:05:13 <aspiers> I can certainly hold off W+1 until you've reviewed
17:05:24 <aspiers> but maybe wait for the next patch set first
17:05:32 <aspiers> maybe later today, not sure
17:05:38 <aspiers> or early tomorrow
17:05:59 <aspiers> #topic Denver
17:06:30 <aspiers> I'll send out a reminder to the ML about the two sessions and the etherpad
17:06:39 <aspiers> last call for topics etc.
17:06:49 <aspiers> are there any other preparations we need to do?
17:08:22 <ekcs> I was hoping for some kind of indication of which topics for which session, but it doesn’t seem like we’ll get enough info to plan that.
17:08:32 <aspiers> haha yeah, probably not
17:08:39 <aspiers> it's always pretty last minute :)
17:09:01 <aspiers> for the Forum it's usually just see who turns up and what they want to discuss
17:09:52 <ekcs> not much I can think of other than that. i can scout out the location once there to see projector situation etc.
17:09:57 <aspiers> good idea
17:10:27 <aspiers> I wonder to what extent the SIG should aim to seek out developer resources for our initiatives, like the dev equivalent of fund-raising ;-)
17:10:54 <aspiers> for example we see clear value community-wide in API health checks but so far noone has stepped forwards to actually do it
17:11:10 <aspiers> although that is a bad example because I really thought I would be able to spend time on it
17:11:13 <aspiers> and then failed ;-/
17:11:30 <aspiers> but automated testing is another big one
17:12:18 <ekcs> yea true.
17:12:23 <aspiers> if we run out of things to discuss in the PTG session (which has never happened before so probably won't this time) then we could always turn it into an actual working session where we try to accomplish or at least kickstart one or two things at accelerated pace
17:12:43 <ekcs> yes that makes sense.
17:12:59 <ekcs> perhaps for automated testing,
17:13:28 <aspiers> Yeah
17:14:33 <ekcs> and things like that, we can help make sure the relevant/interested projects at least identify it within each project as a task of some priority.
17:14:39 <aspiers> right
17:15:11 <ekcs> at the very least it gives a broader range of people the opportunity to volunteer.
17:15:17 <aspiers> yep
17:15:28 <aspiers> I have a whitepaper on Eris contributed by Gautam before he had to drop out
17:15:46 <aspiers> I've converted it in .rst form but never got round to submitting
17:16:08 <aspiers> that could be a quick hack although maybe not easily divisible
17:18:14 <ekcs> I see. maybe just submit as is to gerrit as WIP and make clear people are welcome/encouraged to pick it up and finish.
17:18:22 <aspiers> true
17:18:59 <aspiers> let's both go through storyboard before next week and see if there are any loose ends which can easily be tied up
17:19:16 <ekcs> sounds good
17:19:36 <aspiers> that whitepaper is certainly one of them
17:20:35 <openstackgerrit> zhulingjie proposed openstack/ha-guide master: Replace git.openstack.org URLs with opendev.org URLs  https://review.opendev.org/654927
17:20:35 <aspiers> alright
17:21:00 <aspiers> #action aspiers and ekcs to go through storyboard before next week and see if there are any loose ends which can easily be tied up
17:21:13 <aspiers> #topic oslo.monitoring / oslo.metrics idea
17:21:27 <aspiers> not gonna go into detail on this, but just wanted to mention
17:21:40 <aspiers> my colleague Dirk proposed this idea early today
17:22:12 <aspiers> basically a more standardised way of OpenStack services reporting health / performance metrics in a way which could then be gathered by monitoring systems such as Prometheus
17:22:49 <aspiers> it might belong more to oslo, or maybe to this SIG, or maybe monasca
17:22:50 <witek> I'm interested in joining this effort as well
17:22:53 <aspiers> it's not clear yet
17:22:59 <aspiers> ahah! perfect timing witek ;-)
17:23:20 <aspiers> yeah Dirk mentioned you had some thoughts about monasca and Prometheus
17:23:37 <aspiers> I don't fully understand it yet, but I'd be more than happy to discuss it in the SIG session next Thursday afternoon
17:24:20 <aspiers> witek: I asked Dirk if he could add an entry to https://etherpad.openstack.org/p/DEN-self-healing-SIG but if you feel inclined and understand it well enough then feel free to beat him to it
17:24:26 <openstackgerrit> zhulingjie proposed openstack/ha-guide master: Replace git.openstack.org URLs with opendev.org URLs  https://review.opendev.org/654927
17:24:50 <aspiers> personally I see bad performance as "soft failures", so in that light I think they can fall under the scope of this SIG
17:25:04 <aspiers> especially when cross-project work is required
17:25:16 <witek> hm, Dirk hasn't told me more then two sentences, so I guess we are free to shape it :)
17:25:23 <aspiers> :)
17:25:32 <aspiers> alternatively we could gatecrash the oslo room ;-)
17:25:35 <ekcs> yea that makes a lot of sense. I understand that prometheus defines standard APIs from which it will pull data, and many services implement those interfaces. certainly seems to make sense for openstack services to support it.
17:25:56 <openstackgerrit> jacky06 proposed openstack/ha-guide master: Replace git.openstack.org URLs with opendev.org URLs  https://review.opendev.org/654927
17:26:07 <aspiers> right, apparently Canonical have done a prometheus exporter but it's only providing things like lists of users/projects/fips which isn't really useful for performance
17:26:59 <ekcs> I see
17:27:11 <witek> Monty has recently added functionality to OpenStackSDK which sends statistics both to Prometheus and StatsD
17:27:22 <aspiers> oh that's interesting
17:27:28 <aspiers> let's try to grab him too then
17:27:34 <aspiers> unfortunately I've got to dash soon and I guess we don't have enough info here to discuss it much more anyway
17:27:34 <witek> https://review.opendev.org/#/c/614834/
17:28:16 <aspiers> interesting
17:28:40 <witek> PTG will be a good place to discuss it more
17:29:34 <aspiers> yup
17:29:52 <aspiers> alright, let's wrap it up, unless anyone has any other issues?
17:30:06 <ekcs> i’m good for now!
17:30:52 <witek> thanks, see you next week
17:30:55 <aspiers> cool. looking forward to next week!!
17:30:57 <aspiers> #endmeeting