17:04:25 <aspiers> #startmeeting self-healing
17:04:26 <openstack> Meeting started Wed May  8 17:04:25 2019 UTC and is due to finish in 60 minutes.  The chair is aspiers. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:04:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:04:29 <openstack> The meeting name has been set to 'self_healing'
17:04:35 <aspiers> #topic Denver recap
17:04:54 <aspiers> #link https://etherpad.openstack.org/p/DEN-self-healing-SIG
17:05:18 <aspiers> I think Denver was pretty successful for the SIG, would you agree?
17:05:29 <aspiers> I was very happy with both sessions, at least
17:05:34 <aspiers> Lots of good conversations
17:05:58 <ekcs> yes I think so!
17:06:14 <aspiers> I think we need to make sure all the actions are captured in Storyboard
17:06:17 <ekcs> got a good number of use cases identified and initial discussions.
17:06:22 <ekcs> also a few deep dives.
17:06:30 <aspiers> right
17:07:18 <aspiers> I'm just looking at the etherpad
17:07:42 <aspiers> seeing what's missing
17:07:59 <aspiers> Hrm, are we missing a story for Vitrage/Monasca work?
17:08:05 <ekcs> that’s a good idea. but should we let each action taker add to storyboard or do it more centrally?
17:08:42 <ekcs> yea maybe. I don’t see it.
17:08:55 <aspiers> I suspect most of the actions are ours. But for any actions which aren't, chasing the action taker to add to SB is probably as much work as doing it ourselves
17:09:19 <ekcs> hahaha.
17:09:29 <aspiers> searching Vitrage SB
17:10:23 <aspiers> https://storyboard.openstack.org/#!/story/2004064
17:10:31 <aspiers> https://storyboard.openstack.org/#!/story/2004550
17:11:08 <ekcs> ah great.
17:11:37 <aspiers> so we need to add tasks for documenting in the SIG, I guess
17:13:19 <aspiers> hrm, maybe let's do it topic by topic then
17:13:55 <aspiers> #topic compute HA
17:14:58 <aspiers> added a doc task
17:15:57 <aspiers> to https://storyboard.openstack.org/#!/story/2002124
17:16:25 <aspiers> also need a doc story for masakari
17:16:54 <aspiers> Looks like they're not using SB yet :-/
17:17:04 <aspiers> OK, that's an action for sampath
17:17:43 <ekcs> what do you think about doing it this way? one of us takes line 111-175. the other one 176-end. we go ahead and add whatever we think we need for that section of the etherpad.
17:18:12 <aspiers> Sure, that makes a lot more sense doing it in parallel
17:18:16 <ekcs> then come back to this meeting and cross check a bit.
17:18:21 <aspiers> yup
17:18:51 <aspiers> I'll minute mine as I go, and then we can meet back here in 10-20 and minute yours?
17:19:01 <ekcs> ok which section you taking?
17:19:05 <aspiers> the first
17:19:10 <ekcs> ok!
17:20:12 <aspiers> added another task to https://storyboard.openstack.org/#!/story/2002124 for webhooks idea
17:20:31 <aspiers> #topic Vitrage / Monasca integration
17:25:40 <aspiers> added two doc tasks to the existing stories
17:25:50 <aspiers> and linked to the two stories from the DEN etherpad
17:27:31 <aspiers> messaged Sumit about getting Watcher in the loop (line 149)
17:27:42 <aspiers> #topic API health checks
17:28:44 <aspiers> IIRC we didn't make much progress on this, except for conversations on the next topic, which post-DEN are evolving into an almost consensus to merge into this:
17:28:52 <aspiers> #topic RPC service health checks
17:29:12 <aspiers> I've already followed up on both actions here
17:38:04 <aspiers> added 3 tasks to https://storyboard.openstack.org/#!/story/2001439 which came out of those discussions
17:38:31 <aspiers> I guess I need to mail the ML about all this
17:38:52 <aspiers> in fact I should send a report on the SIG activities
17:39:01 <aspiers> #action aspiers to send a report on the SIG activities in DEN
17:40:32 <aspiers> #topic gating and tempest setup
17:42:30 <aspiers> adding ricolin's reviews to the etherpad
17:43:32 <ekcs> ok weird I’m stuck on a deadlock error on storyboard. maybe parallel wasn’t a good idea =p
17:43:41 <aspiers> haha oh dear
17:43:46 <aspiers> which story?
17:45:33 <ekcs> deadlocks when I try to save a story. I’ll leave that alone for now haha.
17:45:50 <aspiers> report it in #storyboard
17:48:54 <ekcs> ok well maybe we should sync back up now.
17:48:59 <aspiers> #topic automated testing
17:49:01 <ekcs> before ime runs out.
17:49:13 <aspiers> OK
17:49:18 <aspiers> I think we timed that perfectly :)
17:49:25 <aspiers> I just reached your first section
17:51:07 <ekcs> ok. so I didn’t get quite as far.
17:51:10 <ekcs> going backwards:
17:51:28 <ekcs> I added a story and tasks re monitoring number of database connections and taking preventative action.
17:51:29 <ekcs> https://storyboard.openstack.org/#!/story/2005631
17:52:23 <ekcs> write story and tasks for “oslo.metrics” topic, but that one fails to create on story board.
17:52:33 <ekcs> I’ll need to figure that out later.
17:52:47 <aspiers> #topic rest of topics from DEN
17:52:50 <aspiers> no problem
17:53:01 <aspiers> I think dirk was promising a write-up of that anyway
17:53:13 <aspiers> since we had some follow-on conversations with bnemec
17:53:19 <aspiers> on Sat afternoon
17:53:30 <ekcs> ready to submit story on complex self healing strategies.
17:53:41 <aspiers> nice
17:53:48 <ekcs> haven’t gotten to ERIS.
17:53:59 <aspiers> ERIS is already captured in SB
17:54:09 <aspiers> I just added a task for me to watch the enos videos
17:54:22 <ekcs> ok perfect.
17:54:55 <ekcs> I’ll finish up what I couldn’t get through after we finish meeting =)
17:55:05 <aspiers> OK
17:55:24 <aspiers> I think that's far too much progress for one day, so we can probably finish here ;-)
17:55:29 <ekcs> =p
17:55:31 <aspiers> unless you have anything else
17:55:44 <aspiers> oh
17:55:49 <aspiers> I remembered one important link
17:55:57 <aspiers> the most important, in fact
17:56:16 <aspiers> #link https://twitter.com/adamspiers/status/1124091096554987522
17:56:46 <ekcs> haha!
17:57:12 <aspiers> alright, catch you soon ;-)
17:57:28 <ekcs> yup. have a great rest of the week!
17:57:34 <aspiers> you too!
17:57:36 <aspiers> #endmeeting