14:00:12 <ricolin> #startmeeting self_healing
14:00:13 <openstack> Meeting started Tue Jan  7 14:00:12 2020 UTC and is due to finish in 60 minutes.  The chair is ricolin. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:16 <openstack> The meeting name has been set to 'self_healing'
14:00:22 <ricolin> #topic roll call
14:00:46 <ricolin> This meeting is for auto-scaling and self-healing both:)
14:03:24 <ricolin> looks like we won't get enough people to start meeting today
14:04:57 <ricolin> for meeting logs, we now start the effort to combine two SIGs into one, and merge the meeting, events will be the first step. We need some discussion on what else we should merge too
14:05:34 <ricolin> And if you missed the meeting, it will be biweekly-even meeting schedule as shows in http://eavesdrop.openstack.org/#Self-healing_SIG_and_Auto-scaling_SIG_Meeting
14:05:40 <ricolin> #link http://eavesdrop.openstack.org/#Self-healing_SIG_and_Auto-scaling_SIG_Meeting
14:08:23 <ricolin> CI jobs for autoscaling with heat and monasca is currently WIP, will build zuul job in repo once we have the test ready, and than we start to ask projects to cross-project gating with it if possible
14:09:18 <ricolin> and besides CI the guildeline should start next phase tasks too which IMO should include some detail guideline
14:09:24 <ricolin> as shows in story
14:09:26 <ricolin> #link https://storyboard.openstack.org/#!/story/2007046
14:09:59 <ricolin> here's story for cross-project CI if you're interested in
14:10:01 <ricolin> #link https://storyboard.openstack.org/#!/story/2005752
14:11:00 <witek> hi ricolin, sorry for being late
14:11:07 <ricolin> NP
14:11:26 <ricolin> we have this scheduled in rush
14:11:44 <ricolin> the meeting patch actually landed few hours ago:)
14:12:33 <witek> thanks for working on auto-scaling testing jobs
14:12:52 <ricolin> witek, did you see my comments yet?
14:13:52 <witek> yes, I pointed to your changes in Monasca meeting one hour ago
14:14:41 <ricolin> the test in https://review.opendev.org/#/c/700970 still fail because I miss-written the template, which I will correct it later today
14:14:48 <ricolin> witek, how's that goes
14:15:25 <witek> what do you mean?
14:16:16 <ricolin> I mean, you pointed my changes in Monasca meeting, is there's any feedback for those changes
14:16:53 <witek> Sumit has promised to review the changes
14:17:02 <ricolin> cool
14:17:06 <witek> you also got a review comment from Doug
14:17:17 <ricolin> okay, will take a look
14:17:29 <ricolin> thanks
14:17:59 <ricolin> #topic open discussion
14:18:30 <ricolin> besides the CI job
14:18:56 <ricolin> It will be great if we can start putting some detail guideline down too
14:19:29 <witek> where are the necessary libraries getting installed in these CI jobs for heat_tempest_plugin?
14:19:48 <witek> in particular python-monascaclient?
14:21:24 <ricolin> it's collected when install any project require python-monascaclient
14:21:57 <witek> that would be heat itself
14:22:29 <witek> and because listed in Zuul's 'required-projects' it should use HEAD, right?
14:23:01 <witek> and not tagged version
14:23:04 <ricolin> yes
14:23:51 <ricolin> if we check under /opt/stack/python-monascaclient it will be master
14:24:07 <ricolin> and pip install will directly go to master branch
14:26:08 <ricolin> correction,  /opt/stack/python-monascaclient it will HEAD we point to
14:27:05 <witek> so https://review.opendev.org/700886 should be testing your fix from python-monascaclient now, but it still fails
14:27:23 <ricolin> indeed
14:28:34 <ricolin> maybe that patch is not working too, I thought pip might be get the master branch from opendev site, but it directly use HEAD too https://982697e52cb2ad6aee54-6c5d61f7d9b09f80ec4de0e8f6953df6.ssl.cf5.rackcdn.com/700970/7/check/heat-functional/0d22f09/controller/logs/pip3-freeze.txt
14:30:09 <witek> yes, that's why I was wondering if there is some other magic pulling in the released client version
14:30:55 <ricolin> everything we test was installed under /opt/stack/tempest/.tox/tempest
14:31:51 <ricolin> we can check if something override in that tox env
14:35:42 <ricolin> will update the test template later, see if got time for monascaclient
14:35:55 <ricolin> feel free to udpate that patch as you wish too
14:36:09 <witek> will have a look at this as well, thanks a lot for your effort
14:36:14 <ricolin> it's only 1.5 hours for me today:)
14:36:19 <ricolin> NP
14:38:19 <ricolin> I also think we should take actions to invite members from related project teams to join this meeting
14:40:55 <witek> ricolin: good point
14:42:42 <ricolin> #action ricolin will invite members from related project teams to join next meeting
14:43:14 <ricolin> #action witek and ricolin works on the Heat+Monasca CI job
14:43:36 <ricolin> #action we need to find people to volunteer to work on detail guideline
14:43:50 <ricolin> anything else?:)
14:44:57 <witek> I guess it's a good start
14:45:11 <ricolin> witek, think so too:)
14:46:32 <ricolin> Okay, let's end this meeting time
14:46:36 <ricolin> thanks witek
14:46:45 <witek> thanks Rico, see you around
14:46:59 <ricolin> #endmeeting