13:00:29 <Qiming> #startmeeting senlin
13:00:30 <openstack> Meeting started Tue Jun 16 13:00:29 2015 UTC and is due to finish in 60 minutes.  The chair is Qiming. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:34 <openstack> The meeting name has been set to 'senlin'
13:00:50 <Qiming> #topic roll call
13:01:16 <lkarm> o/
13:01:17 <janonymous_> o/
13:01:21 <haiwei> hi
13:01:33 <janonymous_> Jaivish Kothari
13:01:38 <Qiming> don't think a lot of us will show up, this is the first meeting for senlin anyway
13:02:22 <Qiming> #topic get to know each other
13:02:24 <haiwei> at least four :)
13:03:10 <Qiming> I'm expecting everyone to say a few words about yourself
13:03:32 <haiwei> ok, I am xuhaiwei from NEC, nice to meet you
13:03:38 <haiwei> I am in Tokyo
13:03:43 <Qiming> so people get to know your name, where you are located, and your expertise, etc
13:04:02 <janonymous_> Hi i am Jaivish from NEC :) india
13:04:25 <lkarm> Hi, i'm Lisa from IBM in Austin, TX
13:04:30 <Qiming> Qiming Teng, with IBM Research, in China
13:05:38 <haiwei> currently four of us?
13:06:20 <janonymous_> I normally work in swift , keystone and ceilometer .
13:06:32 <Qiming> anyone else?
13:06:55 <haiwei> janonymous, you are in India office?
13:06:58 <Qiming> cool, not a big team so far
13:07:07 <Qiming> let's move on
13:07:14 <Qiming> #topic project status report
13:07:44 <Qiming> Senlin was started last December, positioned as a generic clustering service for OpenStack
13:08:03 <Qiming> the project is now located on stackforge, with both server side and client side code
13:08:30 <Qiming> we have presented the design in the Heat design summit, because we were deeply rooted from Heat
13:08:54 <janonymous_> haiwei : yes .
13:09:03 <Qiming> the top priority for the project for the first release (Liberty) would be making autoscaling work
13:09:21 <Qiming> and hopefully, bridge the Heat support to autoscaling to Senlin
13:09:39 <haiwei> Qiming, so how far are we there?
13:09:44 <Qiming> there are a lot of work to do for us to achieve that goal
13:10:17 <Qiming> to support autoscaling, we are developing a scaling policy spec and the supporting plugin
13:10:32 <Qiming> hopefully, that will be done by Liberty-2
13:11:12 <janonymous_> Yes i am ready to work hard . but i could only work after my office hours because it's my priority :) . will that be ok?
13:11:15 <Qiming> I have to say, it is not a trivial thing, considering that we may need to explore message queue service (zaqar) some time
13:11:35 <Qiming> sure
13:11:48 <Qiming> any kinds of contributions are welcomed, sir
13:11:48 <janonymous_> Thanks :)
13:12:05 <Qiming> time for you to pour questions on me
13:12:43 <haiwei> what about the short time goal?
13:12:50 <haiwei> short-term
13:13:26 <Qiming> supporting autoscaling is pretty short-term a goal
13:13:27 <janonymous_> Sorry to say but i want to know about senlin , i have very little idea about it.
13:13:43 <Qiming> janonymous_, don't worry
13:13:56 <Qiming> we are working hard to add some documents for developers
13:14:04 <Qiming> for example: https://review.openstack.org/#/c/190447/
13:14:42 <Qiming> you can find us on the #senlin channel most of the time, just jump in and ask questions
13:15:15 <janonymous_> Yes sure sir. is there a mailing list , group for serlin also ?
13:15:19 <haiwei> Qiming, what is not done to support auto-scaling
13:15:36 <Qiming> haiwei, the scaling policy is not done
13:15:49 <Qiming> we have some dependencies on python-openstacksdk project
13:15:57 <lkarm> Just to understand where this is going, once senlin has the scaling policies implemented, the idea is to have something like OS::Senlin::Cluster OS::Senlin::Policy in a heat template to do autoscaling through heat? But then you can also do autoscaling without heat at all right?
13:16:07 <Qiming> we need to push some patches there first
13:16:31 <Qiming> lkarm, right
13:17:12 <Qiming> If you are using Heat for autoscaling, we don't want to break you
13:17:45 <Qiming> however, Senlin has its own APIs and client, that means you can do autoscaling in other ways as well
13:18:00 <lkarm> are you planning on implementing scaling policies in a similar way heat implemented them?
13:18:47 <Qiming> lkarm, yes and no, from user's perspective, we hope we can support their existing autoscaling templates
13:19:15 <Qiming> but implementation perspective, there will be quite some differences
13:19:38 <Qiming> for example, we don't want users to specify alarms, at least that is our current idea
13:20:18 <Qiming> you can check the senlin/examples/policies subdirectory to see how scaling policies will look like
13:20:23 <lkarm> by that you mean no ceilometer dependencies required to do autoscaling?
13:20:49 <Qiming> lkarm, the dependency may exist, but won't be hard-coded
13:21:26 <Qiming> we plan to provide users a choice, use ceilometer, monasca, or whatever 3rd-party monitoring tools
13:22:23 <Qiming> there are plenty of details to be discussed
13:22:51 <Qiming> What I want to say in this meeting is that we need to make all of them a team decision
13:23:39 <Qiming> scaling policy is just one type of policies to be supported, for example
13:24:02 <Qiming> we want to support placement policies, deletion policies, update policies, etc
13:24:31 <Qiming> these policies are all plugins that you can instantiate and attach to a cluster
13:24:42 <Qiming> we believe they are orthogonal to each other
13:25:32 <Qiming> we also plan to submit a talk proposal for the coming Tokyo summit, give the community a deep dive and status update
13:25:58 <Qiming> there have been some requests for Senlin to support clusters of containers, for instance
13:25:59 <yanyanhu> hi, sorry for late, using my phone as hot spot
13:26:45 <lkarm> does that mean magnum integration?
13:26:46 <Qiming> in that case, Magnum will call senlin to create their pool of containers
13:26:54 <haiwei> Qiming, that is an important job I think
13:27:15 <janonymous_> Apart from senlin wiki ,can i get more info about it. because i m not from heat background so i would be needing some docs.
13:27:31 <Qiming> yip, we have talked to Adrian and Steven Dake for this, the only concern they have today is that we are still on stackforge
13:27:46 <Qiming> and they want no dependencies on stackforge projects
13:28:05 <lkarm> so what is the plan for moving from stackforge
13:28:11 <Qiming> janonymous_, okay, we will work on more docs
13:28:16 <haiwei> so it's better to push openstacksdk to be a openstack project
13:28:42 <yanyanhu> or maybe we can start to implement some drivers directly based on other services client?
13:28:50 <Qiming> Senlin project itself, based on the community's criteria, can be proposed as a openstack project today
13:29:03 <haiwei> janonymous_, maybe understanding heat autoscaling first is helpful
13:29:24 <Qiming> the only reason we are not pushing that line is that we have dependencies on python-openstacksdk
13:29:38 <Qiming> and python-opentacksdk is today a stackforge project
13:29:49 <Qiming> we are actively helping that project as well
13:30:15 <haiwei> python-openstacksdk can be a openstack project today, but they just don't want  to be?
13:30:32 <Qiming> em, don't have an answer for that, haiwei
13:31:02 <Qiming> Seems to me, though, the SDK project wants their API design stabilized before proposing
13:31:15 <Qiming> that makes sense to me
13:31:31 <Qiming> and ... it will just be a issue of time
13:31:53 <haiwei> how long it will take ?
13:32:18 <Qiming> yanyanhu, if we introduce dependencies on python-***client into Senlin, we are still eventually throwing them away
13:32:29 <janonymous_> and what can we do for that
13:32:40 <Qiming> haiwei, not sure how long it will take
13:32:51 <yanyanhu> Qiming, that's true, openstack-sdk should be the choice
13:33:06 <Qiming> my personal opinin is focus on Senlin feature development, stability improvement
13:33:16 <haiwei> what about setting a deadline for that
13:33:49 <Qiming> the migration to openstack is just one of the many channels to get this service mature and widely used
13:34:21 <Qiming> haiwei, good point, we need to sync with SDK team on a timeline
13:34:38 <Qiming> #action Qiming to sync with SDK team for timeline
13:34:48 <yanyanhu> actually we still have several import features need to implement including customized action, complicated scaling policy
13:35:09 <Qiming> yanyanhu, +1
13:35:35 <Qiming> let's move on
13:35:50 <Qiming> #topic low-hanging fruits for new contributors
13:36:10 <janonymous_> :)
13:36:24 <Qiming> Many of us are new contributors to Senlin, or new developers for OpenStack
13:36:53 <Qiming> it will be a journey, but it won't be very long one
13:37:15 <Qiming> We are currently filing some bugs for your reference
13:37:19 <Qiming> https://bugs.launchpad.net/senlin/
13:38:16 <janonymous_> I have  question.. What about core contributors of senlin..
13:38:22 <Qiming> Some bugs are really easy to fix, but they will help you understand the architecture of Senlin, the development process for fixing bugs, propose patches etc.
13:38:41 <Qiming> janonymous_, currently we have only two cores, yanyanhu and me
13:38:58 <Qiming> I believe we will need more soon, pretty soon
13:39:19 <haiwei> Qiming, currently I am doing this kind of bug fix
13:39:32 <janonymous_> Yes , i would be one .. i hope :)
13:39:37 <Qiming> thanks, haiwei, keep the good work
13:39:48 <Qiming> janonymous_, you will, if you want
13:39:59 <yanyanhu> hope you guys can get familiar with the project soon : )
13:40:13 <janonymous_> Yes.
13:40:18 <Qiming> some low hanging fruits, out of the bug list: Bug #1465565, Bug #1465211, Bug #1465509, Bug #1465518, Bug #1465620
13:40:21 <openstack> bug 1465565 in senlin "Policy attach should use policy defaults if not specified" [High,Triaged] https://launchpad.net/bugs/1465565
13:40:22 <openstack> bug 1465211 in senlin "profile type matching should be checked earlier" [Medium,Triaged] https://launchpad.net/bugs/1465211
13:40:23 <openstack> bug 1465509 in senlin "Policy attach API should perform parameter validations" [Medium,Triaged] https://launchpad.net/bugs/1465509
13:40:25 <openstack> bug 1465518 in senlin "Policy detach action API should do some early validation" [Medium,Triaged] https://launchpad.net/bugs/1465518
13:40:26 <openstack> bug 1465620 in senlin "Policy update API is not checking the JSON body" [Medium,Triaged] https://launchpad.net/bugs/1465620
13:40:35 <Qiming> just some examples
13:41:17 <yanyanhu> hi, Qiming, maybe completing exception translation is also one?
13:41:26 <Qiming> btw, we have two files maintained for short-term and long-term jobs
13:41:42 <Qiming> yanyanhu, that sounds more like a TODO item, not a bug
13:41:48 <yanyanhu> yes
13:41:51 <Qiming> http://git.openstack.org/cgit/stackforge/senlin/tree/TODO.rst
13:42:18 <Qiming> we maintain a TODO file in the code repo, listing things we need to do
13:42:44 <Qiming> items in the TODO.rst file doesn't require a design discussion
13:43:11 <Qiming> if you know how to get it done, claim it by signing your name after that item, do it
13:43:23 <Qiming> remove it when it is finished
13:43:35 <Qiming> another file: http://git.openstack.org/cgit/stackforge/senlin/tree/FEATURES.rst
13:44:10 <Qiming> this is a list of feature request we collected, most of them need some discussions among the team before coding
13:44:34 <Qiming> feel free to start a thread on any of them
13:45:13 <Qiming> if needed, we may create a senlin-specs project for reviewing things like these
13:45:41 <Qiming> questions, comments, suggestions?
13:46:04 <janonymous_> that was helpful.
13:46:45 <Qiming> the FEATURES.rst, to some extent, give you a sense where we are heading, hopefully
13:47:17 <Qiming> okay, let's move on
13:47:24 <Qiming> #topic open discussions
13:48:39 <yanyanhu> hi, Qiming, do we need to arrange some phone calls to answer some questions which may need detailed explaination?
13:49:07 <Qiming> during the Vancouver summit, I met some guys from Alcatel-Lucent, they may join us some day
13:49:35 <haiwei> good news
13:49:37 <janonymous_> Kindly add me on your mailing lists if possible. janonymous.codevulture@gmail.com
13:49:39 <Qiming> phone calls? we can discuss that
13:50:14 <Qiming> janonymous_, all openstack/stackforge projects are supposed to use the official mailinglist for discussion
13:50:14 <haiwei> phone calls means call by phone??:)
13:50:24 <yanyanhu> yes ;)
13:50:41 <haiwei> personal phone call?
13:50:58 <Qiming> when posting your message, be sure to tag your subject with '[Senlin]' so that people can filter it
13:51:01 <yanyanhu> hmm, not sure about the way
13:51:10 <haiwei> I will add your wechat :)
13:51:24 <yanyanhu> nice
13:51:30 <Qiming> phone calls in general is not encouraged, if I'm understanding it correctly
13:51:39 <Qiming> it is kind of private communication
13:52:00 <yanyanhu> yes, I mean something like call conference
13:52:03 <haiwei> i agree with you
13:52:09 <Qiming> I believe all discussions should be open to the public
13:52:17 <yanyanhu> if we can find a way to let everybody join
13:52:28 <yanyanhu> ok, agree
13:52:40 <janonymous_> +1
13:52:48 <Qiming> yep, stay awake on the #senlin channel, be an answer machine, :)
13:53:26 <haiwei> Qiming, that's great
13:53:37 <haiwei> what about your back?:)
13:53:47 <Qiming> not good, recovering
13:53:47 <lkarm> yep I think IRC is best way to commuincate and discuss
13:53:59 <Qiming> yes, lkarm
13:53:59 <haiwei> agree
13:54:15 <yanyanhu> so let join the channel :)
13:54:32 <Qiming> eventually, when we become an openstack project, IRC chats will be logged, you can find whatever discussions you have missed
13:54:58 <lkarm> ah I was wondering why they weren't currently being logged
13:55:19 <Qiming> that said, the best way to answer questions at the moment is to work on some documents, for users, for developers
13:55:28 <haiwei> stackforge project doesn't have the right?
13:55:49 <Qiming> haiwei, I don't think so, maybe I'm missing something
13:56:00 <Qiming> let the team know if you find a way to log the chats
13:56:17 <yanyanhu> agree, Qiming, will try to complete the doc and wiki
13:56:38 <haiwei> what tool are you using? Qiming
13:56:40 <Qiming> thanks, we then don't have to answer the same questions time and time again
13:56:45 <yanyanhu> it's easy to miss some import topics for time difference
13:56:51 <Qiming> I'm using HexChat
13:57:00 <Qiming> right
13:57:01 <janonymous_> whn is the next meeting..
13:57:26 <Qiming> so if you have something for discussion, you may want to post a note to the mailing list
13:57:35 <Qiming> janonymous_, https://wiki.openstack.org/wiki/Meetings/SenlinAgenda
13:57:37 <haiwei> the same time next week
13:57:48 <Qiming> 1300 UTC, every Tuesday
13:58:02 <janonymous_> thank u
13:58:03 <Qiming> time is up
13:58:09 <Qiming> thank you all for joining
13:58:24 <yanyanhu> thanks, ttyl
13:58:25 <Qiming> see you, see your patches
13:58:40 <haiwei> see you
13:58:42 <janonymous_> :) o/
13:58:47 <Qiming> discussions can continue on #senlin
13:58:55 <Qiming> #endmeeting