13:00:20 <Qiming> #startmeeting senlin
13:00:22 <openstack> Meeting started Tue Jun 23 13:00:20 2015 UTC and is due to finish in 60 minutes.  The chair is Qiming. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:25 <openstack> The meeting name has been set to 'senlin'
13:00:34 <Qiming> hello
13:00:38 <yanyanhu> hi
13:00:58 <haiwei> hi
13:01:30 <Qiming> please add/edit agenda items here: https://wiki.openstack.org/wiki/Meetings/SenlinAgenda
13:01:36 <lkarm> hi
13:02:16 <Qiming> first of all, action from last meeting
13:02:52 <Qiming> I have checked with openstacksdk about their roadmap/plan for migrating from stackforge to openstack
13:03:13 <yanyanhu> ok
13:03:22 <haiwei> good news?
13:05:03 <Qiming> the answer is the same as last time I checked
13:05:03 <Qiming> they have been focusing on hardening the code at the moment
13:05:03 <Qiming> migrating to openstack namespace is not yet the top priority
13:05:04 <Qiming> it is on their their todo list
13:05:05 <Qiming> judge it by yourself, haiwei, :)
13:05:09 <Qiming> #topic test case coverage
13:05:58 <Qiming> so ... for any project to be considered mature enough, it has to have a stable design, no radical changes to the architecture is expected
13:06:03 <haiwei> it's on the todo list, so not bad I think
13:06:21 <Qiming> another criteria is to have test case coverage
13:06:37 <Qiming> that is one of our big problems as of today
13:06:51 <Qiming> if you check here: http://git.openstack.org/cgit/stackforge/senlin/tree/senlin/tests
13:07:06 <jruano> hi qiming... sorry im late. on the heat call as well
13:07:20 <Qiming> we have api, engine test cases there
13:07:34 <Qiming> hi, jruano, glad you can attend both, ;)
13:08:00 <yanyanhu> agree with you, Qiming, and we also don't have integration test yet
13:08:05 <Qiming> we don't have any test cases for policies, profiles, drivers, actions
13:08:16 <Qiming> that would mean quite some work to do
13:08:26 <haiwei> what about the coverage of senlin currently, do you have a number of it Qiming
13:08:45 <Qiming> exactly, yanyanhu, funtional testing is also very important
13:09:05 <Qiming> haiwei, check tox.ini, there is a command you can run and get the report
13:09:18 <haiwei> ok
13:09:21 <jruano> tox -e cover
13:17:31 <Qiming> my rough estimation is about 50% or so
13:17:31 <haiwei> in the client side, seems less
13:17:31 <lkarm> does openstack require a specific number for test coverage?
13:17:31 <Qiming> before we are getting our hands dirty, I'd like to propose a split of the cluster_action.py file, for example
13:17:31 <Qiming> it is too big, too complex
13:17:31 <karolyn> Hi Qiming, sorry I'm late
13:17:31 <Qiming> lkarm, not that I'm aware of
13:17:31 <Qiming> nice see you here, karolyn
13:17:31 <Qiming> good test case coverage is a strong proof of code maturity
13:17:31 <Qiming> writing test cases is fun, :)
13:17:31 <haiwei> ok, let's do it
13:17:32 <Qiming> so, please try navigate the source tree, and find some modules to work on
13:17:32 <haiwei> it also helps understand the function of senlin
13:17:32 <Qiming> definitely, haiwei
13:17:32 <yanyanhu> maybe we can also add this work to TODO.rst
13:17:32 <Qiming> please raise questions if you are not familiar with writing test cases
13:17:32 <haiwei> no problem
13:17:32 <Qiming> yes, give them a higher priority seems not a bad idea
13:19:02 <haiwei> no problem
13:19:09 <yanyanhu> besides the exception type design, and I think we may also need to consider where to catch and how to conver these exceptions
13:19:17 <yanyanhu> especially those ones from driver
13:19:31 <haiwei> exactly
13:19:38 <Qiming> any questions so far?
13:19:39 <yanyanhu> since I think most of them should not be exposed to enduser
13:20:05 <Qiming> yanyanhu, I believe haiwei is on the right track: catch them as internal errors, expose to users when necessary, with clear message translated
13:20:33 <yanyanhu> hmm, actually when I was working the patch of lb-policy, sometimes, I'm a little confused about how to catch them
13:21:06 <Qiming> if you have come up an idea, we can discuss it
13:21:28 <Qiming> or we can discuss the problems you met
13:21:38 <yanyanhu> yes, you are right. Just I'm thinking something more detailed, e.g. whether we should catch exception in create_lb or attach method in lb_policy module
13:22:03 <yanyanhu> like in this patch
13:22:05 <yanyanhu> https://review.openstack.org/#/c/188691/
13:22:06 <haiwei> yanyanhu, I saw your patch, currently raise exception.Error is ok, I think, you can also raise exception.InternalError, if you are sure that is an internal error
13:22:27 <Qiming> in that case, I'd suggest we start with a better structure of the lb specific code
13:22:52 <Qiming> once the layer/structure is there, we will have a better idea how to catch/filter/translate exceptions
13:22:55 <yanyanhu> haiwei, yes, I think the type of exception that raised from driver should be finally changed
13:23:04 <haiwei> in the future, we will delete exception.Error and use exception.InternalError instead
13:23:17 <yanyanhu> Qiming, yes, this is what I'm thinking
13:23:20 <Qiming> haiwei, +1
13:23:45 <Qiming> yanyanhu, still reading your patch, will post comments tomorrow
13:24:00 <yanyanhu> ok, thanks
13:24:08 <Qiming> okay, let's move on
13:24:26 <Qiming> #topic talk proposal for Tokyo summit
13:24:54 <Qiming> the deadline is drawing near, we will have some company internal reviews before submission
13:25:05 <yanyanhu> again?
13:25:21 <Qiming> I hope someone from the team can get an opportunity to give the audience a deepdive
13:25:44 <Qiming> not just a design summit session, I mean a talk for the conference
13:26:02 <haiwei> we have propose one
13:26:06 <yanyanhu> that will be great
13:26:14 <Qiming> lkarm, karolyn, jruano, do you have travel plans for the summit?
13:26:23 <jruano> i will be attending
13:26:29 <lkarm> I'm trying to get my team to send me but nothing official yet
13:26:38 <jruano> so i am more than willing to help
13:27:03 <Qiming> okay, in any case, I will propose haiwei to be one of the presenters
13:27:08 <haiwei> we can have a session held by more than one person
13:27:14 <Qiming> haiwei is located in Tokyo
13:27:32 <haiwei> yes, I am 100% there I think :)
13:27:41 <Qiming> if, for any reasons, we cannot go there, there is still be someone showing up
13:28:11 <yanyanhu> right :)
13:28:14 <haiwei> you are sure coming, right?
13:28:18 <haiwei> Qiming
13:28:23 <Qiming> I'll start a draft of the talk proposal and send you all for review tomorrow
13:28:44 <Qiming> haiwei, nothing official yet
13:28:53 <Qiming> hopefully, I will be there, :)
13:29:06 <karolyn> I'm with Lisa, we are hoping, but nothing official yet
13:29:30 <Qiming> karolyn, let's try our best, :)
13:29:55 <haiwei> Tokyo is not far from Beijing, you can come I think, Qiming
13:30:15 <Qiming> just refreshed the agenda wiki, nothing was added besides these topics I have in mind
13:30:36 <Qiming> haiwei, sure, I will swim there
13:30:59 <Qiming> #topic open discussions
13:31:41 <Qiming> anything you want to talk about?
13:31:45 <yanyanhu> hi, Qiming, I'm thinking whether we should give a time schedule for each TODO item
13:31:50 <haiwei> about the presentation, you will mainly use the slides shown in the last summit?
13:32:06 <haiwei> agree
13:32:12 <yanyanhu> to make it easier to track their progress
13:32:30 <Qiming> okay, a schedule sounds good
13:32:50 <yanyanhu> maybe just a brief plan given by the owner
13:32:56 <Qiming> I've copied the milestones for Liberty cycle
13:33:25 <lkarm> yeah i think having a schedule is a good idea
13:33:31 <Qiming> we can assign todo items to each milestone: L2, L3, for example
13:33:41 <yanyanhu> yes, something like that
13:34:02 <Qiming> should we use blueprints for test cases?
13:34:16 <yanyanhu> I think it's a good idea
13:34:16 <haiwei> I think it's not bad
13:35:06 <yanyanhu> maybe one bp for each module
13:35:08 <Qiming> or bug reports?
13:35:31 <Qiming> it looks a little weird to have bps for test cases
13:35:55 <Qiming> how about we report each missing test case as a bug
13:36:00 <haiwei> not bug reports, each module may need many patches to it
13:36:02 <Qiming> then we track the "bugs"
13:36:04 <jruano> +1 Qiming, i think so too...
13:36:19 <yanyanhu> hmm, if using bug report, I think the unit can be smaller, like lb policy, autoscaling policy
13:36:31 <Qiming> blueprints, to some extents, are for new features
13:36:44 <Qiming> yanyanhu, exactly like that
13:37:06 <lkarm> yeah i bug report makes sensu and agree with yanyanhu should be smaller units
13:37:18 <lkarm> *makes sense
13:37:34 <Qiming> #action everyone work hard to file "bugs"
13:38:00 <haiwei> a module a bug report?
13:38:25 <Qiming> yes, haiwei, that sounds a plan
13:38:50 <Qiming> if the module is too big, like the cluster_action module I just mentioned, we may need to split the module first
13:38:58 <haiwei> but to one module, you may need to submit many patches
13:39:11 <Qiming> or in your patches, you can add tag: #partial-bug: #123456
13:39:12 <openstack> bug 123456 in xine-lib (Ubuntu) "podcast crashes amarok" [Undecided,Fix released] https://launchpad.net/bugs/123456
13:39:35 <haiwei> It is difficult to handle big modules
13:39:41 <Qiming> meetbot is smart
13:40:17 <Qiming> haiwei, if the module is too big, we need to split either the module or the test case
13:40:28 <yanyanhu> just like 'partially implement blueprint'
13:40:37 <Qiming> any module beyond 2000 lines would be a headache for maintenance
13:40:55 <Qiming> it will cause a lot of rebases when people are working on the same module
13:41:15 <haiwei> but if a patch is more than 100 lines, it's also difficult to review
13:41:41 <Qiming> for test cases, it won't be very difficult, haiwei, don't worry
13:42:09 <haiwei> ok, just like you said, we have a try
13:42:09 <yanyanhu> I think for the start point of test cases, it's difficult to avoid big patch...
13:42:43 <Qiming> let's give it a try and see if it works
13:42:46 <yanyanhu> ok
13:42:56 <haiwei> ok
13:43:06 <Qiming> plans are meant to be changed
13:43:17 <Qiming> anything else?
13:43:51 <haiwei> I will have a morning vocation again tomorrow :)
13:43:53 <Qiming> we can end the meeting a little bit early?
13:44:13 <Qiming> haiwei, package me, I want to go
13:44:13 <yanyanhu> yes, I guess so :)
13:44:22 <jruano> oh, thomas said he will move heat meetings to wed to avoid conflict here
13:44:33 <Qiming> thank you all for your time
13:44:36 <haiwei> great
13:44:55 <Qiming> let's move to #senlin
13:44:55 <yanyanhu> yes, jruano, I also saw that reschedule
13:45:05 <Qiming> #endmeeting