13:00:38 <Qiming> #startmeeting senlin
13:00:40 <openstack> Meeting started Tue Jul 28 13:00:38 2015 UTC and is due to finish in 60 minutes.  The chair is Qiming. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:41 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:43 <openstack> The meeting name has been set to 'senlin'
13:00:50 <Qiming> hello
13:00:57 <haiwei> hi
13:00:59 <Yanyan> hi
13:01:07 <lixinhui> hello
13:01:22 <jruano> hi
13:01:29 <Qiming> #topic add agenda items
13:01:47 <Qiming> #link https://wiki.openstack.org/wiki/Meetings/SenlinAgenda
13:02:04 <Qiming> please add topics if you have things for discussion
13:03:06 <Qiming> let's get started
13:03:17 <Qiming> #topic liberty-2 milestone targets
13:03:39 <Qiming> please review the work items and see if there are things missing
13:03:49 <Qiming> #link https://etherpad.openstack.org/p/senlin-liberty-workitems
13:04:02 <Qiming> I have just removed those items we have finished
13:04:55 <jruano> I have a couple I am still working on. will have them in for review today
13:05:12 <Qiming> sounds great, jruano
13:05:22 <Yanyan> I think we have all there
13:05:59 <Yanyan> although some of them could be deferred to liberty-3
13:06:12 <haiwei> I newly assigned to heat_v1 driver, but not started yet
13:06:16 <Qiming> okay, we may have to
13:06:43 <Qiming> maybe it's time to work out a plan for liberty-3
13:06:57 <jruano> were we going to try and have a release or wait for lib 3?
13:07:09 <Yanyan> yep
13:07:21 <Qiming> jruano, we may need to wait for liberty 3
13:07:47 <Qiming> there are quite some known defects to be ironed out
13:08:02 <jruano> that makes sense. stable is best :)
13:08:03 <Yanyan> yes
13:08:26 <Qiming> besides that, we have some high priority todos here: http://git.openstack.org/cgit/stackforge/senlin/tree/TODO.rst
13:09:07 <Qiming> some of the issues have been solved
13:09:38 <Qiming> need an update on that to find out what are left
13:10:23 <jruano> ah yes, looking it over now
13:10:28 <Qiming> basically, for lib-3, we will need to have the engine/action/event modules stable
13:10:58 <Qiming> the nova server and heat stack profile completely debugged
13:11:01 <Yanyan> Qiming, I think maybe we should also implement a basic placement policy which provides cross-region node creation
13:11:25 <Qiming> yes, please add that to the TODO.rst file
13:11:26 <Yanyan> maybe also cross-az/cloud
13:11:28 <Yanyan> ok
13:11:39 <Qiming> also we will need some funtional tests
13:12:24 <Qiming> we will aslo need to promote some middle-priority ones to high-priority
13:12:48 <Yanyan> yes, and I think the work item of workflow cleasing should be replaced by adding functional test
13:13:05 <Yanyan> ok
13:13:07 <Qiming> sounds reasonable
13:13:27 <Qiming> I'm reading the FEATURES.rst file: http://git.openstack.org/cgit/stackforge/senlin/tree/FEATURES.rst
13:14:16 <jruano> a lot of work :)
13:14:35 <Qiming> most of the items in FEATURES.rst are nice-to-have kind of features
13:15:02 <Qiming> each of them would need some time for design, some more time for implement and testing
13:15:19 <Qiming> yip, jruano
13:15:30 <Qiming> it would be a long journey to make things realy useful
13:15:32 <Qiming> :)
13:15:46 <jruano> maybe if we can just identify any that need to be a part of lib 3, that would be helpful
13:15:58 <Qiming> agreed
13:16:09 <lixinhui> I think the functional test and placement policy is the most important
13:16:35 <lixinhui> may help some if time permits
13:17:15 <Qiming> exception handling
13:17:21 <haiwei> in the Tokyo summit, will be a demo in our presentation?
13:17:24 <Yanyan> right
13:17:29 <Qiming> let's get it done right, once for all
13:17:49 <Yanyan> I think we may want to complete the basic framework of exception handling
13:18:04 <Qiming> haiwei, jruano and some university students are working on that
13:18:16 <Yanyan> cool
13:18:26 <Qiming> hopefully we can give a live demo of something really useful
13:18:40 <Yanyan> that will be very nice :)
13:18:42 <haiwei> yes
13:19:26 <Qiming> let's spend some time prioritizing the TODO items for liberty-3
13:20:01 <Qiming> #action Qiming to create a etherpad for everyone to prioritize L3 items
13:20:24 <Qiming> let's move on
13:20:37 <Qiming> #topic update on complex (scaling) policy and triggers
13:20:59 <Qiming> well, I didn't expect it to be such a painful process
13:21:19 <Qiming> I have spent almost 2 weeks on this
13:21:43 <Qiming> the original idea was to compile all information into a single scaling policy
13:21:46 <Yanyan> :) more complicated than we imagined before
13:22:30 <Qiming> in that policy, you will specify the properties for the triggers (alarm, queue notification), schedule (when to enable/disable) and handlers (different actions)
13:23:39 <Qiming> when writing the spec, I found it too (unnecessarily) complicated to squeeze everything into a single YAML
13:24:23 <Qiming> the second issue is that it makes the policy inflexible: any single property change necessitates a new policy spec
13:25:18 <Qiming> the third issue is that it is does not conform to our original design of "policy", which was meant to be some rules that will be checked when actions are about to take place
13:25:50 <Qiming> after some brainstorming with Yanyan, I have now switched to a different approach
13:26:15 <Qiming> we abstract external signals using a concept "Trigger"
13:26:36 <Qiming> we create/update/delete it as a separate resource in Senlin
13:27:15 <Qiming> we link Triggers to webhooks or other "endpoints" to build an auto-scaling solution
13:27:37 <Qiming> we can also link Triggers to webhooks or other receiving points to build HA solution
13:28:22 <Qiming> so ... basically, we are again developing some primitives, leaving more complicated use cases to users
13:28:33 <Qiming> I'd like to hear your comments on this
13:29:05 <jruano> sounds almost like you are building a workflow using triggers?
13:29:28 <Qiming> users will build them or we can help build such kind of a workflow
13:29:56 <Qiming> some sample triggers are here for review/comments: https://review.openstack.org/#/c/206526/
13:30:29 <Qiming> A patch for modeling various ceilometer alarm types is here: https://review.openstack.org/#/c/206527/
13:31:46 <Qiming> take ceilometer alarms as an example, there are too many variants to be incorporated into a single policy
13:32:12 <Qiming> these alarms can be used for whatever use cases
13:34:10 <Qiming> comments?
13:34:15 <Qiming> questions?
13:34:33 <Qiming> or you would like to review the patchs, ;)
13:34:35 <Yanyan> so we hope to keep the flexibility by just providing primitives
13:34:36 <lixinhui> I will try this in next few days for demo purpose
13:34:51 <Yanyan> of course this will also reduce the complication
13:34:53 <Qiming> lixinhui, it is not working yet
13:35:04 <lixinhui> ...
13:35:11 <Qiming> it is just a design by code
13:35:42 <jruano> i think its a good approach. let the user design the workflow using these base alarms
13:35:52 <Yanyan> will give feedback about the patch ASAP
13:36:23 <Qiming> jruano, if needed, we can provide some sample "workflows" to get autoscaling up
13:36:36 <jruano> yep, some "templates"
13:36:50 <Qiming> right
13:37:01 <Qiming> #topic clusters of containers
13:37:33 <Qiming> jruano, how are things going on there?
13:37:39 <jruano> i spent some time working on this. i have coreos running within openstack
13:37:44 <jruano> pretty straightforward
13:38:11 <jruano> docker is natively supported within coreos, so that should be relatively easy
13:38:20 <Qiming> with VM clusters created?
13:38:33 <jruano> kubernetes is more challenging under coreos
13:38:43 <Qiming> yep
13:38:46 <jruano> not yet... i am still debugging a little within magnum
13:39:07 <Qiming> cool, pls keep the team posted
13:39:20 <jruano> running into some issues creating docker bays within magnum, so this is what i am working on now
13:39:43 <Qiming> I traveled to Shanghai last weekend to meet some students from Tongji University
13:39:53 <Qiming> we have a SUR project with them
13:39:59 <jruano> i will have more information on this shortly
13:40:16 <Qiming> they are working on this container cluster topic as well
13:40:43 <Qiming> they are moving pretty slow
13:40:55 <Qiming> just get themselves familiarized with Magnum and Senlin
13:41:36 <Qiming> jruano, if you have some ideas for experimentation, they are your interns
13:41:37 <Qiming> :)
13:41:43 <jruano> lol, np
13:41:54 <jruano> i will write up some notes to share
13:42:05 <Qiming> that would be cool
13:42:44 <Qiming> some of the students are already trying to modify Magnum to call Senlin APIs
13:43:19 <Qiming> hope we can get some POCs soon
13:43:43 <jruano> ah ok... that is a little putting the cart before the horse, but thats fine
13:44:21 <Qiming> anyway, they will need to understand Senlin APIs first
13:45:06 <Qiming> #topic open discussions
13:45:47 <lixinhui> I wanna check if cluster-polict-list problems fixed or not
13:45:59 <Qiming> lixinhui, it is fixed
13:46:25 <lixinhui> please point me to the patch, thanks
13:46:30 <Qiming> it is an issue related to environment configuration
13:47:21 <Qiming> seems we should change this line to "project:%(project)s": http://git.openstack.org/cgit/stackforge/senlin/tree/etc/senlin/policy.json#n3
13:47:45 <Qiming> we don't have project_id in the context structure
13:48:10 <Qiming> need to dig more on the impact on other code
13:48:21 <Yanyan> yes
13:48:35 <Yanyan> otherwise, that rule will not take effect
13:49:12 <Qiming> right, you can do almost nothing if the project doesn't match
13:49:20 <Yanyan> yes
13:49:41 <Qiming> any outstanding issues met?
13:50:46 <Qiming> jruano, we may need to work out a draft design for container clusters
13:50:53 <jruano> i think so
13:51:15 <Qiming> a design that will be applicable to both docker and k8s
13:51:24 <jruano> let me compile some notes as a starting point
13:51:49 <Qiming> it is perfectly okay if we only have docker clusters implemented by l3
13:51:57 <Yanyan> cool, I think that will help all of us to understand it more clearly
13:52:30 <Qiming> anything else?
13:52:38 <jruano> yes... the metadata for k8s is significant
13:52:47 <Yanyan> nope from me
13:53:04 <haiwei> nothing for me
13:53:22 <Qiming> lixinhui, still around?
13:53:47 <lixinhui> yes
13:54:02 <lixinhui> nothing except the policy list
13:54:03 <Qiming> since you are more interested into placement policy, could you help take a look at the cross-region implementation in heat?
13:54:26 <lixinhui> yes, I am looking at it
13:54:41 <Qiming> we need to move that to Senlin -- a concensus from heat team back in Vancouver
13:54:51 <Qiming> cool
13:54:53 <Yanyan> and I just proposed a patch to add this work item, you can add you name behind it if it's ok for you :)
13:55:05 <Qiming> shout out if you need help
13:55:30 <lixinhui> definitly, I will
13:55:38 <Qiming> last call
13:55:47 <jruano> nothing else from me
13:55:50 <Qiming> 4
13:55:55 <Qiming> 3
13:56:01 <Qiming> #endmeeting