13:01:37 <Qiming> #startmeeting senlin
13:01:38 <openstack> Meeting started Tue Sep 15 13:01:37 2015 UTC and is due to finish in 60 minutes.  The chair is Qiming. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:40 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:42 <openstack> The meeting name has been set to 'senlin'
13:01:47 <gongysh> qiming: ping
13:01:58 <Qiming> hi, gongysh, welcome
13:02:04 <yanyanhu> hi
13:02:22 <haiwei> hi
13:02:30 <elynn> Hi
13:02:33 <Qiming> please add topics to the agenda: https://wiki.openstack.org/wiki/Meetings/SenlinAgenda
13:02:46 <yanyanhu> hi, elynn
13:02:46 <jruano> hello
13:03:23 <Qiming> #topic liberty work items
13:03:33 <Qiming> #link https://etherpad.openstack.org/p/senlin-liberty-workitems
13:03:53 <Qiming> container cluster work
13:04:04 <yanyanhu> just cleaned some completed workitems this afternoon
13:04:06 <Qiming> I think we will get an update from the SUR team tomorrow
13:04:31 <Qiming> I was contacted by our team there yesterday, however, I was trapped by a two-day long meeting ...
13:04:45 <Qiming> thanks, yanyanhu
13:04:58 <gongysh> what is SUR team?
13:05:08 <jruano> keep me posted with the update from the team
13:05:23 <Qiming> it is a Shared University Research project we had with Tongji Univ
13:06:04 <Qiming> sure, jruano, will post an update to the team after I get inputs from them tomorrow
13:06:04 <Qiming> the team has been doing a great job in prototyping a container cluster using senlin
13:06:13 <Qiming> it was done in the context of magnum
13:07:48 <gongysh> Qiming,  it seems you should change your network provider
13:07:52 <Qiming> if anyone is interested in that work, please let me know
13:08:06 <Qiming> gongysh, yep, my network connection just broke
13:08:53 <Qiming> also, jruano and I just had a phone call on the TOSCA collaboration
13:09:30 <Qiming> we will try leverage the standard to make senlin a very generic service for managing clusters
13:09:59 <Qiming> that also means we will try support container clusters as one of the killer apps
13:10:05 <jruano> yes it is very exciting. i will try to see if i can share that work with the team
13:10:26 <Qiming> jruano, yes, totally agree
13:10:47 <gongysh> qiming, do we have a doc about that?
13:10:50 <Qiming> maybe we can schedule an online session in senlin channel for this
13:11:05 <jruano> sure
13:11:24 <Qiming> sharing with the team what we have today, what's the mid-term, long-term plan
13:11:57 <jruano> gongysh, there is a preliminary document we are working on within tosca. i think that is public. i will double check, and share out what i can
13:13:00 <jruano> in terms of an online session for the team, i will schedule something shortly.
13:13:14 <Qiming> thanks jruano
13:13:29 <jruano> kind of what we are thinking, and what is the vision
13:13:40 <jruano> and how it aligns with senlin
13:14:04 <Qiming> yep, we need to bring anyone onto the same page
13:14:41 <Qiming> okay, next topic?
13:14:59 <Qiming> #topic summit preparation
13:15:12 <Qiming> a good news to share with you
13:15:41 <Qiming> we were just notified that one of our talk proposals was accepted
13:15:48 <elynn> cool
13:15:51 <yanyanhu> great!
13:15:52 <jruano> awesome
13:16:03 <Qiming> it was accepted before as "alternative"
13:16:10 <haiwei> which one
13:16:36 <Qiming> since there was a cancellation, we are now having a timeslot: Thursday October 29th,  9:50am- 10:30
13:16:50 <yanyanhu> haiwei, the one how senlin works with magnum I think
13:16:50 <Qiming> topic: Exploring Magnum and Senlin integration for autoscaling containers
13:16:58 <Qiming> in the Containers track
13:17:03 <jruano> very cool
13:17:20 <haiwei> great
13:17:29 <Qiming> I'll let the SUR team know that as well
13:17:59 <Qiming> it will be the first public show case for the project
13:18:05 <Qiming> we really need to get it done well
13:18:35 <yanyanhu> yep, try our best to ensure it's impressive :P
13:18:37 <Qiming> another thing for the summit prep is some kind of meetup
13:19:11 <Qiming> since the number of meeting rooms is very very limited
13:19:30 <Qiming> even if we want to schedule something, we can only have a round-table discussion
13:19:58 <haiwei> can we do it outside?
13:20:14 <Qiming> certainly
13:20:16 <yanyanhu> Qiming, I think this is ok. The most important thing is to have a chance to make a discussion together :)
13:20:18 <jruano> what day were you thinking. yes outside is another option
13:21:05 <Qiming> I think most participants to the summit will have their own schedule
13:21:12 <jruano> i am there monday through friday. although friday probably wanted to do some sightseeing
13:21:32 <Qiming> in just 4 days, a lot of things to catch up, to watch, to listen, to communicate
13:21:59 <Qiming> we will need to find a timeslot that works for most of us
13:22:06 <yanyanhu> maybe in break time?
13:22:20 <yanyanhu> we can have a meal together :)
13:22:22 <Qiming> #action Qiming to start a poll on the time for team meetup during summit
13:22:38 <Qiming> definitely, yanyanhu
13:23:12 <Qiming> I'll create a poll and send it to the mailinglist
13:23:40 <yanyanhu> ok
13:23:42 <Qiming> I know there are some web apps that can help us do this
13:24:03 <Qiming> #topic mitaka planning
13:24:47 <Qiming> while I'm still trying to create a POC release for senlin, it's time for the team to think about next cycle
13:25:21 <Qiming> what are the goals we want to achieve during the next 6 month
13:26:02 <yanyanhu> yea, and we need a plan for each 2 month
13:26:04 <Qiming> something above my head, for everyone to think about
13:26:37 <Qiming> we will need to do the same, list things on an etherpad page, prioritize them, and track them there
13:26:53 <elynn> yes
13:27:47 <Qiming> em ... why don't we just start input things now ...
13:27:55 <yanyanhu> and also BP I think. We still didn't use it well currently
13:27:56 <Qiming> https://etherpad.openstack.org/p/senlin-mitaka-workitems
13:28:25 <haiwei> Is it mostly the same with the TODO.rst?
13:28:31 <Qiming> yes, yanyanhu, the reason is that we were not adding big features
13:28:58 <Qiming> haiwei, you can dump things from TODO list to the etherpad
13:29:00 <yanyanhu> yes
13:30:38 <Qiming> I'm typing in the etherpad
13:32:39 <Qiming> em ... done
13:32:57 <elynn> ok, lots of things need to be done.
13:32:59 <Qiming> haven't looked at the TODO.rst file and the FEATURES.rst file yet
13:33:13 <yanyanhu> so one of the most important works is implementing those policies for scaling and HA
13:33:35 <janonymous> hey senlin group
13:33:46 <janonymous> Hi Qiming
13:33:51 <Qiming> elynn, yes, lots of things, we need to work on the list to prioritize things
13:33:57 <Qiming> hi, janonymous
13:34:02 <Qiming> welcome
13:34:22 <Qiming> we cannot get everything done in a single cycle
13:34:26 <yanyanhu> hi, janonymous
13:34:44 <janonymous> yanyanhu: hi
13:34:45 <Qiming> you helps are needed to review the items and prioritize them
13:35:07 <Qiming> feel free to add things you think are important
13:36:02 <Qiming> for the placement policy, we already have a WIP from Cindia
13:36:03 <yanyanhu> yea, and sign you name after the workitem you're gonna work on ;)
13:36:35 <janonymous> Haha.
13:36:48 <elynn> : )
13:36:50 <Qiming> we need more hands, more eyes, :)
13:37:01 <janonymous> you got my eyes :)
13:37:27 <Qiming> cool
13:37:41 <janonymous> I could help review but +1 won't matter i guess :(
13:37:59 <Qiming> janonymous, it matters
13:38:21 <Qiming> we respect all reviews
13:39:13 <janonymous> Qiming: I'll try to review things
13:39:21 <Qiming> thanks
13:40:23 <Qiming> please think hard team, what do you want to see in senlin
13:40:55 <Qiming> it won't be a one night job, let's keep working on that
13:40:59 <yanyanhu> definitely
13:41:03 <Qiming> #topic open discussions
13:42:21 <Qiming> just realized that we need to have Heat resource types for Senlin
13:42:52 <elynn> yes
13:43:08 <elynn> to show capabilities to replace ASG
13:43:12 <Qiming> yep
13:43:27 <Qiming> we can place them under contrib if needed
13:43:36 <Qiming> the earlier the better
13:43:39 <elynn> I can work on that
13:43:51 <yanyanhu> cool
13:44:03 <Qiming> getting some early feedbacks from heat team is very important
13:44:24 <Qiming> many thanks, elynn
13:44:55 <Qiming> anything else?
13:45:04 <elynn> I will prepare a spec for it and you guys need to review it.
13:45:07 <Qiming> or questsions?
13:45:20 <yanyanhu> hi, Qiming, about the release of senlin service
13:45:43 <Qiming> yes, yanyanhu
13:45:50 <Qiming> I have been working on that last week
13:45:51 <yanyanhu> so we need to finish those workitems left in ethpad before that?
13:46:16 <Qiming> I tried to create a release for senlinclient first, so that it can be published on Pypi
13:46:19 <yanyanhu> all those ones, right?
13:46:25 <Qiming> it didn't succeed
13:46:54 <Qiming> still tring to figure it out
13:47:00 <yanyanhu> ok
13:47:22 <jruano_> yeah client is probably best to start with
13:47:31 <Qiming> I think it is fine to do a POC release at this stage
13:47:57 <Qiming> I started from senlinclient because it is needed by the senlin-dashboard project anyway
13:48:06 <Qiming> need to find a guru on this
13:48:25 <Qiming> maybe there is some infra setup missing
13:49:09 <Qiming> anything else?
13:49:18 <jruano_> someone from our team just did this last week, but he is out this week
13:49:22 <jruano_> for heat-translator
13:49:48 <Qiming> jruano_, good to know, need some advices from him
13:49:57 <yanyanhu> yea
13:50:13 <jruano_> ill send him a note, but he most likely won't respond until he gets back
13:50:13 <Qiming> jruano_, are you talking about Sandev ?
13:50:18 <jruano_> yeah sahdev
13:50:19 <haiwei_> you are back tomorrow? Qiming
13:50:37 <Qiming> I know him well, :)
13:50:38 <jruano_> he just released tosca parser and heat-translator to pypi
13:50:40 <jruano_> cool
13:50:53 <Qiming> yes, haiwei_, back from a loooooong meeting
13:50:57 <jruano_> took him some time, but since it is fresh in his mind he might be a good help
13:51:19 <Qiming> cool, it will save us a lot of time I believe
13:51:50 <jruano_> so, on another topic... in terms of this notion of openstack "big tent", is that something we are working towards in senlin?
13:52:15 <Qiming> jruano_, we need to understand the new criteria ...
13:52:23 <jruano_> cool
13:53:21 <Qiming> if I'm understanding it correctly, it is mostly about some tags that will be applied on individual projects
13:53:48 <Qiming> there won't be stackforge projects anymore
13:54:13 <Qiming> if you guys know something on this, please let me know
13:54:17 <jruano_> yep... maybe we just ask to tag senlin :)
13:54:27 <Qiming> right.
13:54:39 <Qiming> we can learn from some existing reviews
13:54:45 <jruano_> ill ask around see if i can find anything else more about it
13:54:57 <Qiming> cool
13:55:15 <Qiming> still 5 minutes
13:56:01 <Qiming> if nothing else for discussion today, let's end this meeting
13:56:14 <yanyanhu> nope from me
13:56:23 <Qiming> I'll send emails to you after reviewing the container cluster thread's progress
13:56:34 <Qiming> thanks for joining
13:56:41 <Qiming> #endmeeting