13:01:51 <haiwei> #startmeeting senlin
13:01:51 <openstack> Meeting started Tue Nov 10 13:01:51 2015 UTC and is due to finish in 60 minutes.  The chair is haiwei. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:52 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:54 <openstack> The meeting name has been set to 'senlin'
13:02:22 <haiwei> please check the agenda and feel free to update it https://wiki.openstack.org/wiki/Meetings/SenlinAgenda
13:03:05 <yanyan> sorry I'm late
13:03:22 <haiwei> ok yanyan
13:03:26 <yanyan> hi
13:03:31 <haiwei> let's move on to the first topic
13:03:34 <yanyan> ok
13:03:38 <haiwei> #topic Go through TODO items to ensure everyone get them
13:04:12 <haiwei> here is the TODO list updated recently
13:04:14 <haiwei> https://github.com/openstack/senlin/blob/master/TODO.rst
13:04:25 <yanyan> yes, we just updated the TODO item list based on the discussion on Tokyo meetup
13:05:02 <yanyan> some backlog of liberty cycle were also added
13:05:25 <haiwei> In the first paragraph there are some notices we should pay attention to
13:05:38 <yanyan> yep
13:05:44 <haiwei> we need a BP to start these jobs
13:06:27 <yanyan> and once a workitem is picked up, please also propose a patch to remove it from the todo list and add it to etherpad
13:06:29 <elynn> All of these jobs need a related BP?
13:06:40 <yanyan> here: https://etherpad.openstack.org/p/senlin-mitaka-workitems
13:06:52 <yanyan> elynn, most of them I think
13:07:11 <haiwei> it seems API response modification is not assigned to anyone, I will take this job
13:07:19 <yanyan> or if it is related to bug or it's really a trivial item, we can use a bug report to replace bp
13:07:45 <haiwei> elynn, you need to add a BP for engine lock broker
13:07:49 <jruano> right, if it's something small a bug is sufficient
13:07:59 <yanyan> jruano, yes
13:08:16 <jruano> test cases for example
13:08:23 <haiwei> yes
13:08:23 <elynn> haiwei: I will add a BP if needed.
13:08:38 <yanyan> cool
13:08:59 <haiwei> ok, I think all of you have checked the tasks when this patch is under review
13:09:16 <haiwei> anything need to discuss more?
13:09:43 <yanyan> or if you have any confusion about some workitems, we can make a further discussion here
13:09:44 <haiwei> ok, lets move on
13:10:17 <yanyan> hi, lkarm
13:10:48 <haiwei> ok, next topic
13:10:51 <lkarm> hi
13:10:54 <haiwei> #topic Mitaka work items
13:11:22 <haiwei> yanyan, is there any document about this topic?
13:11:29 <yanyan> https://etherpad.openstack.org/p/senlin-mitaka-workitems
13:11:35 <yanyan> just the etherpad link
13:11:40 <haiwei> thanks
13:12:18 <yanyan> different from TODO.rst, this place is used to maintains all workitems in working progress
13:12:18 <elynn> It's too slow to open this url for me.
13:12:46 <haiwei> got it, yanyan
13:12:54 <haiwei> I didn't update it
13:13:01 <haiwei> will update it later
13:13:04 <yanyan> so each time you guys pickup a workitem from todo list, plz also move it to etherpad
13:13:07 <yanyan> haiwei, no problem
13:13:23 <yanyan> this can help the team to track all in progress work
13:14:16 <yanyan> elynn, I just helped add the workitem about lock breaker which you have started work on :)
13:14:33 <elynn> Thanks, still not open that link...
13:14:43 <yanyan> sigh... poor network
13:14:50 <haiwei> take it easy
13:14:53 <yanyan> I'm using proxy now
13:15:05 <haiwei> network is a little nervous
13:15:34 <elynn> Poor connection tonight.
13:15:48 <yanyan> seems so
13:15:48 <haiwei> can we move on?
13:15:55 <elynn> yes
13:16:08 <haiwei> #topic Quick update about Senlin resource support in Heat
13:16:10 <elynn> I will check later
13:16:17 <haiwei> this is your job elynn
13:16:30 <haiwei> can you share your progress to us?
13:16:35 <elynn> Yes, for now, only one patch submit to review.
13:16:52 <elynn> https://review.openstack.org/#/c/240776/ Adding senlinclient in heat.
13:17:09 <yanyan> nice
13:17:21 <yanyan> this is the first step to support senlin resource type in heat
13:17:28 <elynn> Still waiting for a new version of selinclient comes to global-requirement.
13:17:33 <yanyan> yep
13:17:53 <haiwei> I think senlinclient will have a new version soon
13:17:53 <jruano> ethan, do you need some help with this?
13:17:54 <elynn> So that I can shrink the codes for selin plugin.
13:18:06 <yanyan> since we rebuilt the senlinclient interface to make it consistent with other services client
13:18:52 <elynn> jruano: thanks, I'm not sure if selinclient bump version or not.
13:19:15 <yanyan> elynn, if you need any help, no matter in heat or senlin side, you can just get it from us :)
13:19:24 <haiwei> is there any work left in senlinclient?
13:19:30 <yanyan> I think qiming will handle the client version bumping soon
13:19:31 <elynn> After this patch, I will add 2 resources, OS::Senlin::Cluster and OS::Senlin::Profile
13:19:37 <haiwei> I just started the unit test for senlinclient
13:20:02 <yanyan> haiwei, nice, saw your patch this afternoon
13:20:04 <elynn> yanyan: yes, count on him.
13:20:32 <haiwei> yanyan, please help review it, I am not so confident of the patch
13:20:43 <yanyan> haiwei, no problem
13:21:27 <yanyan> elynn, I recalled we will only propose profile and cluster resource types to heat at the first step?
13:21:41 <elynn> yes, for now
13:22:14 <haiwei> ok, anything else for this topic?
13:22:24 <elynn> I think it's enough to show the capability of senlin in heat for now
13:22:36 <elynn> After all the codes merged
13:23:01 <yanyan> cool, and I think we should refer to resource group when consider what properties and attrs we should add to cluster resource
13:23:05 <jruano> yes i think that is a great first step
13:23:08 <elynn> I will upload some templates to show how to use these resource.
13:23:35 <elynn> yanyan: Yes, property is define in spec.
13:23:58 <elynn> we still need to decide what kind of attrs to add.
13:24:25 <yanyan> yea, we need make further discussion about this
13:24:35 <elynn> For cluster, as we discuss in irc, we have 2 attrs: 'current_size' and 'node_details' for now
13:25:04 <haiwei> elynn, just a question , why node resource is not to be supported in the first step?
13:25:09 <yanyan> and also cluster id and name I think
13:25:40 <haiwei> if node resource is not supported, can a cluster have nodes?
13:26:00 <yanyan> haiwei, sure
13:26:22 <yanyan> cluster resource type can work individually without node resource type
13:26:26 <elynn> haiwei: To support senlin functions, without node resource we can still do autoscale, cause cluster can create nodes itself.
13:26:30 <yanyan> the only dependency is profile
13:26:37 <yanyan> yep
13:27:15 <haiwei> ok, that means we can start nodes without node resource in heat?
13:27:49 <elynn> we can define desired_capacity when creating cluster resource. then cluster will create desired number of nodes.
13:27:57 <yanyan> haiwei, yes. Just those nodes will belong to a cluster.
13:28:00 <elynn> haiwei: Yes.
13:28:08 <haiwei> got it
13:28:29 <haiwei> ready to move on?
13:28:43 <elynn> yes, I'm done
13:28:45 <yanyan> I'm ok
13:28:48 <haiwei> #topic discussions on -dev mailinglist
13:29:11 <haiwei> currently senlin mailing list is not well used
13:29:45 <yanyan> yes, most of our communication happened in irc channel :)
13:29:47 <haiwei> sometimes we think IRC is fast, so we discussed there
13:29:57 <jruano> i saw that comment from doug
13:30:04 <elynn> That's true
13:30:12 <yanyan> jruano, yea
13:30:13 <haiwei> but for USA guys like jruano, there are not there maybe
13:30:37 <haiwei> you will miss the discussion sometime, jruano
13:30:42 <jruano> true
13:31:18 <yanyan> you can only get some information from irc log :)
13:31:19 <haiwei> so for something big, we should use senlin mailing list to make sure everyone can join the discussion
13:31:44 <yanyan> yep
13:31:50 <elynn> agree
13:31:56 <jruano> agreed...
13:32:03 <haiwei> I just sent a mail last week, but ...
13:33:01 <yanyan> really need to use maillist better :)
13:33:07 <haiwei> yes
13:33:23 <yanyan> won't miss your message next time I believe
13:33:36 <haiwei> the mail is still there, anyone can reply it
13:33:41 <yanyan> sure
13:34:07 <haiwei> if you have read it, it's ok to discuss it now
13:34:19 <haiwei> #topic open discussion
13:35:30 <haiwei> about auto-scaling for container, I discussed it with qiming, he said senlin had better not do it
13:35:46 <haiwei> because k8s and docker team will do it
13:36:04 <yanyan> haiwei, actually I have the same feeling
13:36:09 <haiwei> senlin should only concern VM layer auto-scaling
13:36:25 <haiwei> yes, that makes sense to me , yanyan
13:36:28 <yanyan> since this may beyond the scope of senlin
13:36:57 <yanyan> yep, we should focus on the clustering service itself in the first step I think
13:36:57 <haiwei> at least that is not the thing we should consider now
13:37:07 <yanyan> to make the servie itself more stable and scalable
13:37:13 <yanyan> haiwei, right
13:37:25 <jruano> yep... container space is still very fragmented
13:37:36 <jruano> no need to move into that mess
13:37:56 <haiwei> right, jruano
13:38:26 <elynn> So we won't support container in near future?
13:38:31 <haiwei> by the way, when will qiming be back to Beijing?
13:38:48 <haiwei> I think so , elynn
13:39:10 <yanyan> elynn, I think senlin itself won't provide related support directly I think
13:39:46 <yanyan> haiwei, in next week I think
13:40:09 <yanyan> next thursday?
13:40:15 <yanyan> and also xinhui
13:40:30 <haiwei> I saw some new guys had joined to senlin, maybe they don't know the weekly meeting's time, like dongbing
13:40:39 <elynn> I notice that there's discussion about doing autoscaling in magnum.
13:41:06 <elynn> Do you know if that related to senlin?
13:41:10 <haiwei> we should have invited them to the meeting
13:41:11 <jruano> yeah... too many people, too fragmented looking to do autoscaling of containers
13:41:11 <yingjun> is it now senile meeting?
13:41:23 <haiwei> yes
13:41:33 <yanyan> haiwei, yes, I think we can give an update in both senlin irc channel and maillist to ensure everyone can get the latest information
13:41:33 <haiwei> welcome yingjun
13:41:40 <haiwei> you are diving now :)
13:41:42 <yanyan> hi, yingjun, welcome :)
13:41:42 <yingjun> :)
13:41:43 <jruano> tc is already concerned about scope of senlin
13:42:03 <jruano> so at least for now, no need to worry about container support
13:42:16 <jruano> hi yingjun
13:42:25 <elynn> welcome yingjun
13:42:55 <yanyan> jruano, I believe they will help us to make the correct decision :)
13:43:10 <yingjun> hi
13:43:11 <haiwei> yes, I think so
13:43:34 <jruano> yes, or at least block us until we make the right one they agree with :)
13:43:52 <haiwei> yanyan, you mean we should send a mail to announce the meeting time?
13:44:14 <yanyan> haiwei, yes, I think we can do that
13:44:16 <jruano> jay from mirantis brought up autoscaling that murano is attempting to do now
13:44:22 <jruano> which was odd
13:44:22 <haiwei> ok
13:44:50 <haiwei> #action send announcement mail for weekly meeting
13:44:58 <yanyan> jruano, cross-project collaboration is always important
13:45:30 <jruano> yep
13:46:24 <haiwei> ok, anything else?
13:46:43 <yanyan> nope from me
13:46:47 <elynn> not for me
13:47:20 <haiwei> ok, that's all for the meeting
13:47:28 <haiwei> #endmeeting senlin