13:01:23 <Qiming> #startmeeting senlin
13:01:24 <openstack> Meeting started Tue Dec  1 13:01:23 2015 UTC and is due to finish in 60 minutes.  The chair is Qiming. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:27 <openstack> The meeting name has been set to 'senlin'
13:01:37 <Qiming> evening
13:01:43 <yanyanhu> hello
13:01:46 <elynn> Hi
13:01:47 <lixinhui> hi
13:02:00 <Qiming> please check the agenda and see if you have got things to add
13:02:03 <Qiming> #link https://wiki.openstack.org/wiki/Meetings/SenlinAgenda
13:02:27 <Qiming> #topic mitaka work items
13:02:36 <Qiming> let's start with the etherpad, :)
13:02:40 <Qiming> as always
13:02:53 <Qiming> #link https://etherpad.openstack.org/p/senlin-mitaka-workitems
13:03:09 <Qiming> heat resource types
13:03:28 <Qiming> elynn, yours
13:03:53 <haiwei> hi
13:04:00 <elynn> Qiming:
13:04:01 <elynn> Hi
13:04:22 <elynn> I just update one patch for it and unittests are passed.
13:04:24 <Qiming> I think the patches were blocked somehow by the bugs introduced into senlinclient
13:04:51 <elynn> I will continue to update other patches ASAP.
13:05:05 <Qiming> we will be doing more code churn to the client code as we are revising the apis
13:05:35 <elynn> Will it affact senlin  resources?
13:05:52 <Qiming> elynn, I believe there will be some impact
13:06:13 <Qiming> for example, when you do a cluster-create, we plan to return a 202 (request accepted)
13:06:42 <Qiming> in that response body, I'm not sure whether we should include a representation of the cluster
13:07:02 <elynn> Does it return 202 now?
13:07:05 <Qiming> I have checked HTTP spec and api-wg, so far no guidance there
13:07:14 <Qiming> currently not
13:07:34 <Qiming> but in theory, we should return 202, because the cluster creation may take a long time
13:08:01 <Qiming> it is simply wrong to return 200, i.e. to pretend the cluster has been created
13:08:14 <haiwei_> what is the topic now, sorry, missed a lot
13:08:30 <Qiming> haiwei_, heat resource type support
13:08:45 <haiwei_> ok
13:08:46 <elynn> Will it return at least a cluster id?
13:08:49 <jruano> hmmm... i don't think a representation of the cluster is necessary on a 202
13:09:21 <Qiming> in an 202 response, we will add a 'Location' header, where you can get a link to the cluster resource being created
13:10:28 <Qiming> I'm still not sure if we should teach SDK to parse the response header and then do a GET again
13:10:33 <elynn> ok, I will slow down, after you finish revise APIs, I need do more tests.
13:10:37 <haiwei_> it seems the 'Location' header is the http response header
13:11:10 <haiwei_> I confirmed it with the api-wg guys
13:11:13 <elynn> All the resource creation will return 202 only? like profile
13:11:22 <Qiming> yes, most http related packages used today allow you to check the header and behave accordingly
13:11:43 <Qiming> no, elynn, profile-create will return a 201
13:11:52 <Qiming> that creation is for real
13:12:11 <Qiming> https://review.openstack.org/#/c/251771/
13:12:25 <Qiming> this is the revision, a first step
13:12:25 <elynn> If SDK don't continue to parse the response header, it might be difficult to handle in heat
13:12:32 <Qiming> yes
13:12:37 <Qiming> that is a big concern
13:13:02 <Qiming> I'd propose something into SDK so that the heat side code doesn't have to look a lot different
13:13:10 <elynn> If I remember correctly , instance creation only returns 202.
13:13:38 <Qiming> elynn, if that is true, we can check how heat gets instance id today
13:14:10 <Qiming> if necessary, we may have to cap the senlinclient version
13:14:46 <elynn> https://github.com/openstack/heat/blob/master/heat/engine/resources/openstack/nova/server.py#L740-L763
13:14:47 <Qiming> current version 0.1.8 looks good?
13:15:12 <elynn> haven't test it yet.
13:15:31 <Qiming> elynn, that code is not telling you the real things happened behind the scene
13:15:39 <Qiming> may need to check novaclient code
13:15:54 <elynn> Qiming: yes, I think novaclient handles the location.
13:16:12 <Qiming> okay, if that is the case ...
13:16:17 <elynn> http://developer.openstack.org/api-ref-compute-v2.html#createServer
13:16:35 <Qiming> we may need to check with SDK team to come up with a workaround
13:16:50 <Qiming> personally, I hate all xyzclient packages
13:17:03 <Qiming> :)
13:17:06 <Qiming> moving on
13:17:19 <Qiming> senlinclient, one of the things I hate, :)
13:17:35 <Qiming> haiwei_ just proposed test case part 2
13:17:52 <Qiming> https://review.openstack.org/251798
13:18:02 <Qiming> please help
13:18:13 <haiwei_> yes, jenkins failed
13:18:19 <haiwei_> will check it later
13:18:32 <Qiming> ya
13:18:50 <Qiming> API response modification
13:19:13 <Qiming> patch #251771 is a global revision
13:19:13 <patchbot> Qiming: https://review.openstack.org/#/c/251771/ - Fix status code returned from API
13:19:28 <Qiming> need eyes on them too
13:19:50 <Qiming> 404 vs 400 return code, I think we are done with it
13:20:04 <haiwei_> good
13:20:22 <Qiming> health policy
13:20:27 <Qiming> again
13:20:40 <jruano> i will have a look today
13:20:53 <Qiming> I believe lixinhui is looking into that as well
13:21:06 <lixinhui> yes
13:21:13 <Qiming> thx, jruano
13:21:16 <Qiming> we at least need a bp for this
13:21:43 <Qiming> Triggers
13:21:48 <elynn> What will health policy do exactly?
13:22:00 <Qiming> Triggers are history now
13:22:13 <jruano> ah... yep, i figured that was coming
13:22:28 <jruano> looking at monasca, and thats what it felt like
13:22:46 <yanyanhu> elynn, I think that's what we need to discuss in BP :)
13:23:05 <Qiming> health policy is basically a Senlin inherent mechanism to detect node status and take proper actions to fix node failures if told so
13:23:27 <Qiming> yanyanhu, agreed
13:23:50 <elynn> oh, I C.
13:24:10 <Qiming> Profile
13:24:20 <yanyanhu> ah, my job
13:24:32 <yanyanhu> I spent some times on completing related support in sdk side
13:24:50 <yanyanhu> currently, server rebuild and server resize related function calls has been added
13:24:58 <haiwei_> is there a bp for profile?
13:25:02 <Qiming> both merged?
13:25:07 <yanyanhu> yes
13:25:51 <yanyanhu> so it can meet the requirement of supporting property update of flavor and some basic properties of os.nova.server prfile I think
13:25:53 <Qiming> \o/
13:26:21 <Qiming> update of flavor is working too?
13:26:22 <yanyanhu> and network and image propety update support has been done in senlin
13:26:41 <yanyanhu> I'm still working on it
13:27:00 <yanyanhu> but related support in sdk has been there
13:27:05 <Qiming> okay, network and image update are not on the etherpad, so I guess they are all solved
13:27:17 <yanyanhu> yea, I removed them :)
13:27:31 <Qiming> cool, you may want to paste the patch link into etherpad
13:27:40 <Qiming> Receiver
13:27:46 <yanyanhu> sure, will add it
13:27:53 <Qiming> jruano, we need a bp on this
13:27:54 <jruano> im working on the bluprint for receiver
13:28:13 <jruano> i was out last week. i have a design that im working on now
13:28:38 <Qiming> okay, be it a webhook or a message queue, the parameters are almost the same I think
13:29:05 <Qiming> jruano, happy thanksgiving holidays, to you and your family, :)
13:29:09 <jruano> yes. i am going to lay out a class hierarchy that abstracts webhook
13:29:13 <jruano> thanks
13:29:19 <yanyanhu> yea, happy thanksgiving :)
13:29:36 <jruano> then we can extend additional implementations from that as needed
13:29:38 <Qiming> jruano, it doesn't have to be a complex class hierarchy I think
13:29:46 <jruano> yep, i think it is pretty simple
13:29:59 <Qiming> we just need a generalized interface that will be accommodating to future extensions
13:30:02 <jruano> webhook has probably everything there
13:30:04 <jruano> yep
13:30:07 <Qiming> great
13:30:17 <jruano> working on that today
13:30:17 <Qiming> lock breaker
13:30:35 <elynn> The patches are merged.
13:30:43 <Qiming> all of them?
13:30:54 <yanyanhu> yes, this afternoon.
13:31:18 <elynn> Is it better to add functional test for it?
13:31:24 <Qiming> great, that means some bugs on launchpad can be labeled 'invalid' now?
13:31:26 <yanyanhu> elynn, that will be great
13:31:33 <Qiming> elynn, good idea
13:31:49 <elynn> I will start to work on them ;)
13:31:55 <yanyanhu> BTW, there still some failures in current functional test. I will spend some time on it in coming week
13:32:17 <yanyanhu> to ensure you have a clean basement for new test cases
13:32:20 <elynn> Will we enable them by default?
13:32:43 <yanyanhu> elynn, hmm, maybe not now I think
13:33:12 <yanyanhu> but we do recommand check it manually before merge new patches
13:33:30 <yanyanhu> recommend, sorry
13:33:36 <elynn> The command is check experiment?
13:33:40 <Qiming> yep, haiwei_ is still seeing some weird errors from keystoneauth1
13:33:43 <yanyanhu> check experimental
13:33:56 <elynn> cool, got it.
13:34:25 <yanyanhu> Qiming, great, the recent change about authentication caused some trouble :)
13:34:27 <Qiming> anything else about items on etherpad?
13:34:37 <haiwei_> Qiming, the error I said this afternoon is my own fault, sorry
13:34:57 <Qiming> haiwei_, so happy you made mistakes
13:35:07 <Qiming> I mean it is not the code's problem, :)
13:35:19 <haiwei_> I often made it
13:35:21 <Qiming> moving on
13:35:34 <Qiming> haiwei_, keep on good habits then
13:35:41 <Qiming> #topic bug clearance
13:36:00 <Qiming> #link https://bugs.launchpad.net/senlin/?field.searchtext=&orderby=-importance&field.status%3Alist=NEW&field.status%3Alist=CONFIRMED&field.status%3Alist=TRIAGED&field.status%3Alist=INPROGRESS&field.status%3Alist=INCOMPLETE_WITH_RESPONSE&field.status%3Alist=INCOMPLETE_WITHOUT_RESPONSE&assignee_option=any&field.assignee=&field.bug_reporter=&field.bug_commenter=&field.subscriber=&field.structural_subscriber=&field.tag=&field.tags_combinator=ANY&fiel
13:36:00 <Qiming> d.has_cve.used=&field.omit_dupes.used=&field.omit_dupes=on&field.affects_me.used=&field.has_patch.used=&field.has_branches.used=&field.has_branches=on&field.has_no_branches.used=&field.has_no_branches=on&field.has_blueprints.used=&field.has_blueprints=on&field.has_no_blueprints.used=&field.has_no_blueprints=on&search=Search
13:36:01 <haiwei_> btw, does anyone notice that when creating/deleting a node TIMEOUT error will happen first and then creation/deletion will still succeed
13:36:27 <Qiming> haiwei_, I didn't
13:36:36 <yanyanhu> me neither...
13:36:46 <Qiming> such a long url
13:37:21 <Qiming> anyway, we still have 1 critical bug, 3 medium (1 in progress), all others are to be revisited
13:37:29 <haiwei_> ok, if you meet that error just share to us, maybe something wrong there
13:37:56 <Qiming> in total we have 19 bugs, including 3 already marked 'incomplete'
13:38:00 <yanyanhu> less than 20 bugs are in open status
13:38:03 <Qiming> seems we need bugs
13:38:05 <jruano> mine should have a patch checked in today. i was almost done with it heading into last week
13:38:18 <Qiming> jruano, no worry
13:38:31 <Qiming> we will need more bugs
13:38:51 <elynn> How?
13:39:13 <Qiming> elynn, test and find bugs, certainly
13:39:57 <elynn> Ha~ Or we can buy some from store ;)
13:40:09 <Qiming> #action Qiming to go through the bug list and triage/confirm bugs
13:40:30 <haiwei_> the critical one is not one bug I think, it should be many  bugs, but most are fixed now
13:40:34 <yanyanhu> elynn, :P
13:40:58 <Qiming> haiwei_, the problem is we were not linking back those patches to the bug
13:41:12 <Qiming> moving on
13:41:20 <Qiming> #topic Mitaka release schedule
13:41:21 <elynn> Seems patch will not automatically link to bug.
13:41:27 <haiwei_> yes, it'S better not report this kind of bugs
13:41:29 <Qiming> #link https://wiki.openstack.org/wiki/Mitaka_Release_Schedule
13:41:44 <elynn> Even I write bug number in commit message.
13:41:51 <Qiming> maybe you are aware of it, mitaka-1 release is happening now
13:41:52 <jruano> you have to add the Close-bug in commit message
13:41:57 <jruano> ah
13:42:22 <Qiming> this is week 'R-18' for the mitaka cycle
13:42:39 <Qiming> I don't think we are ready to do a release
13:42:47 <yanyanhu> agree
13:43:08 <Qiming> so far, in project config, senlin is tag as "release:independent"
13:43:19 <Qiming> that is buying us some time to catch up, but not for ever
13:43:35 <Qiming> I hope we can catch up soon
13:44:26 <Qiming> once the API is stable, we can start the formal release and apply for "release:whatever-official" tags
13:44:30 <yanyanhu> I think maybe we can try to give the first release after API rework is done
13:44:43 <yanyanhu> yea
13:44:52 <Qiming> maybe by mitaka-2, we can start practicing a formal release
13:45:15 <Qiming> yes, it will be Jan 19-21, 2016
13:45:29 <Qiming> we won't miss next milestone
13:45:49 <Qiming> moving on
13:46:00 <Qiming> #topic recheck blueprints
13:46:13 <yanyanhu> https://blueprints.launchpad.net/senlin/+specs?show=all
13:46:48 <Qiming> okay, we need some approvals to the bps
13:47:00 <Qiming> some are outdated
13:47:13 <Qiming> em ... we need more cores
13:47:21 <yanyanhu> yes. And set some of them to obsolete status
13:47:52 <Qiming> core team please keep your eyes on commits and reviews
13:48:05 <haiwei_> yes
13:48:10 <jruano> yep... the trigger one for monasca i have can be removed now
13:48:13 <Qiming> we need more people
13:48:23 <Qiming> yep, jruano
13:49:02 <Qiming> #action review blueprints and approve/obsolete them as needed
13:49:39 <Qiming> #topic open discussions
13:50:39 <lixinhui> can I leverage some functional tests
13:50:46 <lixinhui> for the scalability testing?
13:50:52 <yanyanhu> oh, plz remeber to use reno to generate release note related info when proposing new patch which adds new feature
13:51:31 <haiwei_> is there a guideline of how to use reno?
13:51:35 <yanyanhu> lixinhui, sure. That will be great.
13:51:37 <elynn> yanyanhu: Is there any example for how to use it?
13:51:40 <jruano> ah... where can we get the info on that tool?
13:51:41 <Qiming> yep, yanyanhu that is a good habit to develop among the team
13:51:52 <yanyanhu> haiwei_, there is a sample patch qiming propose to illustrate how to use it
13:52:07 <yanyanhu> let me find it for you
13:52:20 <haiwei_> i remembered it
13:52:39 <yanyanhu> https://review.openstack.org/#/c/249573/
13:52:42 <yanyanhu> yea, this one
13:53:26 <Qiming> http://docs.openstack.org/developer/reno/
13:54:05 <jruano> ah ok... looks pretty straightforward
13:54:47 <yanyanhu> jruano, for first step, maybe just know how to use it to generate release note info with the patch :)
13:54:52 <Qiming> it is spreading the last minute report writing work into daily jobs
13:55:33 <lixinhui> cool
13:55:41 <Qiming> by the way, I'm studying how to publish our docs (user and developer) to the official site
13:55:59 <elynn> Great news
13:56:16 <Qiming> all those docs are very verbose ... believe me
13:56:16 <haiwei_> you are a robot  Qiming
13:56:26 <yanyanhu> Qiming, this is very very important :)
13:57:52 <Qiming> anything else?
13:58:06 <haiwei_> nope
13:58:08 <yanyanhu> nope from me
13:58:19 <elynn> no
13:58:30 <jruano> not from me
13:59:13 <Qiming> http://snag.gy/5Uox3.jpg
13:59:20 <Qiming> in case you want to take a look
13:59:31 <Qiming> just pasted the generated doc page
13:59:35 <jruano> very nice
13:59:36 <yanyanhu> \o/
13:59:37 <pc_m> hi
13:59:44 <annp> Hi
13:59:46 <Qiming> let's get back to #senlin
13:59:46 <Qiming> #endmeeting