13:00:34 <Qiming> #startmeeting senlin
13:00:35 <openstack> Meeting started Tue Jan  5 13:00:34 2016 UTC and is due to finish in 60 minutes.  The chair is Qiming. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:39 <openstack> The meeting name has been set to 'senlin'
13:00:44 <lixinhui> hi
13:00:52 <Qiming> hello
13:00:55 <haiwei> hi
13:01:14 <elynn> hi
13:01:55 <Qiming> pls revise agenda if you have things to add
13:02:05 <Qiming> #link https://wiki.openstack.org/wiki/Meetings/SenlinAgenda
13:02:25 <yanyanhu> hello
13:02:55 <Qiming> let's check the etherpad
13:03:01 <Qiming> #link https://etherpad.openstack.org/p/senlin-mitaka-workitems
13:03:18 <Qiming> heat resource type
13:03:25 <elynn> yes
13:03:34 <Qiming> mostly blocked by the header thing and action id
13:03:38 <elynn> two patches are already merged
13:03:46 <Qiming> we have discussed that this afternoon
13:03:52 <elynn> on block by openstacksdk
13:04:09 <Qiming> we still don't support cluster update properly I think
13:04:19 <elynn> I will according to your suggestion to work on senlin side.
13:04:28 <Qiming> that would be great
13:04:35 <Qiming> senlinclient unit tests
13:04:52 <haiwei> finished?
13:05:04 <haiwei> v2/shell.py is finished
13:05:07 <haiwei> v1
13:05:09 <Qiming> mostly I believe
13:05:16 <haiwei> should we do something else?
13:05:34 <Qiming> coverage is 86^
13:05:37 <Qiming> 86%
13:05:40 <Qiming> pretty good
13:05:56 <Qiming> this one: senlinclient/openstack/common/cliutils.py
13:06:06 <Qiming> it only has 32% coverage
13:06:07 <haiwei> oh
13:06:14 <Qiming> it is from oslo
13:06:35 <haiwei> not easy to test?
13:06:47 <Qiming> I recalled that something is happening in oslo regarding this module
13:06:53 <Qiming> cannot remember the details
13:07:06 <Qiming> haiwei can you help do a search on mailinglist?
13:07:27 <haiwei> about oslo's change?
13:07:29 <Qiming> this is the only one we are relying on oslo incubation
13:07:46 <Qiming> maybe it has already graduated?
13:08:00 <haiwei> ok, I will check it
13:08:03 <Qiming> senlinclient/common/utils.py
13:08:08 <Qiming> this one has 42%
13:08:43 <Qiming> we are about to remove senlinclient/v1/models.py
13:08:54 <Qiming> since models are all supported in sdk now
13:09:06 <haiwei> great
13:09:30 <Qiming> service calls are all revised
13:10:01 <Qiming> health policy
13:10:26 <Qiming> we do have some progress on this, from lixinhui
13:10:44 <Qiming> we are adding do_check and do_recover for profiles
13:10:56 <haiwei> saw the patches
13:11:05 <yanyanhu> good start point I think
13:11:07 <Qiming> those will serve the foundation for failure detection and recovery
13:11:58 <Qiming> node update support in profiles
13:12:11 <yanyanhu> worked on metadata update support last week
13:12:19 <yanyanhu> patch in senlin side is ready
13:12:28 <Qiming> yep, saw that, brian has some comments
13:12:34 <yanyanhu> but it depends on the metadata refactoring in sdk side
13:12:35 <haiwei> good job, yanyanhu
13:12:38 <Qiming> maybe we should help push that work
13:12:39 <yanyanhu> brian is working on it I think
13:12:40 <yanyanhu> yep
13:12:52 <yanyanhu> will wait for brian's job
13:12:59 <Qiming> last time I checked it, it is still merge conflict
13:13:12 <Qiming> we'll have to push him, :)
13:13:12 <yanyanhu> yes, it is still in that status now
13:13:18 <yanyanhu> thanks :)
13:13:32 <yanyanhu> seems they are waiting for some work about image metadata
13:13:41 <yanyanhu> but I guess progress is not good
13:13:48 <Qiming> if he doesn't have cycles, we can take it over
13:13:58 <yanyanhu> yes
13:14:07 <yanyanhu> will keep looking at it
13:14:15 <Qiming> just need to understand server_metadata and metadata
13:14:27 <Qiming> the difference and the direction
13:14:33 <yanyanhu> yes, actually I think the latest design is better
13:14:40 <Qiming> okay
13:14:40 <yanyanhu> it's more clear for user
13:14:47 <Qiming> good
13:14:58 <yanyanhu> although the old one follows the sdk design a little bit better
13:15:35 <yanyanhu> will spend some time on disk update support, will do some investigation first
13:15:52 <Qiming> it is always difficult to unify things
13:15:54 <Qiming> cool
13:15:56 <yanyanhu> yep
13:16:01 <Qiming> receiver
13:16:13 <yanyanhu> haven't started this job
13:16:17 <Qiming> we are removing webhook functional tests
13:16:22 <yanyanhu> yep
13:16:28 <yanyanhu> will work on it soon
13:16:42 <yanyanhu> to recover our functional test :)
13:16:44 <Qiming> next time we work on a receiver test, please consider some actions simpler
13:16:58 <yanyanhu> yep
13:17:03 <yanyanhu> understand
13:17:05 <Qiming> because we are already testing scaling operations in other functional tests
13:17:26 <yanyanhu> yes, so just testing webhook workflow is enough
13:17:38 <Qiming> as we are adding more features, functional tests may eventually take a lot time
13:17:50 <Qiming> just be careful when moving forward
13:17:56 <yanyanhu> ok
13:18:01 <Qiming> release notes
13:18:16 <Qiming> proposed a patch containing most backlogs
13:18:27 <yanyanhu> saw your patch adding omitted release note
13:18:41 <yanyanhu> have +2 it
13:18:42 <Qiming> just realized how much we have accomplished .... really amazing
13:19:06 <yanyanhu> https://review.openstack.org/#/c/263083/
13:19:39 <haiwei> merged now
13:19:42 <haiwei> :)
13:19:47 <lixinhui> cool
13:19:52 <elynn> so quick
13:19:54 <Qiming> please feel proud about ourselves, :)
13:20:08 <Qiming> lock breaker
13:20:12 <elynn> yes
13:20:32 <elynn> I'm thinking about adding a db table to record engine status
13:20:33 <Qiming> I'm blocking your reenabling proposal, elynn
13:20:40 <Qiming> yep
13:20:42 <elynn> like other projects do
13:20:45 <Qiming> that would be great
13:20:58 <Qiming> maybe a dlm ?
13:20:59 <elynn> so we don't need to call rpc to check engine status
13:21:14 <elynn> dlm means?
13:21:21 <Qiming> distributed lock manager
13:21:32 <Qiming> search back mailinglist
13:21:40 <Qiming> there have been some discussions on it
13:21:49 <Qiming> we may need a blueprint for this
13:21:53 <elynn> I don't know what it is now, will search for it first.
13:21:59 <yanyanhu> yes, I remeber there is a long thread talking about this
13:22:04 <Qiming> it is more complicated than we thought
13:22:41 <Qiming> it is a solution for distributed processes to notify each other reliably
13:23:07 <Qiming> there is a project tooz
13:23:19 <Qiming> just heard of its name, no details
13:23:43 <elynn> Seems we have a lot more project I don't know but helpful
13:23:55 <Qiming> deletion policy for cross-az/region
13:23:59 <elynn> I will search for it.
13:24:17 <Qiming> elynn, yep, share the same feeling
13:24:23 <haiwei> just discussed it this afternoon
13:24:43 <Qiming> so ... whenever we start to work on some features, first thing is to check if there are existing wheels
13:24:49 <haiwei> it seems the use case we need will determine the design
13:24:57 <Qiming> yes, haiwei
13:25:03 <Qiming> really a good discussion
13:25:16 <lixinhui> yes, it is
13:25:18 <haiwei> we should list out what we need
13:25:25 <Qiming> we won't be able to cover all use cases
13:26:00 <Qiming> one design philosophy we had when proposing these policies is that we want them to be orthogonal
13:26:05 <haiwei> will summarize it in a ether pad page for discussion
13:26:12 <Qiming> okay
13:26:18 <lixinhui> okay
13:26:22 <yanyanhu> great :)
13:26:51 <haiwei> currently I have no idea about cross region
13:26:53 <Qiming> I do agree that all the problems we are solving can be combined into fewer number of policies
13:27:05 <haiwei> it maybe similar to cross-zones
13:27:10 <Qiming> yes
13:27:53 <Qiming> let's rethink about the design if we are not so sure where we are heading
13:28:04 <lixinhui> yes
13:28:08 <haiwei> ok
13:28:33 <Qiming> etherpad discussion would be good
13:29:01 <Qiming> #topic mid-cycle meetup plan
13:29:14 <Qiming> #link https://etherpad.openstack.org/p/senlin-mitaka-midcycle
13:29:34 <Qiming> so we have a schedule for a 2-days discussion
13:30:01 <Qiming> first day is mostly about meeting users
13:30:11 <haiwei> can we make the schedule more specific? for example add time period
13:30:27 <Qiming> good suggestion
13:30:47 <yanyanhu> will try to contact presenter to confirm the time slot
13:30:52 <haiwei> also including some coffee time
13:31:13 <yanyanhu> sure :)
13:31:21 <haiwei> thanks
13:31:23 <Qiming> #action Qiming to refine meetup schedule (add **coffee** time)
13:31:58 <Qiming> haiwei, do you have something to share in the afternoon?
13:32:45 <haiwei> I have no idea
13:32:54 <Qiming> okay
13:33:03 <Qiming> lixinhui, how about you?
13:33:08 <haiwei> maybe about tempest?
13:33:15 <yanyanhu> the second afternoon?
13:33:31 <yanyanhu> haiwei, good topic, I'm intereted in it :)
13:33:45 <haiwei> ok, I will prepare for it
13:34:39 <Qiming> haiwei, will add a quality assurance session for you
13:35:05 <lixinhui> I am working on health_manager
13:35:17 <Qiming> feel free to add other things you want to talk about
13:35:31 <lixinhui> I do not know if proper to share some work about this
13:35:40 <haiwei> so we will talk in Chinese, right?
13:35:40 <Qiming> lixinhui, 'health management' session will be yours
13:35:50 <lixinhui> oh
13:36:00 <lixinhui> Thanks, Qiming
13:36:06 <yanyanhu> Qiming, about those topics related to Senlin, we should prepare presentation or they are feel talk?
13:36:13 <Qiming> haiwei, you can speak Japanese if you like
13:36:28 <Qiming> it would be mostly free talk
13:36:46 <haiwei> I like free talk
13:36:59 <yanyanhu> got it
13:37:05 <lixinhui> :)
13:37:12 <Qiming> certainly you can create charts to show your design idea or whatever
13:37:14 <yanyanhu> but we can have a holder for them :)
13:37:43 <lixinhui> It would be nice if Yanyan can share something about scalability analysis
13:37:59 <haiwei> currently who are 100% sure to be present?
13:38:09 <yanyanhu> ok, will try to share something about it :)
13:38:18 <yanyanhu> we do meet some issues about DB concurrency
13:38:21 <lixinhui> Great, thanks, yanyanhu
13:38:22 <Qiming> all people who just talked
13:38:41 <Qiming> and some names appeared on etherpad
13:38:50 <Qiming> plus ... some people I don't know
13:38:56 <yanyanhu> lixinhui, no problem :)
13:39:12 <Qiming> yanyanhu, 'container management' session is yours
13:39:20 <yanyanhu> ok
13:39:36 <lixinhui> cool
13:39:41 <yanyanhu> just haven't got too much idea how to talk about it :P
13:39:47 <elynn> cool, I can learn a lot from your guys.
13:39:57 <yanyanhu> maybe some experience about mesos?
13:40:01 <Qiming> emm, if you like to lead a dicussion session, please sign your name there
13:40:25 <Qiming> yanyanhu, day 2 is mostly about senlin design
13:40:50 <Qiming> it would be good to share experiences learnt from mesos anyway
13:41:10 <elynn> I'm interesting in mesos
13:41:10 <yanyanhu> understand, just try to think about something we can work on container management :)
13:41:20 <Qiming> right
13:41:35 <lixinhui> interesting
13:41:40 <Qiming> #topic open discussion
13:42:02 <lixinhui> will IBM offer coffee and cake?
13:42:10 <lixinhui> for the 2 days
13:42:22 <lixinhui> lunch, maybe
13:42:23 <Qiming> lixinhui, you can bring some from vmware if you can
13:42:32 <lixinhui> ...
13:42:41 <yanyanhu> LoL
13:42:46 <haiwei> how about the lunch?
13:42:57 <Qiming> don't worry
13:42:57 <haiwei> that's important
13:43:07 <lixinhui> enen, haiwei
13:43:17 <Qiming> we will try not to starve you
13:43:22 <haiwei> can we have si cai yi tang?
13:43:26 <yanyanhu> haha
13:43:39 <Qiming> we may order lunch boxes
13:43:43 <yanyanhu> you can, haiwei :)
13:43:56 <Qiming> too many topics during the day
13:43:58 <yanyanhu> hello, Daisy
13:44:04 <elynn> si cai yi tang for each :)
13:44:07 <haiwei> in fact, I want to eat lunch boxes
13:44:10 <yanyanhu> elynn, ...
13:44:12 <haiwei> I miss it
13:44:25 <Daisy> Hi, yanyanhu
13:44:26 <lixinhui> god
13:44:44 <Qiming> we can find some nice place for dinner together though
13:44:54 <yanyanhu> sure
13:44:59 <yanyanhu> that's important :P
13:45:10 <Qiming> critical?
13:45:28 <yanyanhu> absolutely
13:45:33 <lixinhui> :)
13:45:51 <lixinhui> no north gate resaurant of software park
13:45:59 <Qiming> btw, I have released senlinclient 0.2.1 today, seeing complaints about compatibility
13:46:26 <Qiming> we are in a good shape now, regarding the client side
13:46:55 <haiwei> why not after deleting v1/models?
13:47:11 <haiwei> doesn't harm though
13:48:00 <Qiming> didn't realize we still have garbage, :(
13:48:09 <Qiming> another heads up
13:48:10 <Qiming> https://review.openstack.org/#/c/258222/
13:48:45 <Qiming> we have promised to do official release this cycle, together with all those famous projects
13:49:31 <haiwei> I understand your urge mode
13:49:50 <yanyanhu> hmm, do need to fix those bugs marked as critical ASAP
13:49:59 <Qiming> yep
13:50:27 <Qiming> http://docs.openstack.org/releases/schedules/mitaka.html
13:50:29 <haiwei> we still have?
13:50:49 <Qiming> Jan 16-22 would be m-2 milestone
13:51:01 <yanyanhu> haiwei, yep, e.g. lb policy doesn't work now
13:51:11 <Qiming> after meetup, we will do a m-2 freeze
13:51:32 <haiwei> I have tested lb policy a few days ago, got an 403
13:51:43 <Qiming> we can discuss more details about things we can finish in this cycle
13:52:33 <yanyanhu> haiwei, soft delete is removed now, so some logic about deleting lb member in lb policy doesn't work
13:52:59 <haiwei> ok, yanyanhu, I will read the source
13:53:04 <Qiming> 403 is a rejection?
13:53:21 <yanyanhu> yes, 403 usually means policy check failed
13:53:37 <haiwei> it seems only admin user can get loadbalancer
13:53:50 <Qiming> what?!
13:54:30 <yanyanhu> hmm, didn't meet this issue before
13:54:32 <haiwei> we are requesting loadbalancer list , right?
13:54:33 <yanyanhu> will check it
13:54:44 <Qiming> pls double check
13:55:00 <haiwei> ok, I am not sure about that
13:55:07 <haiwei> will test it again
13:55:11 <yanyanhu> haiwei, I remeber we didn't do loadbalancer list in lb_policy
13:55:19 <yanyanhu> will also check it
13:56:10 <yanyanhu> haiwei, if it does exist, you can report a bug for it :)
13:56:16 <Qiming> 4 mins
13:56:20 <haiwei> ok
13:56:36 <Qiming> we'll skip weekly IRC meeting next week
13:56:50 <haiwei> cool
13:57:07 <yanyanhu> haiwei, did you find proper hotel
13:57:10 <Qiming> more accurately, replace it with a face-to-face, beer-in-hand meeting
13:57:16 <haiwei> yes
13:57:20 <lixinhui> :)
13:57:21 <yanyanhu> nice
13:57:22 <haiwei> on zhichun road
13:57:24 <cschulz> Will there be a conference call hookup for the meet?
13:57:27 <yanyanhu> ok
13:57:29 <lixinhui> wow
13:57:35 <haiwei> not far from IBM I think
13:57:41 <Qiming> cschulz, it will last a whole day
13:57:42 <lixinhui> very close to VMware, haiwei
13:57:54 <yanyanhu> Qiming, maybe we can enable a callin number?
13:58:00 <Qiming> we can use a etherpad though, cschulz
13:58:03 <haiwei> haha, have a visit to your company?
13:58:06 <yanyanhu> but not sure we can get a passcode
13:58:20 <lixinhui> Welcome, haiwewi
13:58:23 <lixinhui> :)
13:58:52 <Qiming> yanyanhu, we can
13:59:03 <lixinhui> webex
13:59:23 <yanyanhu> cool, some people who can't be onsite can join by calling in
13:59:24 <lixinhui> if need, I can share my account out
13:59:27 <Qiming> time's up
13:59:40 <Qiming> switch to #senlin now
13:59:43 <haiwei> see you
13:59:46 <yanyanhu> thanks
13:59:47 <Qiming> #endmeeting