13:00:13 <Qiming> #startmeeting senlin
13:00:14 <openstack> Meeting started Tue Apr 5 13:00:13 2016 UTC and is due to finish in 60 minutes. The chair is Qiming. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:17 <openstack> The meeting name has been set to 'senlin'
13:00:37 <Qiming> evening/morning
13:00:45 <Yanyanhu> hi
13:00:45 <haiwei> hi
13:00:55 <Qiming> #link https://wiki.openstack.org/wiki/Meetings/SenlinAgenda
13:00:55 <elynn> o/
13:01:03 <Qiming> pls check if you have items to add
13:01:23 <cschulz> Hi
13:01:49 <Qiming> #topic Rally testing intro
13:02:11 <Qiming> Yanyanhu, could you share with us something?
13:02:11 <Yanyanhu> my part?
13:02:15 <Yanyanhu> sure
13:02:24 <Qiming> who is rally expert in the team?
13:02:30 <Yanyanhu> in last two weeks, I worked on Senlin support in Rally
13:02:39 <Yanyanhu> haiwei, I guess :)
13:02:56 <haiwei> not an expert, Yanyanhu
13:03:09 <Yanyanhu> we try to leverage Rally's scenario test ability to support stress/performance test of senlin api/engine services
13:03:19 <Yanyanhu> haiwei, met neither :)
13:03:33 <Yanyanhu> so the first step is adding senlin support into Rally
13:03:46 <haiwei> saw your patch
13:03:56 <Yanyanhu> two patches have been proposed here https://review.openstack.org/298109
13:04:02 <Yanyanhu> and here https://review.openstack.org/301522
13:04:03 <Qiming> rally is not using tempest model?
13:04:20 <Yanyanhu> not very sure about it, but I guess so
13:04:26 <elynn> Will it overlap with existing tempest scenarios?
13:04:41 <Yanyanhu> user can define a test job using decription file
13:04:53 <Yanyanhu> elynn, I guess there could be overlap
13:05:53 <elynn> Okay, then two codes need to be maintained...
13:05:54 <Yanyanhu> but IMHO, Rally is very suitable for performance test
13:05:59 <Qiming> I'm wondering what's the advantage of using both rally and tempest
13:06:33 <cschulz> Rally site seems to imply that Rally runs tempest test under the covers.
13:06:36 <Qiming> is it legitimate to create 1000 VMs ?
13:06:43 <Yanyanhu> elynn, actually, for senlin support of Rally, all codes will be submitted to Rally project
13:07:04 <Yanyanhu> Qiming, that's possible
13:08:10 <Qiming> I'm a little bit concerned with patch #301522, because we are (will be) duplicating quite some code
13:08:21 <Yanyanhu> cschulz, nice. If so, we can consider to integrate the senlin rally test and tempest support
13:08:39 <Yanyanhu> Qiming, that's true
13:08:43 <cschulz> I think so.
13:09:38 <Yanyanhu> Qiming, but I'm not sure how to let rally support senlin based on our current work about tempest?
13:09:44 <elynn> OK, then the question would be how to integrate these two things.
13:09:55 <Qiming> if test cases are written in the tempest plugin model
13:10:03 <Qiming> should they live in senlin code base instead?
13:10:06 <Yanyanhu> I guess that means we need to contribute some support about senlin to tempest project?
13:10:24 <Yanyanhu> Qiming, not sure how rally can use them if so
13:10:40 <Qiming> it is just stevedore plugin
13:10:45 <Yanyanhu> will make investigation
13:10:49 <elynn> Yanyanhu, with tempest plugin , we don't need to touch tempest project.
13:24:43 <Qiming> am I still alive?
13:24:43 <haiwei> Qiming, yes
13:24:43 <elynn> Qiming: Yes.
13:24:43 <Qiming> hello, world!
13:24:43 <haiwei> again
13:24:50 <Qiming> okay, ping you tomorrow morning 10am bejing time?
13:24:56 <haiwei> ok, I will draw a graph and mail to you
13:24:58 <Qiming> we can have a quick call on this
13:25:00 <Qiming> thanks
13:25:11 <haiwei> I am fine with it
13:25:17 <Qiming> my whole afternoon is about ...s..h...i..t meeting
13:25:28 <Yanyanhu> me too. But I'm only free on Friday
13:25:46 <Yanyanhu> have visa review on Thursday
13:25:54 <Qiming> oh, xinhui sent me a text this evening
13:26:01 <Yanyanhu> Qiming, our patent review is on wednesday?
13:26:23 <Qiming> she wants me to talk to vmware chief architect about senlin
13:26:29 <Qiming> will do that on Friday morning
13:26:30 <haiwei> so your budget is ok, Yanyanhu?
13:26:44 <Yanyanhu> haiwei, yes, but I'm a little worried about the visa
13:26:47 <Qiming> will update you if we have some outcomes from the discussion
13:26:59 <haiwei> I am also waiting for the visa
13:27:02 <Qiming> #topic newton work items
13:27:12 <Qiming> #link https://etherpad.openstack.org/p/senlin-newton-workitems
13:27:42 <Yanyanhu> if the application go into administrative processing, it costs at least 3 weeks...
13:27:50 <Qiming> I pinged china mobile, hopefully we can schedule a meeting on scalability testing and experience sharing
13:28:00 <Yanyanhu> Qiming, cool
13:28:03 <Yanyanhu> that's very helpful
13:28:21 <Qiming> elynn, tempest infra is ready?
13:28:29 <elynn> yes
13:28:38 <Qiming> removing line 8
13:29:03 <elynn> Initial patch is ready for review.
13:29:18 <elynn> Just feel free to +-1
13:29:24 <elynn> https://review.openstack.org/#/c/295647/
13:29:24 <Qiming> did I +2 it?
13:29:34 <elynn> Not yet.
13:29:53 <Qiming> ah, will check again
13:30:03 <Qiming> I think Mark's suggestion is a good one
13:30:18 <elynn> The rest of it would be move the functional tests to it and add negative tests.
13:30:23 <Qiming> was waiting for your response
13:30:57 <elynn> Qiming: Yes, but I'm haven't find a way to generate a tempest config file...
13:31:10 <Qiming> that is easy
13:31:27 <Qiming> just a separate conf file for oslo.config generator
13:31:41 <Qiming> then you specify where the output will be placed
13:31:55 <Qiming> check the tools/ subdir
13:32:05 <Qiming> there is the conf file for senlin as a whole
13:32:15 <elynn> If we generate it under senlin repo, can I get the options from tempest?
13:32:21 <Qiming> for tempest, you may need just one or two modules I believe
13:32:56 <Qiming> you can try that, not 100% sure
13:33:04 <elynn> well, I will have to try.
13:33:17 <haiwei> what options?
13:33:26 <elynn> Will seek your help if you have time :)
13:33:26 <Qiming> anyway we will have dependency on tempest because we are using its plugin/lib
13:33:49 <Qiming> so we can certainly reference its module when generating conf file
13:34:07 <Qiming> #action Elynn to sync with Qiming on tempest conf file generation
13:34:39 <elynn> But I don't see other project add tempest to their requirements.txt.
13:34:55 <Qiming> since xinhui is not online today, we can skip the health management part
13:35:07 <Qiming> it should be in test-requirements.txt
13:35:26 <Qiming> we do have 'from tempest import blablah' right?
13:35:29 <elynn> Oh, I see...
13:35:44 <elynn> Will update my patch :)
13:35:58 <Qiming> xinhui told me that she is looking into the fencing support
13:36:11 <Qiming> hopefully she can make some progress this coming week
13:36:19 <Yanyanhu> elynn, Qiming, can we have a f2f talk tomorrow to sync our understanding on tempest and rally?
13:36:48 <Qiming> +1 from me
13:36:48 <Yanyanhu> or a call
13:36:53 <elynn> Morning or afternoon are both ok for me Yanyanhu.
13:37:02 <Qiming> maybe starbucks time again?
13:37:11 <elynn> But noon is not...
13:37:16 <Yanyanhu> bingo
13:37:20 <Yanyanhu> oh...
13:37:34 <Yanyanhu> ok, let me try to arrange a phone call tomorrow morning
13:37:46 <Qiming> just allocated 10am-11am to haiwei
13:37:48 <Yanyanhu> maybe at 10:30 am?
13:37:51 <elynn> Have a training at 12~13 oclock.
13:38:06 <Qiming> my whole afternoon was occupied as well
13:38:15 <Qiming> then 9am?
13:38:29 <Yanyanhu> a little early for me...
13:38:42 <Yanyanhu> maybe 11:00 to 11:20?
13:38:44 <elynn> 9 is ok for me.
13:38:47 <Yanyanhu> just after the call with haiwei
13:38:53 <elynn> I don't think it will take much time.
13:38:54 <Qiming> that's fine
13:38:54 <Yanyanhu> since I will also join that call as well
13:39:05 <elynn> Okay
13:39:07 <Yanyanhu> just a quick talk will be ok
13:39:12 <Qiming> I suggest we spend more time on studying rally
13:39:24 <Yanyanhu> Qiming, sure, just try to sync our understanding
13:39:28 <Qiming> before the meeting to make the meetings more efficient
13:39:31 <Qiming> but anyway
13:39:39 <Qiming> 11:00am okay for me
13:39:54 <Yanyanhu> ok
13:40:11 <Qiming> no documentation progress update from me
13:40:32 <Qiming> API microversioning is already in
13:41:13 <Qiming> cschulz, any thing to share from you?
13:41:25 <cschulz> Yes,
13:41:28 <Qiming> semi-autoscaling and zaqar support
13:41:49 <cschulz> I've gotten through the IBM administration stuff to contribute. So can do that now.
13:42:01 <Qiming> \o/
13:42:11 <cschulz> Been working with Zaqar some. to become familiar.
13:42:13 <elynn> That's great!
13:42:36 <cschulz> I'd like to have a talk with you about contribution. Can we have a call?
13:42:49 <Qiming> yes
13:42:52 <cschulz> Choose a time I'll be available.
13:43:15 <Qiming> sure, feel free to schedule a call :)
13:43:34 <cschulz> OK. Your morning OK?
13:43:41 <Qiming> not tomorrow
13:43:53 <Qiming> you can check my calendar availability
13:43:53 <cschulz> OK Thurs. maybe.
13:44:28 <Qiming> Thusday morning good for me
13:44:50 <Qiming> #topic open discussions
13:45:42 <Qiming> any thing, from anyone?
13:45:57 <Qiming> we have 15 minutes to complain about visa now, ;)
13:46:03 <Yanyanhu> ...
13:46:04 <haiwei> hi, guys, I want to quit earlier today, just got a cold
13:46:13 <elynn> ...Hope I can pass...
13:46:15 <Yanyanhu> haiwei, have a good rest
13:46:20 <Yanyanhu> elynn, me too
13:46:23 <Qiming> sure, haiwei, good night
13:46:25 <haiwei> i am worrying visa tooo
13:46:27 <Qiming> it's late for you
13:46:30 <haiwei> see u
13:46:36 <Yanyanhu> haiwei, it should be ok for U I think
13:46:48 <haiwei> :)
13:46:49 <elynn> haiwei: have a good night
13:46:50 <haiwei> 88
13:47:07 <Yanyanhu> bye
13:47:21 <Yanyanhu> I'm little worried because my college
13:47:41 <Yanyanhu> anyway, good luck for me
13:47:43 <Qiming> just tell them you are from beihang, not BUAA
13:47:46 <Yanyanhu> and for elynn as well :)
13:47:55 <elynn> good luck for us
13:47:56 <Yanyanhu> yes, I write it in my resume
13:47:57 <Qiming> elynn has the same problem?
13:48:03 <Yanyanhu> but they know it, you know
13:48:12 <Yanyanhu> he doesn't :)
13:48:22 <elynn> No, my university is not that good :P
13:48:23 <Qiming> Pehang
13:48:38 <Yanyanhu> sigh...
13:49:55 <Qiming> seriously, anything else you want to talk about?
13:50:04 <Yanyanhu> nope from me
13:50:21 <elynn> Is newton starts?
13:50:22 <cschulz> Nothing here
13:50:23 <Qiming> we can call it a day if no
13:50:38 <Qiming> yes, master is already about newton
13:50:50 <Qiming> this week is the last one before mitaka release
13:51:03 <Qiming> thanks gusy
13:51:06 <Qiming> guys
13:51:07 <elynn> ok, got it
13:51:18 <Qiming> #endmeeting