17:00:30 <cathy_> #startmeeting service_chaining
17:00:39 <openstack> Meeting started Thu Sep 17 17:00:30 2015 UTC and is due to finish in 60 minutes.  The chair is cathy_. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:41 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:43 <openstack> The meeting name has been set to 'service_chaining'
17:00:51 <cathy_> hi everyone
17:00:52 <vikram> hi
17:01:06 <s3wong> hello
17:01:45 <mohankumar_> Hi
17:02:38 <cathy_> any topics you have in mind? I have several.
17:02:43 <LouisF> hi
17:02:59 <xgerman> o/
17:03:43 <cathy_> 1. action items, 2. Document links 3. CLI integration with APi 4. Horizon client status
17:03:49 <johnsom> o/
17:03:54 <s3wong> cathy_: sounds good
17:04:04 <cathy_> #topic last meeting action items update
17:04:47 * cathy_ Louis or Cathy finish and post the UT codes (cathy_, 17:44:55) ACTION: Louis or Cathy finish and post the updated API, DB, DB migration, Driver Manager etc. codes to be compliant with the approved APIs (cathy_, 17:45:46)
17:05:29 <cathy_> These actions have been completed. UT codes and updated API, DB, DB migration and Driver Manager codes were uploaded
17:06:22 <cathy_> I see a Jenkins -1. Louis?
17:07:03 <LouisF> i am working on the merge issue and will post new patch https://review.openstack.org/#/c/207251/
17:07:19 <cathy_> LouisF: cool. thanks
17:07:21 * cathy_ vikram investigate full-stack testing and bring the info back in next IRC meeting (cathy_, 17:46:46)
17:07:34 <cathy_> vikram: any update?
17:08:05 <vikram> Sorry, I couldn't much.. I was on a vacation
17:08:19 <vikram> Urgently, need to go home
17:08:43 <cathy_> vikram: OK, could you get this done by next meeting?
17:08:48 <vikram> sure.. i will
17:09:00 <cathy_> vikram: Thanks.
17:09:38 <cathy_> #action vikram investigate full-stack testing and bring the info back in next IRC meeting
17:09:50 <cathy_> s3wong investigate neutron feature testing and bring the info back in next IRC meeting
17:09:57 <cathy_> s3wong: any update?
17:10:31 <s3wong> so for Neutron, outside of the aforementioned (in the last meeting) tests of {unit, functional, API, Tempest}
17:10:56 <s3wong> there are two more: {Grenade, Rally}
17:11:09 <s3wong> Grenade is for upgrade/downgrade, which doesn't affect us
17:11:19 <cathy_> s3wong: could you elaborate on these two?
17:11:25 <s3wong> and Rally is for scale, which at this point we shouldn't put too much effort at this point
17:11:41 <cathy_> s3wong: I see. Thanks!
17:12:39 <cathy_> w.r.t functional and API testing, we are covering these in the UT. DO you mean there are some other specific API testing we need to cover?
17:13:25 <s3wong> cathy_: as the projects become bigger (hopefully), we need to separate out the API tests
17:13:37 <s3wong> cathy_: Neutron does that
17:13:53 <vikram> API tests test plugin and neutron-server integration.. I believe it will be usefu
17:14:57 <vikram> As per neutron, any change in the API we should have corresponding API test case.
17:15:38 <cathy_> vikram: do you mean change in the original Neutron API or change in SFC API?
17:15:56 <vikram> cathy_: anything new as well..
17:16:20 <vikram> cathy_: 'change' menas 'addition'/'deletioin/'modification'
17:16:47 <vikram> SFC is also neutron sub-project ;)
17:16:52 <cathy_> vikram: 'addition'/'deletioin/'modification' in Neutron API or in SFC API?
17:17:15 <cathy_> vikram: could you clarify what you mean?
17:17:16 <vikram> for SFC API also it should be applicable
17:18:30 <vikram> cathy_: As we have added new API's, I believe we MUST add API testcases
17:19:32 <cathy_> vikram: let's break the issue down so that we are on the same page. If Neutron API change, as long as we have our SFC testing scripts, we can verify whether there is collateral damage. If SFC API change, I assume that tempest tests will catch any caveat
17:20:32 <vikram> cathy_: We will be adding Tempest right?
17:20:43 <vikram> cathy_: You just mentioned unit tests?
17:21:02 <cathy_> vikram: yes, we will run tempest
17:21:55 <cathy_> vikram: our UT includes API testing and functional testing. As s3wong mentioned, in the future we could consider separating them
17:22:04 <vikram> cathy_: Then that will be fine.. But in my view we need to have some opinion with exiting cores like amuller or armax on this
17:22:49 <vikram> cathy_: These will be responsible for approving test sufficiency I believe
17:22:58 <cathy_> vikram: sure. would you like to take the action item? Or I can take that
17:23:20 <vikram> cathy_: My plate is full :) Better someone can take this UP
17:23:30 <cathy_> ok
17:24:39 <cathy_> #action Cathy check with Neutron core to see if any integration testing with Neutron is needed. Also how to automate the testing of SFC functionality when Neutron API change
17:25:29 * cathy_ pcarver follow up with Abhinav on functional testing and get back to us in next meeting.
17:27:52 <cahty> sorry folks, I got disconnected
17:28:50 <cathy___> hi
17:29:04 <s3wong> cathy_: cathy___: seems like both you and LouisF are having problems
17:29:13 <cathy___> s3wong: yes
17:29:24 <cathy___> now I am back. sorry about this.
17:29:41 <cathy___> Paul sent me email telling me that he can not join today's meeting.
17:29:59 <cathy___> So let's get the status of the action from him in next meeting.
17:30:16 <cathy___> But he sent me some work he has finished. Let me share the info here
17:31:58 <cathy___> A new meeting agenda link is created which you can add your topic to it before each week's meeting.
17:32:05 <cathy___> #link https://wiki.openstack.org/wiki/Meetings/ServiceFunctionChainingMeeting
17:32:40 <cathy___> Paul said Change to publish networking-sfc/doc/source documents to http://docs.openstack.org/developer/networking-sfc has merged
17:33:24 <cathy___> But when I checked, that link is invalid. Could you check to see if it is valid?
17:33:48 <LouisF> not found
17:34:29 <cathy___> #action Louis contacted Paul to let him know the issue.
17:34:40 <LouisF> i will check with Paul
17:34:53 <cathy___> #action Louis contacts Paul to let him know the issue.
17:36:34 <cathy___> #topic CLI integration with API
17:36:51 <cathy___> vikram: mohankumar_ any update or issue?
17:37:27 <vikram> mohankumar_: Please update the status
17:37:40 <mohankumar_> Facing some integration issue with server code
17:37:52 <vikram> mohankumar_: What issue?
17:38:53 <mohankumar_> Plugins are not getting installed correctly ..while starting devstack getiing installation error
17:39:28 <LouisF> what install error?
17:39:42 <mohankumar_> Tomorrow I 'll check with vikram and get back
17:39:51 <cathy___> mohankumar_: OK, sounds good.
17:40:06 <vikram> cathy__: Thanks for posting the code...
17:40:07 <LouisF> ok contact me on any problems
17:40:18 <vikram> cathy__: Will update the status by tomorrow EOD
17:40:22 <cathy___> vikram: sure
17:40:27 <vikram> LouisF: Thanks
17:40:30 <cathy___> vikram: sure
17:40:47 <cathy___> #topic horizon client status
17:40:53 <mohankumar_> cathy__: Horizon patch with compliant with new api ,  planning to publish in  next week ..
17:41:07 <cathy___> mohankumar_: cool
17:41:26 <cathy___> #action mohankumar_ publish Horizon client codes next week
17:41:46 <cathy___> #topic code review timeline
17:42:02 <vikram> mohankumar__: great work!
17:42:10 <vikram> mohankumar_: great work!
17:42:26 <cathy___> mohankumar_: yes, great work and thanks for your contribution
17:42:53 <mohankumar_> cathy___: vikram  thanks
17:43:29 <cathy___> what is a reasonable timeline for us to finish the integration testing and code review?
17:43:45 <cathy___> let's put some pressure on everyone:-)
17:44:11 <mohankumar_> cathy___: directory structure need to modify as per entry points specified
17:44:30 <mohankumar_> In setup.cfg file
17:45:03 <cathy___> mohankumar_: OK, could you post your comment on this online?
17:45:03 <LouisF> mohankumar_: will fix
17:45:18 <mohankumar_> cathy___:  I did
17:45:34 <cathy___> mohankumar_: OK, thanks.
17:46:01 <cathy___> LouisF: thanks for fixing this.
17:46:36 <mohankumar_> LouisF: thanks
17:47:10 <cathy___> LouisF: vikram s3wong mohankumar_ what do you think is a reasonable timeline to have the code review completed?
17:48:05 <vikram> cathy__: Code size is around 8K.. We need atleast 2 weeks time
17:48:30 <LouisF> oct 9?
17:48:43 <mohankumar_> vikram: +1
17:48:54 <vikram> LouisF: that would be fine for me
17:48:55 <s3wong> cathy___: yeah, I think what vikram said is reasonable... this patch set is too big for a quick glance. we probably need at least 2 weeks
17:49:04 <cathy___> How about 3 weeks, by Oct. 9th let's get ready to merge the codes?
17:49:17 <LouisF> sure
17:49:29 <s3wong> cathy___: +1
17:49:46 <s3wong> couple weeks before the summit for any slippage, sounds reasonable
17:49:47 <mohankumar_> cathy___: sounds good
17:50:13 <vikram> cathy__: I would have preferred breaking the patch sets in chunks for effective review :)
17:50:43 <vikram> cathy___: But anyways, let's not do that now .. as we have lot of other wrok
17:51:19 <vikram> cathy___: 3 weeks would be okay
17:52:02 <cathy___> #agreed everyone helps with the integration testing, bug fixes, and update of the codes and actively does code review. We will have all review done and code merged by 10/9/2015
17:52:39 <cathy___> any other issue you would like to discuss?
17:53:40 <cathy___> s3wong: if you see some issues of the codes, feel free to fix them and upload new patches. OK with you?
17:53:49 <s3wong> cathy___: sure
17:53:55 <cathy___> s3wong: thanks!
17:54:10 <vikram> cathy___: +1
17:54:17 <LouisF> +1
17:54:22 <cathy___> That's all for today's meeting. bye now.
17:54:29 <LouisF> bye
17:54:32 <mohankumar_> Bye
17:54:35 <s3wong> bye
17:54:48 <cathy___> #endmeeting
17:55:03 <vikram> I believe if we want to make it happen then all of us should jump rather making cathy___ and LouisF to fix all the comments
17:55:14 <s3wong> cathy___: well, you are no longer cathy_ who started the meeting :-)
17:55:17 <LouisF> +1
17:55:27 <cathy___> vikram: 100% agree
17:55:34 <s3wong> cathy___: so I don't think your #endmeeting is going to work anymore :-)
17:55:35 <cathy___> s3wong: Ok I see
17:55:44 <vikram> ;)
17:55:50 <cathy___> s3wong: how to fix it?
17:56:09 <s3wong> cathy___: unfortunately no way to fix that :-(
17:56:22 <vikram> probably we can ask infra help
17:56:28 <s3wong> cathy___: next time make other attendees chairs just in case
17:56:39 <vikram> otherwise i feel meeting couldn't be logged?
17:56:39 <cathy___> s3wong: sure.
17:57:09 <vikram> cathy___: register nick for you
17:57:15 <cathy___> s3wong: we would like the meeting to be logged. Anyway to do this?
17:57:22 <vikram> cathy___: you will never have this issue then
17:57:32 <LouisF> #nick Louis
17:57:32 <s3wong> cathy___: cathy_ has dropped out, so you may be able to log back in as cathy_?
17:57:46 <cathy___> s3wong: OK, let me try
17:58:45 <s3wong> LouisF: I do believe one would have a issue a /msg to NickServ
17:58:48 <cathy___> s3wong: vikram before I try, could you copy the meeting logs into a file and we can ask the infra team to post them if nothing works
17:58:59 <cathy___> I only see partial log
17:59:07 <vikram> me too
17:59:18 <s3wong> cathy___: try /nick cathy_
17:59:26 <vikram> i have copied
17:59:39 <cathy___> vikram: thanks!
18:00:14 <cathy_> #endmeeting