17:00:32 <cathy__> #startmeeting service_chaining
17:00:33 <openstack> Meeting started Thu Jan 14 17:00:32 2016 UTC and is due to finish in 60 minutes.  The chair is cathy__. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:36 <pcarver> hi, I can only be here for 10-15 minutes. I need to leave for a conflict.
17:00:38 <openstack> The meeting name has been set to 'service_chaining'
17:00:47 <cathy__> pcarver: hi
17:00:54 <vikram> cathy_: hi
17:00:57 <cathy__> pabelanger: ok
17:01:00 <cathy__> vikram: hi
17:01:07 <cathy__> pcarver: ok
17:01:20 <cathy__> LouisF: raofei hi
17:01:50 <cathy__> any topic you could like to discuss?
17:01:54 <cathy__> Swami: hi
17:02:11 <vikram> some updates on horizon and heat patch
17:02:21 <cathy__> vikram: ok
17:02:25 <LouisF> hi
17:02:30 <cathy__> #topic update on horizon and heat
17:02:35 <vikram> mohankumar will  be able to post the patch by next week
17:02:39 <Swami> cathy__:hi
17:02:39 <pcarver> There's some Gerrit problem with https://review.openstack.org/#/c/249488/
17:02:58 <vikram> facing some issues with getting all the code inside networking-sfc repo
17:03:00 <cathy__> pcarver: let me take a look at the link
17:03:14 <hdaniel> cathy__, LouisF , vikram , pcarver , pabelanger : hi
17:03:22 <cathy__> hdaniel: hi
17:03:37 <vikram> hdaniel: welcome ;)
17:03:41 <hdaniel> cathy__: thanks :)
17:04:01 <hdaniel> if you guys don't mind /me snooping around - I'd appreciate some help when you're done
17:04:18 <cathy__> pcarver: vikram seems some problem with Gerrit?
17:04:40 <cathy__> pcarver: I see that +2 and workflow has been approved, but it is still not merged
17:04:50 <pcarver> cathy__: correct
17:04:51 <vikram> cathy__: yup
17:05:06 <LouisF> pcarver: yes
17:05:17 <vikram> may be we can seek infra teams help
17:05:27 <cathy__> pcarver: vikram is someone in OpenStack working on this Gerrit issue?
17:05:35 <cathy__> vikram: yes
17:05:42 <vikram> #openstack-infra
17:05:56 <cathy__> vikram: would you like to let the infra team know this problem?
17:06:02 <vikram> sure i will
17:06:08 <cathy__> vikram: thanks!
17:06:19 <vikram> cathy__: welcome
17:07:20 <cathy__> #action vikram will talk with openstack_infra team on the Gerrit problem for the patch and "can not getting all the code inside networking-sfc repo" issues
17:08:07 <cathy__> vikram: Is Mohan going to post horizon and heat patches next week?
17:08:17 <vikram> cathy__: yes he will ...
17:08:42 <cathy__> vikram: great. Could you get some core members of Horizon and Heat to review them?
17:08:49 <vikram> cathy__: working around how to resolve dependencies to move the code in networking-sfc repo
17:09:14 <cathy__> vikram: I see some discussion on this in the alias some time back.
17:09:16 <prithiv> hllo
17:09:37 <cathy__> vikram: Is there final consensus on how to do this for sub-projects?
17:09:41 <cathy__> prithiv: hi
17:09:52 <vikram> cathy__: develope inside your repo
17:10:06 <vikram> cathy__: BTW, merge issue is resolved ..
17:10:13 <cathy__> pcarver: since you need to leave early, do you have topic you would like to discuss?
17:10:24 <cathy__> vikram: oh, great!
17:10:42 <vikram> https://review.openstack.org/#/c/249488/ can't merge because it's parent is under review
17:11:11 <pcarver> cathy__: Nothing really. I had a few comments on the FC API and they're in Gerrit now.
17:11:14 <vikram> https://review.openstack.org/gitweb?p=openstack/networking-sfc.git;a=commit;h=2c4a9bb8313102c16a1816fd1d965ad2c9d0763b
17:11:20 <vikram> is the parent
17:11:51 <cathy__> vikram: what is this parent?
17:12:03 <cathy__> cathy__: I see that you are the author
17:12:13 <cathy__> vikram: I see that you are the author
17:12:32 <vikram> cathy__: Parent patch is still under review
17:12:50 <cathy__> pcarver: good. Could you review the OVS driver and OVS agent patches as soon as possible?
17:12:50 <vikram> Realizing SFC: OVS Agent and OVS
17:13:24 <cathy__> pcarver: In our last meeting, we agreed to get these patches merged by this week:-)
17:13:34 <vikram> ;-)
17:13:52 <vikram> cathy__: I have a question
17:14:12 <cathy__> vikram: go ahead
17:14:15 <vikram> cathy__: Are we planning to have API/Functional tests
17:14:23 <vikram> I can't find them
17:14:41 <pcarver> cathy__: will do. Too many all day meetings this week, but tomorrow is a lighter schedule
17:14:54 <cathy__> pcarver: great, Thanks!
17:15:11 <cathy__> vikram: Do you mean end-to-end functional tests?
17:15:15 <pcarver> got to go. I'll read the rest of the meeting log later.
17:15:28 <cathy__> pcarver: ok, bye
17:15:43 <vikram> cathy__: yes
17:16:10 <vikram> cathy__: + API endpoint tests
17:16:20 <cathy__> vikram: yes, we have conducted end-to-end functional tests last two months and have updated patches to fix bugs we found.
17:16:39 <vikram> cathy__: In neutron we write API test for new API's
17:16:40 <cathy__> vikram: now if you download the latest patches, they should work very well and smooth
17:17:13 <vikram> cathy__: https://github.com/openstack/neutron/tree/master/neutron/tests/api
17:17:29 <vikram> cathy__: https://github.com/openstack/neutron/tree/master/neutron/tests/functional
17:17:44 <cathy__> vikram: For API UT, we have uploaded testing scripts. Let me take a look at the links
17:17:46 <vikram> cathy__: https://github.com/openstack/neutron/tree/master/neutron/tests/fullstack
17:18:44 <hdaniel> guys, is there a regular communication channel for the project ?
17:18:54 <cathy__> vikram: I will take a more detail look into these after the meeting
17:19:02 <vikram> cathy__: sure
17:19:22 <vikram> cathy__: We got to review "
17:19:22 <vikram> Agent specific API for L2 agent extensions"
17:19:34 <cathy__> hdaniel: not really, but people sent emails if having questions.
17:19:35 <vikram> proposed by Ihar "https://review.openstack.org/#/c/263819/"
17:20:20 <vikram> this i important for us w.r.t. using L2 agent code...
17:20:23 <vikram> *is
17:20:56 <vikram> cathy__: I hope you remember this..
17:20:56 <cathy__> vikram: yes, I know that. We just have not got time to do it yet since we have been busy with fixing bugs in OVS Agent patch,.
17:21:08 <cathy__> vikram: we will get to review it next week
17:21:18 <vikram> cathy__: great
17:21:37 <cathy__> raofei is expert on OVS agent and is a key contributor to our OVS agent codes
17:21:56 <cathy__> raofei: could you review the L2 agent extension as soon as possible?
17:23:07 <vikram> cathy__: What is the plan for getting this merged in neutron.. or we continue as a stadium project..
17:23:07 <cathy__> I will review too. Other people in the team, please review it if you have time.
17:23:24 <vikram> cathy__: I will have a look this weekend
17:23:50 <cathy__> vikram: we will continue as a stadium project since this is not a small feature
17:24:01 <vikram> cathy__: +1000
17:24:06 <cathy__> vikram: great, thanks!
17:24:21 <raofei> sure, i will review L2 agent extension. this is a good idea.
17:24:30 <cathy__> raofei: thanks!
17:25:25 <raofei> many L2 feature need this extension.
17:25:28 <cathy__> vikram: could you please review the OVS driver and OVS agent this week so that we can get these patches merged as everyone agreed in our last meeting?
17:25:38 <vikram> raofei: I agree
17:25:56 <vikram> cathy__: I will .. Sorry for the delay from my end
17:26:16 <cathy__> vikram: no problem. Appreciate it. I know if will be your weekend time soon:-)
17:26:22 <vikram> cathy__: Will do it on priority
17:26:30 <cathy__> vikram: thanks!
17:26:58 <cathy__> #topic bugs
17:27:42 <cathy__> prithiv: wrt the bugs you reported, have you got a chance to try the latest codes? Those problems should be gone if you use the latest codes
17:28:01 <vikram> bug-id?
17:28:14 <vikram> cathy__: Bug-Id?
17:28:28 <cathy__> https://bugs.launchpad.net/networking-sfc
17:29:18 <cathy__> prithiv: are you still there?
17:29:19 <hdaniel> cathy__:  what branch/ref should be used now as the latest ?
17:29:27 <prithiv> yes
17:29:42 <prithiv> i am still facing the issue cathy
17:29:50 <prithiv> i tried with patch set 15
17:30:19 <cathy__> LouisF: could you help post the link to the latest codes for hdaniel?
17:30:33 <cathy__> prithiv: which one are you facing?
17:30:40 <prithiv> i mean, about flow classifier issue in the multi node setup
17:30:49 <prithiv> i will close the port-chain-update today...
17:32:32 <cathy__> prithiv: I am checking patch set 15 now
17:32:43 <LouisF> hdaniel: the installation is posted at the wiki https://wiki.openstack.org/wiki/Neutron/ServiceInsertionAndChaining
17:33:11 <hdaniel> LouisF: yeah, I used that. thanks - thought there's something I miss out.
17:33:34 <LouisF> hdaniel: that is the latest procedure
17:33:50 <cathy__> prithiv: when you say patch set 15, which patch are you referring to?
17:34:04 <LouisF> prithiv: does the FC work correctly with single node setup?
17:34:36 <prithiv> yes it did
17:35:18 <cathy__> prithiv: we tried it and it worked fine.
17:35:21 <hdaniel> LouisF: and I understand that it's supposed to be merged into master at some point ?
17:35:27 <prithiv> https://review.openstack.org/#/c/249488/
17:35:50 <prithiv> as per the steps provided in wiki i used this patch
17:35:53 <LouisF> prithiv: can you send me dump-flows -Oopenflow13 and dump-groups -Oopenflow13 for br-int for both single and mult-node
17:36:24 <cathy__> prithiv: OK. for the OVS driver patch and OVS agent patch, are you using the latest ?
17:36:24 <LouisF> also the dump-flows for br-tun for the mutli-node case
17:36:59 <prithiv> i have sent the dump-flows for multiple node yesterday to you, cathy and xiaodong… i will send the dump group for multiple and single node in a while
17:38:09 <cathy__> prithiv: so for single node, it works fine, right?
17:38:37 <prithiv> yes.. so far, i didnt see any issue in single node for various scenarios i have tested
17:39:00 <cathy__> prithiv: OK, we will take a look at the dump you sent after the meeting.
17:39:46 <cathy__> any other topic you would like to discuss today?
17:40:09 <vikram> i have none
17:40:12 <hdaniel> cathy__: yeah, I have a quick question
17:40:19 <cathy__> hdaniel: sure
17:40:32 <cathy__> hdaniel: shoot
17:40:37 <hdaniel> cathy__: if I'd like to add some features to the classifier, which branch/ref should I use ?
17:41:00 <LouisF> prithiv: is import to do the -Oopenflow13 for the dump-flows because it appears that the group-related rules are missing from the dump-flows you sent
17:41:01 <cathy__> hdaniel: are these features for SFC?
17:41:08 <LouisF> important
17:41:14 <hdaniel> cathy__: yep,
17:41:15 <cathy__> hdaniel: or for generic FC usage?
17:41:41 <hdaniel> cathy__: I had in mind of adding IP tos/dscp marking classification caps
17:41:52 <hdaniel> cathy__: for the steering
17:42:15 <cathy__> hdaniel: Ok, that is good. we have extensions for FC.
17:42:38 <hdaniel> cathy__: great. so should I just base the work on https://review.openstack.org/#/c/249488/ ?
17:42:54 <cathy__> hdaniel: for this first release which is near, we won't have time to include the extensions. But we can include this in the next release.
17:43:11 <cathy__> hdaniel: make sense to you?
17:43:22 <hdaniel> cathy__: when are you planning on the release ?
17:43:33 <LouisF> hdaniel: can that be done after we complete the first release?
17:43:43 <hdaniel> LouisF: ^
17:44:13 <cathy__> hdaniel: The sooner, the better, latest with Mitaka cycle since many people are asking for the official release.
17:44:22 <LouisF> hdaniel: M2
17:44:45 <hdaniel> cathy__, LouisF: I see. so I can focus on the dev without expecting it to be merged. sounds fair ?
17:44:55 <cathy__> hdaniel: sure!
17:45:10 <hdaniel> cathy__: great. thanks
17:45:23 <vikram> hdaniel: can do a initial write to know what you exactly want?
17:45:29 <hdaniel> vikram: sure, will do
17:45:31 <LouisF> hdaniel: we expect the flow-classifier to evolve significantly over the next cycle
17:45:50 <hdaniel> LouisF: I'd be more than happy to contribute to it :)
17:46:13 <cathy__> hdaniel: we also have plan to evolve the FC into a common FC in Neutron which can be used for features other than SFC.
17:46:18 <vikram> LouisF: I also have few things in my mind to add ;-)
17:46:32 <cathy__> vikram: go ahead
17:46:41 <vikram> cathy__: there is a separate project for that now ;-)
17:46:47 <vikram> neutron-classifier
17:47:04 <cathy__> vikram: OK
17:47:05 <LouisF> hdaniel: vikram we can have a planning session after the release
17:47:10 <vikram> https://github.com/openstack/neutron-classifier
17:47:21 <vikram> LouisF: Sure
17:47:39 <hdaniel> LouisF: sure, great
17:47:56 <cathy__> Cool. any other topic you have in mind?
17:48:45 <vikram> One announcement
17:49:02 <vikram> We tested the SFC NBI's with ONOS it works fine ;)
17:49:14 <LouisF> just ask everyone to review and +1
17:49:23 <cathy__> vikram: great news! Way to go!
17:49:43 <LouisF> vikram: are you plannng to add the onos driver?
17:49:51 <vikram> LouisF: Yes
17:50:11 <vikram> https://review.openstack.org/#/c/266797/
17:50:54 <vikram> once networking-sfc is released we can also release networking-onos
17:50:55 <cathy__> vikram: we will review it
17:51:06 <vikram> cathy__: thanks
17:51:11 <cathy__> vikram: yes!
17:51:17 <LouisF> vikram: great! we can add details to the wiki
17:51:34 <vikram> LouisF: Sure!...
17:51:46 <igordcard_> sorry vikram: you mean ONOS NBI with networking-sfc or networking-sfc SBI with ONOS?
17:51:53 <vikram> LouisF: Let's wait for ONOS official release to happen
17:52:19 <cathy__> igordcard_: it should be networking-sfc SBI with ONOS
17:52:26 <LouisF> vikram: when will that be?
17:52:33 <cathy__> vikram: right?
17:52:48 <vikram> cathy__: you are correct
17:52:59 <vikram> LouisF: I think next month
17:53:34 <LouisF> can you post a link to the onos nbi
17:54:02 <vikram> LouisF: okay.. once it's officially published I will
17:54:11 <cathy__> igordcard_: do you know how NSH is going in OVS open source ? When will it be accepted?
17:54:49 <igordcard_> cathy__: no cathy__ , haven't followed OVS specific progresses
17:55:02 <hdaniel> cathy__: I had a conversation regarding that with OVS guys today.
17:55:15 <LouisF> hdaniel: and?
17:55:20 <cathy__> hdaniel: Oh, great. How is it going?
17:55:34 <hdaniel> VXLAN-gpe is planned for next week, nsh is the next to follow
17:55:44 <vikram> LouisF: https://github.com/opennetworkinglab/onos/tree/master/apps/vtn/sfcmgr/src/main/java/org/onosproject/sfc
17:55:53 <LouisF> vikram: thanks
17:56:20 <cathy__> hdaniel: do you know about when will the NSH codes be officially accepted in OVS?
17:56:22 <LouisF> hdaniel: so the new nsh  will be decoupled form vxlan encap?
17:56:48 <hdaniel> cathy__: no sorry :( they're still under review
17:57:02 <LouisF> hdaniel: do you have a link to the nsh patches for ovs?
17:57:17 <hdaniel> LouisF: yeah, I have some thread. 1 sec
17:57:28 <cathy__> hdaniel: why not support NSH over existing VXLAN too? Or it is planned already?
17:57:58 <hdaniel> cathy__: I don't know - I just started the conversation today. can ask that
17:58:13 <LouisF> cathy__:  the original nsh patch supported nsh over only one encap - vxlan
17:58:23 <hdaniel> LouisF: http://openvswitch.org/pipermail/dev/2015-October/061214.html
17:58:40 <LouisF> the new patch will allow nsh over different encaps
17:59:38 <cathy__> LouisF: so I hope this original nsh over VXLAN will continue to be supported.
17:59:38 <vikram> we are timeout ;-)
17:59:43 <vikram> only 1 min
17:59:52 <cathy__> ok, let's end the meeting.
17:59:59 <LouisF> cathy__: yes it will
18:00:25 <LouisF> plus tlv support as mentioned in that email
18:01:55 <eglute> hello, can someone end previous meeting?
18:02:41 <eglute> cathy__, would you end the meeting?
18:02:41 <vikram> cathy__:
18:03:16 <eglute> #endmeeting