16:59:39 <LouisF> #startmeeting service_chaining
16:59:41 <openstack> Meeting started Thu Mar 24 16:59:39 2016 UTC and is due to finish in 60 minutes.  The chair is LouisF. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:59:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:59:45 <openstack> The meeting name has been set to 'service_chaining'
16:59:52 <pcarver> hi
17:00:23 <LouisF> pcarver: hi cathy just got back from business trip and will not join today
17:00:48 <pcarver> yes, I saw her email.
17:01:12 <LouisF> i was out last week at onf but i see you and vikram were on the meeting
17:01:24 <pcarver> yes. It was pretty quiet.
17:01:49 <pcarver> We talked a bit but I think it was pretty much just the two of us
17:03:48 <LouisF> looks quiet today also
17:04:17 <pcarver> Yes. I don't know if there's anything major. There's been some minor bug fix activity.
17:04:31 <pcarver> Most of my attention has been elsewhere.
17:04:31 <vishnoianil> LouisF, pcarver hey
17:04:37 <LouisF> yes https://review.openstack.org/295407
17:04:50 <LouisF> vishnoianil: hi
17:05:21 <vishnoianil> LouisF, pcarver let me introduce myself, i am contributor/committer  to opendaylight project (ovsdb,controller,openflowplugin)
17:05:22 <mohankumar> Hi LouisF, Pcarver
17:05:34 <pcarver> vishnoianil: welcome
17:05:56 <vishnoianil> LouisF, i am interested in contributing to odl sfc driver in networking-sfc
17:06:00 <vishnoianil> pcarver, thanks :)
17:06:39 <LouisF> vishnoianil: i had a brief chat with yi yang at onf on that driver
17:06:39 <vishnoianil> LouisF, pcarver , just wanted to know if anybody already working on that with whom i can sync up
17:06:44 <pcarver> That would be great. I'm very interested in seeing many drivers developed
17:06:54 <LouisF> vishnoianil: do you work with him?
17:06:55 <pcarver> I don't think an ODL driver has been started
17:07:15 <vishnoianil> LouisF, I work with Sridhar (tacker)
17:07:30 <vishnoianil> i know YiYang ( i believe from Intel)?
17:07:44 <LouisF> vishnoianil: yes he is at intel
17:08:09 <LouisF> vishnoianil: i think it would be good to contact him
17:08:22 <vishnoianil> LouisF, any idea whether he is planning to contribute / start on the driver?
17:08:40 <vishnoianil> LouisF, cool, i will sync up with him.
17:08:43 <s3wong> hello. Sorry, a bit late
17:08:47 <LouisF> vishnoianil: he is located in china i believe so he is not on this call
17:09:01 <vishnoianil> in case he is still interesting in contributing on it
17:09:17 <LouisF> s3wong: hi, we are discussing the odl driver for networking-sfc
17:09:55 <s3wong> LouisF: oh, OK. trozet (Tim Rozet from Redhat) has experience there and is also interested to contribute ODL SFC driver for networking-sfc
17:10:23 <LouisF> vishnoianil: contact yi yang on the odl driver and its design
17:10:43 <LouisF> vishnoianil: there is an onos driver already
17:11:05 <vishnoianil> s3wong, yes, i had a discussion with him (Tim) as well
17:11:20 <s3wong> vishnoianil: good
17:11:29 <LouisF> s3wong: yes i saw his comments on tacker-to-networking-sfc driver
17:11:47 <vishnoianil> LouisF, so i believe Tim, Yi are interested, so i think we can need to discuss it to make some progress on it
17:12:09 <LouisF> vishnoianil: that would be good
17:12:20 <s3wong> LouisF: as he already wrote a driver for ODL SFC in Tacker (not committed), I think his experience would be invaluable for ODL SFC integration here
17:12:21 <vishnoianil> LouisF, s3wong do we have any existing blueprint for sfc odl driver?
17:12:37 <s3wong> vishnoianil: don't think so
17:12:41 <LouisF> vishnoianil: no
17:12:51 <vishnoianil> s3wong, yup totally agree, i will be keeping Tim in the loop
17:13:13 <s3wong> vishnoianil: great!
17:13:22 <vishnoianil> s3wong, LouisF okay, i will work with tim.Yi to comeup with the blueprint and lets start from there
17:13:36 <LouisF> vishnoianil: that would be a great start
17:13:45 <s3wong> vishnoianil: sounds good!
17:14:20 <vishnoianil> s3wong, LouisF , is there any place where this action item can be put against me, so if anyone else is interested they can reach out to me ?
17:14:50 <LouisF> vishnoianil: we can add to the wiki
17:15:04 <s3wong> vishnoianil: not really... but once you added the blueprint, you can assign that to yourself
17:15:34 <s3wong> vishnoianil: you can further add an item on networking-sfc launchpad and assign that to yourself as well
17:15:46 <LouisF> vishnoianil: btw the tacker / networking-sfc integration spec is at https://review.openstack.org/#/c/290771/
17:16:05 <LouisF> vishnoianil: please review
17:16:10 <vishnoianil> s3wong, LouisF great, i will add it to launchpad and then will push the blueprint
17:16:40 <vishnoianil> LouisF, yes, i am aware of the networking-sfc intergration spec, i will review it
17:16:56 <LouisF> vishnoianil: thanks
17:17:20 <s3wong> vishnoianil: ODL SFC networking-sfc driver isn't a dependency on tacker/networking-sfc integration, though it is a requirement for OPNFV
17:17:38 <LouisF> s3wong: agree
17:17:58 <s3wong> vishnoianil: so it is great that you and trozet step up to contribute there. Thanks!
17:18:35 <vishnoianil> LouisF, s3wong , yes it's to add support for SDN controller as a backend sfc provider
17:19:00 <vishnoianil> and OPNFV is a first big consumer
17:19:08 <LouisF> #action vishnoianil to add networking-sfc odl driver spec to launchpad
17:19:57 <s3wong> vishnoianil: looking forward to your spec (please send gerrit review against networking-sfc repo)
17:20:10 <vishnoianil> LouisF, s3wong sure will do Thanks folks
17:20:41 <vishnoianil> s3wong, LouisF i just noticed i didn't mention my name :)
17:20:51 <vishnoianil> s3wong, LouisF my name is Anil
17:21:12 <LouisF> vishnoianil: hi Anil, welcome
17:21:18 <mohankumar> Anil welcome to netwoking-sfc
17:21:26 <s3wong> vishnoianil: nice to meet you virtually, Anil
17:21:45 <vishnoianil> LouisF, mohankumar s3wong thanks folks. I am in San Jose area
17:22:03 <vishnoianil> so if you guys do have hackton, i would be happy to join :)
17:22:16 <vishnoianil> hackton in bay area
17:22:51 <LouisF> ok moving on
17:23:09 <LouisF> #topic new work
17:23:58 <trozet> s3wong, vishnoianil: yeah I mean I have a driver that works with Tacker (bypasses neutron), so we can leverage some of that for the networking-sfc driver
17:24:09 <LouisF> i posted a list of items at a previous meeting: SDN controller drivers, support of a mixed chain of VM, container, physical device, integration with upstream Tacker,  enhancement of Flow Classifier, Horizon, OAM, Heat,  tempest tests
17:24:55 <LouisF> i think we have some progress with the odl driver work
17:25:05 <s3wong> trozet: yes --- that would be valuable experience for networking-sfc ODL driver; please work with vishnoianil on this. Thanks!
17:25:11 <LouisF> and also the tacker integration
17:25:22 <trozet> s3wong: yeah vishnoianil and I have a meeting setup netxt week
17:25:35 <s3wong> trozet, vishnoianil: great. Thanks!
17:25:46 <LouisF> trozet: when is the meeting?
17:25:55 <s3wong> LouisF: (sorry for hijacking your topic)
17:26:07 <trozet> LouisF: 3pm EST Monday
17:26:09 <LouisF> s3wong: np all part of new work
17:26:34 <LouisF> on openstack-meeting-4?
17:26:42 <trozet> LouisF: vishnoianil is the organizer, if you want to join that would be cool.  I think its a google hangout
17:26:59 <LouisF> can you send details
17:27:08 <trozet> LouisF: sure send me your email
17:27:21 <LouisF> louis.fourie@huawei.com
17:27:55 <trozet> LouisF: got it
17:28:18 <LouisF> trozet: btw i posted an updated version of the integration spec https://review.openstack.org/#/c/290771/
17:28:38 <LouisF> s3wong: trozet please review
17:29:08 <trozet> LouisF: will do
17:29:15 <s3wong> LouisF: sure
17:29:32 <trozet> LouisF: review mine as well ;) https://review.openstack.org/#/c/292196/
17:29:39 <LouisF> trozet: will do
17:30:32 <s3wong> trozet: for that one you are basically just moving it from mitaka to newton, right? :-)
17:30:55 <trozet> s3wong: yeah and making sure it points to networking-sfc as the driver rather than ODL driver
17:31:11 <s3wong> trozet: cool  :-)
17:31:29 <LouisF> trozet: great
17:32:13 <LouisF> mohankumar: what is the status on Horizon?
17:32:59 <mohankumar> LouisF  For Horizon i didn't get chance to work last week
17:33:27 <LouisF> mohankumar: ok thanks keep us posted on progress
17:34:15 <mohankumar> LouisF ,Heat i ve posted 4 patches .. there are some review coments i need to work upon
17:34:44 <LouisF> mohankumar: thanks what are the patches?
17:35:15 <mohankumar> https://review.openstack.org/#/c/249729/
17:35:21 <mohankumar> https://review.openstack.org/#/c/277849/
17:35:25 <mohankumar> https://review.openstack.org/#/c/277940/
17:35:30 <mohankumar> https://review.openstack.org/#/c/277988/
17:36:19 <LouisF> mohankumar: thanks - everyone please review these
17:39:19 <LouisF> regarding fc enhancements - vikram had some ideas but he is not on the call - we can pick up next week
17:40:24 <mohankumar> LouisF , I ve a question  , our code supports port_pairs across OVS in one port_pair_group ?
17:41:45 <LouisF> mohankumar: not clear on your question - a port-pair can only be in one PPG
17:42:53 <LouisF> each PPG can be in different port-chains
17:43:09 <mohankumar> LouisF, say  i want to do load-balance among Service Function VMs  which are in different OVS
17:43:47 <LouisF> mohankumar: ok i see, yes that is possible.
17:44:11 <mohankumar> LouisF , OK
17:44:35 <LouisF> the port-pairs in a PPG can reside on different nodes (HVs)
17:44:57 <mohankumar> LouisF , thanks
17:45:06 <LouisF> the ovs driver we have currently supports that
17:45:47 <LouisF> #topic open discussion
17:46:06 <LouisF> any questions?
17:46:12 <LouisF> comments, ideas?
17:46:49 <mohankumar> any one downloaded sfc master code and working on it ?
17:46:59 <mohankumar> me getting some error https://bugs.launchpad.net/networking-sfc/+bug/1557600
17:46:59 <openstack> Launchpad bug 1557600 in networking-sfc "port-chain-delete failing as "SfcDriverError"" [Undecided,New] - Assigned to Mohankumar (mohankumar-n)
17:48:05 <LouisF> mohankumar: let me check on that
17:48:36 <mohankumar> In stable/liberty  branch  is okay
17:48:50 <LouisF> mohankumar: ok
17:49:13 <mohankumar> LouisF , thanks ..Please comment in Lanchpad
17:49:23 <LouisF> mohankumar: ok
17:50:12 <LouisF> anything else?
17:50:14 <mohankumar> these are bugs filled last week
17:50:17 <mohankumar> https://bugs.launchpad.net/networking-sfc/+bug/1557960
17:50:17 <openstack> Launchpad bug 1557960 in networking-sfc "neutron ext-list name fileld should be descriptive " [Undecided,In progress] - Assigned to Mohankumar (mohankumar-n)
17:50:18 <mohankumar> https://bugs.launchpad.net/networking-sfc/+bug/1558012
17:50:19 <mohankumar> https://bugs.launchpad.net/networking-sfc/+bug/1558020
17:50:20 <mohankumar> https://bugs.launchpad.net/networking-sfc/+bug/1557600
17:50:20 <openstack> Launchpad bug 1558012 in networking-sfc "incorrect error message for invalid argument in "neutron port-pair-group-create --port-pair"" [Undecided,New] - Assigned to Mohankumar (mohankumar-n)
17:50:21 <openstack> Launchpad bug 1558020 in networking-sfc "API document have to modify as per changes introduced in flow classifier" [Undecided,New] - Assigned to Mohankumar (mohankumar-n)
17:50:22 <openstack> Launchpad bug 1557600 in networking-sfc "port-chain-delete failing as "SfcDriverError"" [Undecided,New] - Assigned to Mohankumar (mohankumar-n)
17:50:28 <mohankumar> please review it
17:50:37 <LouisF> mohankumar: ok will do
17:52:23 <LouisF> ok then I am going to end
17:52:34 <LouisF> bye all
17:52:40 <mohankumar> bye :)
17:52:42 <s3wong> bye
17:52:49 <s3wong> 8 minutes saved!
17:52:50 <LouisF> #endmeeting