17:00:32 <cathy_> #startmeeting service_chaining
17:00:33 <openstack> Meeting started Thu Apr 21 17:00:32 2016 UTC and is due to finish in 60 minutes.  The chair is cathy_. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:38 <openstack> The meeting name has been set to 'service_chaining'
17:00:45 <cathy_> hi everyone
17:00:47 <vikram> hi
17:00:52 <iyamahat> hello
17:00:52 <pcarver_> hi
17:00:52 <scsnow> hi
17:01:25 <LouisF> hi
17:01:34 <cathy_> Ok, let's start
17:02:00 <cathy_> #topic f2f meeting time and place
17:02:21 <cathy_> John suggested we meet f2f at the summit
17:03:28 <georgewang> hi
17:03:29 <cathy_> I am thinking about we have a lunch meet on Monday/Tuesday/Wednesday. Any suggestion?
17:04:23 <LouisF> is there an etherpad for the meeting?
17:04:41 <pcarver_> I'm booked for lunch Monday, but definitely would like to meet
17:04:55 <cathy_> pcarver_: sridhar_ram scsnow vikram iyamahat and others : any day not good for you?
17:05:16 <vikram> i won't be there ;(
17:05:18 <iyamahat> I prefer wednesday. But Tuesday may work
17:05:41 <sridhar_ram> cathy_: as of now, Tuesday seems better
17:06:54 <cathy_> Ok, let's do it on Tuesday then.
17:07:12 <cathy_> I will find a room and let you know
17:08:29 <cathy_> #topic Maintain the CI seriously and ensure the code in the repo pass all the basic static checks (ownership)
17:08:48 <vishnoianil> cathy_, Tuesday is better for me
17:08:57 <cathy_> Vikram suggested this and I think this is a great suggestion to maintain our code quality going forward
17:09:32 <cathy_> vishnoianil: great, we will meet on Tuesday. I will find a room and let everyone know the room
17:09:48 <vikram> cathy_: I can observer several patches are waiting to be merged for log time
17:09:51 <vikram> *long
17:10:05 <vishnoianil> cathy_, great thanks
17:10:16 <cathy_> vikram: yes, we will get to that in the next topic
17:10:20 <vikram> cathy_: ok
17:10:51 <cathy_> so we need an owner for maintaining the CI
17:11:00 <cathy_> who would like to take that ownership?
17:11:45 <cathy_> vikram: do you have someone in mind for the ownership?
17:11:59 <pcarver> Is this CI distinct from the infra maintained part?
17:12:26 <cathy_> Yes, I think it should include networking-sfc tests
17:13:02 <vikram> cathy_: how about mohankumar?
17:13:17 <cathy_> vikram: is he on line?
17:13:22 <pcarver> I know there are configs in project-config Git repo that control Gerrit and Jenkins, but is that what you're talking about or are you talking about ensuring that individual networking-sfc changes pass tests?
17:13:27 <vikram> cathy_: I can't find him
17:13:51 <cathy_> vikram: could you talk with him offline on taking this ownership?
17:13:53 <vikram> pcarver: I believe individuals ensuring the tests
17:14:01 <vikram> cathy_: sure
17:14:31 <vikram> pcarver: Sometime, global changes impact test and static checks
17:14:40 <pcarver> vikram: in that case we should make sure all committers know how to run tests pre-commit
17:14:44 <vikram> pcarver: e.g. i118n changes
17:14:57 <pcarver> and if the documentation isn't clear we should seek help from other teams
17:15:16 <pcarver> I mean the non-networking-sfc documentation that talks about how to run tox and so forth
17:15:28 <cathy_> pcarver: good point. I think we need to post instructions on how to run the tests pre-commit for each patch
17:15:34 <pcarver> basically, it should be possible for a committer to locally run all the tests that the gate runs
17:15:50 <pcarver> They shouldn't have to push a patch to Gerrit in order to see the test failures
17:16:20 <pcarver> but it's possible that the documentation doesn't spell it out clearly enough, or that people don't know where to look for the documentation
17:16:35 <vikram> pcarver: +1, My concern here is although we ensure green CI before we approve but then how the failures still happens
17:16:43 <pcarver> The Neutron devrefs are a good place to start, but I couldn't swear that there aren't gaps
17:17:36 <pcarver> Maybe we don't have the gate pipelines configured quite correctly?
17:17:44 <cathy_> pcarver: yes, now that more features and patches will be added and merged, gating test is important.
17:18:50 <pcarver> I'm not sure. I learned what little I know about Gerrit and Jenkins by looking at other project entries in the project-config repo. I certainly haven't read the Gerrit/Jenkins docs beyond specific Google search results for specific things
17:20:07 <cathy_> pcarver: I think besides the gating tests, we also need to make sure each merged patch does not break the end-to-end service chain testing
17:20:31 <pcarver> cathy_: well ideally that's what the test are supposed to guarantee
17:20:45 <pcarver> but we may need to work on getting the tests configured correctly
17:20:56 <cathy_> we are setting up a test bed for end-to-end testing of the service chain and we are working on automating all the test scripts.
17:20:58 <pcarver> and ensuring that all patches include sufficient test code
17:21:35 <pcarver> cathy_: by test bed, do you mean Huawei contributing hardware?
17:22:08 <pcarver> If so, it would be worth reaching out to the infra team to gain an understanding of the tooling
17:22:58 <cathy_> Ok, so three actions: 1. check to make sure the tests are configured properly . 2. post instructions on how to run the tests pre-commit for each patch 3. setting up end-to-end test beds and automating all the test scripts
17:23:03 <pcarver> Given how Neutron third party CI used to work, there are people who have experience with that sort of thing
17:24:16 <cathy_> pcarver: yes, Huawei can contribute the hardware. We are working on automating the test scripts since we do not want to block a patch because of a bug in the test scripts. We have been working on this for some time and are still testing the "test scripts".
17:25:03 <cathy_> pcarver: do you have contact for people who have such experience?
17:26:21 <pcarver> cathy_: I don't specifically remember names. I wasn't really involved in it. But Neutron used to mandate third party CI so there was documentation on how to set it up and people from various companies set up their own CI that voted on all Neutron changes.
17:26:48 <pcarver> Might be the sort of thing to ask in the hallway at the summit
17:27:25 <cathy_> pcarver: OK, I will try to find those documents and reach out to people to leverage their experience of doing this. Thanks for the info
17:27:38 <cathy_> s3wong: Hi, are you going to the summit?
17:27:51 <cathy_> hi mohankumar_
17:28:36 <pcarver> here's a document: http://docs.openstack.org/developer/neutron/policies/thirdparty-ci.html
17:28:43 <vikram> cathy_: I think he is offline
17:29:12 <cathy_> pcarver: thanks!
17:30:00 <s3wong> cathy_: hello
17:30:10 <s3wong> cathy_: yes, I will be at the summit from Tues to Fri (morning)
17:30:23 <s3wong> cathy_: I do plan to join you on the Wed lunch discussion
17:30:37 <cathy_> vikram: pcarver could you help with action item#1  check to make sure the tests are configured properly? I will take care of actions 2 and 3
17:30:42 <cathy_> s3wong: cool
17:31:00 <vikram> cathy_: ok
17:31:29 <cathy_> #action vikram check to make sure the tests are configured properly
17:31:30 <pcarver> cathy_: I can definitely try. I'm not an expert, but I did do some learn by doing with some of the Gerrit/Jenkins config.
17:31:53 <cathy_> #action vikram pcarver check to make sure the tests are configured properly
17:32:38 <cathy_> LouisF: could you take care of action #2 post instructions on how to run the tests pre-commit for each patch?
17:32:54 <LouisF> cathy_: yes
17:33:07 <cathy_> LouisF: thanks!
17:33:10 <cathy_> #action LouisF post instructions on how to run the tests pre-commit for each patch
17:34:04 <cathy_> #action Cathy take ownership of setting up end-to-end test beds and automating all the test scripts
17:36:22 <cathy_> #topic Code Patches scrub
17:37:12 <iyamahat> Hi I'd like to raise https://review.openstack.org/#/c/300898/
17:37:25 <iyamahat> Now I and Anil are fine with it.
17:37:29 <cathy_> vikram: you mentioned some patches have been open for quite some time. would you like to post the links. we can go through those first
17:37:43 <vikram> cathy_: give me a min
17:38:05 <iyamahat> Is there anyone to give reviews on it? otherwise, I'm going to merge it.
17:38:17 <vikram> https://review.openstack.org/#/c/279924/
17:38:23 <vikram> https://review.openstack.org/#/c/282896/
17:38:28 <vikram> https://review.openstack.org/#/c/285040/
17:38:30 <cathy_> iyamahat: OK, I will go through it and review it.
17:38:41 <vikram> https://review.openstack.org/#/c/305162/
17:39:19 <cathy_> LouisF: pcarver s3wong vikram I suggest that you take a final look at https://review.openstack.org/#/c/300898/ too
17:39:29 <vikram> iyamahat: LGTM
17:39:42 <vishnoianil> cathy_, that's the one that i posed as a blueprint to networking-sfc and you recently approved
17:39:46 <vishnoianil> networking-sfc driver for odl
17:39:48 <LouisF> iyamahat: i am ok with it
17:40:06 <iyamahat> Can you please give +1 explicitly?
17:40:25 <LouisF> iyamahat: will do
17:40:29 <iyamahat> Anyway this evening, I'll merge it.
17:40:37 <iyamahat> thanks!
17:40:49 <pcarver> I'm tight on time for reading code, but I'll read whichever of the above reviews are RST files by tomorrow
17:40:58 <cathy_> vishnoianil: yes I know. I would like to go through the spec once more and will give it +1 if looks OK.
17:41:11 <vishnoianil> cathy_, sure, that would be great
17:41:19 <cathy_> vishnoianil: you will be in the summit, right?
17:41:26 <vishnoianil> cathy_, yes
17:41:39 <s3wong> cathy_: OK
17:42:17 <cathy_> now let's go through the patches Vikram posted
17:42:52 <cathy_> iyamahat: could you give us some time until Friday?
17:43:50 <cathy_> iyamahat: I think some people like pcarver and s3wong might be the first time to look through it
17:44:18 <s3wong> iyamahat: that's right
17:45:04 <pcarver> iyamahat: yes, please give me until Friday if they're documentation reviews that I haven't seen. I'll also want to look into why I missed notification emails.
17:45:05 <iyamahat> cathy_, that's fine. I'll wait.
17:45:29 <iyamahat> Then, I'll wait until openstack summit.
17:45:36 <cathy_> iyamahat: thanks!
17:45:38 <iyamahat> We can also discuss on it there.
17:45:38 <pcarver> I'm too swamped to read a large amount of code, but I try to at least read the specs when I see notification emails
17:46:07 <cathy_> iyamahat: sure. Actually I will be very busy next two days writing my presentation slides:-)
17:46:56 <cathy_> vikram: I see jenkins -1 for patch https://review.openstack.org/#/c/285040/
17:47:28 <cathy_> vikram: same for patch https://review.openstack.org/#/c/285040/
17:47:59 <vikram> cathy_: We need first merge these
17:48:15 <vikram> https://review.openstack.org/#/c/302362/
17:48:26 <vikram> cathy_: We need first merge this : https://review.openstack.org/#/c/302362/
17:48:36 <vikram> after that we can recheck these patches
17:48:45 <vikram> everything will run fine
17:49:55 <cathy_> vikram: Ok, agree. I really need to merge this https://review.openstack.org/#/c/302362/. Now I see this patch passes the test cleanly.
17:50:02 <scsnow> vikram, actually this fixes only pep8 check
17:50:15 <scsnow> py27 and py34 tests are fixed by https://review.openstack.org/#/c/302324/
17:50:32 <vikram> scsnow: there was a patch recently which fixed py27 and py34
17:50:54 <vikram> scsnow: that's why the jerkin is green for https://review.openstack.org/#/c/302362/
17:52:11 <cathy_> vikram: do you mean we do not need patch https://review.openstack.org/#/c/302324/ since there is another patch fixing py27 and py34?
17:52:29 <scsnow> https://review.openstack.org/#/c/302362/ has dependency on https://review.openstack.org/#/c/302324/ that's why tests are green
17:53:34 <cathy_> scsnow: I see jenkins -1 for patch https://review.openstack.org/#/c/302324/ ?
17:54:14 <vikram> cathy_: I will clean this mess..
17:54:16 <scsnow> for pep8 issues related to i18n
17:54:52 <vikram> cathy_: Let me re-arrange these patches in proper dependency order
17:55:05 <cathy_> vikram: OK, thanks!
17:55:20 <vikram> cathy_: Will publish by tomorrow ..
17:56:05 <cathy_> #action Vikram will re-arrange these patches in proper dependency order by 4/22 to fix the test errors. Thanks Vikram!
17:56:18 <scsnow> vikram, there is a cyclic dependency. that's why I cannot rebase  https://review.openstack.org/#/c/302324 on https://review.openstack.org/#/c/302362/
17:56:38 <vikram> scsnow: Let me have a look
17:56:39 <scsnow> if I do so, jenkins won't pick up my patchset
17:56:48 <vikram> scsnow: If required will break the patches
17:56:52 <scsnow> vikram, ok
17:57:01 <cathy_> Now next topic which we might not be able to finish today since we have only 4 min
17:57:09 <cathy_> #topic Consistent Repository rule for networking-sfc related drivers
17:58:02 <LouisF> cathy_: no meeting next week?
17:58:13 <cathy_> I think we can discuss this and reach consensus during our Tuesday lunch time at the summit. We can probably follow how Neutron does it or how FWaaS project does it
17:58:28 <cathy_> LouisF: no, no meeting next week. Thanks for bringing this up!
17:58:55 <LouisF> can we have an etherpad for the networking-sfc meeting at the summit?
17:59:08 <vikram> LoiusF: Nice Idea
17:59:20 <cathy_> Ok, time is up. Look forward to meeting you on Tuesday at the Summit.
17:59:44 <scsnow> bye, have a safe trip
17:59:45 <LouisF> bye
17:59:46 <vikram> bye
17:59:52 <fsunaval> bye
17:59:52 <cathy_> LouisF: yes, would you like to set it up?
17:59:56 <vishnoianil> cathy_, are we planning to have a discussion about changing the time of the meeting ?
17:59:59 <LouisF> cathy_: sure
18:00:10 <vishnoianil> in this or next meeting
18:00:30 <cathy_> vishnoianil: oh, yes. But we can discuss that at the summit. no hurry for that
18:01:26 <cathy_> vishnoianil: remind me of new meeting time. I can not find a channel for Wednesday, so we might need to have the meeting on Friday. Let's sync up at the summit
18:01:33 <cathy_> bye everyone
18:01:38 <LouisF> https://etherpad.openstack.org/p/networking-sfc-austin-summit-meeting
18:01:51 <vishnoianil> cathy_, sure
18:02:03 <iyamahat> bye
18:05:51 <pcarver> cathy_: I think you forgot the endmeeting command
18:06:41 <s3wong> #endmeeting