17:01:30 <cathy__> #startmeeting service_chaining
17:01:31 <openstack> Meeting started Thu Jun  9 17:01:30 2016 UTC and is due to finish in 60 minutes.  The chair is cathy__. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:34 <openstack> The meeting name has been set to 'service_chaining'
17:01:39 <cathy__> hi everyone
17:01:44 <pcarver> hi
17:01:48 <iyamahat> hello
17:01:48 <mohankumar_> Hi all
17:01:52 <regXboi> \o/
17:01:54 <igordcard> hi
17:02:04 <LouisF> hi
17:02:22 <cathy__> let's quickly go through the action status
17:02:37 <cathy__> #topic use case status
17:03:20 <doonhammer> hi
17:03:50 <cathy__> pcarver: have you got a chance to post the required features?
17:04:53 <pcarver> cathy__: I haven't been able to get any usable input from our users. I've been asking, but not really getting any response.
17:05:12 <pcarver> I think folks are just too busy to get anything together for me
17:06:09 <cathy__> pcarver: OK, it will be great to get those from your users since you are closer to the users than most of us
17:06:43 <s3wong> hello
17:06:49 <cathy__> pcarver: when do you think you can get those? just give us an idea.
17:07:10 <cathy__> igordcard: fsunaval How are your use cases going?
17:07:37 <fsunaval> cathy__: I will do it by end of day today.
17:07:49 <cathy__> fsunaval: great, thanks!
17:07:54 <scsnow> hi
17:07:57 <pcarver> cathy__: I really don't have anything other than just saying what features currently exist in Contrail. I've solicited input from a selection of people, but if nobody gives me anything I can't provide anything.
17:08:39 <cathy__> igordcard: how is your use case going?
17:08:45 <cathy__> pcarver: OK
17:09:53 <cathy__> igordcard: are you still there?
17:10:07 <cathy__> #topic FC priority status
17:10:26 <cathy__> mohankumar_: how is it going?
17:10:35 <mohankumar_> catht__ :  ovs agent code  yet to add
17:10:52 <cathy__> mohankumar_: ok, thanks
17:10:57 <scsnow> I'll take care about ovs part
17:11:22 <cathy__> scsnow: Good, thanks!
17:11:31 <cathy__> #topic Move the Path ID generation
17:12:25 <cathy__> I got email that georgewang and igordcard are working on this.
17:12:45 <cathy__> #topic OVN driver for networking-sfc spec and implementation
17:13:15 <cathy__> LouisF: how is the OVN driver spec going?
17:13:51 <doonhammer> cathy: Implementation I have most of the code ready to submit as patches - I have create done, need to add delete/update
17:13:53 <LouisF> cathy__: written, farhad and john are reviewing
17:14:16 <LouisF> i will post today
17:14:19 <regXboi> is there a link to be shared with the minutes for later readers?
17:14:29 <cathy__> doonhammer: LouisF great progress, thanks!
17:14:44 <doonhammer> cathy: will submit wip patches to networking-sfc/networking-ovn/ovs/ovn
17:15:21 <regXboi> doonhammer: I've been following the email, but got pulled into a bunch of 4.6 kernel stuff this past week
17:15:29 <doonhammer> Louis: I will try and get comments today - stuck in all day meetings for next few days though
17:15:38 <cathy__> regXboi: are you talking about this meeting minute or the review minutes for the spec?
17:15:46 <doonhammer> regXboi: Juno has been a great help
17:16:00 <regXboi> doonhammer: good to hear that
17:16:09 <regXboi> cathy__: I'm talking about these meeting minutes
17:16:42 <cathy__> Here it is #link http://eavesdrop.openstack.org/meetings/service_chaining/2016/
17:16:56 <cathy__> #link http://eavesdrop.openstack.org/meetings/service_chaining/2015/
17:17:06 <regXboi> thanks, but I mean a link to the spec LouisF was talking about
17:17:20 <LouisF> regXboi: will post today
17:17:27 <regXboi> LouisF: ack
17:18:16 <cathy__> #topic add PPG parameter to specify insert-mode behavior for all PPs in a PPG
17:18:48 <cathy__> scsnow: how is it going?
17:19:56 <scsnow> cathy__, you promised to provide more details in bug report
17:20:19 <cathy__> scsnow: Oh, sorry I will do it today.
17:20:45 <scsnow> from what I see now I cannot clearly understand what to do in API part
17:21:11 <cathy__> #action cathy provides more detail in the bug report https://bugs.launchpad.net/networking-sfc/+bug/1588463
17:21:11 <openstack> Launchpad bug 1588463 in networking-sfc "Add port-pair-group parameter" [Undecided,New] - Assigned to Louis Fourie (lfourie)
17:21:50 <cathy__> #topic Add "NSH" support----'correlation-nsh' in the chain-parameters
17:22:36 <cathy__> I think we can start experimenting with this
17:22:58 <scsnow> is someone trying to use ovs + nsh patches w/o dpdk?
17:23:22 <cathy__> and merge when there is a reference implementation in a open source such as OVS
17:23:58 <s3wong> cathy__: we also get this by default when ODL driver comes in
17:24:20 <cathy__> As far as I know, the patch for VXLAN-gpe+NSH has been rejected in OVS
17:24:50 <cathy__> s3wong: ODL driver also uses OVS, right?
17:25:08 <s3wong> cathy__: a patched version --- actually, so does ONOS
17:25:17 <doonhammer> cathy: I saw a new patch set sent to ovs this week for nsh
17:25:28 <s3wong> cathy__: so while they don't work with our reference, they could work with other drivers
17:25:30 <mohankumar_> scsnow , i have working ovs + NSH  , i tried  with ONOS driver its working fine
17:25:33 <doonhammer> no idea of status
17:25:58 <igordcard> scsnow: without dpdk, me
17:26:35 <igordcard> scsnow: but hadn't a chance to progress much this week
17:26:46 <s3wong> doonhammer: I saw it also, but Jesse Gross doesn't seem very receptive of the patch (from Yi form Intel)
17:26:59 <igordcard> doonhammer: hmm, I'll try that one
17:27:02 <scsnow> ok, I have some issues with vxlan tunnels between nodes when using patched ovs. I'll continue my digging.
17:28:28 <scsnow> For those who is going to try ovs+nsh without SDN controllers, don't forget to set OVS_DATAPATH_TYPE=netdev in local.conf because with these patches OVS doesn't work with kernel dataplane
17:28:36 <cathy__> I see that the NSH patch is VXLAN-gpe+nsh, not VXLAN+NSH.
17:29:21 <cathy__> But OpenStack only supports VXLAN, not VXLAN-gpe
17:30:11 <scsnow> gpe is a kind of vxlan extension?
17:30:19 <s3wong> cathy__: I think this is just NSH:   http://openvswitch.org/pipermail/dev/2016-June/072209.html
17:30:38 <cathy__> scsnow: kind of, but it is not backward compatible with VXLAN
17:31:09 <scsnow> cathy__, probably that's the reason why I have problems with vxlan tunnels on pure neutron
17:31:29 <cathy__> scsnow: most probably
17:31:43 <cathy__> s3wong: the patch shows it is VXLAN-gpe
17:31:52 <scsnow> cathy__, do you know what should be changed in neutron to support vxlan-gpe?
17:32:16 <cathy__> scsnow: add VXLAN-gpe tunnel support to Neutron ML2
17:32:26 <scsnow> cathy__, ok :)
17:32:30 <cathy__> scsnow: needs Neutron team's approval
17:33:09 <s3wong> cathy__: ? This is the VxLAN-gpe patch:  http://openvswitch.org/pipermail/dev/2016-June/072187.html
17:33:19 <s3wong> cathy__: same person, different patch...
17:33:30 <cathy__> It seems quite some way to get NSH encap datapath officially supported in OpenStack
17:33:54 <cathy__> s3wong: both patches are VXLAN-gpe
17:34:18 <s3wong> cathy__: although the vport-vxlan.c change has reference to VXLAN_F_GPE
17:34:47 <cathy__> That is why it is better to have official NSH patch support, otherwise it could keep changing and there is no quality guarantee
17:34:48 <s3wong> cathy__: right
17:34:48 <scsnow> s3wong, so vxlan-gpe requires latest linux kernel, right?
17:35:14 <cathy__> scsnow: yes
17:35:32 <scsnow> cathy__, can you confirm that 4.6.0 contains necessary changes?
17:35:38 <igordcard> see section 5 at https://www.ietf.org/archive/id/draft-quinn-vxlan-gpe-04.txt
17:35:44 <s3wong> scsnow: I actually am not on net-next mailing list, so I don't know if anyone has patched vxlan-gpe into kernel net
17:36:22 <cathy__> I have given suggestion to folks (Yi Yang) working in OVS to push a patch of "VXLAN+ether+NSH+original payload" which is IETF compliant too and easier to get it approved in OVS
17:36:40 <igordcard> actually, this one is the one up to date https://www.ietf.org/id/draft-ietf-nvo3-vxlan-gpe-02.txt
17:37:31 <cathy__> scsnow: I can not remember the version. Shoot an email to Yiyang for the version. But OVS has not incorporated this NSH VXLAN-gpe patch yet
17:38:58 <cathy__> igordcard: are you working with Yi on the NSH patch?
17:39:22 <igordcard> cathy__: no
17:39:45 <igordcard> cathy__: but as I develop the PoC I'll get in touch with him
17:40:25 <igordcard> cathy__: but as I develop the PoC I'll get in touch with himI agree that starting with the eth+nsh would be simpler for now
17:41:03 <cathy__> We are depending on the NSH patch and hopefully it can be approved in OVS and merged into an OVS version so that when networking-sfc is released, the package can bundle networking-sfc with an OVS version with NSH support
17:41:44 <cathy__> igordcard: yes, let us know how the eth+NSH goes.
17:42:30 <cathy__> let's go to next topic
17:42:40 <cathy__> #Functional Test script
17:43:53 <cathy__> There is a patch for review
17:44:09 <LouisF> cathy__: it is being reviewed
17:44:43 <LouisF> https://review.openstack.org/#/c/324135/
17:45:02 <cathy__> LouisF: thanks for the link.
17:46:47 <cathy__> So we are waiting for Infra team to approve it. Seems Andreas has a question. I will take a look and ping the infra team
17:47:29 <LouisF> cathy__: also https://review.openstack.org/#/c/321870/
17:48:20 <LouisF> once the gate patch is in the functional test can be merged
17:48:36 <cathy__> LouisF: yes, thanks.
17:49:13 <cathy__> #topic Dynamic service chain update without service interruption
17:51:47 <doonhammer> cathy: is ISSU mainly a function of the switch?
17:51:51 <cathy__> anyone would like to work on this?
17:52:14 <cathy__> doonhammer: I don't think so. That is not a small effort:-)
17:52:43 <doonhammer> cathy: there is a set of load-balancing patches coming to ovn - perhaps we can take a look at them to see it they can be leveraged?
17:52:53 <cathy__> ISSU involves version negotiation and message format transformation between different versions
17:53:41 <doonhammer> cathyL yes you are right
17:53:46 <cathy__> and a good defined process of doing in service upgrade.
17:54:31 <LouisF> this depends on the back end infrastructure
17:54:35 <cathy__> doonhammer: do you have a link to the load-balancing patch to OVN.
17:54:37 <cathy__> ?
17:55:47 <doonhammer> cathy: was in the ovn irc and shettyg says he is going to submit them again next week
17:56:10 <cathy__> LouisF: yes, ISSU needs a generic ISSU Infra and different "apps" can hook up to that Infra to do the version negotiation, message transformation etc.
17:56:28 <LouisF> uninterupted service chain update depends on the back end infrastructure
17:56:45 <cathy__> doonhammer: cool, could you give us a heads-up when the patch is submitted?
17:58:14 <cathy__> We are running out of time. If you have any topic you would like to discuss, please post it on the networking-sfc meeting topic wiki page
17:58:36 <cathy__> bye for now
17:58:40 <LouisF> doonhammer: guru shetty added a patch
17:58:50 <mohankumar_> cathy__ :ok ,  may be about our mitaka  release plan ..
17:58:51 <mohankumar_> bye
17:59:01 <cathy__> mohankumar_: ok
17:59:01 <LouisF> bye
17:59:02 <scsnow> bye
17:59:17 <cathy__> #endmeeting