17:00:52 <LouisF> #startmeeting service_chaining
17:00:53 <openstack> Meeting started Thu Aug 11 17:00:52 2016 UTC and is due to finish in 60 minutes.  The chair is LouisF. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:55 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:57 <openstack> The meeting name has been set to 'service_chaining'
17:01:02 <pcarver> hi
17:01:07 <LouisF> hi all
17:01:12 <LouisF> pcarver: hi
17:01:20 <fsunaval> hi
17:01:27 <bcafarel> hi
17:01:28 <LouisF> fsunaval: hi
17:01:33 <LouisF> bcafarel: hi
17:03:02 <LouisF> agenda for today https://wiki.openstack.org/wiki/Meetings/ServiceFunctionChainingMeeting#Agenda_for_the_Networking-SFC_Meeting_.288.2F11.2F2016.29
17:03:17 <LouisF> any items to add?
17:04:19 <pcarver> I'd like to talk about the API documentatino
17:04:40 <LouisF> pcarver: ok go ahead
17:04:53 <pcarver> I'm trying to figure out if there's anything I can do to help.
17:05:34 <LouisF> pcarver: it is merged into the api_ref in the networking-sfc repo
17:05:36 <pcarver> I tried to enable publishing of of the api-ref changes that you did, but it seems that it all needs to move to neutron-lib
17:06:03 <pcarver> I mean publishing out to a rendered web page
17:06:03 <LouisF> however, it will move to neutron-lib
17:06:59 <s3wong> hello
17:07:08 <LouisF> pcarver: i think the armando is working on the docs files for neutron-lib
17:07:13 <LouisF> s3wong: hi
17:07:52 <LouisF> pcarver: can you check with him on when/where he wants the networking-sfc api ref to land
17:07:53 <pcarver> it looks like there's already a lot in neutron-lib/api-ref but I'm not clear on what's keeping networking-sfc out.
17:08:14 <pcarver> I'm trying to understand if there's anything to do other than sit and wait
17:08:38 <LouisF> pcarver: armando to give go ahead on when/where
17:08:50 <LouisF> pcarver: can you check with him on that?
17:09:21 <pcarver> I was exchanging comments with him on a Gerrit review. I'll see if he says anything further.
17:09:43 <LouisF> i would definitely like to see the networking-sfc api-ref moved to neutron-lib repo
17:10:14 <pcarver> I'd be happy to help move it, but I'm not sure if I'd be wasting my time in the attempt
17:10:33 <LouisF> pcarver: go ahead
17:11:11 <pcarver> I'll try starting by adding the SFC .inc files to this Etherpad with my name next to them https://etherpad.openstack.org/p/neutron-api-ref-sprint
17:11:39 <LouisF> #action pcarver to initiate api-ref move to neutron-lib
17:12:20 <pcarver> oh, one other thing not on the agenda. I'm trying to fix the failing gate job
17:12:39 <pcarver> https://review.openstack.org/#/c/354006/
17:13:12 <pcarver> That change causes the job to succeed but there are a lot of "Could not load" messages in the log and I'm not sure if they should be there.
17:14:01 <pcarver> I'm going to do some digging and see what I can find out, but if the messages are ok then it should fix gate-functional-dsvm-networking-sfc-nv
17:14:04 <LouisF> pcarver: yes thats related to the functional tests
17:14:21 <LouisF> pcarver: thanks
17:15:27 <LouisF> s3wong: what is the status of the tacker/networking-sfc driver?
17:16:59 <s3wong> LouisF: some comments to address --- and sridhar_ram suggested that I should have the driver as a MixIn with Tacker's openstack_driver
17:17:11 <s3wong> LouisF: that became available since the multi-VIM support
17:17:34 <s3wong> LouisF: that would hide the info on which OpenStack instance's Neutron the driver should talk to
17:17:49 <s3wong> LouisF: I will work on that over the weekend (and perhaps longer)
17:18:05 <LouisF> s3wong: thanks for the update
17:18:30 <LouisF> bcafarel: you are working on https://bugs.launchpad.net/networking-sfc/+bug/1593693
17:18:30 <openstack> Launchpad bug 1593693 in networking-sfc "SFC neutron-openvswitch-agent has same name as vanilla agent" [Undecided,In progress] - Assigned to Ihar Hrachyshka (ihar-hrachyshka)
17:19:15 <LouisF> and https://bugs.launchpad.net/networking-sfc/+bug/1586024
17:19:15 <openstack> Launchpad bug 1586024 in networking-sfc "Switch OVS agent to l2 agent extensions" [Medium,In progress] - Assigned to Bernard Cafarelli (bcafarel)
17:19:22 <bcafarel> yes the later will fix the former at the same time
17:19:58 <LouisF> bcafarel: you are working with farhad sunavala on this?
17:20:43 <bcafarel> LouisF: we will, so far we mostly checked we were on the same page on the idea
17:20:57 <fsunaval> LouisF:  I have email bcafarel my diffs for the ovs agent extension.
17:21:21 <LouisF> bcafarel fsunaval thanks
17:21:56 <bcafarel> these allow to use the wrapped bridge objects in an OVS agent extension (with another cookie set)
17:22:24 <LouisF> bcafarel: ok
17:23:26 <bcafarel> converting OVSNeutronAgent to a full L2 agent extension will be more work, but it has othe advantages, including no need for a specific binary anymore :)
17:23:37 <bcafarel> (and fixing the concern for binary distributions)
17:24:50 <LouisF> bcafarel: ok thanks
17:24:57 <bcafarel> a skeleton for this idea is at https://review.openstack.org/#/c/351789/
17:26:09 <LouisF> bcafarel: great
17:26:53 <LouisF> #topic move to openstack client
17:27:11 <LouisF> looks like mohan is not on
17:27:16 <LouisF> moving on
17:28:13 <LouisF> #topic weighted SFs in PPG
17:28:16 <LouisF> https://review.openstack.org/#/c/348136/4
17:28:32 <LouisF> i see comments on splitting this patch
17:29:12 <LouisF> from paul and pavel
17:29:33 <LouisF> i will contact xiaodong on that
17:29:44 <pcarver> When I reviewed it I had a hard time telling whether everything in it really related to what was stated in the commit message
17:31:01 <LouisF> pcarver: will post a new patch
17:31:34 <LouisF> #topic tempest tests
17:31:37 <LouisF> https://review.openstack.org/#/c/351486
17:32:04 <LouisF> this can be approved and merged
17:32:55 <LouisF> #topic functional tests
17:33:02 <LouisF> https://review.openstack.org/#/c/351484
17:33:35 <LouisF> there is jenkins failure on this
17:33:42 <LouisF> i will follow up
17:34:59 <LouisF> #topic symmetric chains
17:35:03 <LouisF> https://review.openstack.org/#/c/308274/
17:36:02 <LouisF> scsnow: you posted a new patch
17:37:06 <LouisF> you mentioned that the ovs driver work was to be done
17:38:08 <LouisF> we need to have that complete before moving on with this patch
17:38:39 <s3wong> Agreed, this patch lacks reference implementation on an addition to API/data-model
17:39:01 <LouisF> need to have a design for the symmetrical reverse path
17:39:56 <LouisF> with PPGs in reverse order and classification from logical destination port
17:40:37 <LouisF> moving on
17:40:49 <LouisF> #topic bug scrub
17:41:09 <LouisF> we went though all the bugs last week
17:43:12 <LouisF> all of them are wip with associated patch to fix
17:43:31 <LouisF> any comments on these?
17:44:17 <LouisF> ok any other topics to discuss?
17:44:53 <s3wong> meeting finishing early!!!
17:45:03 <LouisF> ok thanks all
17:45:05 <bcafarel> :)
17:45:11 <LouisF> bye
17:45:11 <fsunaval_> bye
17:45:21 <s3wong> bye
17:45:23 <bcafarel> bye
17:45:26 <LouisF> #endmeeting