17:00:16 <cathy_> #startmeeting service_chaining
17:00:17 <openstack> Meeting started Thu Aug 25 17:00:16 2016 UTC and is due to finish in 60 minutes.  The chair is cathy_. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:20 <openstack> The meeting name has been set to 'service_chaining'
17:00:26 <LouisF_> hi
17:00:28 <mohankumar> hi
17:00:34 <doonhammer> Hi Louis
17:00:36 <cathy_> hi LouisF_ mohankumar doonhammer
17:00:38 <bcafarel> hi
17:00:43 <cathy_> hi bcafarel
17:00:50 <pcarver> hi. I'm here but double booked in an unrelated face to face meeting
17:01:01 <cathy_> hi pcarver
17:01:44 <cathy_> pcarver: then you can ignore that unrelated meeting and concentrate on this very related one:-)
17:01:52 <cathy_> hi fsunaval
17:02:17 <LouisF_> hi doonhammer
17:02:23 <fsunaval> hi cathy_
17:02:25 <cathy_> hi mohankumar
17:02:37 <cathy_> OK, lets' start
17:02:54 <cathy_> #topic mitaka release
17:03:33 <cathy_> We have got most needed patches reviewed and merged. Now there are a few left. Here are the links
17:03:54 <cathy_> #link https://review.openstack.org/#/c/356070/
17:04:12 <cathy_> #link https://review.openstack.org/#/c/360306/
17:05:05 <pcarver> I saw that Louis added test cases to 356070. I haven't reviewed them yet, but assuming they're good I'll be fine with it.
17:05:56 <cathy_> pcarver: yes.
17:06:28 <LouisF_> pcarver: added test cases
17:06:42 <cathy_> pcarver: mohankumar and everyone, could you please review these two changes and give your +1 or +2 if no issue?
17:06:53 <mohankumar> cathy_ : yes , sure
17:07:10 <pcarver> cathy_: I'm booked solid all day today but will review tomorrow morning
17:07:23 <cathy_> mohankumar: thanks
17:07:53 <cathy_> pcarver: OK, I will wait for your review by tomorrow. thanks.
17:10:18 <cathy_> we also need to revert the change of project ID to tenant ID to be compatible for the mitaka release, right?
17:11:28 <LouisF_> cathy_: correct
17:11:56 <cathy_> LouisF_: could you help find and post that patch which needs to be reverted?
17:13:34 <LouisF_> cathy_: ok is related to change from HasTenant to HasProject
17:14:25 <cathy_> LouisF_: yes. could you post a patch to revert the change?
17:14:27 <LouisF_> i think it is in 3 files
17:14:55 <LouisF_> let me find the patch that made the change
17:15:24 <cathy_> LouisF_: ok
17:15:27 <cathy_> thanks
17:15:33 <georgewang> hi
17:15:52 <cathy_> hi georgewang
17:16:09 <georgewang> https://review.openstack.org/#/c/360306/
17:16:26 <cathy_> could you explain a little bit on the patch you posted https://review.openstack.org/#/c/360306/
17:17:14 <georgewang> it reverts the change previously merged
17:17:38 <georgewang> the reason that I did not notice there were another change do the same thing
17:18:05 <georgewang> and when I do the split, the base repo do not include that change
17:18:47 <georgewang> so when I do the split, I accidentally split an unnecessary change
17:19:08 <georgewang> https://review.openstack.org/#/c/355304/
17:19:46 <LouisF_> this is the patch that changed tenant -> project https://review.openstack.org/#/c/342361/
17:20:49 <cathy_> georgewang: yes, I see that this new patch reverts the previous change. But we need the previous change for fixing the OVS agent restart problem. You said there is already another change doing the same thing. Could you post that "another change" link?
17:20:59 <cathy_> LouisF_: thanks
17:21:37 <cathy_> LouisF_: could you revert this change https://review.openstack.org/#/c/342361/?
17:22:06 <cathy_> or someone else can help with this?
17:22:21 <cathy_> hi s3wong
17:22:28 <s3wong> hello, sorry --- late
17:22:56 <georgewang_> hi
17:22:56 <bcafarel> https://review.openstack.org/#/c/348574/ is the original ovs agent restart fix?
17:23:16 <LouisF_> i have not done a revert before - any guidance?
17:23:38 <fsunaval> cathy_: I can take care of that...
17:23:47 <cathy_> fsunaval: thanks!
17:24:50 <cathy_> s3wong: any idea how to quickly revert a merged patch? Or we need to upload a new patch doing the reverse?
17:25:23 <georgewang_> the revert is a new change
17:25:48 <georgewang_> just follow the same procedure to approve a new change
17:25:49 <s3wong> cathy_: do that?  http://stackoverflow.com/questions/588414/rolling-back-a-remote-git-repository
17:25:57 <csun> I think you can try git revert HEAD
17:26:25 <s3wong> cathy_: I never tried it --- but presumably you can push that reverted patchset and the main networking-sfc repo will take on the new history
17:26:48 <cathy_> fsunaval: up to you, whichever the most simple and reliable way
17:26:59 <mohankumar> cathy_  , s3wong : it's for local git system i guess
17:27:12 <mohankumar> we should raise new change
17:27:17 <bcafarel> with gerrit it's mostly git revert commit_sha1 and run a new git review on that
17:27:23 <s3wong> mohankumar: the link I posted was for remote
17:27:49 <s3wong> mohankumar: although TBH I don't know how it works with OpenStack's gerrit, which inherently heavily uses rebase
17:28:04 <mohankumar> s3wong :  yes ..
17:28:42 <cathy_> If none of us has tried those mechanism before, then I will suggest that we upload a new patch doing the reversed code, which is faster and safer.
17:28:58 <mohankumar> s3wong: i too not have srong comment on this
17:28:58 <s3wong> cathy_: +1
17:29:10 <cathy_> let fsunaval do this.
17:29:18 <mohankumar> cathy_ : agree
17:30:06 <cathy_> georgewang_: could you answer bcafarel 's question? https://review.openstack.org/#/c/348574/ is the original ovs agent restart fix?
17:31:26 <fsunaval> cathy_: I assume we are talking about https://review.openstack.org/#/c/342361/
17:31:29 <fsunaval> yes, no problem.
17:32:03 <cathy_> fsunaval: yes
17:33:20 <georgewang_> yes
17:33:27 <georgewang_> https://review.openstack.org/#/c/355304/ is the other change
17:34:36 <cathy_> So after we get these two patches reviewed and merged and fsunaval gets the other patch reversed. Let's not approve any code merge until mitaka is released. sounds good?
17:35:11 <s3wong> cathy_: +1
17:35:20 <LouisF_> cathy_: +1
17:35:28 <mohankumar> cathy_ +1
17:35:43 <pcarver> cathy_ sounds good for functional code, but if I get time to troubleshoot the failing gate test, is it ok to fix that?
17:35:50 <pcarver> https://review.openstack.org/#/c/354006/
17:36:11 <pcarver> I haven't had time to dig through the error messages, but was hoping to do that tomorrow
17:36:25 <cathy_> After the patches are merged, each of us can start getting networking-sfc code from latest and getting Neutron code from table/mitaka, then start testing.
17:37:57 <cathy_> pcarver: sure you can fix that. But that will not impact the functionality.
17:38:35 <cathy_> I mean impact the released functionality. AFAIK, it is the tempest test scripts issue
17:38:54 <georgewang_> https://review.openstack.org/#/c/358864/ is to fix functional tests skipping issue
17:39:15 <georgewang_> functional tests and tempest tests is merely the test coverage
17:39:49 <georgewang_> If you cut a mitaka release, without this two change, it does not affect any features
17:40:03 <pcarver> georgewang_: I think that's a different issue from the missing test_hook script, right?
17:40:48 <pcarver> post_test_hook.sh is what I'm adding, but after I added it there are still error messages in one of the logs
17:40:58 <cathy_> pcarver: do you mean the issue that https://review.openstack.org/#/c/354006/ tries to fix?
17:41:15 <pcarver> cathy_: yes
17:41:21 <cathy_> georgewang_: could you take a look at https://review.openstack.org/#/c/354006/?
17:41:26 <pcarver> I think it's separate from 358864
17:41:29 <georgewang_> I think the missing hook gate file issue have already been resolved
17:43:02 <pcarver> georgewang_: resolved as in a fix proposed? Or a fix merged. I think we're still seeing failures
17:44:00 <pcarver> non-voting, but still failure
17:45:26 <georgewang_> for functional tests, it is another reason
17:45:40 <georgewang_> the skipping issue is I did not set OS_TEST_SUDO=1 in tox.ini
17:46:01 <cathy_> #action fsunaval upload a patch reverting https://review.openstack.org/#/c/342361/ to make codes compatible with stable/mitaka
17:47:07 <cathy_> #action pcarver finish review of https://review.openstack.org/#/c/356070/ by 8/26 Friday morning.
17:48:38 <cathy_> georgewang_: so you will fix all the failures in the functional and tempest tests, right?
17:48:55 <georgewang_> yes
17:49:03 <cathy_> georgewang_: cool. Thanks.
17:49:14 <georgewang_> but maybe not that quick to catch up mitaka release
17:49:26 <cathy_> georgewang_: it is OK
17:49:51 <cathy_> georgewang_: since they are the gating script issues, it is OK
17:50:37 <cathy_> I plan to get needed patched merged by Tomorrow and then each of us can start testing.
17:51:23 <cathy_> Let's target at finishing all the tests by next Tuesday. Then I will request the release. We really can not postpone anymore since Newton cycle already started
17:52:06 <cathy_> That's all from my side. Any other topic you would like to discuss? We only have 8 min left
17:53:26 <cathy_> OK, we can end the meeting early today
17:53:35 <cathy_> bye everyone
17:53:51 <bcafarel> bye
17:53:57 <LouisF_> bye
17:53:58 <mohankumar> bye
17:54:02 <fsunaval> ...bye
17:54:12 <cathy_> #endmeeting