05:03:13 <yamahata> #startmeeting servicevm-device-manager
05:03:14 <openstack> Meeting started Tue Jul  1 05:03:13 2014 UTC and is due to finish in 60 minutes.  The chair is yamahata. Information about MeetBot at http://wiki.debian.org/MeetBot.
05:03:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
05:03:17 <openstack> The meeting name has been set to 'servicevm_device_manager'
05:03:33 <yamahata> Is bob here?
05:03:53 <yamahata> Let's give him a minute
05:03:57 <s3wong> yamahata: doesn't look like he is online
05:04:37 <yamahata> Oops.
05:04:53 <yamahata> This week  natarajk is also absent.
05:05:11 <yamahata> He'll catch up with the log
05:05:56 <yamahata> Okay let's start anyway.
05:06:02 <yamahata> #topic Announcement
05:06:21 <yamahata> The starckforge repo for servicevm has been created.
05:06:40 <yamahata> Thus gerrit review system can be used for our review.
05:07:04 <yamahata> #link http://git.openstack.org/cgit/stackforge/tacker/ tacker repo
05:07:17 <yamahata> #link http://git.openstack.org/cgit/stackforge/tacker-specs/ tacker-specs repo
05:07:33 <yamahata> #link http://git.openstack.org/cgit/stackforge/python-tackerclient/ python-tackerclient repo
05:08:46 <yamahata> So the group in gerrit system is also created. Please let me know privately your account name/email address to add tacker-core tacker-specs-core
05:09:08 <s3wong> yamahata: OK
05:09:16 <yamahata> #action candidate for core please let me know privately your account/mail address of gerrit.
05:09:28 <yamahata> #action yamahata add core members to gerrit system
05:10:05 <yamahata> Now I've created a sort of working tacker server/client in github.
05:10:17 <s3wong> yamahata: I think bobmel could be Bob
05:10:30 <yamahata> #action yamahata push the current code to review system.
05:10:43 <yamahata> oh.
05:10:45 <bobmel> Hi all. This is Bob.
05:10:53 <yamahata> bobmel: Hi. glad to see you.
05:11:05 <s3wong> bobmel: how many handles do you have :-) ?
05:11:31 <bobmel> s3wong: too many... :-)
05:12:20 <yamahata> bobmel: could you please let me know privately your account/email address of the gerrit system later.
05:12:42 <bobmel> yamahata: Sure
05:12:58 <yamahata> The a sort of working code is based on Neutron. So the it includes "uninteresting" code.
05:13:06 <yamahata> I think we can merge those patches at first.
05:13:17 <yamahata> For example deleting unnecessary Neutron specific files.
05:13:24 <yamahata> renaming neutron -> tacker
05:14:04 <yamahata> After merging tedious patches,  we can start actual api discussion and patch review.
05:14:41 <yamahata> #link https://review.openstack.org/#/c/103724/   API review patch
05:15:01 <s3wong> yamahata: bobmel: have you guys thought about merging your pieces (serviceVM lifecycle mgmt / mgmt interface & device manager) together? Is that one of the goals?
05:16:52 <yamahata> s3wong:  the current goal is to reach consensus with API, then consolidate the existing three or four implementations.
05:17:16 <s3wong> yamahata: OK
05:17:25 <bobmel> s3wong, yamahata: Yes that makes sense.
05:18:25 <yamahata> I think bobmem and I have close idea for API. So minor adjustment would suffice.
05:19:01 <yamahata> But I had a looked at DNRM document, their api is a different. So we needs discussion.
05:19:30 <yamahata> Unfortunately today we don't have Karthik.
05:19:39 <s3wong> the interceptor component probably won't have too many fans in Neutron community
05:20:13 <yamahata> s3wong: agree.
05:20:42 <yamahata> DNRM server has the feature of pooling VM.
05:21:06 <yamahata> I'm not sure where pooling vm live.
05:21:23 <yamahata> where the feature of pooling vm should live.
05:22:36 <yamahata> we can continue concrete discussion with gerrit.
05:23:03 <s3wong> about API? Or the DNRM thing?
05:23:04 <yamahata> #topic incubation process
05:23:09 <yamahata> #undo
05:23:09 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0x1cf4cd0>
05:23:42 <yamahata> s3wong: both. I think DNRM guys want to join the API discussion.
05:23:54 <s3wong> OK
05:24:03 <yamahata> Probably API needs modification based on their input
05:24:40 <yamahata> #topic servicevm spec/code review
05:24:51 <s3wong> yamahata: we do have to evaluate as a community which pieces, if any. of DNRM would make sense to integrate
05:25:06 <s3wong> (go on to the next topic, please. No need to undo :-) )
05:25:15 <yamahata> s3wong: Agree
05:25:38 <yamahata> I need to have a closer look at their code.
05:26:25 <s3wong> yamahata: +1
05:26:28 <yamahata> anything else with spec/code review?
05:26:45 <yamahata> #action everyone have a closer look at DNRM code
05:26:50 <s3wong> bobmel is now bmelande :-)
05:26:58 <yamahata> #action yamahata have a closer look at DNRM core more.
05:27:51 <yamahata> Last week One of my action item is to create l3 plugin.
05:28:15 <yamahata> I haven't done it yet. After pushing the tacker code for review, I'll create the blueprint.
05:28:32 <yamahata> #action yamahata create a blueprint for reference l3-plugin with servicevm
05:29:28 <yamahata> #topic Open Discussion
05:29:52 <yamahata> Okay do we have anything to discuss?
05:30:18 <s3wong> all good for me
05:30:35 <yamahata> cool.
05:30:54 <yamahata> It seems one hour time slot is too long.
05:31:04 <yamahata> How about 30min slots from the next time?
05:31:24 <s3wong> yamahata: OK, either that or biweekly
05:32:03 <yamahata> s3wong: Surely biweek is also an option.
05:32:11 <bmelande> yamahata, s3wong: I think I prefer weekly but potentially make it shorter.
05:32:35 <s3wong> bmelande: OK. Let's go with yamahata 's original suggestion of 30 mins then
05:32:57 <yamahata> #agreed 30min weekly meeting
05:33:15 <bmelande> Regarding API: Some notifications from device manager to its "customers" could be useful
05:34:10 <bmelande> For example: to let a service plugin know that a VM is discovered to be "dead"
05:34:13 <yamahata> bmelande: interesting. Could you be more specific? Probably in gerrit review part.
05:34:34 <bmelande> Yes I'll comment to document.
05:34:35 <s3wong> bmelande: exception handling?
05:35:49 <bmelande> s3wong: Well possibly it could be done like that. Not sure.
05:36:43 <s3wong> bmelande: cool, let's comment on it on gerrit review (API)
05:37:21 <bmelande> In our impl. the device manager does some basic checks of VM health. Ok, I'll make a comment there.
05:37:57 <yamahata> any other issues?
05:38:36 <s3wong> no, will review API doc
05:38:47 <yamahata> thank you. see you next week
05:38:54 <s3wong> thanks
05:38:54 <yamahata> #endmeeting