05:02:01 <yamahata> #startmeeting servicevm-device-manager
05:02:02 <openstack> Meeting started Tue Sep 16 05:02:01 2014 UTC and is due to finish in 60 minutes.  The chair is yamahata. Information about MeetBot at http://wiki.debian.org/MeetBot.
05:02:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
05:02:05 <openstack> The meeting name has been set to 'servicevm_device_manager'
05:02:13 <yamahata> #topic Announcement
05:02:46 <yamahata> Now neutron has feature freeze for rc1
05:02:59 <yamahata> the planning for the next summit is going on
05:03:13 <yamahata> #link https://wiki.openstack.org/wiki/Summit/Planning
05:03:27 <yamahata> #link https://etherpad.openstack.org/p/kilo-neutron-summit-topics
05:03:39 <yamahata> #link http://lists.openstack.org/pipermail/openstack-dev/2014-September/045844.html
05:04:13 <yamahata> regarding to reference implementation of routervm, I'm still working on it.
05:04:18 <yamahata> Sorry for slow progress.
05:04:37 <yamahata> Do you have any announcement?
05:05:05 <bmelande> That summit topic list is really long
05:05:09 <s3wong> Looking at the topics in etherpad, it seems like again at most there will only be one or two features going into Kilo...
05:06:09 <yamahata> yeah...
05:06:26 <s3wong> most of the stuff is spilling over from Juno, or Icehouse, or Havana, or Grizzly...
05:06:30 <yamahata> do we want to push routervm and firewallvm to it?
05:06:31 <bmelande> s3wong: Yes, sadly neutron in a nutshell.
05:07:04 <s3wong> from the ML, the format will be different this time
05:07:14 <yamahata> anyway we can have ad-hoc meetings in paris.
05:07:18 <s3wong> there will be way less dedicated design sessions
05:07:26 <yamahata> #topic summit planning
05:07:37 <s3wong> pods, and Friday's "contributor meetings" will probably be it
05:09:47 <bmelande> yamahata: Yes, let's fit some meetings about service vm there.
05:09:58 <yamahata> s3wong: that's same to my understanding.
05:10:31 <yamahata> I had also a contact for similar goal.
05:10:36 <yamahata> #link https://blueprints.launchpad.net/neutron/+spec/tcs-fwaas-netconf-host-plugin
05:10:52 <yamahata> Their goal is firewall vm in a word.
05:11:10 <yamahata> One of their engineer will go to Paris, I heard.
05:11:51 <yamahata> bmelande: Sure, let's do so.
05:12:21 <s3wong> yamahata: bmelande: yes, I think we can put it in etherpad
05:12:26 <yamahata> bmelande: So far I haven't looked at firewall side yet. Do you have any requirement for firewall?
05:12:30 <s3wong> service vm, that is
05:13:13 <s3wong> but honestly given the slots, and the number of topics already on there, I am not too optimistic that it will make it --- likely we will try to grab a pod session
05:13:34 <s3wong> internally we should also discuss f2f in Paris what our goal is for Kilo
05:14:22 <yamahata> s3wong: +1, sounds like practical good plan
05:14:28 <yamahata> a pod session
05:14:33 <bmelande> s3wong: +1
05:15:03 <s3wong> yamahata: bmelande: well, first thing first, let's put the topic on etherpad :-)
05:15:18 <s3wong> maybe it will be selected
05:15:31 <yamahata> #action everyone put the topics on etherpad
05:15:35 <bmelande> yamahata: Sridar K in our team is working on fw on CSR. There are no new reqs wrt it.
05:17:24 <yamahata> bmelande: good. we can also discuss on those in paris. I'd like to understand it.
05:17:47 <s3wong> bmelande: yes, we should see if our framework can satisfy other services as well
05:17:58 <s3wong> bmelande: the more services using our framework, the better
05:19:18 <bmelande> yes, how to handle multi services in the same device is worth discussing and looking into.
05:19:19 <yamahata> #topic Open Discussion
05:19:33 <s3wong> bmelande: yes, absolutely
05:20:48 <yamahata> bmelande: yeah, you are ahead, so there are so many we can learn from you
05:21:09 <bmelande> Glad you have that illusion. :-)
05:21:45 <s3wong> bmelande: your code landed in Juno :-)
05:22:14 <s3wong> bmelande: hopefully we can factor it out as generic device mgmt framework for all service VMs
05:22:20 <bmelande> Yes, we were really, really lucky.
05:22:47 <yamahata> I hope refectoring patch would be easy to be accepted.
05:23:01 <bmelande> s3wong: but what got it was a stripped down version where took away a lot of things.
05:23:38 <s3wong> bmelande: still great --- this is normal procedure in OpenStack anyway :-)
05:24:02 <s3wong> yamahata: moving forward, what is our goal? Do you want tacker to eventually merge back to Neutron?
05:24:05 <yamahata> bmelande: start small and grow it. It's quite common practice.
05:24:35 <s3wong> if so, we may want to pay attention to Neutron incubator...
05:24:54 <yamahata> s3wong: I think merging back the project to neutron  is difficult, given recent situation.
05:25:17 <yamahata> I don't care if It's dependent project or in neutron.
05:25:27 <bmelande> yamahata: Yes I think so too.
05:25:35 <yamahata> It's a implementation detail.
05:25:51 <s3wong> yamahata: I actually agree. I am in the group-based policy (GBP) subteam - I guess everyone knows our frustration there...
05:25:52 <yamahata> The essential goal is to promote servicevm conecpt and implentation.
05:26:42 <yamahata> The implementation itself is not goal. Just a way.
05:26:54 <bmelande> For now probably most important is to keep tacker on Neutron radar so people knows about it and to make clear what people can excpect for kilo, then make sure to deliver that.
05:27:37 <s3wong> bmelande: +1
05:28:29 <s3wong> bmelande: yamahata is so upset that he quitted the meeting :-)
05:28:42 <bmelande> s3wong: :-)
05:28:57 <yamahata> Oops. wifi was unstable
05:28:59 <yamahata> sorry
05:29:01 <yamahata> #char s3wong bmelande
05:29:03 <yamahata> #chair s3wong bmelande
05:29:04 <openstack> Current chairs: bmelande s3wong yamahata
05:29:22 <s3wong> yamahata: it is OK, we only have one minute left anyway :-)
05:30:10 <yamahata> Did I miss something important?
05:30:15 <yamahata> Do we have any other items?
05:30:45 <s3wong> yamahata: no, you came back quickly, and didn't miss much
05:31:21 <yamahata> thanks, it's time up.
05:31:34 <yamahata> see you next week.
05:31:46 <s3wong> see you guys next week. Thanks!
05:31:48 <bmelande> Ok, let's put items on the ehterpatd
05:31:54 <bmelande> Bye!
05:31:56 <yamahata> bye
05:31:58 <s3wong> bmelande: yes
05:31:58 <yamahata> #endmeeting