05:02:10 <yamahata> #startmeeting servicevm-device-manager
05:02:11 <openstack> Meeting started Tue Oct 28 05:02:10 2014 UTC and is due to finish in 60 minutes.  The chair is yamahata. Information about MeetBot at http://wiki.debian.org/MeetBot.
05:02:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
05:02:15 <openstack> The meeting name has been set to 'servicevm_device_manager'
05:02:49 <yamahata> bob doesn't seem here...
05:02:52 <yamahata> anyway
05:02:59 <yamahata> #topic Announcement
05:03:17 <yamahata> #info neutron session schedule is announce
05:03:27 <yamahata> #link http://kilodesignsummit.sched.org/overview/type/neutron#.VE7A73WUd1y
05:03:42 <yamahata> There is a session for LT.
05:03:49 <yamahata> LT poll page is created
05:03:56 <s3wong> tacker will be discussed (hopefully) here: http://kilodesignsummit.sched.org/event/8a0b7c1d64883c08286e4446e163f1a6#.VE8jjJPF9j4
05:03:59 <yamahata> #link https://www.surveymonkey.com/s/RLTPBY6
05:04:19 <s3wong> #link http://kilodesignsummit.sched.org/event/8a0b7c1d64883c08286e4446e163f1a6#.VE8jjJPF9j4
05:04:28 <yamahata> s3wong: thanks for link.
05:04:57 <s3wong> how does tacker affect Neutron advanced services? and how will advanced services' inevitable spinning out affect tacker?
05:04:59 <yamahata> #link http://kilodesignsummit.sched.org/event/8a0b7c1d64883c08286e4446e163f1a6#.VE8jjJPF9j4 Advanced Services Spin Out servicevm project seems also subject to discuss
05:05:16 <s3wong> I think those are some discussion points we need to prepare before that session
05:05:27 <yamahata> s3wong: +1
05:05:57 <yamahata> Let's discuss at open discussion.
05:06:24 <s3wong> yamahata: sure
05:06:38 <yamahata> any other to annouce?
05:07:34 <yamahata> okay, let's move on
05:07:38 <yamahata> #topic Action Items from the last week
05:08:05 <yamahata> I created poll page for servicevm time slot poll.
05:08:15 <yamahata> and announce it on ML
05:08:37 <yamahata> The current best candidate seems Tue.
05:09:17 <yamahata> Given Advanced service spin out session is Thursday, November 6 � 11:50 - 12:30, the lunch after the session is also good candidate.
05:09:51 <yamahata> Maybe we can have more than one meeting.
05:10:23 <natarajk> thursday sounds better for me
05:10:49 <s3wong> yamahata: Tuesday @12:05pm I need to attend the Group-based-policy design session (as does several people who care about services)
05:11:22 <yamahata> Okay, I revised the page. Thursday Lunch time is best.
05:12:05 <yamahata> Let's schedule it on Thu 6 1:15 for now.
05:12:17 <yamahata> If it conflicts with NFV or something, rethink at that time.
05:12:49 <s3wong> yamahata: right after the advanced service spin-off session?
05:12:57 <yamahata> #info servicevm BoF on Thursday 6 1:15pm-
05:13:10 <s3wong> yamahata: trying to catch those that are interested in continuing the conversation? :-)
05:13:12 <yamahata> s3wong: Yes. So that we can catch other candidate hopefully
05:14:34 <yamahata> Do we want to have another BoF before the session?
05:15:39 <s3wong> yamahata: perhaps we want to do some cross-project stuff with NFV (Tuesday has a lot of cross-project workshop)
05:15:42 <s3wong> ?
05:16:06 <s3wong> yamahata: though at this point I haven't found anything on NFV actually having work on project (other than proposing stuff)
05:16:58 <s3wong> yamahata: another possibility is to work with Neutron advanced services folks on "cross-project" session to see how we can create a common framework
05:17:13 <yamahata> s3wong: sounds good idea.
05:17:42 <yamahata> At this point, I don't see which slot for cross project is NFV-related.
05:18:05 <yamahata> Probably we will recognize it there.
05:18:34 <yamahata> s3wong: I think at least VLAN trunking is driven as NFV requirement
05:19:37 <yamahata> we could arrange  gathering ad-hoc way in Paris as usual.
05:19:56 <s3wong> yamahata: definitely --- now closer into the summit, there was a lot of noise on the VLAN trunking piece
05:20:25 <s3wong> mestery has made it one of Neutron Kilo priorities to gather requirements from NFV working grop
05:20:29 <s3wong> group
05:21:02 <yamahata> we have 10min left. let's move on to discussion point
05:21:05 <yamahata> #topic Open Discussion
05:21:11 <Hareesh> yamahata: sorry a little late to this. have we agreed to a common time to meet in paris? what is the conclusion from the doodle?
05:21:46 <yamahata> Hareesh: For now it's planned on Thu 6 1:15
05:22:05 <s3wong> yamahata: for open discussion, I would advocate reading the Neutron meeting log from today: http://eavesdrop.openstack.org/meetings/networking/2014/networking.2014-10-27-21.01.log.html
05:22:06 <yamahata> After the session of Advanced Services Spin Out
05:22:11 <yamahata> http://kilodesignsummit.sched.org/event/8a0b7c1d64883c08286e4446e163f1a6#.VE8jxXWUd1x
05:22:20 <s3wong> some discussion on advanced services spinoff
05:22:35 <yamahata> servicevm stuff would be also discussed, so we can catch related people.
05:22:45 <Hareesh> yamahata: thanks
05:23:08 <yamahata> #action yamahata put meeting schedule at wiki and etherpad
05:23:17 <s3wong> Our good friend from LBaaS side, dougwig, also mentioned something about having common framework for service VM (which the LBaaS is working on their own VM mgmt framework in Octavia)
05:23:31 <yamahata> s3wong: cool.
05:23:36 <dougwig> my ears are burning.
05:24:03 * s3wong thinks dougwig is really in Hawaii instead of Central timezone
05:24:13 <yamahata> My current thinking is that to create new project and to have other project use it would be difficult.
05:24:45 <yamahata> As a first tiny step, small library based on the current CSR1kv will be created. and put it in Neutron.
05:25:01 <yamahata> In fact CSR1kv routervm code is already there.
05:25:18 <s3wong> yamahata: so the one item that everyone agrees on w.r.t. advanced service spinoff is that L3/routers is NOT service
05:25:26 <yamahata> So just cleanup/refactor it and move it common place
05:25:55 <s3wong> Neutron will at least maintain the responsibility of L2/L3 plumbing
05:26:10 <yamahata> s3wong: Does it mean l3 router will remain in Neutron?
05:26:29 <s3wong> yamahata: current discussion seems to point that way
05:26:41 <dougwig> i believe it will, along with dhcp services.
05:26:42 <yamahata> s3wong: I see.
05:27:04 <s3wong> L2/3 in Neutron, L4+ may (likely will) get the spinoff
05:27:23 <yamahata> I see.
05:28:16 <dougwig> i would bet that a few l4 exceptions will be made for nova-network like things, like dhcp.
05:28:33 <yamahata> Once common library in Neutron is proved useuful, the code further can be moved from Neutron to Oslo.
05:28:53 <yamahata> (Or its own rep.)
05:29:15 <s3wong> yamahata: I think it is good to reach out to various advanced service folks and see if tacker can help --- given how frustrating service insertion has been, perhaps we can roll them into tacker as well
05:29:30 <s3wong> s/them/that
05:29:50 <yamahata> s3wong: That's very great.
05:30:16 <Hareesh> +1
05:30:35 <dougwig> it's probably worth having lbaas and tacker meet next week; we might be a good first use case.  we have some members that don't want the risk of outside involvement getting in the way of delivery, but i think it's worth a conversation.
05:30:36 <yamahata> I suppose those people would like to try just simple library which calls nova. then try to tacker or something.
05:31:10 <s3wong> yamahata: got to know the requirements though --- so far, insertion "into the router" is something that may require some additional Neutron APIs
05:31:42 <s3wong> dougwig: +1 --- would like to see if there is common stuff we can do w.r.t. tacker now to aide Octavia delivery
05:32:05 <yamahata> +1. good to know the requirement
05:32:49 <yamahata> Is LBaaS BOF or something planned?
05:32:58 <yamahata> or Octavia BoF
05:33:25 <dougwig> BoF?
05:33:53 <yamahata> a sort of ad hoc meeting in addition to official design summit session.
05:34:43 <dougwig> we've talked about it, but nothing firm yet.  there will be something.
05:35:38 <s3wong> dougwig: we can find a cross-project session sometimes on Tuesday to have a cross-project session between Octavia and Tacker
05:35:59 <dougwig> that sounds good.
05:36:06 <dougwig> if anyone wants to look, start here:  https://blueprints.launchpad.net/octavia
05:36:19 <yamahata> #link  https://blueprints.launchpad.net/octavia
05:36:39 <dougwig> the nova driver and network driver interfaces are the "service vm" stuff, and "amphora" is our term for the vm image (roman "container").  don't get me started on how long that name took the group to agree on.
05:37:48 <s3wong> dougwigL let me see how we can sign up the cross-project sessions on Tues
05:38:00 <s3wong> s/dougwigL/dougwig
05:38:23 <dougwig> or even a pod meeting on friday could also work.
05:38:38 <s3wong> since it is Octavia and Tacker, we can involve the service folks from Neutron also --- because it can be classified as "cross-project" :-)
05:38:39 <dougwig> that might be easier to schedule.
05:38:58 <yamahata> ha ha
05:39:14 <s3wong> dougwig: that is a good idea. since we would get some idea due to having been to the advanced service spinoff session
05:39:40 <s3wong> TBH, 40 minutes of adv. service spinoff discussion will likely lead to nowhere...
05:39:47 <dougwig> yes, there is no way that is going to get resolved in 40 minutes.
05:40:11 <s3wong> Oh well...
05:40:21 <Hareesh> :)
05:40:44 <s3wong> dougwig: anyway, let's connect on when/where to meet in Paris for advanced service folks
05:41:17 <dougwig> #action dougwig coordinate time for paris adv.services/tacker/lbaas meeting
05:41:28 <dougwig> #action s3wong coordinate time for paris adv.services/tacker/lbaas meeting
05:41:29 <s3wong> dougwig, yamahata: I will also try to work with SumitNaiksatam and SridarK to get them to join
05:42:10 <yamahata> s3wong: sure. Firewall people.
05:42:53 <s3wong> dougwig, yamahata: let's hopefully get some concrete planning of work for Kilo (instead of stalling stuff for another cycle)
05:43:16 <yamahata> s3wong: +1 definitively
05:43:33 <s3wong> now that all our projects are on stackforge, we should be able to iterate quicker
05:45:41 <yamahata> the discussion seems to conclude. any other topic? or can we close the meeting?
05:45:57 <s3wong> yamahata: sounds good. See you next week!
05:46:15 <s3wong> dougwig: see you next week in Paris also!
05:46:25 <dougwig> looking forward to it!
05:46:31 <yamahata> thank you. see you in Paris.
05:46:42 <yamahata> #endmeeting