15:08:10 <s3wong> #startmeeting servicevm_device_manager
15:08:11 <openstack> Meeting started Tue Nov 11 15:08:10 2014 UTC and is due to finish in 60 minutes.  The chair is s3wong. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:08:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:08:14 <openstack> The meeting name has been set to 'servicevm_device_manager'
15:08:20 <s3wong> #chairs bmelande
15:08:30 <s3wong> #chair bmelande
15:08:31 <openstack> Current chairs: bmelande s3wong
15:08:34 <bmelande> My irc skills are so poor. You chair it Stephen. :-)
15:08:59 <s3wong> there he is
15:09:03 <s3wong> #chair yamahata
15:09:04 <openstack> Current chairs: bmelande s3wong yamahata
15:09:17 <yamahata> hello
15:09:19 <yamahata> sorry for delay
15:09:26 <s3wong> yamahata: I just started the meeting
15:09:28 <bmelande> Hi yamahata
15:09:37 <yamahata> s3wong: bmelande hi
15:09:41 <s3wong> yamahata: but I haven't started the first topic --- do you want to drive?
15:10:07 <yamahata> s3wong: can you please drive today.
15:10:13 <s3wong> yamahata: sure
15:10:21 <s3wong> #topic meeting time
15:10:27 <yamahata> today I made it. but I'm not sure for several weeks.
15:10:44 <yamahata> I updated the wiki and meeting page.
15:10:54 <s3wong> Guys, my understanding is today's meeting is temporary --- so let's quickly finalize on when we are going to meet starting next week
15:11:34 <vishwanathj> if the current slot is available, I am OK with that
15:11:42 <SridharRamaswamy> I proposed a slot on Wednesday
15:11:48 <SridharRamaswamy> along with Adv Services
15:11:54 <s3wong> Does the time we have now (1500 UTC Tuesdays) work for everyone?
15:12:05 <SridarK> SridharRamaswamy: +1 but Adv services may move to today
15:12:15 <s3wong> SridharRamaswamy: advanced service meeting is now on 1700 UTC Tuesday
15:12:22 <s3wong> (2 hours from now)
15:12:33 <bmelande> We should avoid colliding with that
15:12:35 <s3wong> actually the LBaaS meeting is next (1600 UTC Tuesday)
15:12:40 <SridarK> s3wong: would same time wed be okay ?
15:12:48 <yamahata> the info on the meeting wiki is old for adv service and lbaas?
15:12:54 <s3wong> SridarK: no problem for me
15:13:04 <SridharRamaswamy> SridarK: I see
15:13:41 <s3wong> yamahata: the link here is updated: #link https://wiki.openstack.org/wiki/Meetings#LBaaS_meeting
15:13:52 <SridharRamaswamy> +1 on conflicting with Adv Services & LBaaS
15:14:11 <yamahata> s3wong: oh, got it.
15:14:14 <SridharRamaswamy> is it possible to get something 9 or 9am Pacific ?
15:14:25 <SridharRamaswamy> 9:30am
15:14:27 <s3wong> yamahata: and advanced service is right below
15:14:50 <s3wong> SridharRamaswamy: need to get OK with bmelande and hareeshpc
15:15:26 <s3wong> for advanced service: #link https://wiki.openstack.org/wiki/Meetings#Neutron_Advanced_Services.27_team_meeting
15:15:36 <bmelande> For me 9am pacific should be ok
15:15:51 <s3wong> hareeshpc: how about you?
15:16:07 <vishwanathj> are we suggesting 9am pacific on wednesday's?
15:16:10 <s3wong> hareeshpc: is 1700 UTC OK with you?
15:16:17 <hareeshpc> s2wong: that is ok with me, its tesday or wedensday?
15:16:32 <s3wong> vishwanathj: I think so, 9am pacific conflict with advanced service, so that timeslot is out
15:16:39 <s3wong> hareeshpc: that would be Wednesday
15:17:01 <hareeshpc> Ya, thats ok with me
15:17:01 <s3wong> (and I am still operating under the assumption that #openstack-meeting-4 is free for all for now :-) )
15:17:02 <vishwanathj> I am fine with 9AM pacific on wednesdays
15:17:37 <s3wong> OK --- sold! Meeting time from next week onward would be 1700 UTC Wednesday
15:18:04 <vishwanathj> I will mark my calendar that this will be on 1700 UTC wednesday on openstack-meeting-4
15:18:14 <s3wong> #agreed New meeting time starting 19th of Nov will be 1700 UTC Wednesday
15:18:36 <s3wong> Good, next topic
15:18:59 <SridharRamaswamy> thanks .. this meeting slot helps!
15:19:12 <s3wong> #topic tacker workflow
15:19:37 <s3wong> during Friday of the Summit, we had a short 1/2 hour talk on tacker workflow
15:20:05 <s3wong> and since we needed to rush to the positron meetup, we haven't yet reached conclusion
15:20:20 <s3wong> honestly, I don't expect us to finalize tacker workflow on the IRC
15:20:23 <natarajk> I think everyone should review the tacker spec again and add review comments
15:20:33 <SridharRamaswamy> s3wong: yes, we need a clearer demarkation of what belongs to plugin and where the boundary of tacker starts
15:20:42 <s3wong> natarajk: agreed
15:21:03 <SridharRamaswamy> s3wong, all: do we have the use cases written down somewhere ?
15:21:09 <yamahata> natarajk: +1. I'll update the spec in this week for kilo at least.
15:21:29 <s3wong> SridharRamaswamy: does it make sense to have a Google Doc where all of us can edit and comment
15:21:59 <SridharRamaswamy> similar to NFV subteam we can have a table of use-cases along with when we are shooting to support them (Kilo, L, etc)
15:22:11 <s3wong> yamahata: a shared Google doc would be a better tool to express comments and opinions (and adding contents among the team) than doing spec comment on gerrit, right?
15:22:17 <bmelande> SridarRamaswamy: +1
15:22:31 <yamahata> s3wong: okay, then let's use google-doc.
15:22:32 <s3wong> SridharRamaswamy: +1
15:22:41 <hareeshpc> Google doc: +1
15:22:45 <SridharRamaswamy> I propose lets start with a Wiki table and have Google Doc for detailed design doc
15:22:48 <SridarK> +1 on google doc with pictures
15:22:49 <bmelande> s3wong: +1
15:22:52 <s3wong> yamahata: do you want to move the spec content to Google doc and shared with the team?
15:23:36 <SridharRamaswamy> I can volunteer to put the use-case table in wiki
15:23:39 <s3wong> SridharRamaswamy: that's also a good suggestion. Let's start with Wiki page table for use cases, then go into Google doc
15:23:40 <yamahata> s3wong: I'm fine to move/reformat it to googledoc.
15:23:40 <bmelande> There was a google doc but perhaps it makes sense to start a new one and bring in content to that
15:23:52 <s3wong> SridharRamaswamy: cool, a volunteer!
15:23:58 <SridharRamaswamy> :)
15:24:22 <s3wong> #action SridharRamaswamy to start putting together a table of use cases (for Kilo) on Tacker Wiki page
15:24:58 <s3wong> #action yamahata to move current Tacker spec to a Google doc and share with team
15:25:43 <bmelande> I think we should also update the tacker wiki to clearly specify what tacker/service VM aims for
15:25:53 <s3wong> Guys, we can also have some discussions on your train of thoughts with bmelande 's email thread
15:26:13 <SridharRamaswamy> bmelande: +1
15:26:28 <s3wong> bmelande put it a lot of discussion topic (starting points) in that email, it would be great to get some discussions started there also
15:26:58 <yamahata> +1 for clarify the scope/goal
15:27:07 <SridharRamaswamy> IMO Tacker wiki is not for us (we all know what it is and what we going to do).. it primarily for folks outside this project to get to know and get interested and support us
15:27:31 <s3wong> any volunteer for updating the charter/mission/goal/scope on Wiki?
15:27:45 <bmelande> s3wong: I can take a first stab at it.
15:27:54 <yamahata> SridharRamaswamy: Are you claiming for splitting user page and developer page? If yes, +1.
15:28:16 <s3wong> #action bmelande to update Tacker Wiki with Tacker project goal/charter/mission
15:28:51 <SridharRamaswamy> yamahata: not nescessarily, but we can organize that way if it will help
15:29:23 <s3wong> yamahata: is that common for a project this new? I don't think we have finalized user operation flow/documentation yet...
15:29:39 <bmelande> My thinking was that at least it'd be good to add those bullets we had on the whiteboard in Paris on the wiki
15:30:03 <SridharRamaswamy> bmelande: +1
15:30:09 <natarajk> +1
15:30:17 <yamahata> s3wong: Right, it isn't finialized. I had tried with spec, but it's not.
15:30:38 <SridharRamaswamy> yamahata: let Bob & me take on the initial wiki updates and see how it comes
15:30:42 <s3wong> yamahata, SridharRamaswamy: besides, our users are either (1) tenants importing their services in OpenStack, or (2) the advanced services
15:31:02 <yamahata> SridharRamaswamy: Sure. We will see the outcome.
15:32:07 <s3wong> #action SridharRamaswamy and bmelande to update Wiki to reflect on the items outlined during K-Summit meeting
15:32:24 <yamahata> s3wong: do you mean Neutron adv svc by (2)?
15:32:33 <s3wong> yamahata: yes
15:33:36 <s3wong> so I think we have a good number of action items handed out for this meeting
15:33:47 <SridharRamaswamy> As discussed in the summit we should plan for a webex / conf call within next few weeks to discuss the design document
15:33:56 <SridharRamaswamy> perhaps in next couple of weeks
15:34:09 <yamahata> For my memo, yamahata upload LT slide
15:34:16 <s3wong> SridharRamaswamy: yes --- after we have couple iterations of the Google doc
15:34:27 <SridharRamaswamy> s3wong: sounds good
15:34:58 <SridharRamaswamy> i know we are out of time...
15:35:04 <hareeshpc> One question i had: is tacker dependent on any particular feature in neutron?
15:35:11 <SridharRamaswamy> we need folks from HP and Oracle to join this meeting
15:35:18 <hareeshpc> say like the anti spoofing patch?
15:35:42 <hareeshpc> I think it would be good to list tacker's wish list from neutron/nova if there is any?
15:36:08 <natarajk> hareeshpc: yes, i believe VLAN trunking is also needed
15:36:13 <yamahata> hareeshpc: https://wiki.openstack.org/wiki/ServiceVM/neutron-port-attributes is the list
15:36:17 <s3wong> hareeshpc: +1 ... though we are providing APIs to Positron services, so we have to ensure we have NO dependency on Positron
15:36:28 <hareeshpc> So we should have a list in wiki for capturing the status of these
15:36:30 <SridharRamaswamy> s3wong: +1
15:36:35 <s3wong> hareeshpc: Neutron should be OK --- as Positron will also have dependency on Neutron
15:37:08 <s3wong> hareeshpc: you want to take a stab at putting together a table on tacker wiki page? :-)
15:37:11 <hareeshpc> yamahata: thanks
15:37:42 <hareeshpc> s3wong: :) ok! I have do it
15:37:48 <yamahata> hareeshpc: maybe the page needs update though. The current wiki is badly organized.
15:37:48 <s3wong> yamahata: yes, that is a wish-list mostly coming from NFV team and we took them :-)
15:38:17 <yamahata> so it may be difficult to find the info.
15:38:18 <hareeshpc> s3wong: I can take a first stab at the wish list
15:38:19 <s3wong> #action hareeshpc to update Tacker Nova/Neutron wish list table on Wiki
15:39:10 <s3wong> Many good action items for next week for the team
15:39:23 <yamahata> yamahata will update the current status I'm involved with.
15:39:30 <s3wong> #topic Open Discussions
15:39:42 <s3wong> anything else the team wants to bring up?
15:39:47 <yamahata> portsecurity, l2-gateway at least
15:40:00 <s3wong> yamahata: cool
15:40:22 <yamahata> hareeshpc: can you please let me know when you finished? then I'll update them.
15:40:32 <s3wong> yamahata: my understanding is there is no consensus reached on VLAN trunk port during the K-Summit
15:40:53 <yamahata> s3wong: It's contrary to my understanding.
15:40:58 <SridharRamaswamy> all wiki-updates need to co-ordinate .. pls give a shout out when u r starting / ending the wiki updates
15:41:05 <s3wong> yamahata: and there are at least two or three proposals on L2 GW
15:41:07 <natarajk> s3wong: i thought Eric's proposal might make it
15:41:14 <yamahata> My understanding is that each three proposal will go independently as Ian organized.
15:41:38 <yamahata> For l2-gateway, I talked with HP guys. I'm willing to let them work on it.
15:41:44 <s3wong> yamahata, natarajk: Oh, OK... good --- I only listened on ijw's talk, and everyone in the audiences seemed a bit lost
15:41:47 <hareeshpc> yamahata: ok
15:41:53 <yamahata> I'll review L2 gateway spec and patch.
15:42:09 <SridharRamaswamy> s3wong: yeah, i was not sure if any consensus was reached either
15:42:50 <s3wong> yamahata: yikes, three proposals going independently is a recipe for -2s during SAD :-)
15:43:43 <SridharRamaswamy> perhaps Bob can check w/ Ian on the current status ?
15:43:44 <yamahata> s3wong: Sure. Ian claimed they are different. Not sure how coredev felt like.
15:43:49 <bmelande> About next coming ircs, I think we should announce meegting time on dev list and from now have email discussions there
15:44:16 <SridharRamaswamy> bmelande: +1
15:44:23 <yamahata> bmelande: +1
15:44:24 <hareeshpc> bmelande: +1
15:44:27 <s3wong> bmelande: +1 --- now we have good number of active contributer
15:44:37 <yamahata> I'm willing to announce. or s3wong will?
15:44:39 <bmelande> SridharR: I'll take to Ian
15:44:48 <s3wong> contributors, and perhaps outside interests --- we should do things more in the open
15:44:48 <bmelande> s/take/talk
15:44:51 <SridharRamaswamy> we agree to use [Neutron][ServiceVM] as Isaku proposed
15:44:56 <SridharRamaswamy> bmelande: thanks!
15:44:59 <s3wong> yamahata: do you want to, and should I?
15:45:10 <yamahata> s3wong: okay will do.
15:45:36 <s3wong> #action yamahata to announce new meeting time on ML
15:46:02 <s3wong> anything else to discuss for the team?
15:47:10 <s3wong> Thanks, everyone!
15:47:19 <yamahata> thanks.
15:47:22 <hareeshpc> Bye!
15:47:30 <SridharRamaswamy> Bye all!
15:47:30 <s3wong> Talk to you guys next week! Bye!
15:47:31 <vishwanathj> bye
15:47:34 <s3wong> #endmeeting