17:01:40 <yamahata> #startmeeting servicevm-device-manager
17:01:41 <openstack> Meeting started Wed Feb 25 17:01:40 2015 UTC and is due to finish in 60 minutes.  The chair is yamahata. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:43 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:45 <openstack> The meeting name has been set to 'servicevm_device_manager'
17:02:04 * yamahata giving people several minutes...
17:05:28 <yamahata> now 5 min, let's start...
17:05:37 <yamahata> #topic Announcement
17:05:50 <yamahata> Now voting for openstack summit was closed
17:05:57 <yamahata> #link https://www.openstack.org/summit/vancouver-2015/speakers/
17:06:05 <yamahata> thanks for your votes
17:06:38 <yamahata> that's it from me. anything else?
17:06:42 <s3wong> hello
17:06:47 <s3wong> sorry, a bit late
17:06:51 <SridharRamaswamy> yamahata: hope it makes thru, but i see lots of good proposals
17:07:00 <SridharRamaswamy> s3wong: hi
17:07:03 <yamahata> s3wong: hi
17:07:08 <s3wong> yamahata: didn't see what you wrote above, what did you say?
17:07:17 <yamahata> SridharRamaswamy: Yeah. the accept rate would be low.
17:07:28 <SridharRamaswamy> yamahata: :)
17:07:29 <yamahata> The voting for summit was closed.
17:07:35 <yamahata> https://www.openstack.org/summit/vancouver-2015/speakers/summit
17:07:37 <s3wong> yes
17:07:59 <s3wong> generally I agree with yamahata, the possibility of the talk getting in is low
17:09:01 <s3wong> but we are happy that during this exercise, we got a somewhat clear direction for Tacker
17:09:35 <s3wong> that we are trying to build a VNF Manager
17:09:40 <SridharRamaswamy> s3wong: yeah, can we list the high level functions of tacker as it stands ..
17:09:44 <yamahata> definitively
17:10:00 <s3wong> SridharRamaswamy: good question
17:10:01 <SridharRamaswamy> health-monitoring, automatic-restart, automatic-reconfig on failure, etc
17:10:29 <s3wong> so as VNF Manager, at the minimum, we need to do "lifecycle and config management"
17:10:47 <SridharRamaswamy> threw out few that was floating in my head
17:11:04 <SridharRamaswamy> i'm thinking beyond spin up ServiceVM
17:11:37 <s3wong> in the MANO diagram, VNF Manager also lives on top of VIM (virtual infrastructure manager), so we have to avoid making direct Nova/Glance/Neutron calls
17:11:41 <s3wong> make them a plug in
17:12:24 <s3wong> SridharRamaswamy: agreed. setting up a management channel from get-go is a must
17:12:30 <SridharRamaswamy> s3wong: hmm, why are you making that assumption ?
17:12:48 <s3wong> as we talked about last week with auto configuration of provider-net
17:13:01 <yamahata> #chair SridharRamaswamy s3wong
17:13:02 <openstack> Current chairs: SridharRamaswamy s3wong yamahata
17:13:12 <yamahata> #topic Open Discussion
17:13:34 <yamahata> Yea.
17:13:54 <s3wong> SridharRamaswamy: it is in http://www.ietf.org/proceedings/88/slides/slides-88-opsawg-6.pdf
17:14:03 <s3wong> pg 6
17:14:25 <SridharRamaswamy> s3wong: coincidence, i was looking at the same :)
17:14:31 <s3wong> VNFM and VIM have a common interface (Vnfm-Vi)
17:14:35 <s3wong> SridharRamaswamy: :-)
17:15:10 <s3wong> given that MANO mentions VIM can be vmware, or OpenStack, or CloudStack, my guess is we need to abstract out pure OpenStack calls
17:15:30 <SridharRamaswamy> s3wong: yeah, that make sense
17:15:39 <s3wong> I don't work for a company that is a member of ETSI, so I don't know if Vnfm-Vi is being standardized
17:15:50 <s3wong> if so, we should actually follow what ETSI NFV proposes
17:16:12 <yamahata> the draft of ETSI is publicly available.
17:16:18 <yamahata> I'm not sure how new they are.
17:16:20 <yamahata> though
17:16:38 <s3wong> yamahata: I know about the four high-level drafts
17:17:00 <s3wong> yamahata: but not sure if the API proposals (if there are any) are publicly available
17:17:21 <SridharRamaswamy> the guidance i got from ppl who are active in these standards body  .. we shouldn't take every box and line to the exact definition to the implementation
17:17:57 <s3wong> SridharRamaswamy: sounds fair, Tacker can have a first crack at what plugin interface  we should use
17:18:03 <SridharRamaswamy> as long as we are providing the functions described in MANO in a way that can map back, it should be fine
17:18:13 <s3wong> SridharRamaswamy, yamahata: then if there are standard APIs coming up, we can try to map them
17:18:46 <s3wong> SridharRamaswamy, yamahata: TBH, I would be surprise at the end of the day, the APIs would look drastically different from Nova/Glance/Neutron anyway :-)
17:19:31 <SridharRamaswamy> there are normalize toolkits like Apache Jclouds that can help to map to wherever VIM in the back
17:19:58 <s3wong> SridharRamaswamy: OK
17:20:22 <SridharRamaswamy> jclouds, for eg, can do openstack, vmware or even ec2 :)
17:20:36 <s3wong> SridharRamaswamy: nice
17:20:48 <s3wong> yamahata: I would like to know the state of the Tacker codebase
17:21:20 <yamahata> s3wong: it's stable for a while
17:21:24 <s3wong> yamahata: is the keystone endpoint for Tacker setup yet?
17:21:34 <s3wong> yamahata: is devstack integration in place?
17:21:48 <yamahata> It works with keystone as neutron does.
17:22:04 <yamahata> devstack patch is not available yet.
17:22:41 <yamahata> If necessary, I can put half-baked patch for devstack somewhere.
17:22:45 <yamahata> maybe github
17:22:56 <yamahata> I'll upload it to github
17:23:02 <s3wong> yamahata: sure, that would be great
17:23:30 <s3wong> yamahata: what we need is Tacker being in some form where we can set up and start doing some  test
17:23:38 <yamahata> #action upload devstack patch to github
17:23:38 <s3wong> yamahata: admittedly we can do unit tests
17:24:02 <s3wong> yamahata: but if we are to abstract out Neutron/Nova/Glance --- then it seems like the testing ought to be done with devstack
17:24:03 <yamahata> #action yamahata upload devstack patch to github
17:24:49 <yamahata> Sure. makes sense.
17:24:52 <s3wong> yamahata: also, when bobmel was still involved, he mentioned going with Pecan --- but I guess that isn't needed to bring up the API server per se, right?
17:24:56 <yamahata> Unfortunately UT is missing
17:25:31 <yamahata> At this moment, tacker is independent API server
17:25:58 <s3wong> yamahata: do we need to set up some framework for UT? or you were saying UT in general is missing (i.e., no UT was written)?
17:26:11 <yamahata> the latter.
17:26:17 <s3wong> yamahata: to should just work when we have the UTs, right?
17:26:18 <yamahata> tests direction is almost empty for now.
17:26:24 <yamahata> directory
17:26:33 <yamahata> Right
17:26:43 <s3wong> yamahata: that's OK, as we develop the APIs/DB model, we will write the UTs
17:27:06 <s3wong> yamahata: currently you haven't really completed the APIs/DB model anyway, right?
17:27:32 <yamahata> Not fully completed. but mostly.
17:27:59 <s3wong> yamahata: sure, we can start with that
17:29:19 <SridharRamaswamy> s3wong: yamahata: folks - i got leave for another mtg in a min
17:29:31 <s3wong> SridharRamaswamy: sure. Have a good day
17:29:37 <yamahata> SridharRamaswamy: sure. np
17:29:41 <SridharRamaswamy> i'll catchup w/ the meeting minutes
17:29:46 <SridharRamaswamy> ttyl
17:30:43 <s3wong> yamahata: I may start to look into abstract out Nova/Neutron/Glance as plugin (i.e., plugin model) --- though since I only work on this ~20% time, the progress may be slow
17:31:09 <yamahata> s3wong: That's quite fine.
17:31:22 <yamahata> It seems everyone has time constraint.
17:31:31 <s3wong> yamahata: certainly :-)
17:32:09 <yamahata> Feel free to contact me when necessary.
17:32:25 <s3wong> yamahata: hopefully if we lay the groundwork nicely, it will attract more people from the community to join the project
17:32:52 <yamahata> Yea, hopefully :-)
17:33:00 <s3wong> yamahata: and that you and SridharRamaswamy's employers will allow you guys to dedicate more time into the project also :-)
17:33:17 <s3wong> (if and when the project becomes popular)
17:34:18 <s3wong> I do think VNF Manager is attractive, but we need to build something to show people this is a serious project first to get to be recognized as the OpenStack OSS VNF Manager
17:34:22 <s3wong> long way to go :-)
17:34:38 <yamahata> Definitively long way
17:34:41 <yamahata> and hard way
17:34:59 <s3wong> yamahata: one step at  a time
17:35:07 <s3wong> anyway, that's it for me
17:35:15 <yamahata> anything else to discuss.
17:35:21 <yamahata> TBH I'm also running out of time...
17:35:28 <s3wong> yamahata: sure. Have a good week
17:35:37 <yamahata> s3wong: you too!
17:35:43 <yamahata> thank you. bye
17:36:00 <yamahata> #endmeeting