14:01:19 <gampel> #startmeeting Smaug
14:01:21 <openstack> Meeting started Tue Mar 22 14:01:19 2016 UTC and is due to finish in 60 minutes.  The chair is gampel. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:25 <openstack> The meeting name has been set to 'smaug'
14:01:36 <gampel> Hi everyone
14:01:40 <gampel> who is here ?
14:01:40 <xiangxinyong> Hi
14:01:42 <yuval> Hi
14:02:07 <saggi> hi
14:02:13 <gampel> #info xiangxinyong, yuval, saggi in the meeting
14:02:23 <gampel> anyone else
14:02:52 <gampel> let wait a bit
14:02:53 <chenying__> hi
14:03:07 <gampel> #info chenying__ in the meeting
14:03:15 <gampel> hi how are you welcome back
14:03:31 <chenying__> fine thanks.
14:03:36 <zhonghua-lee> Hi
14:03:44 <zhonghua-lee> sorry I'm late
14:03:45 <yinweimac> hi, guys
14:04:01 <gampel> #info yinweimac in the meeting
14:04:03 <gampel> welcome
14:04:12 <gampel> shell we wait a bit more or lets start ?
14:05:09 <gampel> Ok lets start ?
14:05:18 <gampel> #topic Announcements
14:05:36 <gampel> I would like to propose chenying as core for smaug
14:05:43 <yinweimac> +2
14:05:44 <gampel> The quality and the quantity of his patches and review is notable
14:05:48 <yinweimac> :)
14:06:03 <xiangxinyong> +1
14:06:06 <yinweimac> cons to ying
14:06:14 <chenying__> Thanks.
14:06:17 <saggi> +1
14:06:21 <gampel> +1
14:06:23 <yuval> +1
14:06:31 <yinweimac> +1
14:06:31 <zhonghua-lee> +1
14:06:32 <gampel> any objection ?
14:06:43 <gampel> zhonghua-lee:welcome
14:06:55 <chenzeng> +1
14:06:58 <zhonghua-lee> gampel: :)
14:07:06 <gampel> congratulation chenying
14:07:29 <gampel> :)
14:08:03 <zhonghua-lee> chengying_:congratulation
14:08:13 <xiangxinyong> :)
14:08:39 <gampel> #topic: Merge Proposed Smaug API v1.0
14:08:52 <gampel> saggi: can you please update
14:09:30 <gampel> saggi: ?
14:09:36 <saggi> We can merge it
14:09:43 <saggi> There were only minor comments
14:09:53 <saggi> so unless someone has any objection
14:10:01 <saggi> it should be merged soon.
14:10:02 <gampel> there are some comments from yuval that you missed
14:10:12 <saggi> About ScheduledOperation?
14:10:16 <yuval> yes
14:10:36 <gampel> Lets all reveiw tomorrow and lets try to finally  merge this patch
14:10:46 <saggi> I didn't miss them, I wrote that this is the proper name.
14:10:48 <gampel> saggio: we need another partch for the operation log api
14:10:59 <gampel> Ok
14:11:08 <chenying__> Another patch about  operation log api need be considered.
14:11:30 <gampel> saggi: can i assign it to you ?
14:11:37 <saggi> Sure
14:11:38 <xiangxinyong> yeah, this patch is important
14:11:49 <gampel> #action saggi send another patch for the operation log
14:12:08 <gampel> #topic REST API status
14:12:44 <gampel> I tried to rebase the Trigger and operation api with no dependencies
14:13:24 <gampel> so we could merge them @zengchen can you take a look
14:13:33 <chenying__> <xiangxinyong> Do we need consider any api about update resources?
14:13:34 <chenzeng> ok
14:13:56 <gampel> chenying__: what do you mean ?
14:14:57 <gampel> #action chenzeng try to rebase  https://review.openstack.org/#/c/287036/ and https://review.openstack.org/#/c/286406/ with minimal dependencies
14:15:33 <gampel> chenying__: i am not sure i understand  ?
14:15:45 <chenying__> some resourece we didn't consider update action.
14:15:49 <yuval> chenzeng: both Trigger and ScheduledOperation REST API patches depend on "276081
14:15:55 <yuval> (Implement rpc interfaces of OperationEngine)
14:17:00 <gampel> chenying__: which one i think we have for plan,trigger,operation
14:17:10 <chenzeng> yes, tommrow i will try to change the dependencies.
14:17:40 <gampel> chenzeng: please revert my changes if they do not make sense
14:18:06 <gampel> chenying__: which resources we are missing update ?
14:18:44 <chenying__> Ok trigger,operation have consider update aciton.
14:19:24 <gampel> #action chenying__ review the API resources and make sure we are not missing update
14:19:43 <chenying__> Ok I will review these api patches.
14:19:57 <gampel> if we are missing the PUT command please comment
14:20:12 <chenying__> Ok.
14:20:20 <chenzeng> gampel:i see your changes about the two apis. i will check them.
14:20:27 <gampel> #topic Protectables status
14:20:41 <gampel> Yuval can you please update
14:21:07 <yuval> The ClientFactory and almost all of the clients were merged (besides neutron)
14:21:27 <yuval> We can now rebase all protectables patches over master
14:22:01 <yinweimac> Not sure if wla is here, he is writing patch for network protectable and has committed neutron client today
14:22:11 <yuval> However, please note:
14:22:34 <yuval> The "Implement protectable RPC handlers" changed the ProtectablePlugin base class
14:23:10 <gampel> #action yuval and Yingzhe Zeng and wla rebase  the protectables
14:23:20 <yuval> chenzeng: could you please rebase the "Implement protectable RPC handlers" patch and address the comments?
14:24:35 <gampel> #action chenzeng rebase "Implement protectable RPC handlers"
14:24:51 <gampel> it is blocking the protectable
14:25:04 <gampel> chenzeng: Ok ?
14:25:38 <gampel> i will update him tomorrow
14:25:41 <gampel> #topic Workflow Engine
14:25:46 <chenzeng> gampel:ok
14:26:02 <gampel> yinweimac saggi can you please update
14:26:25 <yinweimac> we have checked with saggi, so there's no dependency on checkpoint patch anymore
14:26:47 <saggi> There are some patches by walinguan that still need some work
14:26:59 <saggi> yinwei is working on getting the leases working
14:26:59 <yinweimac> wla will address saggi's comment, and expose more necessary params in base class
14:27:17 <gampel> what about the bank collection
14:27:19 <gampel> #link Create BankCheckpointCollection implementation https://review.openstack.org/#/c/280325/
14:27:40 <yinweimac> wla will also complete protection task flow and then we can start debugging from api service to cinder protection plugin
14:28:04 <yinweimac> I think this patch could be merged
14:28:05 <gampel> yinweimac saggi what time frame do you think we can expect this patches to be ready ?
14:28:24 <yinweimac> and saggi and I will work based on this patch on parallel
14:28:27 <saggi> This patch I'll fix today
14:28:42 <saggi> The patch that serializes the resources will be done next week
14:29:09 <gampel> Ok if we could merge the workflow we could start doing integration test
14:29:39 <yinweimac> one second, we still need merge the graph wolker listener as well
14:30:36 <gampel> can you share the link
14:30:48 <gampel> Lets all try to focus review on API workflow patches  and protectabl
14:30:56 <yinweimac> sorry I find I couldn't open the gerrit link now
14:31:12 <saggi> I reviewed it. It had some minor problems but nothing major.
14:31:14 <gampel> is it one of
14:31:14 <gampel> wangliuan patches
14:31:17 <yinweimac> saggi, could you pls. check the link? You reviewed it once.
14:31:26 <yinweimac> no, it's from luobin
14:31:52 <saggi> https://review.openstack.org/#/c/287572
14:31:53 <gampel> #link he resource graph walker listener
14:31:53 <gampel> https://review.openstack.org/#/c/287572/
14:32:11 <yinweimac> yes, I think it's this one
14:32:48 <gampel> #action saggi gampel chenying__ review graph walker listener
14:33:18 <gampel> so we have 5 patches for the workflow taht we need to merge
14:33:57 <gampel> any think else on this topic
14:34:03 <yinweimac> yes
14:34:13 <yinweimac> one question about heat
14:34:26 <yinweimac> what version of heat template we will use
14:34:56 <saggi> Why not the latest?
14:35:08 <gampel> what are the available versions and what is the difference ?
14:35:18 <yinweimac> some intrinsic functions
14:35:47 <yinweimac> latest has mapmerge, the second lastest has repeat
14:35:52 <yinweimac> things like that
14:36:20 <gampel> I will go with the latest if there's no problem with it
14:36:46 <yinweimac> ok
14:37:17 <gampel> #action  yinweimac provide restore flow spec (research heat template and restore flow )
14:37:27 <gampel> yinweimac  is it OK ?
14:37:36 <yinweimac> ok
14:37:42 <gampel> great thanks
14:37:44 <yinweimac> btw, luobin and hurong has committed patches for image/server protection plugin reference implementation
14:37:59 <gampel> yes i looked at them today looks very good
14:38:08 <yinweimac> that's good
14:38:29 <gampel> #topic Protection Plugin & Service
14:39:02 <gampel> yinweimac: any other update i see that cinder, nova  are  all most ready
14:39:03 <yinweimac> Currently chenzeng is working on network protection plugin, together with wla
14:39:15 <yinweimac> chenzeng could update
14:39:30 <yinweimac> he has traveled to shenzhen, and becomes a big help here
14:39:51 <gampel> chenzeng: please update
14:40:59 <chenzeng> ok, today, i start to write the codes, i hope to submit one patch about 'neutron:subnet' tommorrow.
14:41:34 <gampel> ok if you need any help with the neutron data module contact me on the IRC
14:42:17 <gampel> so it seem that we could even merge this week most of the protection plugin
14:42:29 <gampel> besides neutron
14:42:36 <yinweimac> hope so
14:42:45 <gampel> very good job guys
14:42:50 <gampel> #topic Smaug Python Client
14:42:54 <yinweimac> and try to start integration test next week
14:43:14 <gampel> that will be excellent
14:43:21 <gampel> chenying__ do you want to update
14:43:36 <gampel> about Smaug Python Client
14:44:16 <chenzeng> gampel:thanks very much.
14:44:31 <chenying__> I will submit last one patch about scheduler_operation
14:44:31 <xiangxinyong> i know chengying had finished most of them.
14:45:25 <gampel> very good so when we have the integration working we could set up CI to run the fullstack test
14:45:54 <gampel> good job we will try to review the last patches
14:46:23 <gampel> #topic smaug UI dashboard
14:46:35 <gampel> xiangxinyong: the stage is yours
14:46:41 <xiangxinyong> ok
14:46:48 <xiangxinyong> I make some patches, but it could not be submit because the py27 will not be passed.
14:46:57 <xiangxinyong> The dashboard refers to some python-smaugclient.
14:46:57 <xiangxinyong> The python-smaugclient need be tagged a inital version.
14:47:22 <gampel> which patch ?
14:47:27 <gampel> can you share the link
14:47:38 <xiangxinyong> no link
14:47:41 <xiangxinyong> eran
14:48:07 <gampel> chenying__: can you set the tag
14:48:14 <xiangxinyong> the patches are still local
14:48:29 <chenying__> Ok
14:48:57 <xiangxinyong> we need to add python-smaugclient into smaug and smaug-dashboard's requirements.txt
14:49:04 <gampel> #action chenying__ set tag initial on python-smaugclient
14:49:21 <xiangxinyong> saggi gave a lot of suggestions about the dashboard. Thanks.
14:49:39 <xiangxinyong> The dashboard has still some work to do, especially about the resource tree which is very complex.
14:50:15 <gampel> Ok do you want to have a meeting about that ?
14:50:31 <yinweimac> xinyong, do you mean we will show topology graph of resource tree in dashboard?
14:50:43 <xiangxinyong> yeah
14:50:48 <yinweimac> cool
14:51:14 <gampel> I see that currently we support only UI install with coping files we need to add devsatck install as well
14:51:37 <xiangxinyong> yeah, eran.
14:51:44 <gampel> xiangxinyong: you want to do it differently from  the  mock up UI
14:52:27 <xiangxinyong> not
14:52:56 <gampel> ok i suggest to have a meeting about the UI issues
14:53:09 <xiangxinyong> we need to take a way to implement it.
14:53:22 <xiangxinyong> ok
14:53:24 <gampel> Ok lets discuss this
14:53:29 <gampel> #topic Open Bugs
14:53:35 <chenzeng> saggi:one question, what's the dir 'smaug/services/protection/plugins' used for?
14:53:38 <gampel> any open bugs that are blocking
14:53:49 <saggi> all the files for the protection service
14:54:12 <chenzeng> does all the protection plugins should be put at that dir?
14:54:15 <saggi> The should be smaug/services/operationengine
14:54:32 <saggi> Yes, under some directory
14:55:01 <gampel> we have organized the plugins by sub directories for protection and protactabole ..
14:55:10 <saggi> +1
14:55:16 <gampel> #topic open issues
14:55:26 <chenzeng> so you can see the patch 'https://review.openstack.org/#/c/286458'
14:55:53 <gampel> i would like to suggest moving to weekly every odd week in time better for china
14:55:57 <gampel> what do you think ?
14:56:11 <gampel> so one week this time the other a good time for china
14:56:15 <gampel> sorry adding
14:56:16 <yinweimac> +1
14:56:42 <chenzeng> should the volume plugin files be move to plungins dir?
14:57:15 <gampel> chenzeng: i will reveiw and see that it match all the other patches
14:57:18 <chenying__> every week is better.
14:57:32 <gampel> i have comment on that on the cprotection and protecabole patches
14:57:34 <chenzeng> gampel:ok, thanks.
14:57:58 <gampel> #action gampel find slot for other week that is earlier in china
14:58:06 <gampel> any other isuues
14:58:46 <gampel> thank you for very good job everyone we are almost there to having end to end protection
14:59:09 <xiangxinyong> :)
14:59:13 <gampel> any last comments
14:59:47 <yinweimac> good night and good day
14:59:53 <xiangxinyong> bye
14:59:57 <yinweimac> :)
15:00:07 <gampel> bye good night
15:00:09 <saggi> bye
15:00:11 <yuval> bye
15:00:11 <gampel> thanks
15:00:12 <chenying__> bye
15:00:25 <gampel> #endmeeting