14:01:15 <saggi> #startmeeting smaug
14:01:18 <openstack> Meeting started Tue May 17 14:01:15 2016 UTC and is due to finish in 60 minutes.  The chair is saggi. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:22 <openstack> The meeting name has been set to 'smaug'
14:01:23 <yuval> Hey
14:01:26 <gampel> hi
14:01:29 <zhonghua-lee> hi
14:01:45 <saggi> Are we waiting for anyone?
14:02:03 <saggi> Does anyone know if yinwei wanted to attend?
14:02:12 <xiangxinyong> hi
14:02:44 <xiangxinyong> she is sick
14:03:27 <saggi> xiangxinyong: I've heard I've spoken with her today and she was feeling fine. But she probably doesn't want to over exert herself.
14:03:36 <saggi> So lets start
14:03:55 <saggi> #topic meeting time
14:04:17 <saggi> We want to make the meeting weekly but in different times.
14:04:27 <chenying__> hi
14:04:34 <saggi> I've sent an email to the mailing list but I didn't get a lot of responses.
14:05:08 <xiangxinyong> i think the time is very suitable for the eastern side
14:05:09 <saggi> Does anyone have any objection to the suggestion of:
14:05:09 <saggi> - 15:00 UTC for west, biweekly-even
14:05:09 <saggi> - 09:00 UTC for east, biweekly-odd
14:05:19 <xiangxinyong> +1
14:05:24 <saggi> We can always change it later
14:05:24 <chenying__> +1
14:05:27 <zhonghua-lee> looks good to me
14:05:36 <chenying__> I think it is good.
14:05:41 <gampel> sound good  to me
14:05:46 <xiangxinyong> :)
14:05:47 <yuval> +1
14:05:55 <saggi> Then I'll submit a patch to change it.
14:06:06 <xiangxinyong> thanks saggi
14:06:27 <saggi> Hopefully next week we'll have more west hemisphere people in here :)
14:06:50 <saggi> #action send patch to update meeting time (saggi)
14:07:10 <saggi> Is the bot asleep?
14:07:33 <gampel> :)
14:07:41 <xiangxinyong> ^-^
14:07:44 <saggi> #info test
14:07:55 <saggi> Let's hope this is getting logged
14:08:17 <zhonghua-lee> saggi: :)
14:08:36 <saggi> #topic Status updates
14:08:51 <saggi> He's just being selective
14:09:37 <saggi> Anyway, I just want to know what is everyone in china working on and to make sure no one is blocked.
14:10:34 <saggi> nothing?
14:10:44 <xiangxinyong> https://etherpad.openstack.org/p/smaug
14:10:55 <xiangxinyong> saggi: you could take a look at this
14:11:47 <gampel> chenying can  you share about  Design and development of replication plug-in
14:11:49 <chenying__> I am working on the Integration Test on the master branch. It does not work now. Some patches need be merged.
14:12:01 <saggi> xiangxinyong: thanks, but not everyone has a task there.
14:12:28 <xiangxinyong> yeah. we will work on the important items first
14:12:32 <xiangxinyong> do you agree?
14:12:35 <saggi> chenying__: What patches?
14:12:41 <saggi> xiangxinyong: yes.
14:12:42 <gampel> which patches , you mean end to end integration fullstack test
14:13:11 <chenying__> luobin and hurong's plugins and workflow patches.
14:13:24 <chenying__> Yes
14:13:46 <gampel> they are waiting for fixes on the comments
14:13:51 <chenying__> eran some fullstack test are developmented by other gays.
14:14:28 <xiangxinyong> yeah
14:14:30 <xiangxinyong> https://review.openstack.org/317209
14:14:43 <chenying__> After I finish the integration test on the master, These  fullstack test  can be submited.
14:15:18 <chenying__> Eran do you think I sould start working on  Design and development of replication plug-in?
14:15:26 <xiangxinyong> https://review.openstack.org/#/c/317209/
14:15:46 <gampel> did you submit the CI job ?
14:15:50 <chenying__> The  important item task xiangxinyong list have not finished yes.
14:15:54 <xiangxinyong> https://review.openstack.org/#/c/312008/
14:16:09 <chenying__> did you submit the CI job ? I have finished. I will submit later.
14:16:14 <xiangxinyong> https://review.openstack.org/#/c/314925/
14:16:53 <xiangxinyong> sorry, the above patches are about the fullstack
14:17:01 <gampel> xiangxinyong: this are all the fullstack test , but what rae the test that are missing for the integration
14:17:14 <gampel> "luobin and hurong's plugins and workflow patches."
14:17:50 <chenying__> I have listed some on our irc channel.
14:17:55 <saggi> yuval: What is the link to the trello board you opened.
14:18:02 <saggi> ?
14:18:23 <yuval> https://trello.com/b/Sudr4fKT
14:18:47 <yuval> You can join in this link:
14:18:49 <yuval> https://trello.com/invite/b/Sudr4fKT/826e3dcffc7259b1447d4ecc448c1a45/smaug
14:19:08 <chenying__> OK I will join it.
14:20:13 <xiangxinyong> i have joined it
14:21:19 <chenying__> operation engine patches also need be reviewed and merged.
14:21:22 <xiangxinyong> gampel: understood
14:22:40 <saggi> I'm still not sure what the best way to organize it is.
14:22:44 <saggi> I'll think about it.
14:23:29 <saggi> But we need a better way to coordinate.
14:23:50 <chenying__> As I konw, replication API in cinder only be implemented for admin. They are designing API for tenant in N.
14:24:36 <saggi> chenying__: I've spoken with them in the summit. And our name is even in the spec. They will give us a service token that will allow us to do some admin action on behalf of the tenant.
14:25:33 <zhonghua-lee> saggi:trello is a good tool
14:25:38 <gampel> chenying_: what are the reviews that are blocking you ?
14:25:54 <xiangxinyong> saggi: what about using the etherpad to coordinate?
14:26:29 <saggi> xiangxinyong: The history on etherpad is a bit obtuse so it's hard to track changes.
14:26:54 <xiangxinyong> saggi: ok
14:27:30 <saggi> We tried to use it but we noticed that someone might just make a big change and it will be hard to figure out why\what
14:27:43 <saggi> #topic Task flow improvements
14:27:43 <saggi> We've spoken about it in the last meeting. We understand the the current patches are a bit hard to review and we are working on it.
14:27:43 <saggi> But apart from the deleted code we do need to know if there are any technical objections.
14:27:43 <saggi> Please try and ignore the deleted code and concentrate on the actual changes.
14:27:51 <zhonghua-lee> saggi: if we plan to use trello, as you said, should find a organization way. it just a tool
14:28:15 <saggi> zhonghua-lee: I know
14:28:31 <zhonghua-lee> saggi: :)
14:29:04 <gampel> I agree lets see if some one have comment on the design , Yuval can you share  the spec
14:29:18 <saggi> zhonghua-lee: If you or anyone has any suggestions or can point me to a good trello board to get inspiration from please send me an email.
14:29:31 <saggi> It'
14:29:40 <yuval> saggi: https://trello.com/inspiringboards
14:29:49 <chenying__> <saggi>: I will focus on the design progress in cinder. And reivew the spec.
14:29:56 <saggi> It's important to note that some of the changes are as a result from use cases I got during the summit.
14:30:28 <saggi> chenying__: Look up the replication spec. I've commented on it but see if there are things you want to ask them about it.
14:30:49 <gampel> are there any technical objections to the new TaskFlow workflow design by Yuval
14:30:49 <zhonghua-lee> saggi: ok
14:31:15 <chenying__> saggi: OK
14:31:24 <xiangxinyong> saggi: perhaps we can discuss trello in the mailing list
14:31:38 <saggi> xiangxinyong: sure
14:31:44 <saggi> xiangxinyong: good idea
14:32:42 <zhonghua-lee> xiangxinyong: +1
14:32:52 <xiangxinyong> Thanks. i can do it tomorrow
14:33:12 <xiangxinyong> swift guys are using the trello
14:33:58 <zhonghua-lee> xiangxinyong: a good coordination tool.
14:34:13 <xiangxinyong> yeah
14:34:48 <chenying__> new TaskFlow workflow design, I think it is good. There are maybe lots of plugins refactoring work to do.
14:35:00 <saggi> Will the changes introduced in yuval's patches effect testing?
14:35:06 <gampel> are there any technical objections to the new TaskFlow/workflow design by Yuval  ? As saggi said we will fix the patch delete ...
14:35:08 <gampel> https://review.openstack.org/#/c/310386/7/smaug/services/protection/resource_flow.py
14:35:44 <gampel> https://review.openstack.org/#/c/316669/
14:36:35 <gampel> i think that it is critical that we agree on the design  and get comments from all the team
14:37:42 <xiangxinyong> gampel: i agree with you. it seems like a big change
14:38:04 <gampel> It is a critical bottleneck , that will allow us to merge all the protection plugin
14:38:39 <gampel> I think that the design is good and we should push it in as early as possible , to avoid extra work later
14:39:07 <chenying__> I think the changes may affect integration testing. Because  lots of plugins need be  refactored. could we do the  integration test using the old design.
14:39:28 <chenying__> ?
14:39:58 <gampel> All the new code is done by yuval and can be merged togther
14:40:07 <saggi> chenying__: Does the integration test get that deep in the code?
14:40:08 <yuval> chenying__: do integration tests with the old design benefit us?
14:40:27 <gampel> the fullstack is testing the API layer
14:40:53 <gampel> we will merge the new design only once it does not break the fullstack
14:41:24 <yuval> Anyhow, we should pass the spec updates first
14:41:57 <gampel> we could merge the fullstack and then yuval could run local integration here and we will merge the code only when it pass fullstack
14:42:04 <chenying__> I also think it is better using new design.  If we can  refactor the plugins ASAP. But now portect action does not work in the master branch yes.
14:42:33 <saggi> yuval: +1
14:42:45 <xiangxinyong> maybe we can merge these patches firstly. https://review.openstack.org/#/q/owner:luobin_smile%2540163.com+status:open
14:42:55 <chenying__> we could merge the fullstack and then yuval could run local integration  It is a good idea.
14:43:09 <yuval> what patches are missing for the fullstack?
14:43:14 <yuval> chenying__: can you give the list?
14:43:16 <chenying__> It is a good idea. If yuval can do the  fullstack test in his local.
14:44:17 <chenying__> yuval: what list? fullstack test or patches?
14:44:33 <yuval> chenying__: the patches required for the fullstack tests to start running
14:44:41 <yuval> chenying__: what patches block the full stack
14:45:06 <chenying__> wait a minute
14:45:13 <gampel> I think this is the list ? am I correct chenying__ ?https://review.openstack.org/#/c/287572/
14:45:13 <gampel> https://review.openstack.org/#/c/316674/
14:45:13 <gampel> https://review.openstack.org/#/c/303355/
14:46:14 <xiangxinyong> open engine service
14:46:14 <xiangxinyong> https://review.openstack.org/#/c/309898/
14:46:14 <xiangxinyong> https://review.openstack.org/#/c/282263/
14:46:14 <xiangxinyong> https://review.openstack.org/#/c/310394/
14:46:14 <xiangxinyong> restore workflow
14:46:15 <xiangxinyong> https://review.openstack.org/#/c303277
14:46:16 <xiangxinyong> https://review.openstack.org/#/c/287572/
14:46:18 <xiangxinyong> https://review.openstack.org/#/c316674
14:46:21 <xiangxinyong> https://review.openstack.org/#/c307737
14:46:39 <xiangxinyong> i think these patches are important for the fullstack test
14:46:59 <chenying__> The resource graph walker listener https://review.openstack.org/#/c/287572/ https://review.openstack.org/#/c/316674/  https://review.openstack.org/#/c/303355/
14:47:16 <yuval> chenying__: right. thanks. everybody please make sure you review these 3 patches\
14:47:22 <chenying__> I think portect action need these patches.
14:47:32 <gampel> lets start with fullstack  only to the protection service
14:47:39 <chenying__> If we want to test restore action we need more.
14:48:03 <gampel> this one https://review.openstack.org/#/c/287572/ need to be updated tomorrow by smile-luobin
14:48:50 <xiangxinyong> gampel: we will tell him tomorrow
14:48:55 <chenying__> I will ask luobin to update  tomorrow.
14:49:13 <chenying__> But sometime I also can not find him.
14:49:29 <saggi> Also, everyone, please email me patches that you think are ready for final review or are blocking your tasks. I will try and get to those first.
14:49:44 <saggi> Stuff get lost in the clutter.
14:49:49 <gampel> Ok but anyway please review the spec we coudl merge it anyway if there are no comments
14:50:19 <gampel> Ok we will try to focus on this 3 tomorrow , then we can merge the fullstack patches
14:50:41 <yuval> Updated Trello with the patches to review
14:51:20 <saggi> #topic open discussion
14:51:29 <saggi> Anything else before we finish for today?
14:51:49 <yuval> Yes, if anyone didn't join the Trello, please do
14:51:54 <chenying__> Ok thanks I think if we have  fullstack job, we can start lots of optimization work.
14:52:16 <yuval> https://trello.com/invite/b/Sudr4fKT/826e3dcffc7259b1447d4ecc448c1a45/smaug
14:53:40 <chenying__> I have joined it.
14:54:58 <saggi> OK, than thanks everyone. hopefully in two weeks in an earlier time.
14:55:03 <saggi> #endmeeting