09:00:34 <saggi> #startmeeting smaug
09:00:35 <openstack> Meeting started Tue Aug  2 09:00:34 2016 UTC and is due to finish in 60 minutes.  The chair is saggi. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:38 <openstack> The meeting name has been set to 'smaug'
09:00:43 <saggi> Hi everyone
09:00:59 <xiangxinyong> hello
09:00:59 <zhonghua-lee> hi
09:01:11 <yuval> hey
09:02:03 <saggi> Are we waiting on anyone? yiwei, chenzeng, etc
09:03:15 <yuval> chenzeng should be here, he wanted to discuss his suggestion
09:03:37 <chenying> yinwei is off the office today.
09:03:46 <zengchen> yuval:yes
09:03:52 <saggi> Do you guys know where everyone is?
09:04:29 <xiangxinyong> :)
09:04:33 <zhonghua-lee> I am here :)
09:04:42 <zengchen> yuval:as i descirbed on the launchpad, we may need to add a new executor
09:05:08 <saggi> OK let's start
09:05:15 <saggi> #topic mascot selection
09:05:25 <saggi> We didn't get the koala mascot
09:05:31 <saggi> Kolla won the coin toss
09:05:39 <zengchen> saggi:i am online
09:05:41 <zhonghua-lee> is there any option?
09:05:53 <saggi> Their name is also an alternative name for a Koala so they have the same claim on the animal.
09:06:40 <chenying> we use Karbor as the name  or voting a new name?
09:06:41 <zhonghua-lee> so we have to pick another one?
09:07:02 <saggi> We can change the name since we did not announce the name yet
09:07:05 <saggi> We suggested a tardigrade http://apod.nasa.gov/apod/ap130306.html which is the most resilient animal on earth.
09:07:10 <saggi> Not as a name but a mascot
09:07:40 <zhonghua-lee> saggi:what's that?
09:08:18 <saggi> https://zh.wikipedia.org/wiki/%E7%BC%93%E6%AD%A5%E5%8A%A8%E7%89%A9%E9%97%A8
09:10:16 <zhonghua-lee> looks good
09:10:38 <zhonghua-lee> except looks like maggot
09:10:42 <saggi> :)
09:10:47 <zhonghua-lee> forgive me
09:10:52 <chenying> It looks fearsome.
09:10:57 <saggi> That's the problem. It fits thematically but it not as cute.
09:11:26 <yuval> imo it is quite cute
09:11:28 <chenying> Can we pick another cute animal?
09:11:31 <zhonghua-lee> :)
09:11:41 <saggi> Yes
09:11:41 <xiangxinyong> :(
09:11:57 <saggi> But it needs to be somewhat related.
09:12:13 <zhonghua-lee> can we use dragon?
09:12:25 <saggi> They don't allow mythical animals.
09:12:33 <zhonghua-lee> oj
09:12:35 <zhonghua-lee> ok
09:12:46 <xiangxinyong> I guess this animal is from the mars
09:12:49 <chenying> can we use panda?
09:12:49 <xiangxinyong> :)
09:13:12 <saggi> yuval: Where is the list of the taken mascots?
09:13:23 <yuval> https://www.openstack.org/project-mascots
09:13:36 <yuval> they just added another batch of taken mascots
09:13:57 <saggi> The problem with panda is that the name is to generic.
09:14:07 <saggi> And that the WWF already uses it as a mascot
09:14:17 <xiangxinyong> what about the glass crab?
09:14:22 <xiangxinyong> http://image.baidu.com/search/detail?ct=503316480&z=0&ipn=d&word=glass%20crab&hs=0&pn=5&spn=0&di=25493893821&pi=&rn=1&tn=baiduimagedetail&ie=utf-8&oe=utf-8&cl=2&lm=-1&cs=1366933940%2C1128410029&os=3481574606%2C599075615&simid=0%2C0&adpicid=0&ln=30&fr=ala&fm=&sme=&cg=&bdtype=15&oriquery=&objurl=http%3A%2F%2Fpre01.deviantart.net%2F736a%2Fth%2Fpre%2Ff%2F2016%2F005%2F3%2F8%2Fglass_toon_crab_by_laticis-d9mu0k1.jpg&fromurl=ippr_z2C%24qAzdH3FA
09:14:22 <xiangxinyong> zdH3Fg5pj_z%26e3Bpwwksj_z%26e3Bv54AzdH3Fr5fpAzdH3F8nC0AzdH3F4w6t3jkj6ptg2_z%26e3B1jetwgpw6p_z%26e3Bv54AzdH3Fw6pAzdH3FLwvj-Lw1y-cb8mn09an&gsm=0
09:14:36 <yuval> btw Quokka taken
09:15:30 <chenying> crab?
09:15:37 <yizhihui> camel?
09:16:12 <xiangxinyong> yizhihui: welcome to join the weekly meeting
09:16:21 <yizhihui> :)
09:16:24 <zhonghua-lee> camel, good idea
09:16:37 <yizhihui> or Black Mamba
09:17:11 <zhonghua-lee> ohh...no
09:18:15 <chenying> golden monkey
09:18:17 <zhonghua-lee> I think we can not get the conclusion this time
09:18:52 <saggi> Please send suggestions if you have any.
09:18:59 <xiangxinyong> I guess we can submit the mascot in this link. https://etherpad.openstack.org/p/smaugmascot
09:19:04 <chenying> http://s15.sinaimg.cn/mw690/65d9d9a5tx6CFUsY8z4be&690   golden monkey
09:19:14 <saggi> #topic Add a new executor for Operation Engine service
09:19:17 <zhonghua-lee> saggi: +1
09:20:07 <saggi> ping zengchen, this is your item
09:20:34 <zhonghua-lee> https://bugs.launchpad.net/smaug/+bug/1608415
09:20:34 <openstack> Launchpad bug 1608415 in Smaug "Add a new executor for Operation Engine service" [High,Triaged] - Assigned to zengchen (chenzeng2)
09:20:36 <chenying> It is better add the mascot with a picuter link.
09:21:02 <zengchen> saggi:
09:21:03 <tommylike_321> monkey +1
09:21:08 <zengchen> saggi:ok
09:21:34 <zengchen> do you have seen it.
09:21:59 <yuval> zengchen: sounds like a good idea
09:22:32 <saggi> zengchen: It's a great idea
09:22:41 <saggi> Looks simple enough to implement
09:22:53 <saggi> and have it retrofitted so we don't need the threaded one
09:22:59 <zengchen> yuval:ok, if you all agree with it, i will try to implement it.
09:23:13 <saggi> zengchen: will it come instead of the threaded one
09:23:14 <saggi> ?
09:23:50 <zengchen> saggi:we can keep the thead, because we can set the config to choose which to be used.
09:23:51 <zhonghua-lee> is it a addition or default?
09:24:22 <zengchen> zhonghua-lee:i suggest to be default.
09:24:28 <saggi> isn't the green thread one more powerful. Why would you want the threaded one?
09:24:44 <zhonghua-lee> zengchen: thanks
09:24:51 <chenying> I only care about the executor whether meet all the test scene of engine.
09:25:21 <zengchen> saggi:you mean delete the codes of thread?
09:25:30 <saggi> yes
09:26:14 <zengchen> saggi:i suggest to wait a time. when the new executor runs, we can try to delete it.
09:26:34 <zhangshuai_> +1
09:26:38 <saggi> zengchen: OK, but I'd rather not have a lot of code goes unused.
09:27:09 <zengchen> saggi:ok, i will keep the codes clean.
09:27:38 <saggi> # topic Scheduled Operation Improvements Proposal
09:27:45 <saggi> ping xiangxinyong
09:27:53 <xiangxinyong> hello saggi
09:28:01 <xiangxinyong> https://etherpad.openstack.org/p/scheduledoperation
09:28:16 <xiangxinyong> could you take a look at this link?
09:28:22 <saggi> I already did
09:28:26 <xiangxinyong> thanks
09:28:54 <gsagie> So what is Smaug mascot?
09:28:58 <gsagie> Chenying?
09:29:20 <xiangxinyong> saggi:what do you think about it?
09:29:28 <chenying> We will add the suggested mascot to the link.
09:29:29 <saggi> It's fine by me as long as you can set retention time and max checkpoint to be infinite
09:29:37 <chenying> https://etherpad.openstack.org/p/smaugmascot
09:29:47 <zhonghua-lee> I think it's reasonable to add the description
09:30:02 <saggi> gsagie: We already selected a mascot: https://media.licdn.com/media/p/2/000/18e/3dd/1d99b9c.jpg
09:30:34 <xiangxinyong> yeah. i need to add description into scheduled operation
09:30:38 <yuval> saggi: :P:
09:30:51 <zengchen> xingxinyong:+1
09:31:07 <zhangshuai_> xiangxinuong:+1
09:31:15 <saggi> xiangxinyong: +1
09:31:25 <saggi> The rest can be added if they are optional
09:31:25 <xiangxinyong> saggi: about retention_duration and max_backups
09:31:43 <chenying> add description into scheduled operation--- I also think add the description filed to other resources. like plan resotre
09:31:57 <xiangxinyong> yeah. description is optinal
09:32:02 <zhonghua-lee> chenying:+1
09:32:07 <saggi> chenying: Also retention and max_backups
09:32:15 <saggi> xiangxinyong:
09:32:20 <saggi> should be optional
09:32:27 <chenying> name  and  description field have different meaning.
09:33:06 <saggi> xiangxinyong: I think we are all in agreement that these are good additions as long as they are optional.
09:33:16 <chenying> yes it is optional
09:33:16 <xiangxinyong> understood.
09:33:21 <saggi> Is retention time per checkpoint?
09:33:39 <xiangxinyong> but how to implement max_backups and retention_duration for scheduled operation?
09:33:47 <xiangxinyong> do you have some suggestions?
09:34:09 <zhonghua-lee> add new Operation?
09:34:17 <saggi> You run the operation periodically looking for checkpoints that you created that are older than duration.
09:34:57 <saggi> You will need to keep record of all created checkpoints in the operation db since querying the bank is slow.
09:35:13 <yuval> I don't understand: if I manually create a checkpoint, and then later a scheduled operation is defined with max_backups, it may delete my checkpoint?
09:35:31 <saggi> If it was created by this operation
09:35:47 <xiangxinyong> I guess we need to launch a delete checkpoint request from the operation engine service
09:35:50 <zhonghua-lee> saggi: who will trigger this operation? Operation engine?
09:35:55 <saggi> yes
09:36:01 <saggi> Since it's policy
09:36:07 <xiangxinyong> I guess operation engine service will trigger
09:36:41 <chenying> all  retention time and max backups are the parameters of policys.
09:37:43 <xiangxinyong> OK. I will write a spec about this features
09:38:03 <xiangxinyong> thanks guys
09:38:05 <zhonghua-lee> xiangxinyong:+1
09:38:29 <chenying> xiangxinyong:+1 need a spec about these parameters.
09:38:31 <zhonghua-lee> xiangxinyong: some guys may want to know the detaild flow
09:38:42 <yuval> How will the scheduled operation find all the checkpoints?
09:38:54 <yuval> originated from it?
09:38:57 <chenying> call the list checkpoint api
09:39:12 <xiangxinyong> chengying:+1
09:39:14 <saggi> yuval: When it creates the checkpoint it will need to keep the ID returned
09:39:26 <yuval> chenying: and list ALL checkpoints?
09:39:32 <yuval> chenying: we don't have filter on metadata
09:39:43 <yuval> saggi: keep where?
09:39:49 <saggi> operation engine db
09:39:53 <xiangxinyong> yuval: but i guess we filter it by plan
09:39:55 <saggi> Since it's local
09:40:24 <chenying> make sure we have save the checkpoint id to the operation engine db
09:40:46 <chenying> not the operation engine db some operation db table.
09:40:59 <zhonghua-lee> xiangxinyong: do you consider the use case: user can create it manually
09:41:17 <zengchen> i suggest xiangxinyong give a complete desgin.
09:41:21 <saggi> Don't design anything that filters the checkpoints. It won't scale until we decide on a querying mechanism. This will only happen for P-version, not Newton.
09:41:25 <saggi> zengchen: +1
09:41:58 <xiangxinyong> zhonghua-lee: yeah. The requirement is only about the scheduled protection
09:42:28 <xiangxinyong> OK.guys. I will specify a spec about this feature
09:42:30 <zhonghua-lee> xiangxinyong: so it is just a policy, not for the protection resource
09:42:50 <saggi> #action xiangxinyong write a BP on advance backup policy
09:42:58 <saggi> #topic Volume OPTIONS_SCHEMA Improvements Proposal
09:43:38 <saggi> Don't Huawei implement this through Cinder Backup?
09:43:52 <chenying> i note that SAVE_SCHEMA not being used when creat checkpoint data.
09:44:11 <xiangxinyong> saggi: there is some differenece
09:44:46 <xiangxinyong> we could add emc volume plugin or eisoo volume plugin.
09:45:12 <xiangxinyong> https://etherpad.openstack.org/p/volumeschema
09:45:26 <xiangxinyong> guys,please review it. thanks
09:45:30 <saggi> xiangxinyong: I would like to have everything else in the reference implementation working perfectly before adding new protection plugins.
09:45:39 <saggi> Also we need these to be tested as well
09:45:52 <saggi> I the full stack tests
09:46:46 <yuval> xiangxinyong: you want these to be added to the default cinder protection plugin?
09:47:47 <xiangxinyong> yuval: yeah. I want to add a new protection volume plugin
09:48:01 <saggi> xiangxinyong: Id
09:48:49 <xiangxinyong> saggi:?
09:48:55 <saggi> xiangxinyong: I'd rather wait with alternative plugins until we have everything we gurantee for v1 solid..
09:49:13 <zhonghua-lee> saggi:+1
09:49:32 <zhonghua-lee> saggi: do we accept other vendors to join us?
09:49:46 <xiangxinyong> saggi: good suggestions
09:49:53 <saggi> zhonghua-lee: Sure, everyone is invited
09:50:06 <zhonghua-lee> espacially the backup vendors
09:50:19 <zhonghua-lee> saggi: :)
09:50:33 <saggi> And if they spend the time on their plugins it's OK. But we, as the core team, should concentrate on the core for now.
09:50:45 <chenying> I think verdor can add their plugins. Like backup software verdor can add ther plugins.
09:50:54 <saggi> We also need to take the Cinder route and only accept plugins with proper tests and CI
09:51:04 <zhonghua-lee> saggi: OK
09:51:25 <saggi> Otherwise we have to do all the testing ourselves, which doesn't scale.
09:51:44 <zhonghua-lee> saggi:+1
09:52:57 <zhonghua-lee> according the conclusion, I think we prefer to delay this proposal
09:53:22 <yizhihui> when will v1 solid?
09:53:46 <saggi> When N is stable hopefully
09:53:53 <saggi> That the target
09:54:26 <zhonghua-lee> yizhihui: why you ask this question?
09:54:51 <zhonghua-lee> yizhihui: do you have any plan to add your plug-in?
09:55:17 <yizhihui> yes
09:55:27 <saggi> If we get there sooner we can tag and start building v2. BTW, v2 roadmap will be discussed at Bacelona.
09:55:42 <chenying> <yizhihui is from a backup software vendors. They plan to develop a new plugin about app backup.
09:56:02 <zhonghua-lee> saggi: yizhihui: I guess you can add it as you please
09:56:14 <saggi> roadmap is here https://etherpad.openstack.org/p/smaug
09:56:15 <zhonghua-lee> saggi: what's your opinion?
09:56:21 <yizhihui> ok
09:56:27 <saggi> zhonghua-lee: about what?
09:56:57 <zhonghua-lee> saggi: yizhihui is from 3rd backup vendor, he wants to add a plug-in into Smaug
09:57:09 <zhonghua-lee> saggi: can he add it now?
09:57:43 <saggi> You can add anything to Ocata. it's just candidates
09:57:57 <saggi> We will filter the list in Barcelona
09:58:30 <zhonghua-lee> saggi:OK
09:59:01 <saggi> We will accept 3rd party plugin code even now. But we can't gurantee it will ship as supported in N.
09:59:32 <saggi> Also, it will require dedication as things are moving fast and breakage may oocure in the plugin interface before N.
09:59:36 <yizhihui> saggi: I got it
09:59:39 <zhonghua-lee> saggi: +1
10:00:03 <saggi> We are out of time
10:00:18 <saggi> #topic open discussion
10:00:20 <yuval> mascot?
10:00:21 <saggi> any last words?
10:01:08 <saggi> Thank you everybody
10:01:12 <xiangxinyong> Thanks
10:01:14 <zhonghua-lee> thanks
10:01:15 <xiangxinyong> good bye
10:01:16 <saggi> yizhihui: Hope to see you next time as well
10:01:18 <saggi> :)
10:01:23 <saggi> #endmeeting