16:01:07 <adrian_otto> #startmeeting Solum Team Meeting
16:01:07 <openstack> Meeting ended Tue Dec 17 16:01:04 2013 UTC.  Information about MeetBot at http://wiki.debian.org/MeetBot . (v 0.1.4)
16:01:08 <openstack> Minutes:        http://eavesdrop.openstack.org/meetings/marconi/2013/marconi.2013-12-17-15.11.html
16:01:09 <openstack> Minutes (text): http://eavesdrop.openstack.org/meetings/marconi/2013/marconi.2013-12-17-15.11.txt
16:01:11 <openstack> Log:            http://eavesdrop.openstack.org/meetings/marconi/2013/marconi.2013-12-17-15.11.log.html
16:01:12 <openstack> Meeting started Tue Dec 17 16:01:07 2013 UTC and is due to finish in 60 minutes.  The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:15 <openstack> The meeting name has been set to 'solum_team_meeting'
16:01:15 <adrian_otto> welcome everyone
16:01:20 <kgriffs> alcabrera: can you snag those minutes?
16:01:24 <alcabrera> kgriffs: will do
16:01:27 <adrian_otto> #topic Roll Call
16:01:32 <funzo> Chris Alfonso
16:01:34 <coolsvap> Swapnil
16:01:36 <tomblank1> tom blankenship
16:01:36 <kgriffs> Kurt G. o/
16:01:36 <adrian_otto> Adrian Otto
16:01:37 <gokrokve> Georgy Okrokvertskhov
16:01:42 <noorul> Noorul
16:01:43 <paulmo> Paul Montgomery
16:02:03 <devkulkarni> Devdatta
16:03:29 <adrian_otto> ok, while we are waiting for a few more participants to join, I'd like you to think about meeting schedule for Dec 24 and Dec 31.
16:03:58 <adrian_otto> I will be on vacation those days, and think those are good days to cancel
16:04:04 <adrian_otto> as many of us will be out
16:04:34 <rajdeep> rajdeep joined
16:05:28 <muralia> murali
16:05:33 <adrian_otto> I would still like to arrange an update that we can send to the ML for those of us who will continue working. You could possibly email all your updates, and I could post them to the ML in a single status update, or we could post status only to the Wiki. How do you all feel about that?
16:06:01 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Solum Our Agenda
16:06:33 <adrian_otto> ^^ perhaps we could actually put our status there in lieu of holding meetings on those dates?
16:06:42 <paulmo> +1
16:07:22 <adrian_otto> any objections to this approach? I know a gap of 3 weeks is pretty long, so I want to be sure you are all happy with this.
16:07:35 <devkulkarni> +1 to wiki
16:07:53 <tomblank1> adrian_otto: +1 on canceling the meetings but posting updates/status
16:07:59 <muralia> +1
16:08:02 <coolsvap> +1
16:08:15 <adrian_otto> topic #Announcements
16:08:58 <adrian_otto> #agreed meetings for 2013-12-24 and 2013-12-31 will not be held by IRC, but status will be posted by each stakeholder at https://wiki.openstack.org/wiki/Meetings/Solum
16:09:28 <adrian_otto> Adrian will be on vacation Dec 23-Jan 8
16:09:41 <adrian_otto> travelling internationally, reading email.
16:09:58 <adrian_otto> any announcements other team members would like to make?
16:10:36 <adrian_otto> ok, if you think of anything we can address them in the Open DIscussion section
16:10:39 <adrian_otto> #topic Review Blueprints
16:10:49 <adrian_otto> before I dive in here
16:11:09 <adrian_otto> I expect the last one on this list will require some meaningful time to discuss
16:11:24 <adrian_otto> most of our other topics probably have updates that are pretty short
16:11:38 <adrian_otto> #link https://launchpad.net/solum/+milestone/milestone-1 Blueprints for milestone-1
16:12:01 <adrian_otto> note that I do plan to split the logging blueprint, which paulmo will mention in a moment
16:12:27 <adrian_otto> a more narrow scope will be targeted for milestone-1 and a wider scope will be targeted to a future milestone
16:12:31 <paulmo> (I added notes to the logging bp about that)
16:12:37 <adrian_otto> here we go...
16:12:38 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/api Solum API (aotto)
16:12:45 <adrian_otto> #link https://wiki.openstack.org/wiki/Solum/API was edited to include plan resources, and eliminate camelCase
16:13:04 <adrian_otto> note that there is a difference between plan *files* and plan resources
16:13:24 <noorul> I see that we have documents scattered on etherpad and Wiki
16:13:24 <adrian_otto> the wiki page above calls out that difference. I will propose a separate blueprint/spec for the plan files
16:13:40 <devkulkarni> Whiteboard list is huge.
16:13:43 <adrian_otto> yes, the etherpads will be consolidated into wiki pages
16:14:05 <adrian_otto> specifically:
16:14:06 <adrian_otto> #link https://etherpad.openstack.org/p/solum-api-spec-review will yield new blueprints for PATCH, pagination, resource query/parameters, etc
16:14:14 <adrian_otto> #link https://etherpad.openstack.org/p/solum-demystified will yield a new blueprint for plan files
16:14:49 <devkulkarni> At the end of this splitting I think we will get a better idea of the big picture from end to end perspective
16:16:37 <adrian_otto1> whoops, network glitch
16:17:12 <adrian_otto> devkulkarni: did I miss anything after your remark?
16:17:36 <paulmo> Nothing else was typed
16:17:44 <adrian_otto> ok, next BP then
16:17:46 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/solum-minimal-cli Command Line Interface for Solum (devdatta-kulkarni)
16:17:48 <devkulkarni> no, there was a network glitch effect on this side as well..
16:18:03 <devkulkarni> okay, so there is not much update on this.
16:18:13 <devkulkarni> I will be getting together with Noorul to understand his PR
16:18:17 <rajdeep> perhaps having a few sequence diagrams in addition to demystified doc would help
16:18:19 <devkulkarni> and take it from there
16:18:37 <adrian_otto> ok, thanks
16:18:45 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/solum-git-pull Pull integration of Solum from an external Git repo (kraman)
16:19:25 <devkulkarni> If kraman is not around, I can give an update from the git-integration working group meeting
16:19:48 <devkulkarni> Okay, here goes..
16:19:54 <adrian_otto> funzo: are we expecting kraman?
16:20:12 <funzo> adrian_otto: I haven't talked to him. I'll see if I can get him
16:20:18 <adrian_otto> devkulkarni: ok, proceed, and if kraman arrives, he can add to your update.
16:20:23 <devkulkarni> So the main discussions were whether Zuul can be used for all of Solum's workflow needs..
16:20:59 <devkulkarni> kraman and mordered have done some work with regards to understanding Zuul.
16:21:19 <funzo> adrian_otto: on his way
16:21:26 <adrian_otto> funzo: tx!
16:21:57 <devkulkarni> We have agreed to using zuul for git integration (pull and push)
16:21:57 <devkulkarni> but zuul may not be a right fit for deploying DU workflow
16:22:03 <devkulkarni> after a POC around zuul we will be able to know for sure though.
16:22:20 <devkulkarni> that was about it from the meeting
16:22:25 <adrian_otto> ok, that's promising!
16:22:26 <funzo> adrian_otto: he's here
16:22:39 <adrian_otto> hi kraman1
16:22:44 <kraman1> hi
16:22:54 <adrian_otto> we are doing an update on solum-git-pull
16:23:05 <kraman1> i had a conversation with monty after the git meeting as well
16:23:09 <adrian_otto> devkulkarni has summarized about the Zuul discussion
16:23:17 <kraman1> we discussed in detail about how zuul will be used
16:23:27 <kraman1> and I will be taking to rest of working group tomorrow
16:23:41 <kraman1> we should have a clear picture about how to proceed after tomorrow atleast for milestone 1
16:23:49 <kraman1> devkulkarni: thanks for summarizing
16:24:01 <devkulkarni> kraman1: cool
16:24:05 <adrian_otto> kraman1 and devkulkarni: ok, anything more you want to mention today?
16:24:19 <kraman1> adrian_otto: no, that was it for today.
16:24:27 <adrian_otto> do we have any code review posted for anything?
16:24:31 <adrian_otto> git related
16:24:48 <adrian_otto> or anyone planning to start code soon?
16:24:51 <kraman1> adrian_otto: no code yet. after tomorrow's meeting. will start developing a prototype
16:24:57 <adrian_otto> ok, tx
16:25:02 <adrian_otto> next BP...
16:25:08 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/user-authentication User authentication for incoming requests (gokrokvertskhov)
16:25:18 <adrian_otto> #link https://review.openstack.org/58811
16:25:38 <gokrokve> Its done. Just blocked by Nooril's tests patch.
16:25:52 <devkulkarni> This looks good to merge after adding back test_functional.py I guess
16:25:56 <noorul> gokrokve: What do you mean by blocked?
16:26:01 <adrian_otto> ok, please link us to that so we can take a quick peek, please?
16:26:10 <gokrokve> You put -1 for some reason.
16:26:18 <noorul> There is a valid reason
16:26:23 <rajdeep> one question on keystone integration
16:26:33 <rajdeep> any special roles for solum users?
16:26:52 <gokrokve> Nothing special yet for keystone.
16:27:07 <gokrokve> Just validation of supplied token.
16:27:08 <noorul> I think all you have to do is to remove test_functional.py deletion from your patch
16:27:32 <rajdeep> ok thanks
16:28:18 <adrian_otto> rajdeep: we expect to have an RBAC setup for future milestones
16:28:23 <gokrokve> noorul: If I remove it I will have to wait for your patch. Which means I cant merge it before your patch. So its blocked.
16:28:33 <adrian_otto> gokrokve: you set on the direction for overcoming the remaining −1 on the 58811 patch?
16:28:34 <gokrokve> That is fine
16:28:53 <adrian_otto> it sounds to me like there is actually no dispute on it
16:28:56 <noorul> gokrokve: Why do you have to wait for my patch?
16:29:16 <gokrokve> Because test_functional will fail at the gate.
16:29:26 <gokrokve> I removed it for a reason.
16:29:53 <noorul> But I don't see the reason in commit log
16:30:33 <gokrokve> If you take a look on my previous path you will se that I rewrote test_functional to work in functional tests. You did the saeme.
16:30:48 <gokrokve> Ok. I will add this info to commit log.
16:31:19 <adrian_otto> ok, so noorul and gokrokve, are you willing to regroup after our meeting (at some mutually convenient time) and hash this out further so we can get to a nice merge point?
16:31:33 <gokrokve> Sure.
16:31:46 <adrian_otto> it sounds like a bit of working together can get us through the last bit of this.
16:31:48 <gokrokve> We just need to sync our patches to merge them in proper order.
16:31:49 <adrian_otto> thanks guys.
16:32:00 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/specify-lang-pack Specify the language pack to be used for app deploy (devdatta-kulkarni)
16:32:20 <devkulkarni> I have a WIP for this.
16:32:28 <adrian_otto> #link https://review.openstack.org/62548
16:32:33 <adrian_otto> ^^ the WIP
16:32:47 <devkulkarni> Clayton had some comments about the attributes of a LP
16:32:50 <devkulkarni> Will be syncing up with him today/tomorrow
16:33:05 <devkulkarni> The WIP will change based on comments to Murali's WIP
16:33:29 <devkulkarni> Also, I need to integrate with the nova object model from Clayton's recently merged patch
16:34:14 <adrian_otto> ok, any more on this one?
16:34:16 <gokrokve> Angus mentined that datamodel is not versioned.
16:34:25 <devkulkarni> Thats pretty much it
16:34:27 <adrian_otto> I did not understand that remark
16:34:34 <muralia> devkulkarni: lets work together on that. i need to integrate with nova objects too.
16:34:41 <devkulkarni> gokrokve: yep. saw that comment on muralia's wip
16:34:46 <devkulkarni> muralia: +1
16:35:07 <muralia> the datamodel was moved out of api/v1
16:35:20 <muralia> in my WIP. we need to move that back under v1
16:35:21 <devkulkarni> will work with muralia on nova objects and datamodel versioning changes
16:35:38 <muralia> for versioning.
16:35:41 <gokrokve> Ok.
16:35:50 <devkulkarni> muralia: yep
16:35:55 <adrian_otto> oh, don't we want it to be versioned
16:36:07 <adrian_otto> ok
16:36:09 <muralia> yes we do.
16:36:13 <adrian_otto> ready for the next one?
16:36:17 <gokrokve> Why do we need additional handlers and dispatchers for services?
16:36:17 <devkulkarni> we do want it to be versioned.
16:36:34 <gokrokve> It looks overcomplicated.
16:36:39 <devkulkarni> although, we also want to separate the wsme objects from Solum
16:36:44 <devkulkarni> internal objects
16:36:57 <adrian_otto> gokrokve: we will discuss the api worker blueprint in just a moment
16:37:07 <gokrokve> ok
16:37:12 <adrian_otto> so let's revisit that in just a moment
16:37:15 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/logging Logging Architecture (paulmo)
16:37:35 <devkulkarni> adrian_otto: yes, ready for the next one
16:37:40 <paulmo> I am proposing that we split the logging requirements into an M1 blueprint and a potential future >=M2 blueprint
16:37:45 <adrian_otto> devkulkarni: tx
16:38:11 <paulmo> As long as everyone agrees to the following logging rules (that we continue to follow as Clayton already has examples of): https://wiki.openstack.org/wiki/Solum/Logging
16:38:13 <adrian_otto> paulmo: do you want to split it, or would you like me to?
16:38:30 <adrian_otto> I see you made a comment in the whiteboard
16:38:44 <paulmo> I can (if we need).  The reason for the split is to not hold up M1 and to give me some time to track down the potential changes to Oslo log that I keep hearing rumors of.  I want to sync and not duplicate work.
16:39:05 <adrian_otto> seems reasonable to me
16:39:26 <paulmo> The final part is that we will need unique user identification in the logs (tenant/project ID, etc).  Do we want to shoot for M1 for that since RBAC and database isn't fully there for a while?
16:39:28 <adrian_otto> ok, let me know if you'd like my assistance at all
16:39:57 <adrian_otto> next one
16:39:57 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/api-worker-architecture API service/worker architecture for async operation (murali-allada)
16:40:15 <muralia> did everyone get a chance to take a look at my WIP. https://review.openstack.org/#/c/62466/
16:40:23 <muralia> if not, please do and give me your feedback.
16:40:43 <muralia> The basic idea is to get us to a point where api requests are reading from the DB
16:40:58 <muralia> I've already got some nice comments
16:41:10 <muralia> one interesting comment from angus
16:41:14 <devkulkarni> Any specific files that we should look at for Clayton's examples?
16:41:32 <noorul> Does WIP really gets reviewed?
16:41:48 <muralia> WIPs should get reviewed.
16:41:56 <muralia> to comment on the general direction of the work
16:42:15 <muralia> devkulkarni: the handlers is where we would integrate with claytons work
16:42:43 <muralia> one comment I got from angus was that there is a lot of indirection in this code. with no value.
16:43:11 <muralia> i agree that we dont see it right now, but theres a reason to break it up into a controller/dispatcher/handler model.
16:43:14 <noorul> https://review.openstack.org/#/c/62466/
16:43:18 <noorul> That has -1 from Jenkins
16:43:50 <devkulkarni> muralia: thanks. I was actually asking for specific files to look at for logging examples.
16:43:51 <muralia> right now all method calls are just pass throughs, but we have place holders for adding queues
16:44:03 <muralia> authentication and db integration
16:44:36 <muralia> devkulkarni: let me look at some files and give you some pointers.
16:44:42 <devkulkarni> we do need decoupling and separation between controllers and things that will actually query db.
16:45:10 <devkulkarni> The "service" layer would be the place where we do all the logic, if any.
16:45:36 <devkulkarni> So at a minimum I do see the following arch: controllers -> services -> db
16:45:37 <claytonc> devkulkarni: what sort of coupling are you imagining?
16:45:37 <muralia> noorul: yes, jenkins −1'd is. I'm still working on the code, but wanted to put it out there as devkulkarni was working on some work that needs this.
16:45:47 <claytonc> devkulkarni: compositional style calls?
16:46:04 <claytonc> Command pattern style services?
16:46:20 <adrian_otto> muralia: did you follow up with asalkeld about his remarks?
16:46:34 <devkulkarni> claytonc: just separation of concerns actually. controllers should not do any more logic than basic error checking
16:46:44 <muralia> adrian_otto: not yet. i plan to do that today
16:46:51 <adrian_otto> I encourage you to chat with him in #solum and fully explore the concern.
16:47:00 <muralia> yup.
16:47:06 <adrian_otto> and reach some consensus. Thanks.
16:47:08 <noorul> muralia: If you can split this into multiple patches then it will be easy for reviewers
16:47:10 <claytonc> devkulkarni: for simple CRUD it's probably reasonable we should be doing a bare minimum of work in controller, and let the object model handle the details
16:47:16 <claytonc> for more complex flows completely agree
16:47:19 <muralia> noorul: agreed.
16:47:24 <claytonc> for an abstraction around "process"
16:47:35 <devkulkarni> claytonc: either compositional or command/control.. don't know which pattern is the best for us yet.
16:48:01 <devkulkarni> claytonc: was about to say that.. based on your merged work, we need to revisit this
16:48:23 <claytonc> devkulkarni: +1
16:48:49 <adrian_otto> ok
16:48:52 <adrian_otto> #topic Open Discussion
16:49:01 <adrian_otto> I have one thing for this
16:49:12 <paulmo> I have 3, hopefully quick items whenever I can fit in
16:49:23 <adrian_otto> Gate job for pypy fails on singledispatch. noorul, you mentioned we contacted an upstream somehow about this?
16:49:53 <noorul> adrian_otto: I meant, I submitted an issue in the tracker
16:50:26 * noorul is searching
16:50:37 <briancline> general question - what constitutes a working group, and how does one become a part of one?
16:50:40 <noorul> https://bitbucket.org/ambv/singledispatch/issue/1/failed-to-install-on-pypy-202
16:52:30 <adrian_otto1> I got dropped off the network again, sorry
16:52:41 <noorul> adrian_otto: https://bitbucket.org/ambv/singledispatch/issue/1/failed-to-install-on-pypy-202
16:52:50 <adrian_otto> noorul: thanks!!
16:52:51 <claytonc> briancline: just attend the meetings
16:52:55 <claytonc> they're discussed on the public ML
16:53:11 <claytonc> it's a subgroup of folks working to hammer out specific details for blueprints
16:53:13 <funzo> briancline: and you can joing the blueprints for update notifications
16:54:06 <devkulkarni> The working group meeting times are on the Wiki, right adrian_otto? If not, we should add them.
16:54:48 <adrian_otto> devkulkarni: yes, on the Breakout Meetings wiki page
16:55:18 <adrian_otto> paulmo: did you get in everything you wanted to mention?
16:55:28 <paulmo> I had a few items
16:55:50 <paulmo> First, I just wanted to link the new security requirements page that I've been working on (and continue to do so): https://wiki.openstack.org/wiki/Solum/SecurityRequirements
16:55:53 <adrian_otto> #link https://wiki.openstack.org/wiki/Solum/BreakoutMeetings meeting schedule
16:56:01 <adrian_otto> ^^ devkulkarni
16:56:09 <paulmo> I'll likely be reviewing using that as a source in the future.
16:56:29 <adrian_otto> paulmo: that's a really impressive wiki page
16:56:33 <paulmo> 2nd, is it possible to get an agreed on logging requirements? https://wiki.openstack.org/wiki/Solum/Logging
16:57:02 <paulmo> Thanks, on the first page there, if you want to review and link a specific topic, use the links on the first column like this: https://wiki.openstack.org/wiki/Solum/SecurityRequirements#git_pull_regex
16:58:13 <paulmo> Just for clarity, relinking the 2nd wiki, the logging requirements: https://wiki.openstack.org/wiki/Solum/Logging
16:58:27 <paulmo> Have we discussed this enough to get an agreed
16:58:29 <paulmo> ?
16:58:38 <adrian_otto> I like the Solum/Logging requirements
16:58:42 <adrian_otto> anyone disagree?
16:59:17 <devkulkarni> I think folks will need time to go through these before voting to agree
16:59:18 <paulmo> (last week, nobody disagreed so trying my luck a little farther this week) :)
16:59:18 <gokrokve> Looks great.
16:59:36 <rajdeep> quick question..anything we are leveraging from oslo for logging
16:59:45 <paulmo> Yes, all Oslo log
16:59:47 <adrian_otto> ok, paulmo we can revisit that at our next IRC meeting
16:59:52 <paulmo> Thanks!
17:00:07 <rajdeep> ok,thanks
17:00:10 <adrian_otto> next irc meeting is 2014-01-14
17:00:22 <adrian_otto> please put updates on wiki page between now and then, thanks!
17:00:24 <adrian_otto> #endmeeting