16:00:33 <adrian_otto> #startmeeting Solum Team Meeting
16:00:34 <openstack> Meeting started Tue Jan 28 16:00:33 2014 UTC and is due to finish in 60 minutes.  The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:38 <openstack> The meeting name has been set to 'solum_team_meeting'
16:00:54 <adrian_otto> #topic Agenda
16:01:03 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Solum#Agenda_for_2014-01-28_1600_UTC Our Agenda
16:01:10 <adrian_otto> #topic Roll Call
16:01:14 <adrian_otto> Adrian Otto
16:01:15 <paulmo_> Paul Montgomery
16:01:18 <tomblank1> tom blankenship
16:01:18 <kraman> Krishna Raman
16:01:18 <stannie> Pierre Padrixe
16:01:19 <julienvey> Julien Vey
16:01:19 <Roshanagr> Roshan Agrawal
16:01:20 <muralia> murali allada
16:01:21 <nmarchenko> Nikita Marchenko, Mirantis
16:01:23 <paulczar> Paul Czarkowski
16:01:25 <coolsvap> Swapnil
16:01:30 <sapuri> Sandeep Puri, Cisco
16:01:33 <ycombinator> Shaunak Kashyap. Rackspace
16:01:37 <devkulkarni> Devdatta Kulkarni
16:01:50 <Roshanagr> Welcome Shaunak
16:02:06 <ycombinator> thanks!
16:02:15 <funzo> Chris
16:03:05 <adrian_otto> hello everyone
16:03:28 <adrian_otto> before I get started, devkulkarni mentioned I have an error in the agenda
16:03:44 <adrian_otto> I'd like to correct that, as it pertains to someone's name, and I really care about getting names right
16:03:53 <adrian_otto> devkulkarni: where is the error?
16:04:11 <devkulkarni> asalkeld's name has typo
16:04:30 <adrian_otto> ok, fixed, thanks for telling me!
16:04:54 <adrian_otto> btw, I am pretty stoked with our attendance today
16:05:00 <adrian_otto> #topic Announcements
16:05:08 <adrian_otto> 1) Core reviewer updates
16:05:13 <adrian_otto> +asalkeld
16:05:13 <adrian_otto> +noorul
16:05:13 <adrian_otto> -mordred
16:05:27 <adrian_otto> Welcome to Angus and Noorul as core reviewers
16:05:41 <adrian_otto> I will be continuing to add more at a steady pace to track with our growth
16:06:07 <adrian_otto> so if you are interested in becoming a core reviewer I am happy to guide you on that track
16:06:10 <adrian_otto> just let me know
16:06:26 <adrian_otto> 2) New Contributors from Numergy (France)
16:06:36 <adrian_otto> Pierre Padrixe and Juien Vey
16:06:40 <adrian_otto> welcome guys.
16:06:42 <devkulkarni> welcome folks
16:06:46 <stannie> thanks :)
16:06:49 <julienvey> Thanks guys :)
16:06:53 <kraman> hi
16:06:58 <muralia> welcome guys
16:06:59 <Roshanagr> Welcome !
16:07:03 <adrian_otto> Pierre and Julien have expressed an interest in helping us finish up our API
16:07:17 <adrian_otto> so we are really happy to add them to our team
16:07:35 <paulmo_> Yay
16:07:39 <paulmo_> :)
16:07:42 <adrian_otto> ok, we will hear more from them toward the end of the agenda
16:07:52 <adrian_otto> next up, as a matter of formality, action item review
16:07:56 <adrian_otto> I know we pushed this one
16:08:00 <adrian_otto> #topic Review Action Items (from last week's meting)
16:08:07 * adrian_otto paulmo to schedule follow up IRC chat about Security Context (adrian_otto, 16:13:17)
16:08:12 * adrian_otto paulmo to add Logging Features to the Security Context followup meeting agenda (adrian_otto, 16:15:38)
16:08:34 <adrian_otto> paulmo, would you like to take one of these again for this week?
16:08:48 <paulmo_> This took a bunch of research getting up to speed on all of the Oslo code but I believe I have wiki that shows the most probably options
16:09:07 <adrian_otto> do we still need an interactive discussion, or will the ML suffice?
16:09:13 <paulmo_> ... and sent out an email to the mailing list to try to come to a conclusion
16:09:21 <adrian_otto> I have this on the agenda at the end as well
16:09:30 <adrian_otto> so we can dive deeper, time permitting
16:09:32 <paulmo_> I've had a hard time getting everyone scheduled at once... I hope the email can work for now as I catch people when they are on from their own timezones. :)
16:09:43 <adrian_otto> ok, thank Paul
16:09:46 <adrian_otto> thanks
16:09:54 <adrian_otto> #topic Splitting API Work into additional sub-blueprints
16:10:13 <adrian_otto> clearly the API is going to have lots of work done on it
16:10:26 <adrian_otto> we can probably afford some more blueprints detailing additional aspects of that work
16:10:31 <adrian_otto> Any objections to splitting the API blueprint into additional work items?
16:10:44 <devkulkarni> sounds good to me
16:10:49 <paulmo_> More granular is probably better
16:10:54 <muralia> we should have blueprints for each resource.
16:11:06 <adrian_otto> muralia: agreed
16:11:07 <devkulkarni> +1 muralia
16:11:23 <muralia> I need to update the main api blueprint to reflect the latest architecture. and then link to other blueprints.
16:11:23 <julienvey> I agree with muralia
16:11:24 <stannie> +1 for each resource
16:11:36 <adrian_otto> okay, I will take that on as an action item unless someone else loves administrative work more than me
16:11:36 <tomblank1> +1 muralia
16:12:05 <muralia> i'm working on assembly and component. i'll have 2 new blueprints for each. julien and pierre already have blueprints for sonsors
16:12:13 <muralia> i'll link to those as well.
16:12:22 <adrian_otto> #action adrian_otto to create blueprints for each of the API REST Resources
16:12:50 <adrian_otto> ok, that should give us some good hooks to hang additional design work
16:13:02 <adrian_otto> in addition to:
16:13:02 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/api Solum API (aotto)
16:13:24 <adrian_otto> this week, to recognize some of our progress, we had some good contributions
16:13:26 <adrian_otto> Several reviews were submitted/merged for API functionality.
16:13:33 <adrian_otto> Language Packs, and Services by Arati, including https://review.openstack.org/#/c/69407/ (MERGED)
16:13:38 <adrian_otto> Database functionality by Angus and Murali
16:13:56 <adrian_otto> so we are at a point were we can start to make this all come together nicely
16:14:04 <adrian_otto> thanks for your continued contributions
16:14:30 <adrian_otto> #topic Review Blueprints: https://launchpad.net/solum/+milestone/milestone-1
16:14:51 <adrian_otto> we just covered the API bits, unless there are any further questions on that one
16:15:09 <adrian_otto> ok, next up is language packs
16:15:23 <adrian_otto> i mean CLI,
16:15:27 <adrian_otto> just kidding!
16:15:31 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/solum-minimal-cli Command Line Interface for Solum (devdatta-kulkarni)
16:15:43 <adrian_otto> we have two reviews open for this
16:15:45 <adrian_otto> https://review.openstack.org/66617 (paulmo) [WIP]
16:15:50 <adrian_otto> https://review.openstack.org/58067 (noorul) [Pending Approval]
16:15:55 <adrian_otto> devkulkarni: any remarks?
16:16:09 <paulmo_> Yes, now with context/logging documented, this is my next focus to get that fixed up and mergable by tomorrow or the next day latest.
16:16:41 <devkulkarni> adrian_otto: did we decide to schedule the working group or now this is settled for M1?
16:16:42 <adrian_otto> paulmo_: awesome, tx
16:16:49 <devkulkarni> paulmo_: +1
16:17:22 <adrian_otto> if we have design items to discuss regarding the CLI, let me know
16:17:40 <adrian_otto> last week I concluded that there was not enough to justify a working group, but I am happy to revisit that
16:17:45 <devkulkarni> okay. my impression was there was overall agreement
16:17:51 <devkulkarni> yep
16:17:53 <paulmo_> I'm not sure if this is CLI M1 or not, but we don't have any delayed response command capabilities built in.
16:17:55 <adrian_otto> yes, I think we are in agreement
16:18:02 <adrian_otto> anyone think otherwise?
16:18:04 <paulmo_> (ie, requery for long running commands)
16:18:40 <adrian_otto> I see noorul is absent for the first time
16:18:49 <adrian_otto> I think he was expecting a new addition to his family
16:18:56 <adrian_otto> so he is probably attending to that
16:19:26 <adrian_otto> ok, next item
16:19:32 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/solum-git-pull Pull integration of Solum from an external Git repo (kraman)
16:19:59 <adrian_otto> kraman: any update on this one?
16:20:11 <kraman> yes
16:20:36 <kraman> i spoke to zuul core member last friday and walked through the proposed changes in the solum_hacks branch
16:20:54 <kraman> he agreed with the changes and suggested some additional things we could work on to incorporate better
16:21:05 <kraman> coolsvap is helping with some of that as well
16:21:13 <adrian_otto> oh, awesome
16:21:23 <kraman> and we will start working towards getting it into master
16:21:33 <adrian_otto> so is it time to submit reviews against zuul contributions in the openstack repo?
16:21:42 <kraman> yes
16:21:50 <kraman> after creating some unit tests :)
16:21:52 <adrian_otto> ok, that's a huge milestone
16:22:01 <adrian_otto> thanks for continuing to drive that
16:22:09 <kraman> there was another gap identified by devkulkarni yesterday connecting git-pull and LP workflows
16:22:09 <adrian_otto> anything you need from our team to support you?
16:22:21 <kraman> and we will need an api endpoint
16:22:30 <kraman> for triggering the zuul flow
16:22:50 <devkulkarni> I am synching up with kraman and coolsvap about this after this meeting in #solum if anyone is interested
16:22:54 <adrian_otto> by default we could use the same API endpoint that the Solum API is using, correct?
16:23:02 <kraman> yes
16:23:09 <kraman> basically something that an external git repo can post to to indicate a change
16:23:29 <adrian_otto> ok, so you are thinking of the case for large scale operators who may want to optionally break that out into a separate endpoint?
16:23:36 <kraman> and we need to tie up some pieces on the plan file side where we will store git repo location, branch details etc
16:23:40 <adrian_otto> or have I misunderstood your intent?
16:24:12 <kraman> adrian_otto: not exactly. i was just thinking that we need a rest endpoint that i can use as a trigger for zuul
16:24:22 <kraman> the large op case can come later
16:24:42 <adrian_otto> oh, is this an anon webhook requirement?
16:24:49 <kraman> yes
16:24:53 <adrian_otto> I see, ok
16:25:02 <kraman> same as we discussed before break
16:25:26 <adrian_otto> that may actually be something that Julien and/or Pierre may want to help out with
16:25:33 <kraman> I will send an email to ML later today outlining the full flow of control that I am picturing
16:25:44 <devkulkarni> kraman: +1
16:25:52 <adrian_otto> so I encourage you guys to check in and better understand the use case, and how we can solve that
16:26:09 <stannie> sure, adrian_otto
16:26:10 <kraman> thats it from my end
16:26:19 <adrian_otto> ok, next
16:26:20 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/specify-lang-pack Specify the language pack to be used for app deploy (devdatta-kulkarni)
16:26:26 <julienvey> yes sure !
16:26:28 <adrian_otto> #link https://review.openstack.org/62548 Defined a resource to query available language packs. (devdatta-kulkarni) [ABANDONED]
16:26:46 <devkulkarni> this was completed in another patch which is merged (by Arati)
16:27:01 <aratim> https://review.openstack.org/#/c/67292/10
16:27:11 <aratim> this is the new one, but not yet merged
16:27:23 <adrian_otto> https://review.openstack.org/67292 is not merged
16:27:29 <adrian_otto> is that the right contribution?
16:27:31 <devkulkarni> oh yeah, sorry about that
16:27:42 <adrian_otto> that is still labeled WIP
16:28:00 <aratim> oh yes, I will change that
16:28:06 <devkulkarni> WIP should be removed. I think asalkeld mentioned that as well
16:28:28 <aratim> I will submit the final patch today
16:28:54 <adrian_otto> ok, so I get the sense we are close to completing this feature
16:29:17 <devkulkarni> still the tables are remaining, right aratim?
16:29:42 <aratim> yes, I am also working on defining the schema for Language packs and Service
16:30:04 <aratim> That might take a couple of days
16:30:15 <devkulkarni> so the API side is close to be done adrian_otto
16:30:30 <adrian_otto> ok, cool
16:31:29 <adrian_otto> next bp
16:31:30 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/logging Logging Architecture (paulmo)
16:31:50 <paulmo_> That is combined with context basically on https://wiki.openstack.org/wiki/Solum/Logging
16:32:10 <paulmo_> I think logging and context now share the same fate. :)
16:32:18 <adrian_otto> ok, so we should have something to talk about in our next meeting on this topic
16:32:23 <paulmo_> Yes
16:32:23 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/solum-zuul-integration Solum integration with Zuul (devdatta-kulkarni)
16:32:29 <adrian_otto> we already discussed this one, I think
16:32:32 <devkulkarni> yes
16:32:35 <adrian_otto> I should combine them
16:32:39 <devkulkarni> +1
16:32:43 <adrian_otto> for next weeks agenda
16:33:04 <adrian_otto> We also had a bug fix this week that I want to recognize
16:33:06 <adrian_otto> #link https://review.openstack.org/#/c/67876/ Refactored api unit tests for DRY (bug/1260417) (nmarchenko) (MERGED)
16:33:09 <adrian_otto> thanks for that one
16:33:41 <adrian_otto> I earmarked a little time for a discussion on contexts. If we could timebox this to under 15 min, that would be helpful
16:33:43 <adrian_otto> #topic Discussion about contexts
16:33:52 <adrian_otto> some reference pointers:
16:33:54 <adrian_otto> #link http://lists.openstack.org/pipermail/openstack-dev/2014-January/025622.html
16:33:59 <adrian_otto> #link https://review.openstack.org/68086 Add context from olso-incubator (asalkeld) (MERGED)
16:34:06 <adrian_otto> #link https://review.openstack.org/63201 Centralized context class for holding "global" data (paulmo)
16:34:11 <adrian_otto> #link https://review.openstack.org/68856 Extend oslo context to include some custom fields (asalkeld)
16:34:38 <paulmo_> russellb, kgriffs, angus, and gokrokve have been the most involved in general.  I would really like input from all of them.
16:34:40 <adrian_otto> I know that asalkeld is not here, but wanted to give other team members a chance to weigh in, since this is currently an active discussion
16:35:20 <devkulkarni> based on the comments on the ML, I feel points made by gokrokve are valid.
16:36:19 <devkulkarni> so I would support option b)
16:36:25 <paulmo_> Since Angus mentioned that he wanted either plain Oslo (option A) or a completely separate implmentation.  This could be considered that non-Oslo option C: https://review.openstack.org/#/c/63201/
16:36:40 <adrian_otto> Angus mentioned yesterday in #solum that we could potentially think about the confidential data issues using some form of a logging context
16:36:46 <paulmo_> (it is linked in the option B section btw)
16:37:09 <devkulkarni> paulmo_: I thought non-oslo was not an option really
16:37:16 <adrian_otto> and that the request context could be kept minimalistic and only include the bits needed to process an incoming request.
16:37:34 <paulmo_> As did I, just added that since Angus mentioned a non-Oslo path (I don't think he is in favor of it though). :)
16:37:47 <devkulkarni> adrian_otto: so separate the request context from logging context.
16:38:15 <devkulkarni> does one of the above patches show this?
16:38:17 <paulmo_> In A and B, context is a separate class and must be passed into the logging function as a parameter.
16:38:25 <adrian_otto> that's an idea that asalkeld suggested we consider
16:38:53 <paulmo_> A is what Angus is talking about I believe in this case.
16:38:57 <adrian_otto> devkulkarni: no, these patches do not exhibit that concept
16:40:09 <adrian_otto> ok, sounds like we can advance to the last item on our agenda
16:40:15 <adrian_otto> #topic Open Discussion
16:40:46 <tomblank1> adrian_otto: i may have missed part of the discussion but have we made any decisions about alternating the timing of this meeting?
16:41:21 <adrian_otto> tomblank1: I did raise that subject last week
16:41:35 <adrian_otto> but I did not record an action item for it, sorry. I did not follow that up.
16:41:57 <adrian_otto> one idea we considered was alternating the time
16:42:41 <adrian_otto> but since we have core reviewers in 3 opposite timezones
16:43:05 <adrian_otto> unless we hold this in late evening hours for the US participants, someone is always asleep when the meeting is scheduled :-)
16:43:06 <tomblank1> adrian_otto: no problem.  understand it's hard... :)
16:43:38 <adrian_otto> There is a silver lining. The good news is that we can get code moved through just about any time around the clock.
16:43:55 <devkulkarni> :)
16:44:10 <adrian_otto> that may come in handy for defect repairs at some point
16:45:03 <devkulkarni> on another note, was there any follow up/updates on f2f meeting? I remember gokrokve had wanted one..
16:45:08 <adrian_otto> we might want to use an ML thread for further discussion on this
16:45:35 <adrian_otto> devkulkarni: one sec
16:46:19 <adrian_otto> #action adrian_otto to propose an alternate meeting time for the Solum team, potentially an alternating time schedule
16:46:30 <tomblank1> adrian_otto: +1 for ML thread
16:46:42 <adrian_otto> ok, I'll kick that off this week
16:46:55 <tomblank1> thanks!
16:47:06 <adrian_otto> on the subject of a F2F, what are all of your thoughts on having another such meeting, and were might be the best location to hold it
16:47:15 <adrian_otto> our last one was in November in San Francisco.
16:47:48 <paulmo_> Hawai... err Austin (we promise, the snow is behind us after today)
16:49:06 <adrian_otto> traditionally F2F meetings alternate among members of a collaboration, so are there contributors who have a facility suitable for hosting one?
16:49:22 <rajdeep> You want to do it india
16:49:24 <rajdeep> :)
16:49:28 <adrian_otto> if not, Rackspace is likely to volunteer a facility in Texas
16:49:34 <adrian_otto> rajdeep: :-)
16:50:09 <rajdeep> just keep in mind the time zone for
16:50:16 <rajdeep> people on hangouts
16:50:21 <paulczar> agree with paulmo Hawaii would be a good central place to meet
16:50:22 <devkulkarni> for the timing, my preference would be to hold it whenever we are close to delivering M1. if that turns out to be near the OS summit, then just meet at the summit
16:50:26 <adrian_otto> rajdeep: yes
16:50:58 <adrian_otto> I have a feeling we can knock out M1 sooner
16:51:56 <adrian_otto> how close to May's summit might we want to hold it?
16:52:03 <adrian_otto> 5 weeks before?
16:52:29 <adrian_otto> for reference: http://www.openstack.org/summit/openstack-summit-atlanta-2014/
16:52:58 <Roshanagr> A logical place could be immediately after wrapping M1, and use the F2F to M2 planning/design
16:53:10 <devkulkarni> 5 to 6 weeks before would be good. that way we will have at least three 2 week sprints to work through items that can be used for further discussion(s) at the summit
16:53:33 <muralia> devkulkarni:  +1
16:54:08 <tomblank1> adrian_otto: what about the option of holding it sooner than that like the end of February?
16:54:21 <adrian_otto> ok, one other consideration is that we will not have meeting facilities provided to us at the Atlanta Summit
16:54:49 <devkulkarni> oh!! did not know that.
16:55:28 <adrian_otto> so if we want to have productive time there, we should plan to arrive a couple of days early
16:56:04 <coolsvap> adrian_otto: also grab unconferences will be a way to go
16:56:53 <adrian_otto> coolsvap: yes, we can do that too, but we have learned from prior events that no time is actually reserved for unconferences
16:57:05 <adrian_otto> so they all overlap with other content/sessions
16:57:47 <adrian_otto> for example if we wanted russellb to be in one, he could not because he would need to be in the Nova meetings
16:58:07 <adrian_otto> that's the beauty of the F2F format were everyone can focus on just one project at a time
16:59:16 <adrian_otto> #action adrian_otto to get input from team members on F2F meetings, and Summit meeting plans
16:59:20 <coolsvap> adrian_otto: yeah, agree! a bit of prior planning will be needed for that, but i think the new 5day format can be a bit breather
16:59:38 <adrian_otto> ok, thanks everyone for attending today
16:59:54 <adrian_otto> I'll catch you on the ML and in #solum
17:00:01 <adrian_otto> #endmeeting