16:01:08 <adrian_otto> #startmeeting Solum Team Meeting
16:01:11 <openstack> Meeting started Tue Feb  4 16:01:08 2014 UTC and is due to finish in 60 minutes.  The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:15 <openstack> The meeting name has been set to 'solum_team_meeting'
16:01:16 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Solum#Agenda_for_2014-02-04_1600_UTC Our Agenda
16:01:26 <adrian_otto> #topic Roll Call
16:01:27 <paulmo> Paul Montgomery
16:01:32 <claytonc> Clayton Coleman
16:01:32 <tomblank1> tom blankenship
16:01:33 <stannie> Pierre Padrixe
16:01:34 <nmarchenko> Nikita Marchenko, Mirantis
16:01:34 <adrian_otto> Adrian Otto
16:01:37 <coolsvap> Swapnil
16:01:39 <paulczar> Paul Czarkowski
16:01:39 <gokrokve_> Georgy Okrokvertskhov
16:01:44 <roshanagr> Roshan Agrawal
16:01:53 <kraman> Krishna Raman
16:01:55 <devkulkarni> Devdatta Kulkarni, Rackspace
16:02:03 <julienvey> Julien Vey
16:02:07 <muralia> murali allada
16:02:14 <ycombinator> Shaunak Kashyap, Rackspace
16:02:51 <aratim> Arati Mahimane
16:02:53 <adrian_otto> Welcome everyone!
16:03:15 <adrian_otto> feel free to chime in at any time to be recorded in the attendance.
16:03:19 <adrian_otto> #topic Announcements
16:03:28 <adrian_otto> Any announcements from our team members?
16:03:59 <gokrokve_> Small update on Glance repository.
16:04:12 <adrian_otto> gokrokve_: :)
16:04:21 <gokrokve_> As you know last week there was a Glance mini-summit.
16:04:51 <gokrokve_> There was a decision made to create generic artifact repository API in Glance.
16:05:17 <gokrokve_> It will have pluggable architecture to support custom artifact types for specific parsing.
16:05:20 <adrian_otto> sweet
16:05:22 <JoelC> gokrokve_, That's good news
16:05:52 <gokrokve_> So, Solum will be able to use it to store its artifacts like LP, definitions and whatever you want.
16:06:09 <adrian_otto> gokrokve_: where can Solum team members learn more about it?
16:06:15 <gokrokve_> Some working code will probably be available in J M1 timeframe.
16:06:28 <adrian_otto> did they already file a BP for it?
16:06:48 <coolsvap> gokrokve_: any etherpads?
16:06:52 <gokrokve_> adrian_otto: Right now there is nothing to learn. I will update you as soon as BPs are submitted and some details appear.
16:07:02 <adrian_otto> rajdeep: welcome
16:07:12 <rajdeep> hi
16:07:16 <gokrokve_> There are some drafts but they are not represent the idea.
16:07:51 <gokrokve_> That is it for Glance part :-)
16:08:04 <adrian_otto> ok, if anyone notices the blueprint go up, please subscribe me, and let's revisit that as a future announcement in one of our team meetings.
16:08:26 <adrian_otto> we should do our part to participate in the design of that to help make it as useful as possible.
16:08:42 <adrian_otto> any other announcements?
16:08:57 <adrian_otto> thanks gokrokve_
16:09:01 <adrian_otto> #topic Review Action Items
16:09:19 <adrian_otto> 1) ACTION: adrian_otto to create blueprints for each of the API REST Resources (adrian_otto, 16:12:22)
16:09:34 <adrian_otto> Status: in progress. This will be done today.
16:09:44 <adrian_otto> 2) ACTION: adrian_otto to propose an alternate meeting time for the Solum team, potentially an alternating time schedule (adrian_otto, 16:46:19)
16:09:55 <adrian_otto> let's dive into this one a bit
16:09:57 <adrian_otto> See: https://wiki.openstack.org/wiki/Solum/ProposedMeetingTime
16:10:07 <adrian_otto> #link https://wiki.openstack.org/wiki/Solum/ProposedMeetingTime
16:10:35 <adrian_otto> I want input from those who are not attending today because it's the middle of the night
16:11:04 <adrian_otto> so we won't make a final decision, but I'd like input on the idea of alternating meetings on a */2 week basis
16:11:15 <rajdeep> i think current time works better for me..
16:11:18 <adrian_otto> so we would alternate between this time, and another time
16:11:29 <adrian_otto> because no option is good for everyone
16:11:30 <noorul> current time is best for IST people
16:11:54 <adrian_otto> I'm particularly sensitive to the effective exclusion of core reviewers from the weekly meeting
16:12:16 <coolsvap> current +option 2
16:12:22 <adrian_otto> and we have cores in at least 4 timezones
16:13:03 <yanndegat> current +  12,7,1,9
16:13:06 <adrian_otto> so what I think I will do is make this into a doodle poll, and get a feeling for the popular vote.
16:13:44 <adrian_otto> because I do want to balance the interests of high weekly attendance with local convenience for those of us distributed throughout the globe.
16:13:50 <yanndegat> i think 12,7,1,9 would be a better option1 ;)
16:14:04 <adrian_otto> let me look at that, one sec.
16:14:37 <adrian_otto> #link http://www.worldtimebuddy.com/?qm=1&lid=8,2158177,1277333,2988507&h=8&date=2014-2-4&sln=12-13
16:15:04 <adrian_otto> so if that were an ever-other-week meeting time, would any of our India contributors attend that?
16:15:43 <adrian_otto> coolsvap: what do you think? noorul?
16:15:43 <rajdeep> you mean the 6am one?
16:16:21 <adrian_otto> rajdeep: visit the link above, which I think would be ~1:00 AM in India, right?
16:16:32 <adrian_otto> this is an option not listed on my wiki page.
16:16:40 <devkulkarni> how about: 9, 4, 10.30, 6
16:16:46 <rajdeep> ah.. thats going to be tough
16:16:50 <noorul> adrian_otto: I don't think 1:30 am is feasible for Indian contributors
16:17:06 <adrian_otto> so that brings us back to alternating the meeting time
16:18:03 <adrian_otto> ideally that time would be somewhat convenient for the majority of the regular attendees (mostly in US timezones), and convenient at least once every second week for all the core reviewers.
16:18:42 <adrian_otto> thoughts on that?
16:18:54 <noorul> which time are you talking about?
16:19:01 <noorul> 9, 4, 10.30, 6 ?
16:19:25 <adrian_otto> Our current time, plus Option 1 in https://wiki.openstack.org/wiki/Solum/ProposedMeetingTime
16:19:56 <noorul> current time is fine for me
16:20:02 <julienvey> I think the best is to have a doodle poll
16:20:15 <adrian_otto> Option 2 is actually better given our criteria
16:20:26 <coolsvap> adrian_otto: yes
16:20:39 <adrian_otto> ok, I'll set up the poll, and we will revisit it again. Thanks everyone for your input. This is a hard issue to address.
16:20:57 <adrian_otto> next action item is:
16:21:00 <adrian_otto> 3) ACTION: adrian_otto to get input from team members on F2F meetings, and Summit meeting plans (adrian_otto, 16:59:16)
16:21:07 <adrian_otto> Status: in-progress. Working to identify an alternate host. If not Rackspace is willing to host.
16:21:26 <adrian_otto> kraman: was Matt able to join is?
16:21:34 <kraman> adrian_otto: unfortunately no
16:21:40 <kraman> he is on the road today
16:21:47 <kraman> i have asked him to email you back
16:21:52 <adrian_otto> kraman: ok, thanks
16:22:09 <paulczar> also Angus is now in Brisbane,  the wiki page shows melbourne.     usually same timezone,  except in summer, brisbane doesn't have DST.   i.e. right now melba is gmt+11,  brisbane is gmt+10
16:22:13 <adrian_otto> Team, in collaborations it's customary to alternate the location and host of F2F meetings
16:22:28 <adrian_otto> paulczar: tx!
16:22:54 <adrian_otto> so I want to give other team members a fair opportunity to host the event if they would like to
16:23:11 <adrian_otto> we would expect attendance in the 30-40 person range, plus remote attendees.
16:23:39 <julienvey> adrian_otto: we would be glad to host but Paris might be a little too far for you :)
16:23:44 <stannie> I will participate to the hangout from Paris if it's in Tx
16:23:47 <adrian_otto> julienvey: Thakns!
16:24:09 <adrian_otto> Rackspace has a number of different locations in the US
16:24:30 <adrian_otto> California, Texas, Georgia, Verginia
16:24:54 <adrian_otto> since the last was on the West coast, we could explore doing a March event elsewhere
16:25:21 <adrian_otto> I checked and we are all willing to travel to the Bay Area again
16:25:35 <adrian_otto> if everyone felt that was a good group
16:26:18 <adrian_otto> Virginia is probably more convenient for the RH team, right kraman and claytonc?
16:26:40 <kraman> adrian_otto: yes claytonc, dan and jessica re on the east coast
16:26:52 <kraman> adrian_otto: but its cold there :)
16:26:53 <paulczar> if nobody specifically cares to host,  we should do it at a place that reduces travel time for majority …  that would be Austin right? ;)
16:27:29 <adrian_otto> paul, yes, that would be lowest overall distance to travel for the whole group
16:27:53 <yanndegat> lowest CO2
16:27:53 <adrian_otto> so that's my current favorite, but I wanted to get as much input as possible
16:28:12 <adrian_otto> gokrokve_: would you be able to attend if we did it in Austin?
16:28:29 <gokrokve_> I think yes.
16:28:30 <kraman> adrian_otto: perhaps we can make it a action item for all to vote on the location
16:28:50 <adrian_otto> #action adrian_otto to hold a vote for next F2F location
16:29:05 <adrian_otto> ok, so now Blueprints
16:29:11 <adrian_otto> #topic Review Blueprints
16:29:23 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/api Solum API (aotto)
16:29:38 <adrian_otto> we have a whole bunch of open reviews on this topic
16:30:14 <adrian_otto> in general I'm feeling pretty good about the progress. It has been steady progress across numerous rest resources in the API
16:30:26 <adrian_otto> I don't see alarming gaps anywhere.
16:30:42 <adrian_otto> the new blueprints will help us finish up focus on this
16:30:57 <adrian_otto> any other thoughts on the API?
16:31:21 <adrian_otto> devkulkarni: I will ask you about linking the CLI to the API in a moment
16:31:31 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/solum-minimal-cli Command Line Interface for Solum (devdatta-kulkarni)
16:31:54 <devkulkarni> adrian_otto: this work is progressing nicely. paulmo and noorul are on top of connecting CLI to API
16:32:23 <devkulkarni> paulmo, noorul: you want to add some more color?
16:32:24 <adrian_otto> in paulmo's recent M1 cli work, there were callouts to API functionality needed to finish up that BP
16:32:49 <noorul> Was tied up last week, nothing much to add
16:32:54 <paulmo> Just some minor edits on the CLI text parsing code from reviews and hopefully good to go on that side
16:33:09 <devkulkarni> paulmo: great!
16:33:18 <rajdeep> is the use of PATCH verb common in OpenStack?
16:33:40 <adrian_otto> paulmo: will you need more help from other Stackers to arrange the bits in the API we need to make the CLI funciton?
16:33:51 <adrian_otto> rajdeep: no, not yet. PATCH is new.
16:33:58 <paulmo> I'm a little confused, I'm not working on the API side of things, that is Noorul
16:34:22 <rajdeep> ok, as i had not seen it very often
16:34:34 <adrian_otto> paulmo, I know, but noorul has been unable to work on that, so I'm checking to see if you want help from alternate sources
16:34:54 <adrian_otto> as that's in our critical path for M1
16:34:55 <paulmo> Are you asking me to finish up the REST API side of the CLI?
16:35:11 <adrian_otto> paulmo: no, I'm actually asking devkulkarni
16:35:27 <noorul> Initial API code is in
16:35:30 <adrian_otto> devkulkarni: do we need more help on the API side of this BP?
16:35:32 <devkulkarni> adrian_otto: let me check back on the CLI to API connection.
16:35:37 <noorul> I can quickly add more resources
16:35:41 <adrian_otto> devkulkarni: thanks.
16:35:54 <adrian_otto> paulmo: I recognize that your part of this is done
16:35:59 <devkulkarni> noorul: lets chat about it later today.
16:36:04 <adrian_otto> I'm more concerned that we don't deadlock on this
16:36:17 <adrian_otto> devkulkarni: thanks!
16:36:32 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/solum-git-pull Pull integration of Solum from an external Git repo (kraman)
16:37:16 <kraman> devkulkarni: and coolsvap have been working on tests
16:37:38 <kraman> and we are also looking into a temporary solution while we continue working on gettingcode into zuul
16:38:24 <adrian_otto> kraman: last week you mentioned that you would begin submitting this work as reviews in openstack-infra. We should not need tests to do that as WIP. Do you have any objections to putting that up for OpenStack review as WIP?
16:38:54 <adrian_otto> and add in the tests from coolsvap and devkulkarni as they are produced?
16:38:55 <kraman> I havent had time to do so yet due to other deadlines. But we will be doing that this week
16:39:05 <kraman> along with adding tests to the WIP patch
16:39:30 <kraman> I should have the patch submitted for discussion later today
16:39:53 <adrian_otto> kraman: thanks. Ideally we should get what we have in for review to get more eyeballs on it as early as we reasonably can
16:40:21 <kraman> yes, makes sense. will take that as an action item for today
16:40:23 <adrian_otto> also, remember not to drop a huge patch
16:40:37 <adrian_otto> consider making it into a few smaller patches if it's a lot of code.
16:41:10 <kraman> ok, will discuss with devkulkarni: coolsvap about splitting up the code into smaller pieces
16:41:12 <adrian_otto> #action kraman to submit zuul work into Gerrit as WIP for review. Tests to be added as they are created.
16:41:14 <kraman> it should be possible
16:41:37 <devkulkarni> kraman: yeah, lets discuss that
16:41:56 <adrian_otto> kraman: thanks for the update, and the commitment to get that up for review
16:42:04 <adrian_otto> any more remarks on this BP?
16:42:27 <kraman> I have schedules a meeting for tomorrow to discuss the temporary service we will put in place while we work n zuul
16:42:53 <adrian_otto> kraman: please announce the time here
16:43:08 <adrian_otto> for those who might take an interest in joining in
16:43:23 <kraman> Meeting will take place at 9 AM PST (http://www.worldtimebuddy.com/?qm=1&lid=100,8,524901,2158177&h=100&date=2014-02-05&sln=17-18)
16:43:35 <adrian_otto> awesome, thanks!
16:43:39 <adrian_otto> any more on this?
16:44:02 <kraman> thats it from my end
16:44:10 <adrian_otto> next is:
16:44:14 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/specify-lang-pack Specify the language pack to be used for app deploy (devdatta-kulkarni)
16:44:31 <devkulkarni> The updates on this are:
16:45:18 <devkulkarni> 1) aratim has been doing great progress. code for the API part is almost done. she is continuing to work on the backend datamodel
16:45:46 <devkulkarni> there are patches  for API part available for review.
16:46:25 <devkulkarni> 2) need to touch base with gokrokve_ to understand if we need to work on adding artifact endpoints for solum in glance
16:46:51 <devkulkarni> that is all
16:47:14 <adrian_otto> devkulkarni: thanks. On #2 gokrokve_ mentioned this is J M1 code in Glance
16:47:22 <adrian_otto> so we will need something to use in the mean time
16:47:48 <noorul> Does glance has versioning?
16:47:50 <devkulkarni> adrian_otto: yes. so that something will be essentially solum's db itself.
16:48:12 <adrian_otto> noorul: it has metadata on the entities stored on it, we could use that for a simple versioning scheme
16:48:36 <stannie> i've the BP for the glance artifacts https://blueprints.launchpad.net/glance/+spec/metadata-artifact-repository
16:48:48 <noorul> Are we going to support multiple versions in M1?
16:48:53 <gokrokve_> noorul: It will have versions in new API. But here are no versios in current Glance. You can use metadata tags, though.
16:48:57 <stannie> I added you adrian_otto and gokrokve_ as subscribers and there is also the etherpad that gokrokve_ was talking about https://etherpad.openstack.org/p/MetadataRepository-ArtifactRepositoryAPI
16:48:58 <adrian_otto> stannie: WHOOT!
16:49:15 <adrian_otto> thanks for subscribing me
16:49:47 <adrian_otto> noorul: probably not multi-version in the initial milestone
16:50:00 <noorul> ok
16:50:07 <adrian_otto> in all honesty I don''t think we have fully considered that question yet
16:51:09 <adrian_otto> ok, devkulkarni any more on this?
16:51:25 <devkulkarni> adrian_otto: no, that is all on this for now.
16:51:28 <adrian_otto> next is:
16:51:29 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/logging Logging Architecture (paulmo)
16:51:34 <paulmo> Short update unless there is interest in diving deeper: We've had several community meetings on logging and context over the last week.  I think we are making progress towards a solution everyone can agree on.  May need another meeting or two to get something solid architected.
16:51:35 <adrian_otto> I know we have good progress on this one
16:52:20 <adrian_otto> thanks paulmo for facilitating the discussions on this. I felt it was productive.
16:52:27 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/solum-zuul-integration Solum integration with Zuul (devdatta-kulkarni)
16:52:27 <paulmo> Glad to help! :)
16:53:01 <devkulkarni> adrian_otto: if I remember correctly, last time you had said you will combine this bp with the git-pull bp
16:53:15 <devkulkarni> in any case, the updates are what kraman provided earlier
16:54:06 <adrian_otto> #action remove https://blueprints.launchpad.net/solum/+spec/solum-zuul-integration Solum integration with Zuul (devdatta-kulkarni) from recurring agenda, to be combined with https://blueprints.launchpad.net/solum/+spec/solum-git-pull
16:54:16 <adrian_otto> need assignee
16:54:28 <adrian_otto> #action adrian_otto remove https://blueprints.launchpad.net/solum/+spec/solum-zuul-integration Solum integration with Zuul (devdatta-kulkarni) from recurring agenda, to be combined with https://blueprints.launchpad.net/solum/+spec/solum-git-pull
16:54:32 <adrian_otto> ok, there we go!
16:54:45 <adrian_otto> #topic M1 Completion
16:54:46 <devkulkarni> adrian_otto: cool. thanks!
16:54:54 <adrian_otto> Can we complete M1 in February?
16:55:02 <adrian_otto> I feel we are pretty darn close
16:55:17 <adrian_otto> lots of little bits here and there to tie up
16:55:17 <devkulkarni> there is one big missing piece of the puzzle
16:55:26 <devkulkarni> the 'deployment workflow'.
16:55:39 <noorul> build part?
16:55:42 <roshanagr> implemention of Java - Tomcat language pack did not surface - which blueprint is tracking that work
16:55:42 <adrian_otto> the bit that generated the heat template.
16:55:53 <adrian_otto> s/generated/generates/
16:56:30 <adrian_otto> roshanagr: Actually paulczar posted a link to that code when we talked about this yesterday. It is in contrib, right?
16:56:35 <devkulkarni> roshanagr: good question. imo, we should discuss about the overall language-pack working group's work. the part you mentioned is being tackled as one of things in that working group.
16:56:58 <roshanagr> adrian_otto: paulcz's was python
16:57:20 <claytonc> devkulkarni: yeah it would be good to talk about the status
16:57:31 <claytonc> it was funzo who owned it but he's fallen a bit behind
16:57:40 <claytonc> and tbh the zuul work blocks a lot of lp
16:58:01 <adrian_otto> ok, so we probably want a new BP to explicitly call out the component of the system that will do the Heat template generation, and kick off the deploy.
16:58:19 <julienvey> do we have to worry about docker integration in nova for M1 ?
16:58:20 <paulczar> here's the contribs that I talked about yesterday - https://github.com/stackforge/solum/tree/master/contrib/diskimage-builder
16:58:21 <adrian_otto> that should help fill the gap that devkulkarni is concerned about
16:58:26 <claytonc> adrian_otto: agree
16:58:31 <devkulkarni> https://blueprints.launchpad.net/solum/+spec/deploy-workflow
16:58:51 <claytonc> devkulkarni: our discussion last week re: plan updates i think is the blocking bit there
16:59:02 <claytonc> transition from plan version a -> plan version b in a controlled fashion
16:59:14 <devkulkarni> claytonc: yes. that discussion is part of it as well.
16:59:23 <adrian_otto> devkulkarni: thanks. I will review this, suggest edits, and get that targeted for M1. Any additional thoughts on this?
16:59:35 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/deploy-workflow
16:59:44 <devkulkarni> claytonc: about lp work being blocked by zuul..
17:00:07 <devkulkarni> could we identify exactly what is getting blocked? the reason I ask is,
17:00:33 <claytonc> devkulkarni: sorry, not blocked, just once we have a zuul flow the actual impl of a lp is a 5-10 minute thing
17:00:37 <devkulkarni> in tomorrow's git-integration meeting, we are planning to discuss an interim service that we should consider while zuul work is still being developed
17:00:41 <claytonc> with the work that paulczar and funzo have done
17:00:50 <devkulkarni> claytonc: oh okay.
17:01:03 <adrian_otto> devkulkarni: that BP is now Direction Approved, and targeted for M1
17:01:20 <devkulkarni> adrian_otto: great. thanks!
17:01:45 <adrian_otto> over time, sorry
17:01:49 <adrian_otto> thanks everyone
17:01:54 <adrian_otto> #endmeeting