16:00:58 <adrian_otto> #startmeeting Solum Team Meeting
16:00:59 <openstack> Meeting started Tue Feb 11 16:00:58 2014 UTC and is due to finish in 60 minutes.  The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:00 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:03 <openstack> The meeting name has been set to 'solum_team_meeting'
16:01:52 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Solum#Agenda_for_2014-02-11_1600_UTC Our Agenda
16:02:01 <adrian_otto> #topic Roll Call
16:02:04 <adrian_otto> Adrian Otto
16:02:06 <paulmo> Paul Montgomery
16:02:08 <muralia> murali allada
16:02:09 <stannie> Pierre Padrixe
16:02:10 <paulczar> Paul Czarkowski
16:02:10 <julienvey> Julien Vey
16:02:15 <nmarchenko> Nikita Marchenko, Mirantis
16:02:25 <devkulkarni> Devdatta
16:02:35 <rajdeep> Rajdeep Dua
16:02:41 <noorul> Noorul Islam
16:02:54 <coolsvap> Swapnil
16:03:44 <adrian_otto> hello everyone
16:04:09 <adrian_otto> feel free to chime in at any time to record your attendance if you have not already
16:04:18 <adrian_otto> #topic Announcements
16:04:34 <adrian_otto> we have selected a date for our upcoming for Solum Summit
16:04:40 <adrian_otto> two dates, actually
16:04:50 <adrian_otto> Tuesday, March 25, 2014
16:04:50 <adrian_otto> Wednesday, March 26, 2014
16:05:16 <adrian_otto> Red Hat has offered to host us in North Carolina
16:05:29 <adrian_otto> we will get you additional details on the specifics soon
16:05:39 <adrian_otto> so that you can plan your travel arrangements.
16:06:13 <adrian_otto> for those of you planning to attend remotely, please earmark your time on these dates to ensure your availability
16:06:39 <adrian_otto> next up, I created a bunch of new blueprints for the various API resources
16:06:58 <adrian_otto> they don't have details in them. If you are interested, links to them are in the agenda
16:07:11 <devkulkarni> adrian_otto: thanks for creating these!!
16:07:24 <noorul> adrian_otto: Good :)
16:07:32 <adrian_otto> You can thank me once I've put the grinding hours into fleshing each one out ;-)
16:07:49 <adrian_otto> the good news is that we actually have code for all of these already
16:07:55 <adrian_otto> so this is not a lift from zero.
16:08:06 <devkulkarni> true.
16:08:24 <adrian_otto> but this gives us a place to focus design work in a place with more narrow scope
16:08:45 <adrian_otto> ok, next topic
16:08:47 <adrian_otto> #topic Review Action Items
16:08:55 * adrian_otto adrian_otto to hold a vote for next F2F location
16:09:01 <adrian_otto> Status: Completed
16:09:09 * adrian_otto adrian_otto remove https://blueprints.launchpad.net/solum/+spec/solum-zuul-integration Solum integration with Zuul (devdatta-kulkarni) from recurring agenda, to be combined with https://blueprints.launchpad.net/solum/+spec/solum-git-pull
16:09:17 <adrian_otto> Status: Completed
16:09:22 <adrian_otto> although I have a question about this
16:09:28 <devkulkarni> yes..
16:09:35 <adrian_otto> kraman owned the second
16:09:43 <adrian_otto> and devkulkarni owned the first
16:09:54 <adrian_otto> who should I ask for the updates for the combination of the two?
16:10:21 <devkulkarni> adrian_otto: I think anyone of us can give updates. we are working together on this.
16:10:32 <adrian_otto> ok
16:10:44 <adrian_otto> and our last action item
16:10:46 * adrian_otto kraman to submit zuul work into Gerrit as WIP for review. Tests to be added as they are created.
16:10:55 <devkulkarni> I think kraman is out today. I can give an update on this.
16:11:03 <adrian_otto> ok
16:11:46 <devkulkarni> I am going to work with kraman today/tomorrow to start submitting WIPs for review. I have more updates which I can give now or when we go to BP status discussion.
16:12:10 <adrian_otto> ok, so I should resubmit this as an open action for this week, correct?
16:12:21 <devkulkarni> yes, that makes sense
16:12:21 <adrian_otto> should I keep it assigned to kraman, or assign it to devkulkarni?
16:12:36 <devkulkarni> for now I would say lets keep it assigned to kraman..
16:12:47 <adrian_otto> #action kraman to submit zuul work into Gerrit as WIP for review. Tests to be added as they are created.
16:12:50 <devkulkarni> I will check with him if we want to reassign it
16:12:56 <adrian_otto> ok, so I will revisit that next week for status.
16:13:03 <devkulkarni> sounds good.
16:13:14 <adrian_otto> ready to begin Blueprint updates?
16:13:21 <adrian_otto> #topic Review Blueprints: https://launchpad.net/solum/+milestone/milestone-1
16:13:31 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/api Solum API (aotto)
16:13:57 <adrian_otto> there has been a lot of progress on this. Many reviews were posted over the past two weeks to add methods to the api, and wire them to the db layer
16:14:10 <adrian_otto> I also created 7 new blueprints for the API
16:14:22 <adrian_otto> which I will report status on at this position in the agenda.
16:14:40 <adrian_otto> feel free to claim those blueprints if you have open reviews against them
16:14:53 <adrian_otto> also, please resubmit your commit messages to reference these blueprints
16:14:59 <devkulkarni> about that..
16:15:09 <adrian_otto> devananda: yes?
16:15:15 <adrian_otto> devkulkarni: yes?
16:15:20 <devkulkarni> has anyone figured out why blueprint links in the commit message do not go to solum project?
16:15:21 <adrian_otto> sorry devananda
16:15:41 <adrian_otto> Yes!
16:15:55 <adrian_otto> that happens because the blueprint slug does not start with the word solum
16:16:03 <adrian_otto> so they are not necessarily unique
16:16:16 <adrian_otto> all of the ones I create are properly named, so that should work properly for you
16:16:22 <noorul> I thought it is because solum is not yet part of openstack
16:16:39 <adrian_otto> also, I have been renaming them as I approve them to prevent this from continuing with new ones
16:16:59 <adrian_otto> no, it's a quirk about the way that Gerrit links to Launchpad
16:17:09 <noorul> adrian_otto: That seems to be incorrect, See https://review.openstack.org/#/c/71923/
16:17:41 <adrian_otto> noorul: oh, I see.
16:18:16 <noorul> I remember asking this question initially to infra and they said it is because we are not part of openstack yet
16:18:21 <adrian_otto> ok, so that should work at such time that this project enters an incubation phase
16:18:37 <adrian_otto> ok, sorry for the misinformation before
16:19:08 <adrian_otto> so I still want to have the references in the commit messages
16:19:13 <devkulkarni> so in the interim, do we put direct links in the commit message? I think gokrokve_ did that for some of his patches
16:19:17 <adrian_otto> even if the links do what they do now
16:19:29 <adrian_otto> we can put both in
16:19:50 <adrian_otto> another option is to put a comment in as you submit the patch that has the full link
16:20:11 <adrian_otto> that way you won't run into the caracter maximum for a line in the commit message
16:20:22 <adrian_otto> s/caracter/character/
16:20:38 <devkulkarni> okay. that would work.
16:20:41 <adrian_otto> more thoughts on the API work?
16:20:49 <adrian_otto> I will mention...
16:21:05 <noorul> Are all these APIs required for M1?
16:21:10 <adrian_otto> muralia has stepped up to help with fleshing out the API for the enablement of the CLI tool
16:21:26 <adrian_otto> not all capabilities of all resources are required for M1
16:21:39 <adrian_otto> I will make it clear in the blueprint descriptions wich parts are essential
16:21:59 <adrian_otto> we need to be able to create/modify/delete plans and assemblies
16:22:09 <adrian_otto> and list assemblies
16:22:11 <noorul> I think it is right time we come up with the list of items we should concentrate for M1
16:22:16 <adrian_otto> that should be enough to start
16:22:31 <devkulkarni> adrian_otto: noorul has shown the way of how to do this, muralia is taking it from there. (btw, that is the update for the next bp)
16:22:34 <adrian_otto> noorul: I agree completely. We ahve an agenda item for that
16:22:36 <adrian_otto> for today
16:22:54 <adrian_otto> nice segway devkulkarni
16:22:55 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/solum-minimal-cli Command Line Interface for Solum (devdatta-kulkarni)
16:23:11 <noorul> submitted around 6 patches last week
16:23:11 <devkulkarni> :) thanks noorul. thanks muralia
16:23:19 <muralia> sure
16:23:28 <devkulkarni> noorul: awesome stuff!!
16:23:46 <noorul> Thanks
16:24:05 <noorul> I was thinking whether we should add functional tests
16:24:07 <adrian_otto> noorul: +1 Thanks!
16:24:38 <adrian_otto> on the subject of the functional tests...
16:24:41 <devkulkarni> noorul: what do other projects do?
16:25:01 <noorul> They have it in tempest, but some read only operations alone
16:25:01 <adrian_otto> other projects really don't test much, as the tests for the CLI are relatively low value
16:25:23 <adrian_otto> Trove for example just runs the cli script to cause it to emit the API version
16:25:36 <adrian_otto> and does a string check against that to be sure it's the expected string value
16:25:38 <devkulkarni> what do recent projects like Heat do?
16:25:43 <adrian_otto> and that's the extent of the test
16:26:11 <noorul> let us not add it now
16:26:15 <noorul> I have another question
16:26:18 <noorul> https://etherpad.openstack.org/p/MinimalCLI
16:26:27 <adrian_otto> I think it's a pretty low value test, so we should focus on features
16:26:39 <noorul> It just talks about assembly and app
16:26:58 <noorul> What about other resources?
16:27:18 <adrian_otto> those are the two essential to basic operation
16:27:21 <noorul> Am I missing something?
16:27:22 <adrian_otto> app = plan
16:27:47 <adrian_otto> so if we have plans and assemblies working, we can demonstrate simple end-to-end functionality
16:27:49 <noorul> How can I define component, lang pack ,etc?
16:27:59 <adrian_otto> good question...
16:28:08 <adrian_otto> components get defined by Solum when interpreting the plan
16:28:30 <adrian_otto> and the first language pack can be pre-loaded in the base distribution
16:28:51 <muralia> We should take a second look and see if this etherpad has everything required for M1. I can do that and update it in the next few days as I start work on the CLI
16:29:27 <noorul> I see
16:29:29 <adrian_otto> muralia: are you willing to take that as an action item?
16:29:34 <muralia> yes
16:29:40 <adrian_otto> I would love your help with that
16:29:52 <muralia> sure. I'll do that
16:30:02 <noorul> It will be great if you can provide an example
16:30:18 <adrian_otto> #action muralia to review https://etherpad.openstack.org/p/MinimalCLI to verify that everything for M1 is tracked, and placed into the appropriate blueprints.
16:30:23 <noorul> How user will invoke assembly create with all those data?
16:30:46 <adrian_otto> #action adrian_otto to support muralia for review of https://etherpad.openstack.org/p/MinimalCLI
16:31:14 <muralia> noorul: sure. i'll provide examples
16:31:18 <adrian_otto> noorul: what data are you concerned about?
16:31:35 <noorul> muralia: ok thanks
16:31:52 <noorul> adrian_otto: How do we pass all these info in command line
16:31:58 <adrian_otto> the info placed into the plan file is what we use as input
16:32:08 <noorul> adrian_otto: Oh I se
16:32:13 <noorul> adrian_otto: got it
16:32:14 <adrian_otto> that goes into the plan, and is subsequently given to the assembly
16:32:18 <adrian_otto> ok, good
16:32:29 <adrian_otto> any mote on this topic?
16:32:30 <adrian_otto> more
16:32:35 <noorul> I am good
16:33:07 <adrian_otto> Next is two blueprints combined as a single update subject
16:33:09 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/solum-git-pull Pull integration of Solum from an external Git repo (kraman)
16:33:09 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/solum-zuul-integration Solum integration with Zuul (devdatta-kulkarni)
16:33:18 <devkulkarni> I have following updates:
16:34:00 <devkulkarni> 1) For Solum specific changes we had to modify Zuul's scheduler. I have added tests to those.
16:34:28 <devkulkarni> 2) I am working with kraman to split the code and tests into patches to be submitted to Zuul repo
16:34:30 <adrian_otto> claytonc: wlecome. devkulkarni is giving us the update on Git pull and Zuul
16:34:50 <claytonc> sorry about the delay
16:35:10 <devkulkarni> 3) We still need tests to be added for the changes to the layout in Zuul. Will be working with coolsvap to get those in
16:35:21 <devkulkarni> 4) We discussed about an 'interim service'.
16:35:38 <devkulkarni> There is not a concrete plan yet about how to build it, but..
16:36:12 <claytonc> devkulkarni: correct me if i'm wrong but we hypothesized not needing an interim service because we could fill that role via the hooks
16:36:13 <devkulkarni> yesterday asalkeld seemed to be thinking along those lines as well and he said he will create a wiki page with his thoughts/ideas etc. I am planning to get this to tomorrow's git-integration meeting
16:36:41 <claytonc> will take that to the meeting tomorrow though
16:36:53 <devkulkarni> claytonc: cool. we can discuss more then.
16:37:00 <devkulkarni> adrian_otto: that is all.
16:37:08 <adrian_otto> ok, let's get that wiki linked as the design to the "https://blueprints.launchpad.net/solum/+spec/solum-git-pull/+edit" of the blueprint
16:37:20 <devkulkarni> sure.
16:37:38 <adrian_otto> ok, also, I'd like to have you add the link to the breakout meetings into our agenda here
16:37:46 <adrian_otto> I think that will help us follow along
16:38:10 <devkulkarni> okay. can do that from next time
16:38:19 <adrian_otto> so as soon as you generate the chat log.minutes, please add them to https://wiki.openstack.org/wiki/Meetings/Solum
16:38:36 <adrian_otto> that way I can link to them in the subsequent team meeting so they become more visible to the wider audience
16:38:48 <devkulkarni> sounds good.
16:38:55 <adrian_otto> I think we are already recording those on the breakout meeting wiki page, right?
16:39:16 <adrian_otto> if not, we should get back into that habbit
16:39:19 <devkulkarni> I will have to double check..
16:39:30 <claytonc> i'm pretty sure they are
16:39:37 <claytonc> but we missed one meeting and rescheduled another
16:39:38 <adrian_otto> not critically important, but it would be nice for the full history to be linked there
16:39:40 <claytonc> will follow up
16:40:32 <adrian_otto> #action claytonc t make sure that https://wiki.openstack.org/wiki/Solum/BreakoutMeetings links to all logs and minutes from breakout meetings we have held
16:40:41 <adrian_otto> thanks claytonc
16:40:58 <adrian_otto> more on this topic?
16:41:23 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/specify-lang-pack Specify the language pack to be used for app deploy (devdatta-kulkarni)
16:41:30 <devkulkarni> Here are the updates on this:
16:41:59 <devkulkarni> aratim has been making great progress on the data model definition, which was the remaining part of this work.
16:42:23 <devkulkarni> btw, thanks claytonc for discussions the other day about the data model
16:42:57 <devkulkarni> another thing is.. we need to start including the plan work either in this bp or discuss it as part of some other bp.
16:43:14 <claytonc> devkulkarni: agreed
16:43:30 <adrian_otto> which plan work do you mean, devkulkarni?
16:43:31 <devkulkarni> the title of the bp is 'specify-lang-pack'. what aratim is part of the story — 'get the list of available lang-packs'.
16:43:49 <devkulkarni> adrian_otto: the work that asalkeld has done on the plan API.
16:44:10 <devkulkarni> *aratim's work is part of the story of this bp
16:44:59 <aratim> I am currently working on connecting the lang pack API to the DB
16:45:11 <devkulkarni> we could rename this bp to something like 'get-lang-pack' and then it should be fine
16:45:25 <devkulkarni> since there is already a bp for plans
16:45:32 <adrian_otto> devkulkarni: perhaps we could land that on https://blueprints.launchpad.net/solum/+spec/solum-api-plan
16:45:34 <aratim> +1 devkulkarni
16:45:53 <adrian_otto> wait
16:46:10 <adrian_otto> let's not rename a bp that we have linked to in prior meeting minutes
16:46:18 <devkulkarni> oh right!!
16:46:24 <adrian_otto> if we need another BP, we can make a new one
16:46:58 <devkulkarni> I can create a new bp and link it to the specify-lang-pack bp.
16:47:14 <adrian_otto> sounds like it would be one that depends on the current blueprint
16:47:30 <claytonc> scope of this BP - defining how plans change as language packs generate DU's, and how plans are used to create templates?
16:48:15 <adrian_otto> #action devkulkarni to make a new blueprint for language pack selection that would have a dependency link relation with specify-lang-pack
16:48:21 <devkulkarni> claytonc: actually, no. I was referring to a BP that will capture the work that aratim is doing.
16:48:44 <claytonc> ah
16:48:59 <adrian_otto> ok, ready to advance to the next item in the agenda?
16:49:01 <devkulkarni> adrian_otto: that is all
16:49:14 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/logging Logging Architecture (paulmo)
16:49:23 <paulmo> After much discussion and design, I created a new pull request for logging/trace: https://review.openstack.org/#/c/71970/
16:49:23 <paulmo> If folks like Angus, kgriffs, gokrokve and anyone else interested could take a look at it and give feedback, I would appreciate it.
16:50:01 <adrian_otto> thanks for putting that together, paulmo!
16:50:21 <adrian_otto> questions on that item?
16:50:31 <paulmo> trace_test.py can be run to see an example with lots of comments inline.
16:50:45 <adrian_otto> thanks paulmo.
16:50:48 <adrian_otto> #topic M1 Completion
16:50:54 <adrian_otto> Do we have all gaps addressed?
16:51:15 <devkulkarni> adrian_otto: Deployment workflow bp is missing in the list of BP updates.
16:51:29 <adrian_otto> Roshan is working on a new wiki page that further describes the ideal end-to-end user experience
16:51:46 <adrian_otto> devkulkarni: yes, let's get that in there now
16:52:00 <adrian_otto> actually, running low on time
16:52:03 <adrian_otto> I will take an action
16:52:19 <devkulkarni> I can give brief update on it. asalkeld is progressing on it..
16:52:34 <adrian_otto> #action adrian_otto to add Deployment workflow bp to our subsequent agenda for review updates
16:52:46 <adrian_otto> devkulkarni: yes, please
16:52:53 <devkulkarni> ^^
16:53:09 <adrian_otto> ok, so back to M1 completion
16:53:21 <adrian_otto> any other gaps that need our focus?
16:53:36 <devkulkarni> are we good on devstack setup?
16:53:49 <devkulkarni> how would someone try out solum end-to-end?
16:53:58 <adrian_otto> top priorities are getting minimal implementaitons of the CLI and Git integration working with a simple plan and have Solum create an Assembly
16:54:23 <adrian_otto> paulczar: what do you think on the devstack question?
16:54:53 <noorul> whom are we targetting M1 with?
16:55:16 <adrian_otto> noorul: M1 should be suitable for a public demo
16:55:17 <paulczar> there are scripts in contrib for the hookup to devstack
16:55:21 <noorul> M1 requires to run keystone and glance
16:55:28 <adrian_otto> to illustrate the concept of Solum
16:55:41 <paulczar> as long as we keep those up to date as we build on solum we should be okay with devstack integration
16:56:09 <adrian_otto> we might also have a dependency on swift
16:56:15 <noorul> I think it is always easy to use devstack if we have multiple services to run
16:56:25 <paulczar> the vagrantfile in the solum-dev repo on rackerlabs does the hookup when it starts devstack
16:56:28 <adrian_otto> noorul: agreed
16:56:37 <devkulkarni> we will also have dependency on heat (and may be zuul)
16:57:01 <adrian_otto> #topic Open Discussion
16:57:03 <noorul> so zuul is independent of devstack
16:57:26 <adrian_otto> we have a few minutes remaining, so we can continue on this, or bring up any other topics
16:57:40 <noorul> I have one question
16:57:47 <devkulkarni> noorul: if someone want to try end-to-end, they would need zuul setup. I was thinking it can be made part of devstack, like other services
16:57:54 <adrian_otto> noorul: proceed
16:58:02 <noorul> How early can we start applying for incubation?
16:58:20 <adrian_otto> noorul: good question.
16:58:45 <adrian_otto> I suppose that if we want to pursue incubation, it's never too early to publicly state that as an intent of ours
16:59:12 <adrian_otto> and when we all feel we are ready to apply, in terms of functionality… then we can do that
16:59:27 <adrian_otto> anyone have objections to stating an intent to file for incubation?
16:59:34 <paulczar> devkulkarni: correct,  I think we would need to add scripts in contrib/devstack/lib/solum  to install/start external tools such as zuul
17:00:01 <noorul> paulczar: So that needs a bp
17:00:07 <adrian_otto> noorul: we could adjust that part of our Wiki to make that intent more clear.
17:00:18 <noorul> adrian_otto: ok
17:00:24 <adrian_otto> anyone agree?
17:00:25 <noorul> adrian_otto: Should we ask M?
17:00:28 <noorul> ML?
17:00:38 <adrian_otto> let;s put it on next weeks agenda
17:00:48 <adrian_otto> so we can ave a good discussion about it
17:01:02 <noorul> adrian_otto: ok, thank you!
17:01:06 <devkulkarni> noorul: good point about bp
17:01:13 <adrian_otto> #action adrian_otto to add incubation discussion to next agenda
17:01:18 <adrian_otto> thanks everyone!
17:01:23 <adrian_otto> #endmeeting