16:00:58 <adrian_otto> #startmeeting Solum Team Meeting
16:00:59 <openstack> Meeting started Tue Feb 18 16:00:58 2014 UTC and is due to finish in 60 minutes.  The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:00 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:02 <openstack> The meeting name has been set to 'solum_team_meeting'
16:01:10 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Solum#Agenda_for_2014-02-18_1600_UTC Our Agenda
16:01:32 <adrian_otto> #topic Roll Call
16:01:34 <adrian_otto> Adrian Otto
16:01:38 <stannie> Pierre Padrixe
16:01:40 <funzo> Chris Alfonso
16:01:42 <paulmo> Paul Montgomery
16:01:49 <nmarchenko> Nikita Marchenko
16:01:53 <muralia> murali allada
16:01:54 <devkulkarni> Devdatta Kulkarni
16:02:34 <julienvey> Julien Vey
16:02:37 <aratim> Arati Mahimane
16:02:38 <adrian_otto> hello amotoki
16:03:05 <tomblank> tom blankenship
16:03:32 <coolsvap> Swapnil
16:04:01 <noorul> Noorul Islam
16:04:59 <adrian_otto> If anyone else would like to be recorded in the roll, you are welcome to chime in at any time during the meeting
16:05:03 <paulczar> Paul Czarkowski
16:05:18 <adrian_otto> welcome everyone!!
16:05:24 <adrian_otto> #topic Announcements
16:05:30 <adrian_otto> Solum Summit Registration (Tuesday, March 25, 2014 to Wednesday, March 26, 2014)
16:05:37 <adrian_otto> #link https://wiki.openstack.org/wiki/Solum/Summit Find Link to registration here
16:05:50 <adrian_otto> please take a moment to register for the Summit
16:06:36 <adrian_otto> funzo: are we expecting kraman today?
16:06:53 <funzo> adrian_otto: I haven't been in touch with him this am....let me reach out to him
16:07:04 <adrian_otto> I wanted to extend my thanks to our Red Hat team members for hosting this Summit event
16:07:11 <funzo> not on irc
16:07:28 <funzo> adrian_otto: i'll take the credit :)
16:07:44 <adrian_otto> sweet, please extend our gratitude
16:07:54 <adrian_otto> any other announcements from our team members?
16:08:23 <adrian_otto> I'll just say that I'm super pumped about where we are with our progress, and I'm looking forward to this very much!
16:08:47 <adrian_otto> #topic Review Action Items
16:08:57 <coolsvap> adrian_otto: are we planning anything for remote attendees?
16:09:10 <adrian_otto> coolsvap: yes, indeed
16:09:20 <adrian_otto> I don't think you need to register to attend remotely
16:09:39 <adrian_otto> but we can confirm that as a follow-up
16:09:50 <adrian_otto> adrian_otto to add Deployment workflow bp to our subsequent agenda for review updates (complete)
16:09:54 <adrian_otto> we will cover this BP today
16:10:06 <adrian_otto> adrian_otto to add incubation discussion to next agenda (complete)_
16:10:11 <adrian_otto> we will discuss this today
16:10:30 <adrian_otto> claytonc had a section of action items
16:10:38 <adrian_otto> claytonc to make sure that https://wiki.openstack.org/wiki/Solum/BreakoutMeetings links to all logs and minutes from breakout meetings we have held
16:10:50 <adrian_otto> was this completed. We can take a peek to find out
16:11:29 <adrian_otto> have we had LP meetings since Jan 6? I think so, right?
16:11:52 <devkulkarni> yes, we have had. but not with the usual protocol (i.e. startmeeting, endmeeting, etc.)
16:11:58 <funzo> ah
16:12:00 <paulczar> we had one yesterday at a weird time
16:12:06 <funzo> but there is a git meeting for 2/12
16:12:12 <funzo> er, entry
16:12:12 <adrian_otto> #action claytonc to make sure that https://wiki.openstack.org/wiki/Solum/BreakoutMeetings links to all logs and minutes from breakout meetings we have held
16:12:18 <adrian_otto> ok, so I will carry that action forward
16:12:50 <adrian_otto> devkulkarni: devkulkarni to make a new blueprint for language pack selection that would have a dependency link relation with specify-lang-pack
16:13:01 <devkulkarni> this is incomplete. I will do this soon.
16:13:13 <adrian_otto> ok, carrying that forward
16:13:18 <adrian_otto> #action devkulkarni to make a new blueprint for language pack selection that would have a dependency link relation with specify-lang-pack
16:13:22 <adrian_otto> thanks
16:13:30 <adrian_otto> muralia to review https://etherpad.openstack.org/p/MinimalCLI to verify that everything for M1 is tracked, and
16:13:36 <adrian_otto> placed into the appropriate blueprints.
16:13:49 <muralia> I went through the etherpad personally and i feel like at a high level we have everything covered.
16:13:52 <adrian_otto> I also had a supporting action for this
16:14:02 <adrian_otto> muralia: did you need any further support from me on this?
16:14:27 <muralia> I might need help with flushing out details as we link tasks to specific blueprints
16:14:50 <muralia> most blueprints are empty right now. i'll work with owners to add details going forward
16:14:56 <adrian_otto> would you like me to track that with an action item, or will you just ping me when you need a peek?
16:15:13 <adrian_otto> ^^ muralia
16:15:14 <muralia> do add an action item so we can discuss it in our meetings
16:15:43 <adrian_otto> #action adrian_otto to support muralia for review of https://etherpad.openstack.org/p/MinimalCLI (for tasks specific to blueprints)
16:15:47 <adrian_otto> look ok?
16:15:52 <muralia> yup
16:16:04 <adrian_otto> ok, anything more on administrativia?
16:16:21 <adrian_otto> if not, we can proceed to BPs
16:16:31 <adrian_otto> #topic Review Blueprints: https://launchpad.net/solum/+milestone/milestone-1
16:16:58 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/api Solum API (aotto)
16:17:07 <adrian_otto> I am really pleased with the progress over the past week
16:17:15 <adrian_otto> my favorite
16:17:17 <adrian_otto> Our API is actually working: https://review.openstack.org/73949
16:17:37 <adrian_otto> we have code that demonstrates the creation of an assembly and a simple build
16:17:50 <adrian_otto> that's an exciting milestone
16:18:04 <tomblank> cool! that is a great milestone...
16:18:06 <adrian_otto> thanks to all of us for advancing on these things
16:18:14 <tomblank> well done everyone...
16:18:27 <adrian_otto> I have a feeling we will see a bunch more achievements like this one
16:18:51 <paulczar> that's fantastic!
16:19:02 <adrian_otto> I'm sure asalkeld was pretty happy to post that review too!
16:19:18 <adrian_otto> ok, thoughts/questions on API development?
16:19:49 <adrian_otto> ok, next BP
16:19:50 <paulczar> lets fasttrack the reviewed and merge of it :)
16:20:15 <devkulkarni> Update on minimal-cli bp:
16:20:20 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/solum-minimal-cli Command Line Interface for Solum (devdatta-kulkarni)
16:20:22 <tomblank> paulczar: +1...  let's get this functionality in and then build on it...
16:20:25 <adrian_otto> paulczar: +1
16:20:41 <paulczar> challenge:  merge this review before Angus wakes up today
16:20:42 <noorul> I have patch in review queue that needs an update
16:20:49 <devkulkarni> We are working through the details of CLI to API integration based on the patches that noorul has submitted
16:21:12 <noorul> I might find time this week to do that
16:21:13 <devkulkarni> noorul: which one is that?
16:21:17 <adrian_otto> paulczar: I am sure that can be arranged
16:21:30 <devkulkarni> noorul: cool!!
16:21:30 <noorul> https://review.openstack.org/#/c/72105/
16:22:14 <adrian_otto> ok, any more on solum-minimal-cli?
16:22:24 <devkulkarni> noorul: will take a look.
16:22:35 <devkulkarni> adrian_otto: that is all.
16:22:39 <adrian_otto> Our next BP is actually two that we plan to update together:
16:22:46 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/solum-git-pull Pull integration of Solum from an external Git repo (kraman)
16:22:48 <adrian_otto> +
16:22:49 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/solum-zuul-integration Solum integration with Zuul (devdatta-kulkarni)
16:23:01 <devkulkarni> I have updates on the second:
16:23:24 <adrian_otto> great discussion on the ML, I thought
16:24:24 <devkulkarni> 1) I have completed adding initial set of tests. 2) We haven't yet posted the patches to the Zuul upstream. 3) I think we should remove these bps from M1 tracking (since I think we agreed that for M1 we would not be able to get to Zuul based workflow).
16:25:15 <tomblank> devkulkarni: do you know when #2 will be completed?
16:25:16 <devkulkarni> I was thinking that for the first bp (pull integration of Solum from external git repo), we can do that independent of Zuul setup
16:25:26 <adrian_otto> ok, let's take these one at a time
16:25:27 <adrian_otto> #1
16:25:35 <devkulkarni> tomblank: don't have a timeline yet.
16:25:37 <adrian_otto> thank you devkulkarni for your work on that!
16:25:40 <adrian_otto> #2
16:25:51 <devkulkarni> So bp #1:
16:25:55 <adrian_otto> are you willing to take that as an action item to drive for this week>
16:25:56 <adrian_otto> ?
16:26:10 <adrian_otto> ^^devkulkarni or tomblank
16:26:20 <devkulkarni> adrian_otto: yes, I will (I have been in touch with kraman about it)
16:26:37 <devkulkarni> just need to sync up about where we are.
16:26:48 <devkulkarni> I am going to follow up again
16:26:53 <adrian_otto> #action devkulkarni to follow up with kraman and submit zuul patches upstream for review
16:27:13 <devkulkarni> going back to bp #1
16:27:39 <devkulkarni> I think the high-level goal can be achieved without Zuul workflow.
16:28:08 <devkulkarni> So may be it will be good to separate that bp out from bp #2. I know I had suggested earlier to club them together. But that might have been a mistake.
16:28:56 <devkulkarni> by doing that we can remove #2 from milestone-1 tracking as well.
16:28:58 <adrian_otto> ok, so let's take a moment to restate the goal
16:29:33 <adrian_otto> it's actually not clearly articulated in the first BP
16:29:44 <adrian_otto> "This blueprint targets the functionality to pull source code from an external Git repository into Solum."
16:30:17 <adrian_otto> our reference to "further processing" is vauge
16:30:18 <devkulkarni> we can refine that..
16:30:45 <adrian_otto> I just marked that one as direction approved
16:31:11 <adrian_otto> I would like to get a more crisp statement of the scope so we have no ambiguity about what is expected for M1 with relation to this.
16:31:22 <devkulkarni> okay. I can do that.
16:31:41 <adrian_otto> devkulkarni: thanks
16:32:06 <adrian_otto> now, to the assertion that zuul is not required to achieve this.
16:32:26 <devkulkarni> I would add "for m1"
16:32:51 <adrian_otto> I do agree, that it's not required. We did discuss this topic in http://lists.openstack.org/pipermail/openstack-dev/2014-February/026981.html and got a considerable range of feedback
16:33:13 <adrian_otto> my interests are to help us focus on getting our first iteration ready
16:33:32 <adrian_otto> and not accumulate a burden of technical debt for later.
16:33:49 <adrian_otto> are we in agreement that an approach without Zuul for M1 strikes this balance?
16:33:56 <paulczar> +1
16:34:03 <julienvey> yes
16:34:09 <stannie> +1
16:34:10 <devkulkarni> yes
16:34:11 <tomblank> adrian_otto: yes
16:35:01 <adrian_otto> ok, are there any opposing viewpoints for us to consider?
16:35:37 <adrian_otto> ok, observing no opposing viewpoints, I'm going to record an agreement.
16:36:42 <adrian_otto> Does this look good to everyone: "#agreed we will proceed to complete https://blueprints.launchpad.net/solum/+spec/solum-git-pull for M1 without using Zuul, revisiting Zuul for adding additional functionality"
16:37:08 <julienvey> lgtm
16:37:09 <devkulkarni> looks good to me.
16:37:11 <stannie> yep
16:37:17 <tomblank> yes
16:37:38 <adrian_otto> ok, thanks
16:37:39 <adrian_otto> #agreed we will proceed to complete https://blueprints.launchpad.net/solum/+spec/solum-git-pull for M1 without using Zuul, revisiting Zuul for adding additional functionality
16:38:32 <adrian_otto> Note: we do expect to use Zuul, or a functional equivalent to allow more compressive set of CI features as we iterate.
16:38:54 <adrian_otto> as we have to intent to re-implement such a system without a very good reason
16:39:15 <adrian_otto> ok, any more thoughts on this BP?
16:39:22 <devkulkarni> yes, and we should continue to keep that long term view in mind when deciding features and options
16:40:16 <adrian_otto> #action adrian_otto to retarget https://blueprints.launchpad.net/solum/+spec/solum-zuul-integration for a subsequent milestone
16:40:38 <adrian_otto> thanks devkulkarni. ok, next BP
16:40:42 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/specify-lang-pack Specify the language pack to be used for app deploy (devdatta-kulkarni)
16:41:02 <devkulkarni> Updates on this is that aratim has been working hard to get the DB model finished.
16:41:10 <devkulkarni> Should be done in couple of days.
16:41:32 <devkulkarni> There was an email that she had sent out to the ML asking opinions about the model.
16:41:45 <adrian_otto> link?
16:42:01 <devkulkarni> don't have handy. let me find out..
16:42:17 <adrian_otto> #link http://lists.openstack.org/pipermail/openstack-dev/2014-February/027072.html
16:42:41 <adrian_otto> ok, team members please consider this thread and post your comments at your earliest convenience.
16:42:41 <devkulkarni> The current plan is to go with option 2
16:42:57 <adrian_otto> yes, I'm happy with 2 provided we track that as technical debt in a wishlist bug
16:43:07 <devkulkarni> makes sense..
16:43:10 <adrian_otto> as dropping JSON blobs into SQL databases is a known anti-pattern
16:43:32 <devkulkarni> good point. I will make sure to track this as a wishlist bug
16:44:03 <devkulkarni> that is all as far as the updates go on this bp
16:44:08 <adrian_otto> devkulkarni: thanks. I have been creating those bugs as we intentionally accept tech debt
16:44:09 <paulczar> adrian_otto: I would only classify it as an anti-pattern if we try and post-process that json data in a SQL-like manner
16:44:26 <adrian_otto> to my delight, our team has been picking those up and working them rather than letting them rot
16:44:31 <adrian_otto> so that process is working nicely
16:44:40 <adrian_otto> paulczar: agreed.
16:45:02 <adrian_otto> it's the precursor to the anti-pattern
16:45:28 <adrian_otto> ok, devkulkarni any more on this BP?
16:45:35 <devkulkarni> no, that will be all
16:45:42 <paulczar> yeah,  I do agree we should track it,   I think we should also spell out in option 2 that we need to avoid doing that …  I'm not sure it's 100% clear in the email
16:46:07 <adrian_otto> paulczar: please reply to the ML thread accordingly, as I will too
16:46:33 <adrian_otto> I know that's what Arati meant, but we could make that intent crisp.
16:46:41 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/logging Logging Architecture (paulmo)
16:47:00 <paulmo> Still going.  I need to make some non-trival changes from a recent review.
16:47:04 <aratim> +1 adrian_otto
16:47:43 <adrian_otto> paulmo: thanks. Do you need anything from members of the team on that one, or are you all set?
16:48:12 <paulmo> Just help getting in merge-able.  This isn't a straight forward process.
16:48:16 <paulmo> it
16:48:24 <adrian_otto> ok, thanks!
16:48:25 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/deploy-workflow Workflow outlining deployment of a DU (asalkeld/devdatta-kulkarni)
16:48:45 <adrian_otto> I mentioned progress toward this earlier
16:48:46 <devkulkarni> The main update is that: the heat stack creation part is still being fleshed out
16:48:58 <devkulkarni> adrian_otto: yes, asalkeld's review is part of it
16:49:07 <adrian_otto> ok, that wil be super exciting!
16:49:08 <devkulkarni> that does not yet do stack creation though
16:49:27 <adrian_otto> ok, for the next topic I wold like to timebox our discussion
16:49:42 <adrian_otto> to <= 10 mins here. and we can take it to the ML if we do not finish
16:49:50 <adrian_otto> #topic Incubation Discussion
16:50:14 <adrian_otto> last meeting we fielded this as a question during open discussion.
16:50:35 <adrian_otto> when we introduced Solum we positioned it as OpenStack Related
16:51:00 <adrian_otto> we can revisit the positioning if the members prefer that we state an intent to position for incubation
16:51:09 <adrian_otto> what are your thoughts on this?
16:51:29 <devkulkarni> never a bad idea. but I think it is a bit too early. personally, I feel we should get to m1 without whole lot of distractions with a great end-to-end user experience and then think about it.
16:52:05 <julienvey> devkulkarni: I agree
16:52:15 <adrian_otto> devkulkarni: I think we can all agree that it's not time to file for incubation until we have more functionality
16:52:16 <stannie> what kind of distraction would that include ?
16:52:41 <devkulkarni> stannie: frankly, I don't know. but it will surely lead to lot of ML activity..
16:52:49 <adrian_otto> but in response to Noorul's questions, I think we could put on our wiki pages an intent to file at that milestone
16:52:52 <stannie> devkulkarni: ok
16:52:53 <devkulkarni> adrian_otto: yes
16:53:11 <devkulkarni> adrian_otto: oh!! so the question was whether to clarify the intent on our wiki.
16:53:17 <devkulkarni> that we should definitely do!!
16:53:18 <adrian_otto> that approach may cause less confusion if that direction is more appropriate for us
16:53:20 <paulmo> What benefit is there in incubating early?
16:53:41 <adrian_otto> paulmo: in our case, I don't think there is an upside
16:53:59 <adrian_otto> but stating an accurate intent could be good
16:54:15 <adrian_otto> as currently we are projecting the opposite impression, which confuses newcomers.
16:54:22 <devkulkarni> adrian_otto: make sense. I am in support of making the intent clear on our wiki
16:54:37 <julienvey> maybe we could decide to apply for incubation when m1 is ready and we have something to demo
16:54:45 <tomblank> adrian_otto: just to be clear, is the question - should we specifically document our intention to go through incubation at some point in the future?
16:55:09 <devkulkarni> julienvey: I don't think we are discussing 'when' we should apply for incubation.
16:55:16 <adrian_otto> julienvey: yes, I suppose the questionis do we have stakeholders that feel that we should not do that when we reach that point, and remain a Related project?
16:55:35 <julienvey> i see
16:55:36 <adrian_otto> this is really a question of should we state that as an intent, and be clear about it.
16:55:57 <devkulkarni> +1 to making the intention clear
16:56:13 <adrian_otto> would anyone potentially oppose this direction, and want more time to consider it?
16:56:23 <paulmo> What exactly is the proposal?
16:57:05 <adrian_otto> to update our wiki where we have a reference to "OpenStack Related" and express an intent to file for incubation at a particular milestone
16:57:45 <adrian_otto> and we can decide as a team when that time should be.
16:59:20 <adrian_otto> Does anyone feel we should table this, and keep everything as is? If not, I can record an "#agreed to change our Wiki content to express an intent to file for incubation upon achievement of additional funcitonality"
16:59:44 <coolsvap> i would +1 for making the intent clear on wiki
16:59:46 <paulmo> I think M1 is too early
16:59:48 <stannie> +1
17:00:09 <paulczar> +1
17:00:11 <julienvey> +1
17:00:17 <adrian_otto> ok, we are running a bit too low on time to record this today
17:00:24 <adrian_otto> sorry I did not get to open discussion.
17:00:25 <tomblank> +1
17:00:32 <adrian_otto> I will put this on the agenda again for next meeting
17:00:41 <adrian_otto> thanks everyone for your input!!
17:00:44 <adrian_otto> #endmeeting