16:01:44 <adrian_otto> #startmeeting Solum Team Meeting
16:01:45 <openstack> Meeting started Tue Apr 22 16:01:44 2014 UTC and is due to finish in 60 minutes.  The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:48 <openstack> The meeting name has been set to 'solum_team_meeting'
16:02:04 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Solum#Agenda_for_2014-04-22_1600_UTC Our Agenda
16:02:21 <adrian_otto> #topic Roll Call
16:02:23 <adrian_otto> Adrian Otto
16:02:23 <paulmo> Paul Montgomery
16:02:24 <datsun180b> Ed Cranford
16:02:30 <muralia1> Murali Allada
16:02:35 <noorul> Noorul Islam K M
16:02:36 <aratim> Arati Mahimane
16:02:37 <julienvey> Julien Vey
16:02:43 <devkulkarni> Devdatta Kulkarni
16:03:16 <ravips> Ravi Sankar Penta
16:04:14 <adrian_otto> #topic Announcements
16:04:43 <gokrokve> Georgy Okrokvertskhov
16:04:58 <adrian_otto> We are a globally distributed team. So, some of our contributors and reviewers are asleep during this meeting timeslot
16:05:14 <adrian_otto> we agreed to begin alternating our meeting times to address this
16:05:18 <adrian_otto> New Alternating Meeting Time - Tuesdays at 2200 UTC, Starting 2014-04-29
16:05:27 <tomblank> tom blankenship
16:05:32 <adrian_otto> so the next time we meet, we will be using our alternate meeting time
16:05:40 <adrian_otto> same IRC channel
16:06:29 <adrian_otto> I need to tweak the links in the "Local Time" table shown at https://wiki.openstack.org/wiki/Meetings/Solum
16:06:32 <devkulkarni> that is 5.00pm in Austin, 3.00pm in bay area
16:06:36 <noorul> adrian_otto: I think only Angus is asleep during this time
16:06:38 <adrian_otto> so they reflect the correct dates.
16:06:46 <adrian_otto> noorul: yes.
16:06:55 <adrian_otto> he indicated he can make the other time.
16:07:29 <adrian_otto> any discussion on the alternating week's meeting time?
16:07:55 <devkulkarni> great to have it finally locked down
16:07:58 * funzo makes a note of the new time in the cal
16:08:25 <adrian_otto> Warning: Don't try and use the "add to calendar" feature from the timeanddate.com using the links I provided
16:08:49 <adrian_otto> unless you set up your own recurrence settings, and base it on UTC, not local time
16:09:19 <adrian_otto> otherwise every 6 months your calendar will be out of sync with the actual time, if you are in a country/province/state that observes DST
16:09:36 <devkulkarni> welcome ravips
16:09:47 <adrian_otto> ravips: hi there
16:09:57 <funzo> ravips: welcome!
16:09:58 <adrian_otto> would you like to address the team?
16:10:19 <ravips> hey Adrian and Dev..thx..just started looking at solum couple of days back.
16:10:45 <devkulkarni> cool. we are in #solum
16:11:05 <ravips> yep, I'm on #solum
16:11:12 <devkulkarni> except when we all are here that is :)
16:11:29 <adrian_otto> ravips: terrific. Please let us know if there is anything you need, or something we can do to help.
16:11:51 <adrian_otto> any other announcements from other team members?
16:11:54 <ravips> hee :)..will be playing with openstack/solum this week..will ping you guys in case of any questions/doubts
16:12:26 <adrian_otto> ok, advancing to our next topic...
16:12:31 <adrian_otto> #topic Review Action Items
16:12:37 <noorul> ravips: welcome
16:12:43 <adrian_otto> adrian_otto to close the voting on the New Alternating Meeting Time Vote, and send the results to the ML
16:12:55 <adrian_otto> this is complete, except I have not yet announced it to the ML
16:13:09 <adrian_otto> #action adrian_otto to announce the alternating meeting schedule to the ML
16:13:22 <adrian_otto> so I will carry that over to next time
16:13:31 <adrian_otto> roshanagr1 to propose a working group, and schedule a recurring series to get input from contributors, and iterate on a plan for adding Environments as a feature to Solum and/or OpenStack
16:13:52 <adrian_otto> I don't think Roshan is present today, but I was invited to a working group
16:14:11 <adrian_otto> he held a poll on Doodle for it
16:14:12 <devkulkarni> yeah. the meetings will start on thursday 8.00am Austin time in #solum
16:14:21 <julienvey> adrian_otto: yes on thursday
16:14:23 <paulmo> I think Roshan is joining now
16:14:31 <adrian_otto> which os 06:00 my time (yawn)
16:14:33 <noorul> adrian_otto: I missed it
16:14:50 <noorul> I think we should announce such polls in ML
16:14:56 <adrian_otto> yes, agreed
16:15:00 <roshanagr1> Hi
16:15:00 <tomblank> noorul:  +1
16:15:13 <adrian_otto> should we record that in a #agreed?
16:15:30 <tomblank> we should also make sure working group minutes, etc are posted to ML as well.
16:15:30 <devkulkarni> +1
16:15:42 <roshanagr1> @noorul: agree
16:15:53 <adrian_otto> #agreed that new working groups and team meetings shall be announced in the openstack-dev mailing list with the [Solum] topic in the subject line
16:16:20 <roshanagr1> on the Environments working group, is it currenly scheduled for Thu 8 am Central US time.
16:16:22 <julienvey> tomblank: I think that was done for the previous working groups, so no reason we don't do the same
16:16:30 <adrian_otto> ok, so what 06:00 PDT in UTC?
16:16:53 <tomblank> julienvey: yes, but sometimes we forgot :)  so just a reminder
16:16:58 <roshanagr1> it is
16:17:19 <noorul> Is that US only timing ?
16:17:45 <roshanagr1> no
16:17:46 <adrian_otto> ok, 1300 UTC
16:18:09 <adrian_otto> for the new Environments working group
16:18:27 <noorul> It is IST friendly :)
16:18:35 <adrian_otto> #link http://www.worldtimebuddy.com/?qm=1&lid=2174003,100,1277333,5368361&h=2174003&date=2014-4-24&sln=23-24
16:19:45 <adrian_otto> ok, next action item...
16:19:57 <adrian_otto> adrian_otto to drop https://blueprints.launchpad.net/solum/+spec/deploy-workflow from the weekly agenda [complete]
16:20:17 <adrian_otto> now, the next section is normally Review Blueprints
16:20:38 <adrian_otto> but we are starting to experiment using Tasks (LP Bugs) instead
16:20:57 <adrian_otto> so I am calling this "Review Tasks"
16:21:19 <adrian_otto> also, I am changing the naming convention of the milestones
16:21:29 <adrian_otto> to use the YYYY.R.R format
16:21:47 <adrian_otto> for example when we released M1, that was actually 2014.1.1
16:22:01 <adrian_otto> so the two links in the agenda to taksks by milestone are busted
16:22:06 <adrian_otto> and I will be fixing that
16:22:36 <adrian_otto> #action adrian_otto to rename milestone-N milestones in LP to YYYY.R.R format
16:22:48 <adrian_otto> I am also targeting the tasks to these milestones
16:22:53 <noorul> Are we not going to use blueprint at all?
16:23:18 <adrian_otto> noorul: Yes, for Epic level feature descrioptions
16:23:42 <noorul> It is always good to say implements blueprint than fixes-bug for features
16:23:44 <adrian_otto> I also want to propose one more idea for consideration by the team
16:24:11 <adrian_otto> noorul: agreed, we can still do that
16:24:24 <adrian_otto> what we started to do is make more granular blueprints
16:24:38 <adrian_otto> which makes it more difficult to manage the work backlog
16:25:07 <adrian_otto> so by recording top level features in BPs and Tasks in bugs, we get the singular work backlog we want
16:25:22 <noorul> So the commit log will have both implements blueprint and fixes bug ?
16:25:47 <adrian_otto> if there is a Task for the feature, then it will have a fixes-bug
16:26:05 <adrian_otto> if there is not, then it will have an implements-blueprint
16:26:18 <adrian_otto> but let me get to my proposal
16:26:44 <adrian_otto> the Nova team has begun using a repo of text files for designs
16:26:55 <adrian_otto> that are put through the same review process as code
16:27:14 <adrian_otto> which allows for a more specific level of collaboration compared to blueprints
16:28:10 <adrian_otto> this way it could be very clear what's approved by the team, and what we are still iterating on
16:28:28 <adrian_otto> and a way of cleanly recording alternate points of view
16:28:34 <adrian_otto> thoughts on this?
16:29:05 <julienvey> I'm not a big fan of this. at least for now
16:29:10 <noorul> -1
16:29:20 <devkulkarni> I like this
16:29:25 <datsun180b> -1 don't we have a wiki and bps already
16:29:27 <ravips> -1
16:29:27 <aratim> -1
16:29:30 <julienvey> nova has a huge team, with many contributors, that's the reason they decided to do this
16:29:40 <julienvey> we are pretty small
16:29:40 <noorul> I would like solum to mature
16:29:40 <adrian_otto> devkulkarni:  hang on one sec and I will come back to you
16:29:52 <noorul> This is too early for approvals to come in before implementing
16:29:56 <adrian_otto> I want to hear out noorul and julienvey
16:30:39 <adrian_otto> that was my initial reaction when I considered the idea
16:30:42 <noorul> adrian_otto: It is really a great but not now is what I feel
16:30:54 <julienvey> noorul: +1
16:31:14 <adrian_otto> ok, devkulkarni please tell us what you like about the idea
16:31:31 <devkulkarni> wikis and bps usually don't provide complete picture (they also become out of date soon)
16:31:41 <devkulkarni> about the spec repo itself..
16:32:03 <devkulkarni> I think it provides a replacement to whiteboarding sessions that we as a globally distributed team miss out on
16:32:22 <devkulkarni> of course I understand that review comments fill that gap
16:32:34 <adrian_otto> devkulkarni: consider this...
16:32:43 <devkulkarni> but I thought having a spec repo will provide quicker feedback than actually implementing the code
16:33:19 <funzo> it's hard to tell from blueprints what is no longer relevant, but I don't think that's a tooling problem and moving it to text files isn't going to fix that issue, it'll just move it to a different place to be potentially out of date
16:33:24 <adrian_otto> if you submit a WIP review against the solum repo, and it just included a design, such as an RST file, you could get input on that and get a sense for how effective it is for this team
16:33:41 <noorul> funzo: +1
16:34:07 <datsun180b> oh please don't enforce RST if it's going to show up as a diff in gerrit
16:34:15 <funzo> it's a matter of discipline, of keeping all the info - in detail and with dates in one place for folks to go look at and know where to jump in to help
16:34:15 <adrian_otto> in all honesty if I spend 80 hours a week in Launchpad we could have a really crisp picture of everything
16:34:32 <funzo> adrian_otto: yeah, that sounds miserable
16:35:09 <adrian_otto> but I am willing to step up my level of commitment to organizing tasks and BPs, and potentially designs one day
16:35:25 <noorul> Having one person owning it will be great
16:36:02 <adrian_otto> devkulkarni do you want to try experimenting with a design posted as a WIP?
16:36:15 <devkulkarni> okay. you all have convinced me.
16:36:23 <julienvey> ?
16:36:25 <adrian_otto> if your gut feeling is right, then we should see benefit from that
16:36:39 <noorul> adrian_otto: RST file ?
16:36:44 <devkulkarni> convinced me that spec repo may not necessarily be good at this stage
16:36:46 <adrian_otto> noorul: yep
16:36:55 <adrian_otto> ok, good discussion
16:37:06 <adrian_otto> I am going to record an #agreed on this one
16:37:29 <adrian_otto> #agreed to table consideration of using a spec/design repo for Solum
16:37:31 <tomblank> btw, , there will be a cross-project workshop at the design summit about tracking incoming features -- "covering blueprint proposal, approval and prioritization. the session will discuss extending the "-specs" repositories experience and see how it fits the whole picture on the long run"
16:38:01 <devkulkarni> tomblank: do you know the date and time of it?
16:38:01 <adrian_otto> tomblank: please share a link to that for reference by the team
16:38:36 <noorul> Do we have a plan for our meeting @ summit?
16:38:46 <tomblank> this is what i have   http://summit.openstack.org/cfp/details/3
16:38:53 <adrian_otto> noorul: We applied for the OpenSource @ OpenStack Summit
16:39:02 <tomblank> it was from an email to the openstack-dev list by Thierry Carrez
16:39:12 <adrian_otto> they were supposed to make their selections this past Friday. but I have not heard back
16:39:38 <adrian_otto> we are anticipating a 1/2 day workshop on Tues or Wed
16:40:10 <adrian_otto> there is also a 90 minute Session on Tuesday for Solum/Murano discussion in the "Other Projects" track of the Design Summit
16:40:26 <devkulkarni> are there other such sessions that we should be aware of? as a team, do we want to try to cover as much potentially useful/important/relevant sessions as possible?
16:40:59 <adrian_otto> #action adrian_otto to follow up with Lauren Sell about "OpenSource at OpenStack Summit"
16:42:25 <adrian_otto> would anyone like to discuss any particular tasks, bugs, or other workstream related items before I switch to Open Discussion?
16:43:01 <adrian_otto> #topic Open Discussion
16:43:27 <paulmo> I created an etherpad with some Solum M2 Demo prototypes for the community to review/comment on: https://etherpad.openstack.org/p/Solum_M2_Demo
16:43:45 <paulmo> I would just ask that we rapidly review/comment as there isn't much runway. :)
16:45:10 <adrian_otto> paulmo: I love the http://192.237.213.128/plan_canvas.html prototype
16:45:19 <datsun180b> you should see it in motion
16:45:19 <noorul> Is this http://192.237.213.128/images/home_page.png what Angus is working on?
16:45:30 <adrian_otto> I did notice that once I make a line it is permanent
16:45:30 <julienvey> paulmo: we should be careful about the application composition part
16:45:35 <datsun180b> oh those aren't screenshots, you are
16:45:43 <julienvey> it really is the same thing as murano
16:45:43 <paulmo> Angus is looking at Horizon plugins, hopefully he can provide feedback soon to the community.
16:46:45 <adrian_otto> Angus has started some work on a plugin here: https://github.com/rackerlabs/solum-horizon
16:46:46 <roshanagr1> @paulmo: great work on the UI so far. I love the way it is coming about
16:46:46 <paulmo> adrian_otto: Yes, this is very early.  I didn't pretty things up much or anything as I expect rapid changes.  I'll have line removal later and such.  Already on my todo list
16:46:57 <noorul> App Definition Canvas looks interesting
16:47:05 <adrian_otto> paulmo: great!
16:47:34 <paulmo> I'll be adding restrictions on what may be linked and everything as well.  It will be very different in a day or two.
16:48:03 <tomblank> paulmo: great job...
16:48:05 <noorul> julienvey: Does murano has something similar to this Canvas?
16:48:08 <paulmo> But again, please write in input soon so we have time to act on it.
16:48:17 <julienvey> noorul: yes
16:48:26 <julienvey> noorul: I can try to find a link, 1s
16:48:26 <rajdeep> mocks look different
16:48:41 <paulmo> PS: Murali, Ed and Roshan helped significantly.  Credit goes to them.
16:48:42 <rajdeep> than anything i have seen in other paas implementations
16:48:51 <rajdeep> good job
16:49:20 <roshanagr1> @rajdeep: anything that stands out that we should do differently?
16:49:33 <noorul> paulmo: muralia datsun180b roshanagr1 : Cool stuff
16:50:06 <rajdeep> App canvas looks pretty interesting ...
16:50:13 <adrian_otto> yes, it's exciting to see this all coming together. I'm thrilled to be part of such a talented team.
16:50:26 <rajdeep> most of the UIs in the paas world are an after thought
16:50:37 <funzo> adrian_otto: who should I talk to about nova-docker usage in solum?
16:50:45 <datsun180b> strike "in the paas world" and you'll still have a valid statement
16:50:57 <adrian_otto> funzo: I'm interested in that topic
16:51:04 <julienvey> noorul: they have the app catalog in murano-dashboard, but don't find a screenshot
16:51:15 <adrian_otto> and so is paulczar, who is out on vacation for about a week
16:51:42 <julienvey> funzo: I'm also looking at that
16:51:55 <funzo> adrian_otto: ok. I'm in contact with derekh, he's submitted a CI patch to create a job upstream, and I'm in contact with slower, he's looking at tempest coverage
16:52:00 <funzo> julienvey: oh cool
16:52:13 <noorul> julienvey: I see
16:52:28 <rajdeep> it will be great to have a UI view of persistent store
16:52:30 <adrian_otto> funzo: that sounds promising
16:52:32 <funzo> julienvey: adrian_otto: i'm trying to figure out the exact direction an priority of getting nova-docker into the compute service and what work still needs to be done - then focus on features
16:52:55 <funzo> adrian_otto: i've created the #nova-docker on freenode for us to talk about the work
16:52:55 <adrian_otto> funzo: excellent! Any way I can help?
16:52:57 <paulmo> rajdeep: Feel free to ping me and discuss your suggestions. :)
16:53:04 <julienvey> funzo: great!
16:53:08 <adrian_otto> funzo: will will join that channel
16:53:27 <funzo> adrian_otto: just trying to distill the work that needs to happen at this point and identify any overlap between work items that anyone has started
16:53:55 <julienvey> funzo: first task was to make the driver work with devstack
16:54:01 <julienvey> funzo: this is almost done
16:54:05 <rajdeep> sure @paulmo
16:54:13 <adrian_otto> tomblank: can you watch in #nova-docker as well, please?
16:54:23 <funzo> julienvey: is that what you've been working on?
16:54:41 <funzo> julienvey: I've been trying to glue all the email posts together to get an idea what is relevant and what is outdated
16:54:47 <julienvey> funzo: I've been reporting bugs on the driver while I was testing it in Solum
16:55:13 <adrian_otto> time check: 5 minutes remaining
16:55:31 <julienvey> funzo: we have some bugs working with docker and neutron
16:55:46 <julienvey> but I haven't tried to spot the issue yet
16:55:56 <funzo> julienvey: ok, I'll continue the topic in #solum
16:56:39 <julienvey> I'll have to leave after this meeting but I will be on IRC tomorrow, in both #solum and #nova-docker
16:57:11 <funzo> julienvey: sounds good
16:58:59 <adrian_otto> ok, thanks everyone for attending. Are there any stragglers who have not yet chimed in who would like to be recorded in attendance today? Chime in now...
16:59:25 <adrian_otto> #endmeeting