16:11:38 <adrian_otto> #startmeeting Solum Team Meeting
16:11:39 <openstack> Meeting started Tue May  6 16:11:38 2014 UTC and is due to finish in 60 minutes.  The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:11:40 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:11:43 <openstack> The meeting name has been set to 'solum_team_meeting'
16:12:02 <adrian_otto> my apologies for the late start today. I was distracted.
16:12:11 <adrian_otto> #topic Roll Call
16:12:14 <paulmo> Paul Montgomery
16:12:14 <adrian_otto> Adrian Otto
16:12:15 <the_instructions> Ed Cranford
16:12:18 <noorul> Noorul Islam K M
16:12:20 <ravips> Ravi Sankar
16:12:21 <muralia> murali allada
16:12:22 <roshanagr> Roshan Agrawal
16:12:23 <aratim> Arati Mahimane
16:12:25 <devkulkarni> Devdatta
16:12:26 <tomblank> tom blankenship
16:12:28 <stannie> Pierre Padrixe
16:12:33 <julienvey> Julien Vey
16:12:42 <rajdeep> rajdeep dua
16:13:08 <adrian_otto> Welcome everyone!
16:13:29 <adrian_otto> #topic Announcements
16:13:35 <adrian_otto> (none prepared)
16:13:43 <adrian_otto> We do have a Demo
16:14:06 <paulmo> https://wiki.openstack.org/wiki/Solum/solum_m2_demo
16:14:13 <adrian_otto> #link https://wiki.openstack.org/wiki/Solum/Demo is currently pointing to the M2 demo page
16:14:16 <the_instructions> oh boy do we
16:14:43 <adrian_otto> so all team members should be aware of this
16:14:56 <adrian_otto> I ask that we all give it a try and shake out all the kinks
16:15:14 <adrian_otto> there was one known problem as of yesterday evening where the image build process was not completing
16:15:23 <adrian_otto> so new assemblies were not exiting BUILDING state
16:15:30 <julienvey> just a question, why are we refering to rackers git repo for the ui ?
16:15:36 <stannie> can we rappatriate the solum-m2 demo ?
16:15:58 <the_instructions> it better not still be pointing at mine
16:16:11 <the_instructions> oh right rackerlabs is also a racker
16:16:26 <adrian_otto> stannie: rappatriate?
16:16:35 <the_instructions> repatriate
16:16:46 <stannie> sorry :)
16:16:53 <the_instructions> he's suggesting we move it to somewhere not rax-affiliated
16:16:54 <rajdeep> is there a plan to have a hosted demo version
16:17:02 <rajdeep> it is easier for people to try
16:17:14 <adrian_otto> yes, of course we will.
16:17:17 <stannie> ok
16:18:01 <adrian_otto> rajdeep: we are exploring that. There are some pitfalls with a hosted system we have not solved yet. It may be subject to abuse.
16:18:04 <rajdeep> great! any projected dates
16:18:23 <rajdeep> i think it is super important
16:18:34 <the_instructions> until delete-assembly works having a hosted demo is going to look like an elevator that can only go up
16:18:39 <rajdeep> for any paas to get some love from developers
16:19:00 <adrian_otto> the_instructions: I was able to delete an assembly yesterday
16:19:04 <the_instructions> oh cool
16:19:13 <ravips> is this the demo for Juno design summit?
16:19:32 <adrian_otto> I will have a video
16:19:48 <adrian_otto> so eanyone can just watch the video of the demo to get a sense of things in a couple of minutes
16:19:58 <adrian_otto> s/eanyone/anyone/
16:20:04 <ravips> nice!
16:20:21 <adrian_otto> and then longer term we can sort out how best to do a hosted demo
16:20:46 <adrian_otto> I am happy to talk about that more in Open Discussion today.
16:20:58 <adrian_otto> ok, other announcements from other team members?
16:21:34 <adrian_otto> #topic Review Action Items
16:21:42 <adrian_otto> (no action items recorded last week)
16:21:50 <adrian_otto> #topic Review Tasks
16:21:57 <adrian_otto> https://launchpad.net/solum/+milestone/2014.1.2
16:22:33 <adrian_otto> sort that list by importance
16:22:55 <adrian_otto> https://bugs.launchpad.net/bugs/1316316 will be fixed ASAP
16:23:34 <julienvey> we can't manage to have a working version of Solum :(
16:23:47 <adrian_otto> that same issue may also be related to https://bugs.launchpad.net/bugs/1315459 which is about a similar symptom where the Assembly state enters BUILDING and never exits (when using a Devstack system configured to produce VM's)
16:23:52 <the_instructions> works on my machine!
16:23:56 * the_instructions ducks
16:23:57 <julienvey> the_instructions: xD
16:24:26 <adrian_otto> we have 10 High priority bugs
16:24:50 <julienvey> adrian_otto: we also have the "Never exists BUILDING state" with almost no logs :(
16:24:52 <adrian_otto> I worked on the Documentation Review: #link https://bugs.launchpad.net/solum/+bug/1313931
16:25:08 <adrian_otto> so I am assigning that to me
16:25:10 <julienvey> s/exists/exits
16:25:51 <adrian_otto> julienvey: are you referring to this : https://bugs.launchpad.net/bugs/1315459 ?
16:26:34 <julienvey> adrian_otto: yes
16:26:43 <adrian_otto> I'd like a volunteer to take that one
16:26:59 <adrian_otto> the localrc needed to reproduce that is in the bug ticket
16:27:09 <adrian_otto> I also have a system that exhibits the symptom
16:27:13 <julienvey> adrian_otto: actually not exactly the same one
16:27:17 <adrian_otto> that I can supply remote login access to
16:27:26 <julienvey> adrian_otto: we are stuck in BUILDING but not with the neutron error in the logs
16:28:04 <adrian_otto> julienvey: I know we have at least two root causes for that symptom
16:28:09 <noorul> julienvey: I think https://review.openstack.org/#/c/92171/ fixes it.
16:28:41 <the_instructions> i should hope it does
16:28:53 <adrian_otto> It is clear to me that Solum in its current form is too hard to debug
16:29:01 <the_instructions> i haven't seen problems with neutron or with docker intermittently failing myself
16:29:01 <julienvey> adrian_otto: agree
16:29:21 <adrian_otto> I really want a unified log where I can look to see what's happening chronologically.
16:29:39 <adrian_otto> and I'd like for additional status to be exposed through the assembly rest resource
16:29:41 <julienvey> adrian_otto: we should work on this https://bugs.launchpad.net/solum/+bug/1302552
16:30:00 <julienvey> bash scripts don't have proper logs and are hard to debug
16:30:19 <the_instructions> ^^
16:30:20 <julienvey> and currently, almost everything happen in the scripts
16:30:24 <stannie> yes I agree converting the bash scripts in python will help to have proper logs
16:30:46 <noorul> julienvey: I agree :)
16:30:52 <julienvey> the_instructions: just saw your comment :)
16:30:58 <stannie> and we would avoid to have to parse CLI outputs etc
16:31:01 <the_instructions> 92171 was just merged
16:31:15 <adrian_otto> julienvey: if we can address Angu's stated concern about making them executable from a script (I think this is doable)
16:31:16 <stannie> while we could simple call python-glanceclient in a python
16:31:23 <adrian_otto> the_instructions: yay
16:31:36 <the_instructions> julienvey: yes, sorry i didn't get more done toward that conversion, i've been focused on the demo
16:31:49 <julienvey> the_instructions: no problem :)
16:32:45 <adrian_otto> ok, so I targeted https://bugs.launchpad.net/solum/+bug/1302552 to juno-1
16:32:58 <adrian_otto> I agree that would be an improvement
16:33:56 <adrian_otto> and I would welcome any patches that add log messages (or at least STDOUT form the scripts) so it's easier to see what's happening
16:34:52 <adrian_otto> https://launchpad.net/solum/+milestone/2014.1.2
16:35:51 <adrian_otto> https://bugs.launchpad.net/solum/+bug/1307703 was unassigned, so I assigned that to paulcz (fix committed)
16:36:23 <adrian_otto> aratim: can you update us on https://bugs.launchpad.net/bugs/1315139 please?
16:36:35 <adrian_otto> https://bugs.launchpad.net/bugs/1315139
16:37:04 <adrian_otto> #link https://bugs.launchpad.net/bugs/1315139 https://bugs.launchpad.net/bugs/1315139
16:37:19 <aratim> adrian_otto: yes, I have a patch for that - https://review.openstack.org/#/c/91674/1
16:37:20 <adrian_otto> my irc client is being tricky with me
16:37:49 <adrian_otto> Workaround: Use pecan instead of wsme for TriggerController's post method
16:37:53 <aratim> I will address devdatta's comment on my patch and resubmit it
16:38:11 <adrian_otto> why is Jenkins unhappy with that patch?
16:38:14 <aratim> also the devstack gate is failing so need to rebase
16:38:19 <adrian_otto> and devkulkarni
16:38:24 <devkulkarni> yes
16:38:37 <devkulkarni> the delete-assembly bug status update
16:39:07 <devkulkarni> working on it. realized that functionaltests are failing because I am not deleting assembly anymore immediately
16:39:25 <devkulkarni> also addressing noorul's comments
16:39:40 <adrian_otto> ok, so we are in good shape on each of those
16:39:56 <adrian_otto> does anyone have any worries about where we are currently?
16:40:51 <adrian_otto> https://bugs.launchpad.net/solum/+bug/1316338 is low hanging fruit
16:41:00 <adrian_otto> I should figure out how to mark it as such
16:41:36 <julienvey> adrian_otto: you could add a tag, as other integrated projects do
16:41:52 <julienvey> https://bugs.launchpad.net/nova/+bugs?field.tag=low-hanging-fruit
16:41:57 <adrian_otto> julienvey: good idea. I will do that
16:43:29 <adrian_otto> #topic Open Discussion
16:43:50 <devkulkarni> did we get any time slots for next week's summit?
16:44:10 <julienvey> devkulkarni: was about to ask the same question!
16:44:18 <the_instructions> i thought we got two
16:44:23 <adrian_otto> yes, let me give you a link
16:44:46 <adrian_otto> #link https://wiki.openstack.org/wiki/Solum/Summit Solum at OpenStack Summit
16:45:22 <adrian_otto> I ask that everyone on the Solum team do everything possible to attend all three of these.
16:46:12 <adrian_otto> are any of you not attending in Atlanta?
16:46:13 <noorul> Apart from that are we meeting as a team ?
16:46:15 <the_instructions> I'll be there TWTh
16:46:41 <julienvey> I think the last slot is about team discussion
16:46:51 <julienvey> http://openstacksummitmay2014atlanta.sched.org/event/6e53527347d56d67120decd49bbac53b#.U2kR1-Z_vZB noorul
16:47:00 <adrian_otto> I propose we cancel next week's IRC meeting and conduct our business on Wednesday at the link above
16:47:28 <the_instructions> sounds like fun
16:47:48 <adrian_otto> this will be a very exciting Summit for us
16:48:30 <adrian_otto> I will also mention that I have been very focused on keeping our bug/task list up to date, and fully prioritized
16:48:47 <adrian_otto> are all of you finding that resource to be helpful for clarity on where to focus your efforts?
16:49:15 <devkulkarni> adrian_otto: is there any homework that we need to do this week regarding the program/project mission statement before next week?
16:49:16 <adrian_otto> is there anything we could be doing better?
16:49:29 <julienvey> adrian_otto: Great work on this
16:49:37 <devkulkarni> +1
16:49:40 <noorul> adrian_otto: +1
16:49:58 <julienvey> should we prepare some discussions point for the meeting on Wednesday ?
16:50:01 <adrian_otto> devkulkarni: excellent question. I will take an action item to revise that further
16:50:01 <noorul> Oops, I meant, I second julienvey
16:50:08 <julienvey> maybe share an etherpad ?
16:50:22 <roshanagr> julienvey: I will take that action
16:50:26 <adrian_otto> and open an ML discussion asking for input on the etherpad as we refine that and get it close to what we want to adopt
16:50:28 <julienvey> roshanagr: great
16:50:49 <devkulkarni> and add that to our list of etherpads at https://wiki.openstack.org/wiki/Solum
16:50:59 <roshanagr> ok
16:51:00 <adrian_otto> #action roshanagr to revise mission statement wiki, and publish to ML requesting input on revised draft.
16:51:20 <adrian_otto> goal is to have us feeling "close" as we enter our Wednesday discussion
16:51:54 <adrian_otto> devkulkarni: good point
16:52:09 <adrian_otto> #action adrian_otto to add the solum mission etherpad to our wiki page
16:52:39 <roshanagr> Environments: do we feel we need to meet tomorrow on IRC on the topic
16:52:49 <adrian_otto> roshanagr: to be clear, I'd like to transfer the etherpad to a wiki page for the mission
16:52:55 <julienvey> about the etherpad I was more thinking about future development discussions
16:53:00 <adrian_otto> and invite edits to that
16:53:42 <roshanagr> adrian_otto: ok
16:53:44 <tomblank> julienvey: +1.  i think we need a list of topics for our Wednesday discussion and i thought that's what Roshanagr was agreeing to start.
16:53:44 <adrian_otto> just mark it as DRAFT so there is no confusion about it's status until after we agree
16:53:59 <roshanagr> yes :-)
16:54:03 <adrian_otto> oh
16:54:10 <adrian_otto> should I take back the other AI?
16:54:21 <adrian_otto> or will you accept both?
16:54:28 <tomblank> i think we need both :)
16:54:28 <roshanagr> but I am happy to take the mission statement as well if there are no other takers
16:54:38 <adrian_otto> roshanagr: <3
16:54:39 <roshanagr> I have it.
16:54:45 <tomblank> roshanagr: thanks!
16:55:02 <adrian_otto> #action roshanagr to make a list of topics for the Summit discussion on Wednesday, and circulate it for input.
16:55:35 <adrian_otto> ok, any other discussion, or would you like to wrap up a few minutes early today?
16:55:49 <roshanagr> Environments
16:56:11 <roshanagr> should we meet tomorrow, or just discuss at the summit?
16:56:25 <adrian_otto> meet tomorrow, and put it on our agenda for next week too
16:56:25 <devkulkarni> discuss at summit
16:56:38 <roshanagr> cool. lets do both.
16:56:59 <adrian_otto> devkulkarni: We don't have anything new to discuss this week?
16:57:35 <devkulkarni> yeah, we can meet tomorrow too
16:57:54 <devkulkarni> just thought looking at the etherpad that there was not much work happened
16:58:02 <adrian_otto> roshanagr: please list he Environments meeting at https://wiki.openstack.org/wiki/Solum/BreakoutMeetings
16:58:13 <roshanagr> adrian_otto: okay
16:58:15 <devkulkarni> so may be allow the team to think about environments till next week and then have informed discussion
16:58:32 <adrian_otto> I am happy to regroup on that the week after the summit if you feel there's not enough to discuss tomorrow
16:58:52 <adrian_otto> ok, w'eel do that
16:59:09 <adrian_otto> #agreed no Environments meeting tomorrow, we will discuss in Atlanta
16:59:34 <adrian_otto> #agreed no Weekly Team Meeting on 2014-05-13
16:59:48 <adrian_otto> next meeting is 2014-05-20 at 1600 UTC
17:00:11 <adrian_otto> thanks everyone!
17:00:17 <adrian_otto> #endmeeting