16:01:33 <adrian_otto> #startmeeting Solum Team Meeting
16:01:34 <openstack> Meeting started Tue Jun 17 16:01:33 2014 UTC and is due to finish in 60 minutes.  The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:38 <openstack> The meeting name has been set to 'solum_team_meeting'
16:01:46 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Solum#Agenda_for_2014-06-17_1600_UTC Our Agenda
16:01:52 <adrian_otto> #topic Roll Call
16:01:54 <paulmo> Paul Montgomery
16:01:55 <adrian_otto> Adrian Otto
16:01:59 <muralia> murali allada
16:02:01 <stannie> Pierre Padrixe
16:02:01 <noorul> Noorul Islam
16:02:03 <datsun180b> Ed "Ed Cranford" Cranford
16:02:16 <PaulCzar> o/
16:02:20 <aratim> Arati Mahimane
16:03:01 <ravips> Ravi
16:03:17 <funzo_> Chris Alfonso
16:03:32 <devkulkarni1> Devdatta Kulkarni
16:04:38 <adrian_otto> how is everyone this fine morning/day?
16:04:48 <anishk> Anish Karmarkar
16:04:49 <muralia> doing great
16:05:09 <devkulkarni1> hi anishk.. long time
16:05:23 <adrian_otto> #topic Announcements
16:05:47 <adrian_otto> We have new contributors joining the project. Anish and Gil form Oracle will be working with us going forward.
16:05:52 * anishk waves to Devdatta
16:05:59 <adrian_otto> please extend your welcomes!
16:06:08 <devkulkarni1> cool.. welcome Anish, Gil
16:06:10 <datsun180b> neat
16:06:10 <funzo> welcome!
16:06:11 <stannie> welcome Anish and Gil
16:06:11 <PaulCzar> welcome oracles!
16:06:14 <muralia> Welcome
16:06:15 <noorul> cool
16:06:15 <paulmo> Welcome!
16:06:17 * anishk is excited to be part of Solum
16:06:21 <noorul> welcome !
16:06:23 <anishk> thanks!
16:06:46 <adrian_otto> anishk, do you want to take a moment to say a few words to the team while you have their attention?
16:07:04 <anishk> sure
16:07:39 <anishk> Both Gil and I joined OpenStack recently and are thrilled to be part of OpenStack and thrilled to be able to contribute to Solum in any which way we can
16:08:02 <adrian_otto> I know that Ed and I have extended some help to get Gil
16:08:08 <anishk> We are very much interested in OpenStack and PaaS and have interest in making things interoperaable and portable
16:08:09 <adrian_otto> up and running with a dev environment
16:08:20 <anishk> thanks for that
16:08:36 <datsun180b> i like maintaining my dev env as a clean room
16:08:44 <adrian_otto> so if there is anything we can do to help you take flight, please let us know. This is a very helpful group.
16:08:51 <datsun180b> i get ruffled if it doesn't "just work"
16:08:54 <anishk> much appreciated
16:09:04 <adrian_otto> ok…
16:09:11 <adrian_otto> #topic Review Action Items
16:09:11 * ravips says hi to Anish and Gil
16:09:12 <anishk> I should also mention that both Gil and I also participate in the CAMP TC
16:09:42 <adrian_otto> we made an action item a couple of weeks back that I'd like to check on
16:09:44 <adrian_otto> devkulkarni to work with adrian_otto to document the LP devleopment approach in BP+task+wiki to clearly outline our approach, and how it solves each use case.
16:10:06 <devkulkarni1> adrian_otto: I will work with you on this in this week
16:10:07 <adrian_otto> we seem to be stalled on this one? IS that right devkulkarni1?
16:10:23 <adrian_otto> ok, we don't ahve anything blocking us now, do we?
16:10:25 <devkulkarni1> yes. I have it on my list for this week
16:10:32 <adrian_otto> ok, thanks, I will carry that one forward.
16:10:33 <devkulkarni1> not directly.
16:10:40 <adrian_otto> #action devkulkarni to work with adrian_otto to document the LP devleopment approach in BP+task+wiki to clearly outline our approach, and how it solves each use case.
16:10:54 <adrian_otto> (keeping the same typo, just for continuity) ;-)
16:11:12 <adrian_otto> #topic Review Tasks
16:11:36 <adrian_otto> I have not officially announced that we tagged the Juno-1 release
16:11:42 <adrian_otto> that came out last week
16:11:55 <devkulkarni1> yeah, saw that message on the irc
16:12:01 <adrian_otto> that was worth having in the announcements section
16:12:05 <devkulkarni1> thanks adrian_otto for that
16:12:17 <adrian_otto> we did not have a bunch of huge features in it, so I did not make a big fanfare on that one
16:12:35 <devkulkarni1> btw,
16:12:40 <adrian_otto> the more important release was the one before that which rolled in a whole bunch of bugfix and paid down a lot of tech debt
16:12:52 <devkulkarni1> the juno-1 plan that roshanagr had put on the wiki page had lot more things
16:13:10 <adrian_otto> devkulkarni1: yes, indeed
16:13:18 <devkulkarni1> I don't think we have finished all those items
16:13:30 <adrian_otto> I rolled forward all blueprints and tasks, and open bugs into J2: https://launchpad.net/solum/+milestone/juno-2
16:13:56 <adrian_otto> we have a whole bunch of reviews that are blocked on Mistral
16:14:20 <adrian_otto> the short story here is that we have showstopper issues with Mistral that have not merged yet
16:14:29 <noorul> We should bring in someone from Mistral to review them
16:14:33 <devkulkarni1> question. do we know if Mistral supports multi-tenancy?? gokrokve — ??
16:14:36 <adrian_otto> and I'm not comfortable taking a dependency on a third party for of Mistral
16:14:47 <adrian_otto> s/for/fork/
16:14:48 <gokrokve> devkulkarni1: It does
16:15:04 <adrian_otto> gokrokve: so my understanding is that all desired code is in review
16:15:12 <paulmo> gokrokve: Can you point me to that, the v0.1 documentation doesn't show tenant awareness that I saw
16:15:26 <adrian_otto> is there any reason to expect that to be delayed for merge, or is this just going to be a short wait?
16:16:32 <devkulkarni1> adrian_otto: you mean the patches that are up on Mistral repo?
16:16:39 <devkulkarni1> can we get pointers to them..
16:16:41 <gokrokve> https://github.com/stackforge/mistral/blob/master/mistral/db/sqlalchemy/models.py#L79
16:17:13 <gokrokve> Workbook is tagged by project_id, so users from one project do not see workbooks from another project
16:17:22 <devkulkarni1> gokrokve: thanks. paulmo
16:17:48 <adrian_otto> yes, so these seem like relatively trivial patches.
16:17:56 <paulmo> gokrokve: But notice that the name field is the primary key in that workbook schema.  So we'll have to do something like hash a tenant and append it to the name right?
16:18:07 <devkulkarni1> seems like project_id is there.. but don't know whether the workbook names are unique across tenants or can same name be used for different tenants
16:19:38 <adrian_otto> sounds like a composite primary key is in order
16:20:30 <paulmo> +1 adrian_otto, or something similar
16:20:32 <adrian_otto> so let's park this one and come back to it in open discussion
16:20:49 <gokrokve> Agree. I dont see that DB queries use project_id as a filter
16:21:13 <gokrokve> It looks simple to fix, though
16:21:20 <adrian_otto> once we get those changes into Mistral, and arrange for a release to be tagged, we can pick op that dependency through pypi on an N.N.N version value
16:21:38 <adrian_otto> does anyone have any objections to this approach?
16:22:00 <adrian_otto> should we come up with workarounds that are intended to make forward progress without any waiting for this?
16:22:20 <devkulkarni1> adrian_otto: sounds fine.. we could, will be great if we have asalkeld in that meeting
16:22:23 <paulmo> I'm documenting workarounds current
16:22:24 <paulmo> ly
16:22:48 <adrian_otto> paulmo: thanks. I love it when you exhibit initiative like that!
16:23:18 <paulmo> (probably just a SHA256 hash of the tenant and append that to the Mistral workbook name btw is my current thought)
16:23:20 <adrian_otto> devkulkarni1: let's plan to regroup with asalkeld later today, if we are expecting him, and just touch base on this one.
16:23:36 <devkulkarni1> adrian_otto: okay. sounds good.
16:23:57 <adrian_otto> #link https://launchpad.net/solum/+milestone/juno-2 juno-2 milestone tasks
16:24:14 <adrian_otto> does anyone want to raise a specific task for discussion today?
16:24:34 <adrian_otto> or report noteworthy progress against any
16:24:55 <datsun180b> sure
16:25:21 <datsun180b> so i've been having trouble with the client, and fragments of conversation were something to do with yaml support in solum
16:25:32 <datsun180b> i guess everyone in that conversation is asleep, aren't they
16:25:51 <adrian_otto> yes, unfortunately.
16:25:56 <noorul> datsun180b: stannie postedpatch
16:26:07 <datsun180b> oh did he? i'll take a look
16:26:09 <noorul> https://review.openstack.org/#/c/100605/1  https://review.openstack.org/#/c/100606/
16:26:18 <stannie> thank you for linking those
16:26:35 <noorul> waiting for jenkins to give green signal
16:26:37 <datsun180b> perfect
16:26:38 <stannie> and there is the one for "list" command that will come soon
16:26:39 <adrian_otto> #link https://review.openstack.org/100605
16:26:44 <adrian_otto> #link https://review.openstack.org/100606
16:27:11 <adrian_otto> ok, and that raises a related topic
16:27:11 <datsun180b> well those should resolve my problems manually testing the unittest changes
16:27:21 <adrian_otto> about functional tests for the CLI
16:27:44 <stannie> it's an expected behavior, we've to update the CLI with the YAML change in the API
16:27:45 <stannie> #link https://bugs.launchpad.net/python-solumclient/+bug/1309493
16:27:46 <uvirtbot> Launchpad bug 1309493 in python-solumclient "Feature: Client changes for Plan YAML support and Plan versionning" [Wishlist,Incomplete]
16:27:52 <stannie> yes
16:28:02 <adrian_otto> How would you feel about adding a func test to both solum and python-solumclient that exercise the CLI?
16:28:29 <stannie> do you mean a func test in python-solumclient ?
16:28:37 <adrian_otto> stannie, in both
16:28:50 <adrian_otto> because in this case we change solum, and it regressed python-solumclient
16:29:09 <adrian_otto> but because we don't test python-solumclient in gate, that defect got in
16:29:33 <stannie> yes that could really help
16:29:37 <noorul> Need to take a look at how tempest is doing i
16:29:52 <adrian_otto> ok, tomblank are you willing to open a task for this one?
16:30:01 <paulmo> I wonder if the Solum CLI should be lower priority given that the Horizon UI (or Mistral CLI) will be the only way shortly to execute something in Solum, correct?
16:30:02 <adrian_otto> any volunteers for coding this up?
16:30:02 <tomblank> adrian_otto: yes, will do
16:30:03 <datsun180b> categorically i don't know that solum ought to bear solumclient tests, but it makes sense that the client should assume a solum endpoint
16:30:13 <adrian_otto> tomblank: thanks
16:31:15 <adrian_otto> datsun180b: so what is your recommendation?
16:31:31 <noorul> We can have the tests in solum client repo
16:31:38 <adrian_otto> I'd argue that python-solumclient is needed in order for most users to interact with Solum
16:31:44 <datsun180b> that the client bear its own functional tests, and require that to run them you have a solum endpoint specified
16:31:45 <noorul> and execute them for both solum and client gate
16:32:02 <adrian_otto> noorul: yes, that's what I would be happy with
16:32:18 <datsun180b> that's all the client is basically, an http client that understands the context of solum and can parse responses and shape requests to communicate with it
16:32:51 <adrian_otto> do we not have an API func test in Solum? Is that the problem?
16:33:02 <datsun180b> like paulmo mentioned, other uis can supplant it
16:33:39 <adrian_otto> datsun180b: please help me understand. I'm not following.
16:33:55 <datsun180b> python-solumclient isn't (or shouldn't) be required to interact with solum
16:34:12 <adrian_otto> it's not.
16:34:36 <datsun180b> right, so keeping functional tests for it in solum's codebase is what i take issue with
16:34:40 <PaulCzar> datsun180b: I think though that we can use solumcli as the reference implementation of a solum client, therefore it makes sense to ensure it always works
16:34:56 <adrian_otto> datsun180b: see noorul's suggestion
16:34:57 <PaulCzar> s/use/think of/
16:35:39 <datsun180b> keeping the client's functional tests in the client's repo is all i'd suggest. i guess that's violent agreement with noorul
16:35:45 <adrian_otto> I think it's fine to kick off tests that live in the python-solumclient repo, so that we don't get out of sync when we adjust the API
16:36:04 <adrian_otto> ok, good, so we are aligned on this
16:36:13 <adrian_otto> thanks for explaining your concerns datsun180b
16:36:32 <adrian_otto> any other task updates to touch on?
16:36:37 <aratim> I am having trouble with the devstack gate. Functional tests are failing for my patch - https://review.openstack.org/#/c/96928/. Functional tests are running fine on mine and Ed's local devstack env. Any pointers would be of great help !
16:37:14 * noorul is looking
16:37:37 <adrian_otto> aratim: did you see this: http://logs.openstack.org/28/96928/8/check/gate-solum-devstack-dsvm/f9b9711/console.html.gz#_2014-06-13_16_47_36_421
16:38:09 <noorul> foreign key constraint violation
16:38:17 <aratim> yes adrian_otto: I have seen that
16:38:27 <aratim> But I think the real problem arises here - http://logs.openstack.org/28/96928/8/check/gate-solum-devstack-dsvm/f9b9711/console.html.gz#_2014-06-13_16_47_36_820
16:38:34 <adrian_otto> what do you make of "Cannot delete or update a parent row: a foreign key constraint fails"
16:38:51 <paulmo> We might need some cascading deletes sprinkled in the schema
16:39:28 <noorul> paulmo: I have not see that in other openstack projects
16:39:33 <noorul> I might be wrong
16:39:51 <datsun180b> oh these are actually DELETE FROMs and not just UPDATE WHEREs
16:40:08 <noorul> We had this issue for component
16:40:10 * paulmo nods.  I'm not sure if there are unwritten rules around the usage but it is handy if you carefully place them where it makes sense.
16:40:30 * noorul agrees
16:40:33 <paulmo> Otherwise code will have to manually walk the chain and delete dependencies.
16:41:26 <aratim> paulmo: the functional tests are doing exactly that
16:41:37 <paulmo> They'd have to. :)
16:41:46 <devkulkarni1> +1 aratim
16:42:04 <aratim> adrian_otto: we can discuss this later on #solum, dont want to take up all the time
16:42:29 <adrian_otto> aratim: do you want me to record any action items on this?
16:42:46 <aratim> sure
16:42:55 <aratim> that would be great!
16:42:57 <adrian_otto> maybe noorul can offer some advice,and help get you unstuck since we did see this before
16:43:22 <adrian_otto> noorul: is it okay if I give aratim an action item to follow up with you on this?
16:43:39 <noorul> The first failure is for component_put and I think that is not related to foreign key
16:43:57 <noorul> adrian_otto: I am okay
16:44:25 <aratim> yes noorul, the problem is here - http://logs.openstack.org/28/96928/8/check/gate-solum-devstack-dsvm/f9b9711/console.html.gz#_2014-06-13_16_47_36_820
16:44:37 <aratim> Assembly is not getting deleted
16:44:38 <adrian_otto> #action aratim to follow up with noorul to plan a solution to https://review.openstack.org/#/c/96928/
16:44:53 <adrian_otto> ok, thanks for that.
16:45:12 <adrian_otto> any other task updates? We have just one more item on the agenda before open discussion.
16:45:46 <adrian_otto> ok, moving on
16:45:53 <adrian_otto> #topic Blueprint Discussion
16:46:19 <adrian_otto> before our mid-cycle meetup for Icehouse I was conducting a Bluepring review during our team meetings
16:46:32 <adrian_otto> this gave the team a chance to sync up on our important work items
16:47:01 <noorul> aratim: http://logs.openstack.org/28/96928/8/check/gate-solum-devstack-dsvm/f9b9711/logs/screen-solum-api.txt.gz#_2014-06-13_16_47_22_808
16:47:06 <adrian_otto> since we switched to tasks using bug tickets, we have done less sync-up, and I wanted to get all your thoughts about if we should make a change
16:47:31 <adrian_otto> and put our key pursuits back into blueprints and ask them to be owned and reported on each week by its owner
16:47:49 <adrian_otto> that approach going give us a better sense of unity in understanding how we are progressing against those goals
16:47:53 <adrian_otto> what do you all think about this?
16:48:19 <adrian_otto> we would not use Blueprints as a task list, but as a status instrument
16:48:31 <muralia> +1
16:48:39 <devkulkarni1> I like this better
16:48:44 <devkulkarni1> i mean the new way
16:49:07 <adrian_otto> devkulkarni1: ok, why do you feel that way about it?
16:49:14 <devkulkarni1> the reason being, many times we did not have details in the blueprints and so it was not really possible to get the overall picture anyways
16:49:26 <paulmo> It seems like we could collapse some of the tools somehow… we'd have to update blueprints, rst specs and bugs, right?
16:49:26 <devkulkarni1> now we are going towards spec repo
16:50:07 <adrian_otto> paulmo: we don't necessarily need to update the BPs
16:50:23 <adrian_otto> but I would use them to form the weekly agenda
16:50:28 <stannie> the bug tasks help to have granularity, before we had a big bps without granular tasks and it was hard to dispatch the work. Can't we use both system ? Bug tickets for granular tasks and blueprint for highlevel task ?
16:50:36 <devkulkarni1> to address adrian_otto your question about how to get overall picture and status update..
16:50:38 <adrian_otto> the other thing I can do is just use the meeting agenda to cover what I think are important topics
16:50:47 <tomblank> adrian_otto:  +1.  i would like to get back to reviewing/giving updates on the blueprints/specs.   we could also review the tasks associated with each BP/spec during that discussion.
16:51:27 <devkulkarni1> I like keeping it informal and trusting adrian_otto (and the entire team) to bring important topics for the meeting discussion
16:51:31 <adrian_otto> stannie: yes, that's what I'm thinking
16:51:38 <stannie> ok great
16:51:53 <adrian_otto> ok, so let's try a half-step at first
16:51:55 <tomblank> stannie: yes, agree...
16:52:13 <adrian_otto> I will call out some agenda points and just ask for updates on them
16:52:37 <adrian_otto> the benefit should be that new and less active contributors can stay in the loop with us, and be able to help out more
16:52:59 <devkulkarni1> sounds good.
16:53:01 <adrian_otto> if we drift too far apart in terms of understanding what's happening, it's hard for those less involved contributors to jump in and help
16:53:22 <devkulkarni1> adrian_otto: good point.
16:53:24 <adrian_otto> ok, so we will re-evaluate in a couple of weeks and see if we should move further in that direction
16:53:45 <adrian_otto> I don't want to force updates if they don't make sense either
16:54:21 <adrian_otto> so if there is something you will be expected to report on, you can update the agenda page, and just put (skip) at the end of one, and I won't raise it for discussion if there is nothing to say about it.
16:54:45 <adrian_otto> are we happy with this? I'm going to note this with a #agreed
16:54:58 <devkulkarni1> agreed
16:55:02 <tomblank> agreed
16:55:03 <stannie> +1
16:55:05 <gokrokve> agreed
16:55:11 <ravips> agreed
16:55:13 <datsun180b> yeah
16:55:18 <muralia> +1
16:55:34 <adrian_otto> #agreed adrian_otto will identify key pursuits for the project, and have them as standing agenda items in our meeting agendas, requesting updates for higher team visibility.
16:55:37 <adrian_otto> thanks
16:55:41 <adrian_otto> #topic Open Discussion
16:56:04 <adrian_otto> anything I could be doing better for you all?
16:56:18 <tomblank> any thoughts on mid-cycle meetup? do we have one?  when? where?
16:56:32 <tomblank> i think they have been helpful to the project in the past...
16:56:39 <devkulkarni1> after juno-2 probably..
16:57:03 <muralia> that sounds like a good time to meet
16:57:21 <adrian_otto> late July would make sense
16:57:35 <adrian_otto> or perhaps the first week of Aug
16:57:36 <anish_karmarkar> where?
16:57:42 <adrian_otto> Austin
16:58:12 <adrian_otto> It's Rackspace's turn to host, and we have the most attendees in Austin, so that would help us from a budgeting perspective
16:58:15 <tomblank> +1 on Austin.
16:58:19 <muralia> +1
16:58:23 <tomblank> :)
16:58:28 <datsun180b> naturally i have to agree
16:58:36 <paulmo> Bring sun tan lotion!
16:58:52 <datsun180b> and plaid shirts
16:59:03 <adrian_otto> anish_karmarkar: you don't have to swim
16:59:08 * anish_karmarkar first week of aug works lot better for me than last week of july
16:59:17 <adrian_otto> but let us know if that's something that you think we could arrange
16:59:24 <adrian_otto> I will circulate a poll to find the best date
16:59:27 <tomblank> with this being holiday season, we should pick dates soon...
16:59:42 <adrian_otto> as long as there are no violent objections to using Austin as the meeting place this time
16:59:42 <tomblank> adrian_otto: +1 thanks...
16:59:58 <ravips> BP for supporting private github repos: https://blueprints.launchpad.net/solum/+spec/support-private-github-repos , plz review and let me know if you see any issues
17:00:05 <devkulkarni1> we should invite mistral folks
17:00:11 <muralia> yes
17:00:13 <devkulkarni1> ravips: awesome!!
17:00:14 <devkulkarni1> thanks
17:00:19 <adrian_otto> ravips: sweet!
17:00:31 <adrian_otto> thanks everyoen for attending this week
17:00:38 <adrian_otto> keep an eye out for the ML
17:00:42 <adrian_otto> #endmeeting