16:02:28 <tomblank> #startmeeting Solum Team Meeting
16:02:29 <openstack> Meeting started Tue Jul 15 16:02:28 2014 UTC and is due to finish in 60 minutes.  The chair is tomblank. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:33 <devkulkarni> really? I thought anybody who does start meeting is a chair
16:02:34 <openstack> The meeting name has been set to 'solum_team_meeting'
16:02:41 <datsun180b> beats me then, guess it was asleep
16:02:47 <tomblank> #topic Roll Call
16:02:51 <paulmo> Paul Montgomery
16:02:52 <datsun180b> Ed Cranford
16:02:56 <devkulkarni> Devdatta Kulkarni
16:02:59 <aratim> Arati
16:03:02 <peoplemerge_> Dave Thomas
16:03:02 <tomblank> Tom Blankenship, pro-tem Chair
16:03:04 <stannie> Pierre Padrixe
16:03:10 <james_li> James Li
16:03:19 <PaulCzar> Paul Czarkowski
16:03:30 <tomblank> #link https://wiki.openstack.org/wiki/Meetings/Solum#Agenda_for_2014-07-01_1600_UTC  our Agenda
16:04:00 <adrian_otto> Adrian Otto - attention divided, will participate as much as I can.
16:04:36 <tomblank> thanks Adrian.
16:04:39 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Solum#Agenda_for_2014-07-15_1600_UTC this week's agenda
16:05:03 <tomblank> #topic Announcements
16:05:16 <tomblank> anyone have any announcements?
16:06:46 <tomblank> since we don't have any open action items listed, let's jump to Blueprint/Task Review
16:07:09 <tomblank> #topic  Blueprint/Tasks Review
16:08:06 <tomblank> Any updates on the Build Farm
16:08:08 <tomblank> #link https://review.openstack.org/100539 Build Farm Spec
16:08:44 <devkulkarni> I guess the work continues on it
16:08:47 <tomblank> #link https://review.openstack.org/#/c/100539/
16:08:48 <stannie> Julien won't be available for the next days
16:09:17 <tomblank> stannie: thanks. do you have any update or should we wait until Julien returns?
16:09:35 <stannie> last newt solum-infra-guestagent repository is now available in stackforge, last review (can't find the link) was merged
16:09:57 <stannie> going to see what I can do on guestagent this week
16:10:11 <devkulkarni> stannie: do we have a spec for guestagent?
16:10:15 <tomblank> stannie:  great, thanks.
16:10:28 <devkulkarni> or a blueprint?
16:10:40 <stannie> it's in the build-farm link dev
16:11:32 <devkulkarni> for the agent as well? https://blueprints.launchpad.net/solum/+spec/solum-build-farm don't see it there
16:11:46 <devkulkarni> https://review.openstack.org/#/c/100539/5/specs/juno/solum-build-farm.rst don't see it here as well
16:12:00 <stannie> but not really detailed for the moment indeed
16:12:01 <devkulkarni> didn't mean to distract
16:12:10 <devkulkarni> okay, that's what I thought
16:12:39 <devkulkarni> could you please then add some details in a bp or a spec before you start work on it?
16:12:53 <stannie> sure
16:13:08 <tomblank> stannie: thanks
16:13:13 <devkulkarni> thanks stannie
16:14:13 <tomblank> anything else on this?
16:14:46 <tomblank> Private git repo integration
16:14:47 <tomblank> #link https://blueprints.launchpad.net/solum/+spec/support-private-github-repos
16:15:05 <devkulkarni> ravips has a WIP for this
16:15:20 <devkulkarni> it looks good. remaining work items are the CLI changes, unit tests
16:15:34 <muralia> i see he has made the changes that paulcz recommended
16:15:50 <muralia> the build is failing though.
16:16:14 <devkulkarni> I thought it was because of the barbican client being absent from requirements.txt
16:16:54 <muralia> he's included it in the new patch
16:17:18 <devkulkarni> hmm.. lets try to touch base with ravips when is available
16:17:26 <muralia> yup
16:18:11 <tomblank> muralia: can you reach out to ravips and see if there is something you can help with?
16:18:12 <devkulkarni> but other than that it looks good to me. it is progressing, tomblank
16:18:19 <muralia> i will
16:18:23 <tomblank> devkulkarni: thanks....
16:18:27 <tomblank> muralia: thanks...
16:18:45 <tomblank> the last one is Chained Trusts (julienvey, asalkeld)
16:18:53 <tomblank> #link https://review.openstack.org/99908
16:19:06 <devkulkarni> last I know about this was that we are getting around this issue
16:19:12 <tomblank> i know that julienvey and asalkeld are both missing but does anyone else have any updates?
16:19:14 <devkulkarni> by creating a heat stack upon startup
16:19:35 <devkulkarni> it is part of one of the mistral patches by asalkeld
16:19:38 <tomblank> devkulkarni: yes.
16:20:47 <devkulkarni> so I guess we need to just take those patches forward
16:20:47 <tomblank> any other blueprints/tasks that people have updates or questions on?
16:21:02 <tomblank> devkulkarni: agree
16:21:33 <peoplemerge_> any reviews that I can do?
16:21:54 <devkulkarni> peoplemerge_: https://review.openstack.org/#/q/status:open+solum,n,z
16:22:13 <adrian_otto> peoplemerge: you are welcome to review everything that's open
16:22:15 <peoplemerge_> devkulkarni: is there one useful yet suitable to a new reviewer?
16:22:55 <devkulkarni> oh okay.. you could start with the spec reviews.. imo they are good place to get a feel for some problem without having to deal with code right away
16:23:37 <peoplemerge_> adrian_otto: devkulkarni: ok
16:23:42 <tomblank> #topic open discussion
16:24:04 <tomblank> I do have one topic for open discussion.
16:24:07 <devkulkarni> also we have some refactoring stuff https://review.openstack.org/#/c/104637/ .. would be great to have more eyes on it
16:24:28 <devkulkarni> peoplemerge_: also feel free to ping on #solum afterwards
16:24:49 <noorul> peoplemerge_: https://review.openstack.org/#/q/status:open+project:stackforge/solum,n,z
16:24:59 <peoplemerge_> devkulkarni: will start with that one, thx
16:25:16 <devkulkarni> peoplemerge_: sounds good.
16:25:40 <adrian_otto> ooh, 104637 looks very interesting. I'm really happy to see that one.
16:26:00 <devkulkarni> datsun180b ^^
16:26:13 <datsun180b> bwuh
16:26:21 <tomblank> what are everyone's thoughts about the need (or not) for a mid-cycle meet-up?
16:26:43 <devkulkarni> tomblank: what time-frame you have in mind?
16:27:17 <adrian_otto> datsun180b: we should probably have copyright notices in our shell scripts too
16:27:35 <devkulkarni> I feel that right now is a bit early to meet — we are kind of clear what need to be done and where we are heading
16:27:35 * datsun180b makes a face
16:27:35 <adrian_otto> that identify the license that they are covered by
16:27:56 <devkulkarni> tomblank ^^
16:28:21 <tomblank> i would think August or early September.  any later and it's too close to the Paris summit.
16:28:48 <devkulkarni> I vote for late August / early September, if we have to hold one
16:28:49 <datsun180b> hey fixup-spec-repo merged
16:28:58 <noorul> also it is important to take look at where we are after atlanta summit
16:29:10 <stannie> yeah late August/early Sept. would be more appropriated than right now
16:29:16 <adrian_otto> tomblank: please elaborate on your rationale about "too close" to the summit
16:29:56 <PaulCzar> adrian_otto: doesn’t this cover the copyright / license for anything in the repo - https://github.com/stackforge/solum/blob/master/LICENSE ?
16:30:01 <adrian_otto> my understanding is that we will have a relatively small number of Solum stackers attending in Paris.
16:30:30 <datsun180b> my French skills have slipped way under what i'd call conversational
16:30:49 <adrian_otto> PaulCzar: yes, for redistribution. It's just a best practice to label each file, so if they end up elsewhere, the provenance of them is more clear.
16:31:05 <datsun180b> adrian_otto: then what purpose LICENSE at all
16:31:40 <tomblank> adrian_otto:  sure.   i see a primary value in a f2f meeting is to sync on the juno deliverables, prioritize those deliverables and then have time to actually complete them prior to the Juno summit.
16:31:54 <adrian_otto> datsun180b: it applies when you have something that's not practical to label individually
16:32:30 <datsun180b> fair enough
16:32:32 <tomblank> if we only have a month or so before the summit, we may not have time to course adjust or get things done prior to the summit.
16:32:37 <datsun180b> those scripts will get a license soon
16:33:25 <tomblank> i am also aware of the time commitment for folks to travel in October and then potentially travel again in November (for those traveling to the summit).
16:33:32 <adrian_otto> tomblank: good reason. So, let's shoot for September?
16:33:42 <noorul> I nova I see that shell scripts carry license header
16:34:09 <noorul> s/^I/In
16:34:12 <tomblank> If we feel we need to meet then September would be appropriate.
16:34:58 <tomblank> I am also ok if folks feel that for this cycle, we don't need to meet.  I know that some people were voicing that opinion last week...
16:35:24 <adrian_otto> we could always make a tentative plan, and ask attendees not to make any non-refundable travel plans until a final confirmation. If it does not make sense to meet as we approach that tentative date, we can cancel it.
16:35:38 <devkulkarni> we could try that and see how it goes..
16:36:04 <devkulkarni> we had also discussed doing a virtual meetup of sorts
16:36:37 <tomblank> adrian_otto: that sounds like a plan.  we should also set a trigger date where we make a decision (ex: 30 days prior to dates).
16:36:51 <adrian_otto> yes, exactly
16:37:58 <tomblank> devkulkarni: the problem with a virtual meeting is the time zone logistics so that everyone interested could attend :)
16:38:06 <iccha> round?
16:39:00 <devkulkarni> tomblank: oh that's right. we had talked about that issue.
16:40:25 <tomblank> devkulkarni: we could still do a virtual meeting because the time zone issue may be less than traveling to Austin...
16:40:59 <devkulkarni> yeah.. and in that case we might do it for more days instead of typical two
16:41:09 <tomblank> devkulkarni: agreed
16:42:07 <tomblank> sounds like we will tentatively plan on a meeting in mid-September but will make a final decision in Mid-August on if we need to meet or not.
16:42:16 <devkulkarni> +1
16:42:16 <adrian_otto> +!
16:42:20 <noorul> +1
16:42:47 <tomblank> #agreed we will tentatively plan on a meeting in mid-September but will make a final decision in Mid-August on if we need to meet or not.
16:42:53 <tomblank> other topics?
16:43:44 <devkulkarni> noorul: how is the spec process working out for you?
16:43:57 <noorul> hardly find time to review
16:44:33 <devkulkarni> hmm.. I think for most of the big changes most of us have now gotten into the habit of creating a spec first.
16:44:55 <adrian_otto> I have been happy with it so far
16:45:09 <adrian_otto> the template challenges us to think about our plans throuroughly
16:45:11 <noorul> but I see that nothing gets merge
16:45:18 <noorul> s/merge/merged
16:45:20 <tomblank> adrian_otto: +1
16:45:25 <devkulkarni> what do you mean?
16:45:37 <noorul> https://review.openstack.org/#/q/status:open+project:stackforge/solum-specs,n,z
16:45:50 <devkulkarni> I think some of the unmerged specs are unmerged because of some minor points which the author needs to resolve
16:45:58 <devkulkarni> this is same as any other review
16:46:12 <noorul> isn't merge == approval ?
16:46:25 <adrian_otto> https://review.openstack.org/#/q/status:closed+project:stackforge/solum-specs,n,z
16:46:28 <datsun180b> right, so work shouldn't officially start on unmerged repos
16:46:40 <devkulkarni> yes, but we have also said that we can start code with WIP, and not merge it before the spec is merged
16:47:04 <devkulkarni> thanks adrian_otto
16:47:47 <noorul> adrian_otto: that list has only one spec
16:47:58 <noorul> sorry two
16:48:04 <datsun180b> for now!
16:48:26 <devkulkarni> I see 5 merged nd 2 abandoned
16:48:48 <noorul> 3 is repo related not acutal spec
16:48:50 <adrian_otto> devkulkarni: his point is that most of those are housekeeping reviews, not specs
16:48:54 <devkulkarni> sure, only 2 are for core features I guess
16:49:22 <devkulkarni> fair enough. but I would still disagree with the contention that specs are not getting merged.
16:49:23 <adrian_otto> noorul's comment is valid, we should make a concerted effort to clean up specs to the point that we merge them
16:49:38 <tomblank> i think it is a valid point.  we need to continue to focus on reviewing and approving (merging) the specs...
16:49:49 <adrian_otto> we naturally de-prioritize that, because these are not actually code
16:50:07 <gpilz> +q
16:50:11 <adrian_otto> but if we treated them like code, then we could get to a merge point sooner
16:50:41 <tomblank> adrian_otto: +1
16:50:48 <gpilz> i have one other thing that I'd like to ask a question about
16:51:23 <adrian_otto> gpilz: in open discussion it's the wild west. ask away.
16:51:27 <devkulkarni> gpilz: listening
16:51:27 <tomblank> gpliz: of course...
16:51:37 <gpilz> the following bp: https://blueprints.launchpad.net/solum/+spec/solum-camp-api
16:51:59 <gpilz> has a note saying that it has be superseded by the "Pipeline" blueprint
16:52:23 <gpilz> from my point of view, the two things have nothing to do with one another
16:52:28 <gpilz> so I'm confused
16:52:44 <adrian_otto> I'll re-open it
16:53:01 <gpilz> thanks
16:53:07 <adrian_otto> that point of view is rooted from the perspective that there was not a volunteer to contribute that
16:55:10 <adrian_otto> gpilz: what is your LP username?
16:55:41 <gpilz> gilbert-pilz
16:55:55 <adrian_otto> ok, you are now the assignee for the BP
16:55:59 <gpilz> woot!
16:56:26 <tomblank> we have 4 minutes left... any other topics?
16:57:30 <tomblank> ok, thanks everyone.  we'll end a few minutes early.
16:57:36 <tomblank> #endmeeting