22:00:21 <adrian_otto> #startmeeting Solum Team Meeting
22:00:22 <openstack> Meeting started Tue Aug  5 22:00:21 2014 UTC and is due to finish in 60 minutes.  The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:00:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:00:26 <openstack> The meeting name has been set to 'solum_team_meeting'
22:00:33 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Solum Our Agenda
22:00:44 <adrian_otto> #topic Roll Call
22:00:47 <adrian_otto> Adrian Otto
22:00:53 <muralia> Murali Allada
22:00:55 <tomblank> tom blankenship
22:00:56 <ravips> Ravi Sankar Penta
22:00:57 <james_li> James Li
22:01:18 <datsun180b> Ed Cranford
22:02:32 <asalkeld> o/
22:02:56 <adrian_otto> welcome everyone!
22:03:11 <adrian_otto> #topic Announcements
22:03:21 <adrian_otto> (none prepared, any from the team?)
22:03:55 <adrian_otto> I am on ETO this week, and will be returning to work on Monday
22:04:17 <adrian_otto> but I have not checked in much in the past few weeks, so I wanted to touch down with you today
22:04:37 <adrian_otto> Ed, did we have action items from last week?
22:04:45 <adrian_otto> #topic Review Action Items
22:04:45 <datsun180b> oh let me go check
22:04:51 <adrian_otto> tx
22:05:25 <datsun180b> #link http://eavesdrop.openstack.org/meetings/solum/2014/solum.2014-07-29-16.03.html
22:05:35 <datsun180b> just one, ravips to add testing docs to repo
22:05:48 <adrian_otto> ok, status of that?
22:06:41 <ravips> I did not add testing docs to the repo, I was able to update the wiki directly
22:06:51 <ravips> updated https://wiki.openstack.org/wiki/Solum/Testing, please review
22:07:34 <adrian_otto> ravips: so to add something to the repo, we need to submit it through Gerrit for review. Did you attempt that?
22:07:58 <ravips> I did not find the corresponding rst file in the repo
22:08:00 <datsun180b> I think the original attempt was to update the docs, and it was assumed that the repo was the route for that
22:08:13 <datsun180b> but the wiki is just a wiki, there's no repo behind it
22:08:19 <adrian_otto> ok
22:08:28 <adrian_otto> so we can consider that action item complete
22:08:50 <adrian_otto> if we do have a gap in our docs, lets submit a bug ticket and then submit patches against that to resolve the gap
22:09:04 <ravips> do we want to move our wiki content to rst files or leave it in wiki for editing?
22:09:08 <adrian_otto> Do members of our team feel the Wiki is sufficient?
22:09:37 <asalkeld> most projects use rst files
22:09:44 <asalkeld> not really wiki
22:09:45 <adrian_otto> I think if something feels like it belongs in the repo, and it's not changing rapidly, then we should put it in the repo docs, and link to that from the wiki
22:09:51 <asalkeld> as they get forgotten
22:09:53 <adrian_otto> asalkeld: +1
22:09:58 <datsun180b> i like having the wiki offhand as a reference
22:10:15 <datsun180b> at worst we just copy and rstify the wiki to INSTALLING.rst and call it good
22:10:21 <datsun180b> no dibs on that
22:10:42 <muralia> ya, im ok with copying the same to rst
22:10:42 <tomblank> my 2 cents is that the Wiki is sufficient.
22:10:44 <ravips> when to use wiki vs rst vs dockbook https://wiki.openstack.org/wiki/Documentation/HowTo#What_Docs_Go_Where.3F
22:10:45 <asalkeld> it's not a big issue, I like our readthedocs tho'
22:11:15 <asalkeld> http://solum.readthedocs.org/en/latest/
22:11:56 <adrian_otto> ravips: according to that guideline this really is RST content for us, yeah?
22:12:12 <ravips> yeah, I think RST is better for us
22:12:56 <adrian_otto> ravips: are you willing to take a new action to put that into RST?
22:12:58 <ravips> I will create rst files for the existing content this week
22:13:07 <adrian_otto> it's okay if you table it for later
22:13:23 <adrian_otto> the action item could just be to file the bug ticket if you want to revisit it another time
22:13:41 <tomblank> ok i withdraw my 2 cents..  and let's put it in the repo :)
22:13:53 <datsun180b> they'll have to be manually updated in the future should something change so it's understood that it's ongoing
22:14:14 <datsun180b> so which is to become the authority, the repo or the wiki?
22:14:23 <adrian_otto> #action ravips to submit a bug ticket to track conversion of testing related Wiki content to RST, when convenient. Entered as a wishlist item.
22:14:51 <adrian_otto> datsun180b: the RST would be authoritative, and we can put links to it in the wiki for convenience
22:15:06 <datsun180b> thanks, just wanted it in writing
22:15:15 <adrian_otto> the rationale is that our team should be comfortable merging patches
22:15:32 <adrian_otto> if we have content sourced by non-developers, we can look at alternate approaches
22:15:39 <adrian_otto> ok, next topic
22:15:56 <adrian_otto> #topic Blueprint/Task Review
22:16:03 <adrian_otto> #link https://launchpad.net/solum/+milestone/juno-2 Juno Development Tasks
22:16:14 <adrian_otto> Subject: Pipelines
22:16:27 <adrian_otto> updates on this?
22:16:58 <asalkeld> adrian_otto, it's in and works
22:17:16 <asalkeld> did a demo over the weekend
22:17:17 <asalkeld> at pyconau
22:17:20 <adrian_otto> asalkeld: sweet!
22:17:24 <datsun180b> nice
22:17:25 <adrian_otto> oh, that's awesome
22:17:36 <asalkeld> so unittest is not in
22:17:49 <asalkeld> but build and build_deploy are in and work
22:17:50 <datsun180b> i was about to ask about de-fire-brigading those methods
22:18:00 <tomblank> asalkeld: is there a video or anything you could share?
22:18:10 <datsun180b> since build calls to unittest and then deploy
22:18:12 <asalkeld> tomblank, they will be uploading soon
22:18:13 <tomblank> of the pyconau demo?
22:18:23 <asalkeld> https://www.youtube.com/user/PyConAU
22:18:25 <tomblank> asalkeld: great, thanks!
22:18:38 <asalkeld> all kinds of talks there
22:18:46 <asalkeld> interesting one about zerovm
22:18:51 <adrian_otto> ok, so what are our next steps with Pipelines, add the unittest module?
22:18:58 <asalkeld> adrian_otto, yip
22:19:08 <asalkeld> and ui
22:19:13 <adrian_otto> do we already have an assignee?
22:19:23 <asalkeld> not yet
22:19:39 <asalkeld> also need some integration with the infra stuff
22:19:53 <datsun180b> i'm guessing the rpc methods in worker need to be updated
22:20:18 <adrian_otto> asalkeld: are you referring to integration with the build farm resources?
22:20:56 <muralia> I'm investigating UI and horizon integration
22:20:59 <asalkeld> yip
22:21:02 <asalkeld> we need to get the outputs from the infra farm heat stack and feed that into the  mistral context
22:21:14 <asalkeld> (pipeline_handler)
22:21:37 <asalkeld> muralia, even something simple to start with would be good
22:21:55 <asalkeld> and integrates with mistal UI
22:22:01 <asalkeld> and heat stacks
22:22:09 <muralia> yup. I'm taking what paul was working on to help us create a simple mistral workflow and use that
22:22:22 <adrian_otto> ok, good.
22:22:33 <adrian_otto> any more thoughts on Pipelines before we advance to the next topic?
22:22:46 <asalkeld> no, I am done
22:23:06 <adrian_otto> Subject: Build Farm
22:23:28 <adrian_otto> what's happened here in the past few weeks?
22:24:04 <asalkeld> guest agent reviews
22:24:21 <asalkeld> and some docker setup stuff
22:24:25 <adrian_otto> anything we should touch base on together today?
22:24:41 <asalkeld> (not a good time for julienvey I guess)
22:24:57 <adrian_otto> I think he is/was out on vacation
22:25:07 <asalkeld> stannie not in
22:25:38 <adrian_otto> ok, will come back to that next week
22:25:46 <adrian_otto> Subject: Private git repo integration (ravips)
22:26:07 <adrian_otto> ravips: how is this coming along?
22:26:18 <ravips> completed the task last week, need code reviews from the team: https://review.openstack.org/105605 , https://review.openstack.org/109468 , https://review.openstack.org/111846
22:26:44 <adrian_otto> ok, good!
22:26:59 <muralia> ravips, were you able to figure out why the f20 gate keeps failing?
22:27:26 <ravips> yes, look at this change https://review.openstack.org/111846
22:27:32 <adrian_otto> Jenkins did not vote on 109468?
22:27:51 <datsun180b> probably waiting for us to move on it first
22:28:10 <muralia> i see a +1 from jenkins
22:28:12 <ravips> adrian_otto: barbican was not installed on devstack and that causing functionaltests to fail
22:28:14 <datsun180b> oh nevermind, i see muralia there
22:28:42 <adrian_otto> ravips: I see, so 109468 addresses that?
22:28:43 <ravips> muralia was talking about the same issue,  https://review.openstack.org/111846 should fix jenkins problem
22:29:01 <muralia> cool. i think most people were waiting for jenkins to +1 before they revire.
22:29:49 <ravips> then i need +1 for 111846 :)
22:30:14 <adrian_otto> ok, so I aded a +2 on 109468
22:30:19 <muralia> I've been testing your code ravi. I'm having a few issues with hookinh up the trigger url with my git repo to test git push, but seems to be working. good stuff.
22:30:38 <adrian_otto> muralia: that's exciting!
22:30:49 <adrian_otto> This is going to be a really slick feature. Let
22:31:12 <adrian_otto> Let's help ravips finish it up by getting those reviews in
22:31:26 <datsun180b> can do
22:31:31 <muralia> we dont support branches yet though. solum will always pull from master.
22:31:46 <ravips> muralia: lets chat on solum after the call about the issues you faced
22:32:09 <adrian_otto> muralia: we might want to track our caveats like that one in tech tebt task/bug tickets
22:32:11 <datsun180b> i added some code to unittest-app and slugtester to pave the way for specifying branches
22:32:24 <muralia> ravips: sure.
22:32:25 <adrian_otto> sweet
22:32:29 <muralia> yup. will add bugs.
22:32:35 <adrian_otto> muralia: tx!!
22:32:44 <adrian_otto> any more on the subject of private repos?
22:32:52 <ravips> i'm done
22:33:10 <adrian_otto> I think we are finished checking in on chained trust things, right asalkeld?
22:33:26 <adrian_otto> is there anything outstanding there we should be keeping track of?
22:34:06 <asalkeld> no
22:34:17 <adrian_otto> #topic Open Discussion
22:34:24 <adrian_otto> thanks asalkeld
22:34:58 <gpilz> i finally got the Solum CAMP API spec in for review
22:35:06 <gpilz> https://review.openstack.org/112154
22:35:12 <adrian_otto> thanks Gil
22:35:37 <gpilz> sorry for the multiple commits - i should have used —amend
22:36:04 <datsun180b> no problem, we can sort it all out. glad you're on the contrib list now
22:36:16 <ravips> we have 20+ bugs that needs to be triaged
22:36:34 <adrian_otto> ravips: I will get that in order starting on Monday
22:36:39 <datsun180b> yeah, i just threw one on the pile yesterday--deploys have been failing for me
22:36:45 <adrian_otto> anything urgent that I should fit in before I come back to work?
22:36:49 <ravips> adrian_otto: ok, thanks
22:37:27 <adrian_otto> you are welcome to start in on a bug even before triage between now and then
22:37:41 <adrian_otto> please don't perceive that as a showstopper.
22:38:38 <adrian_otto> ok, I suggest we wrap up a bit early today
22:39:11 <adrian_otto> next week there will be some news on the dev list about the addition of Containers as a new project in the OpenStack compute program
22:39:11 <datsun180b> no quarrel from me
22:39:13 <PaulCzar> sorry I’m late :)
22:39:21 <adrian_otto> so please keep an eye out for that.
22:39:34 <tomblank> adrian_otto: sounds good.  thanks for taking the time off from your holiday (ETO) to chair the meeting.
22:39:54 <adrian_otto> the Containers team met at the Midcycle meetup, and presented to the nova team to drive early consensus on an approach to adding containers as a first class resource in OpenStack.
22:40:15 <adrian_otto> tomblank: you are welcome. Thanks for helping out when I was away before.
22:40:19 <asalkeld> zerovm in there too?
22:40:32 <adrian_otto> asalkeld: not yet
22:40:47 <asalkeld> might not be as easy to model
22:40:53 <adrian_otto> zerovm might not fit into that plan
22:41:00 <adrian_otto> but it's worth thinking about
22:41:13 <adrian_otto> zerovm fits best into swift I think
22:41:41 <adrian_otto> anyway, thanks for attending everyone. I look forward to getting back to normal again next week.
22:42:03 <asalkeld> I have to go, kids to school ...
22:42:09 <adrian_otto> anyone need to chime in for attendance before I end meeting?
22:42:29 <adrian_otto> thanks everyone!
22:42:31 <adrian_otto> #endmeeting